Re: [PATCH v5 3/3] dt-binding: mediatek: add MediaTek mt8195 MDP3 components

2023-09-18 Thread 何宗原
Hi Krzysztof, On Tue, 2023-09-12 at 10:19 +0200, Krzysztof Kozlowski wrote: > > External email : Please do not click links or open attachments until > you have verified the sender or the content. > On 12/09/2023 09:56, Moudy Ho wrote: > > Introduce more MDP3 components present in MT8195.

[PATCH v2 2/2] backlight: mp3309c: Add support for MPS MP3309C

2023-09-18 Thread Flavio Suligoi
The Monolithic Power (MPS) MP3309C is a WLED step-up converter, featuring a programmable switching frequency to optimize efficiency. The brightness can be controlled either by I2C commands (called "analog" mode) or by a PWM input signal (PWM mode). This driver supports both modes. For DT

Re: [PATCH v5 02/14] arm64: dts: mediatek: mt8195: add MDP3 nodes

2023-09-18 Thread 何宗原
On Tue, 2023-09-12 at 10:23 +0200, Krzysztof Kozlowski wrote: > > External email : Please do not click links or open attachments until > you have verified the sender or the content. > On 12/09/2023 09:57, Moudy Ho wrote: > > Add device nodes for Media Data Path 3 (MDP3) modules. > > > >

[PATCH v5 07/14] media: platform: mtk-mdp3: add checks for dummy components

2023-09-18 Thread Moudy Ho
Some components act as bridges only and do not require full configuration. Signed-off-by: Moudy Ho --- .../platform/mediatek/mdp3/mdp_cfg_data.c | 8 +++ .../platform/mediatek/mdp3/mtk-mdp3-cfg.h | 1 + .../platform/mediatek/mdp3/mtk-mdp3-cmdq.c| 58 ++- 3 files

[PATCH v5 3/3] dt-binding: mediatek: add MediaTek mt8195 MDP3 components

2023-09-18 Thread Moudy Ho
Introduce more MDP3 components present in MT8195. Signed-off-by: Moudy Ho --- .../display/mediatek/mediatek,aal.yaml| 2 +- .../display/mediatek/mediatek,color.yaml | 2 +- .../display/mediatek/mediatek,merge.yaml | 1 + .../display/mediatek/mediatek,ovl.yaml| 2 +-

[PATCH] drm/msm/adreno: Add support for SM7150 SoC machine

2023-09-18 Thread Danila Tikhonov
SM7150 has 5 power levels which correspond to 5 speed-bin values: 0, 128, 146, 167, 172. Speed-bin value is calulated as FMAX/4.8MHz round up to zero decimal places. The vendor's FW GMU is called a618_gmu.bin. And also a618 on SM7150 uses a615 zapfw. Add this as machine = "qcom,sm7150", because

[PATCH v5 03/14] media: platform: mtk-mdp3: add support second sets of MMSYS

2023-09-18 Thread Moudy Ho
MT8195 has two MMSYS sets, VPPSYS0 and VPPSYS1. These sets coordinate and control the clock, power, and register settings needed for the components of MDP3. Signed-off-by: Moudy Ho --- .../platform/mediatek/mdp3/mdp_cfg_data.c | 44 +--

[PATCH v5 13/14] media: platform: mtk-mdp3: add mt8195 MDP3 component settings

2023-09-18 Thread Moudy Ho
Extend the component settings used in MT8195 MDP3. Additionally, it is crucial to read all component settings in a specific manner to ensure that shared memory data structure lengths are aligned across different platforms. Signed-off-by: Moudy Ho --- .../platform/mediatek/mdp3/mtk-mdp3-cmdq.c

[PATCH v5 05/14] media: platform: mtk-mdp3: introduce more pipelines from MT8195

2023-09-18 Thread Moudy Ho
Increasing the number of sets built by MMSYS and MUTEX in MT8195 will enable the creation of more pipelines in MDP3. Signed-off-by: Moudy Ho --- .../platform/mediatek/mdp3/mtk-mdp3-cmdq.c| 80 --- .../platform/mediatek/mdp3/mtk-mdp3-core.h| 7 ++ 2 files changed, 60

[PATCH v5 14/14] media: platform: mtk-mdp3: add support for parallel pipe to improve FPS

2023-09-18 Thread Moudy Ho
In some chips, MDP3 has the ability to utilize two pipelines to parallelly process a single frame. To enable this feature, multiple CMDQ clients and packets need to be configured at the same time. Signed-off-by: Moudy Ho --- .../platform/mediatek/mdp3/mdp_cfg_data.c | 8 +

Re: [RFC PATCH 8/8] dt-bindings: display: panel: add Fascontek FS035VG158 panel

2023-09-18 Thread John Watts
On Tue, Sep 12, 2023 at 08:55:31AM +0200, Krzysztof Kozlowski wrote: > On 11/09/2023 18:47, John Watts wrote: > > On Mon, Sep 11, 2023 at 01:49:39PM +0200, Krzysztof Kozlowski wrote: > >> If the other panel has exactly the same case, then yes, you can do like > >> this. But it depends on the

Re: [PATCH v5 03/14] media: platform: mtk-mdp3: add support second sets of MMSYS

2023-09-18 Thread 何宗原
Hi Angelo, On Tue, 2023-09-12 at 11:18 +0200, AngeloGioacchino Del Regno wrote: > Il 12/09/23 09:57, Moudy Ho ha scritto: > > MT8195 has two MMSYS sets, VPPSYS0 and VPPSYS1. > > These sets coordinate and control the clock, power, and > > register settings needed for the components of MDP3. > > >

[PATCH v5 2/3] dt-binding: mediatek: integrate MDP RDMA to one binding

2023-09-18 Thread Moudy Ho
Due to the same hardware design, MDP RDMA needs to be integrated into the same binding. Signed-off-by: Moudy Ho --- .../display/mediatek/mediatek,mdp-rdma.yaml | 88 --- .../bindings/media/mediatek,mdp3-rdma.yaml| 5 +- 2 files changed, 3 insertions(+), 90 deletions(-)

[PATCH v5 0/3] introduce more MDP3 components in mt8195

2023-09-18 Thread Moudy Ho
Changes since v4: - Rebase on v6.6-rc1 - Organize identical hardware components into their respective files. Hi, The purpose of this patch is to separate the MDP3-related bindings from the original mailing list mentioned below:

[PATCH v5 06/14] media: platform: mtk-mdp3: introduce more MDP3 components

2023-09-18 Thread Moudy Ho
Add configuration of more components in MT8195 MDP3. Signed-off-by: Moudy Ho --- .../platform/mediatek/mdp3/mdp_reg_aal.h | 25 ++ .../platform/mediatek/mdp3/mdp_reg_color.h| 31 +++ .../media/platform/mediatek/mdp3/mdp_reg_fg.h | 23 +

Re: [PATCH v5 2/3] dt-binding: mediatek: integrate MDP RDMA to one binding

2023-09-18 Thread 何宗原
On Tue, 2023-09-12 at 10:16 +0200, Krzysztof Kozlowski wrote: > > External email : Please do not click links or open attachments until > you have verified the sender or the content. > On 12/09/2023 09:56, Moudy Ho wrote: > > Due to the same hardware design, MDP RDMA needs to > > be

[PATCH] staging: fbtft: Removed unnecessary parenthesis around conditions to comply with the checkpatch coding style.

2023-09-18 Thread Angus Gardner
--- drivers/staging/fbtft/fb_ra8875.c | 11 --- 1 file changed, 4 insertions(+), 7 deletions(-) diff --git a/drivers/staging/fbtft/fb_ra8875.c b/drivers/staging/fbtft/fb_ra8875.c index 398bdbf53c9a..658f915b8528 100644 --- a/drivers/staging/fbtft/fb_ra8875.c +++

Re: [PATCH] drm/tests: provide exit function

2023-09-18 Thread José Pekkarinen
On 2023-09-14 15:00, Maxime Ripard wrote: On Wed, Sep 13, 2023 at 07:35:57PM +0300, José Pekkarinen wrote: On 2023-09-13 17:41, mrip...@kernel.org wrote: > On Wed, Sep 13, 2023 at 05:01:40PM +0300, José Pekkarinen wrote: > > On 2023-09-13 12:50, Maxime Ripard wrote: > > > Hi, > > > > > > On

[PATCH v5 00/14] add support MDP3 on MT8195 platform

2023-09-18 Thread Moudy Ho
Changes since v4: - Rebase on v6.6-rc1 - Remove any unnecessary DTS settings. - Adjust the usage of MOD and clock in blending components. Changes since v3: - Depend on : [1] https://patchwork.kernel.org/project/linux-media/list/?series=719841 - Suggested by Krzysztof, integrating all newly

Re: [PATCH v2] drm/simpledrm: Add support for multiple "power-domains"

2023-09-18 Thread Thomas Zimmermann
Hi Am 12.09.23 um 22:22 schrieb Janne Grunau via B4 Relay: From: Janne Grunau Multiple power domains need to be handled explicitly in each driver. The driver core can not handle it automatically since it is not aware of power sequencing requirements the hardware might have. This is not a

Re: [PATCH v9 6/7] drm/mediatek: dsi: Support dynamic connector selection

2023-09-18 Thread 胡俊光

Re: [PATCH v9 5/7] drm/mediatek: Add connector dynamic selection capability for mt8188

2023-09-18 Thread 胡俊光

Re: [PATCH v2 1/5] string.h: add array-wrappers for (v)memdup_user()

2023-09-18 Thread Andy Shevchenko
On Sat, Sep 16, 2023 at 05:32:42PM +0300, Dan Carpenter wrote: > On Fri, Sep 08, 2023 at 09:59:40PM +0200, Philipp Stanner wrote: ... > > +static inline void *memdup_array_user(const void __user *src, size_t n, > > size_t size) > > +{ > > + size_t nbytes; > > + > > + if

Re: [PATCH] drm/ssd130x: Drop _helper prefix from struct drm_*_helper_funcs callbacks

2023-09-18 Thread Thomas Zimmermann
Hi Am 14.09.23 um 21:51 schrieb Javier Martinez Canillas: The driver uses a naming convention where functions for struct drm_*_funcs callbacks are named ssd130x_$object_$operation, while the callbacks for struct drm_*_helper_funcs are named ssd130x_$object_helper_$operation. The idea is that

<    1   2   3