Re: [PATCH] drm/virtio: fix prime export for vram objects

2021-01-12 Thread Anthoine Bourgeois
ting in prime export never working for vram objects. Cc: Gurchetan Singh Cc: Thomas Zimmermann Cc: Gerd Hoffmann Signed-off-by: Chia-I Wu Reviewed-by: Anthoine Bourgeois --- drivers/gpu/drm/virtio/virtgpu_vram.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/gpu/drm/virtio/virtg

Re: [PATCH] drm/virtio: make sure context is created in gem open

2021-01-12 Thread Anthoine Bourgeois
Cc: Gerd Hoffmann Signed-off-by: Chia-I Wu Reviewed-by: Anthoine Bourgeois --- drivers/gpu/drm/virtio/virtgpu_gem.c | 8 +--- 1 file changed, 5 insertions(+), 3 deletions(-) diff --git a/drivers/gpu/drm/virtio/virtgpu_gem.c b/drivers/gpu/drm/virtio/virtgpu_gem.c index c30c75ee83fc..8502400b2

Re: [PATCH] drivers: gpu: drm: virtio: fix dependency of DRM_VIRTIO_GPU on VIRTIO

2020-12-07 Thread Anthoine Bourgeois
for me. Thank you. Reviewed-by: Anthoine Bourgeois --- drivers/gpu/drm/virtio/Kconfig | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/gpu/drm/virtio/Kconfig b/drivers/gpu/drm/virtio/Kconfig index b925b8b1da16..51ec7c3240c9 100644 --- a/drivers/gpu/drm/virtio/Kconfig +++ b

Re: [PATCH 3/3] drm/virtio: consider dma-fence context when signaling

2020-11-25 Thread Anthoine Bourgeois
-off-by: Gurchetan Singh Reviewed-by: Anthoine Bourgeois --- drivers/gpu/drm/virtio/virtgpu_drv.h | 1 + drivers/gpu/drm/virtio/virtgpu_fence.c | 39 -- 2 files changed, 31 insertions(+), 9 deletions(-) diff --git a/drivers/gpu/drm/virtio/virtgpu_drv.h b/drivers/gpu/drm

Re: [PATCH 2/3] drm/virtio: rework virtio_fence_signaled

2020-11-25 Thread Anthoine Bourgeois
) is called. The check for last_fence_id is therefore a bit redundant, and it will not be sufficient to check the last_fence_id for multiple synchronization timelines. Remove it. Signed-off-by: Gurchetan Singh Reviewed-by: Anthoine Bourgeois --- drivers/gpu/drm/virtio/virtgpu_fence.c | 12

Re: [PATCH 1/3] drm/virtio: virtio_{blah} --> virtio_gpu_{blah}

2020-11-25 Thread Anthoine Bourgeois
On Mon, Nov 23, 2020 at 06:19:00PM -0800, Gurchetan Singh wrote: virtio_gpu typically uses the prefix virtio_gpu, but there are a few places where the virtio prefix is used. Modify this for consistency. Signed-off-by: Gurchetan Singh Reviewed-by: Anthoine Bourgeois --- drivers/gpu/drm

Re: [PATCH 5/5] drm/virtio: rename sync_seq and last_seq

2020-11-20 Thread Anthoine Bourgeois
On Wed, Nov 18, 2020 at 05:08:09PM -0800, Gurchetan Singh wrote: To be clearer about our intentions to associate sequence numbers and fence IDs, let's rename these variables. Signed-off-by: Gurchetan Singh Reviewed-by: Anthoine Bourgeois --- drivers/gpu/drm/virtio/virtgpu_debugfs.c | 4

Re: [PATCH 4/5] drm/virtio: use fence_id when processing fences

2020-11-20 Thread Anthoine Bourgeois
On Wed, Nov 18, 2020 at 05:08:08PM -0800, Gurchetan Singh wrote: Currently, the fence ID, which can be used to identify a virtgpu fence, is the same as the fence sequence number. Let's use the fence_id name to clearly signal this. Signed-off-by: Gurchetan Singh Reviewed-by: Anthoine

Re: [PATCH 23/24] drm/virtio: implement blob resources: resource create blob ioctl

2020-08-17 Thread Anthoine Bourgeois
52,4 +684,8 @@ struct drm_ioctl_desc virtio_gpu_ioctls[DRM_VIRTIO_NUM_IOCTLS] = { DRM_IOCTL_DEF_DRV(VIRTGPU_GET_CAPS, virtio_gpu_get_caps_ioctl, DRM_RENDER_ALLOW), + + DRM_IOCTL_DEF_DRV(VIRTGPU_RESOURCE_CREATE_BLOB, + virtio_g

[PATCH] drm/radeon/dpm: implement force performance levels for rs780

2013-08-02 Thread Anthoine Bourgeois
2013/8/1 Deucher, Alexander > > -Original Message- > > From: Anthoine Bourgeois [mailto:anthoine.bourgeois at gmail.com] > > Sent: Wednesday, July 31, 2013 6:34 PM > > To: Deucher, Alexander; Koenig, Christian; Jerome Glisse; Anthoine > &g

[PATCH] drm/radeon/dpm: implement force performance levels for rs780

2013-08-01 Thread Anthoine Bourgeois
Allows you to limit the selected power levels via sysfs. Force the feedback divider to select a power level. Signed-off-by: Anthoine Bourgeois --- drivers/gpu/drm/radeon/radeon_asic.c | 1 + drivers/gpu/drm/radeon/radeon_asic.h | 2 ++ drivers/gpu/drm/radeon/rs780_dpm.c | 67

Re: [PATCH] drm/radeon/dpm: implement force performance levels for rs780

2013-08-01 Thread Anthoine Bourgeois
2013/8/1 Deucher, Alexander alexander.deuc...@amd.com -Original Message- From: Anthoine Bourgeois [mailto:anthoine.bourge...@gmail.com] Sent: Wednesday, July 31, 2013 6:34 PM To: Deucher, Alexander; Koenig, Christian; Jerome Glisse; Anthoine Bourgeois Cc: dri-devel

[PATCH] drm/radeon/dpm: implement force performance levels for rs780

2013-08-01 Thread Anthoine Bourgeois
Allows you to limit the selected power levels via sysfs. Force the feedback divider to select a power level. Signed-off-by: Anthoine Bourgeois anthoine.bourge...@gmail.com --- drivers/gpu/drm/radeon/radeon_asic.c | 1 + drivers/gpu/drm/radeon/radeon_asic.h | 2 ++ drivers/gpu/drm/radeon

[PATCH] drm/radeon/dpm: add debugfs support for RS780/RS880 (v2)

2013-07-18 Thread Anthoine Bourgeois
On Wed, Jul 17, 2013 at 09:44:00PM +, Deucher, Alexander wrote: >> -Original Message- >> From: Anthoine Bourgeois [mailto:anthoine.bourgeois at gmail.com] >> Sent: Wednesday, July 17, 2013 5:23 PM >> To: Deucher, Alexander; Koenig, Christian; Jerome

[PATCH] drm/radeon/dpm: add debugfs support for RS780/RS880 (v2)

2013-07-18 Thread Anthoine Bourgeois
== 19690 and: # cat /sys/kernel/debug/dri/0/radeon_pm_info uvdvclk: 0 dclk: 0 power level 1sclk: 5 vddc_index: 2 when I play supertuxkart with sclk == 49762. Thanks for yesturday, I was in a wrong way, Anthoine > >Alex > >> -Original Message- >

[PATCH] drm/radeon/dpm: add debugfs support for RS780/RS880 (v2)

2013-07-17 Thread Anthoine Bourgeois
-by: Anthoine Bourgeois --- drivers/gpu/drm/radeon/radeon_asic.c | 1 + drivers/gpu/drm/radeon/radeon_asic.h | 2 ++ drivers/gpu/drm/radeon/rs780_dpm.c | 23 +++ drivers/gpu/drm/radeon/rs780d.h | 3 +++ 4 files changed, 29 insertions(+) diff --git a/drivers/gpu/drm

[PATCH] drm/radeon/dpm: add debugfs support for rs780

2013-07-17 Thread Anthoine Bourgeois
2013/7/16 Deucher, Alexander > > -Original Message- > > From: Anthoine Bourgeois [mailto:anthoine.bourgeois at gmail.com] > > Sent: Tuesday, July 16, 2013 5:09 PM > > To: Deucher, Alexander; Koenig, Christian; Jerome Glisse; Anthoine > &g

[PATCH] drm/radeon/dpm: add debugfs support for rs780

2013-07-17 Thread Anthoine Bourgeois
This allows you to look at the current DPM state via debugfs. Signed-off-by: Anthoine Bourgeois --- drivers/gpu/drm/radeon/radeon_asic.c | 1 + drivers/gpu/drm/radeon/radeon_asic.h | 2 ++ drivers/gpu/drm/radeon/rs780_dpm.c | 28 3 files changed, 31 insertions

[PATCH] drm/radeon/dpm: add debugfs support for rs780

2013-07-17 Thread Anthoine Bourgeois
This allows you to look at the current DPM state via debugfs. Signed-off-by: Anthoine Bourgeois anthoine.bourge...@gmail.com --- drivers/gpu/drm/radeon/radeon_asic.c | 1 + drivers/gpu/drm/radeon/radeon_asic.h | 2 ++ drivers/gpu/drm/radeon/rs780_dpm.c | 28 3 files

Re: [PATCH] drm/radeon/dpm: add debugfs support for rs780

2013-07-17 Thread Anthoine Bourgeois
2013/7/16 Deucher, Alexander alexander.deuc...@amd.com -Original Message- From: Anthoine Bourgeois [mailto:anthoine.bourge...@gmail.com] Sent: Tuesday, July 16, 2013 5:09 PM To: Deucher, Alexander; Koenig, Christian; Jerome Glisse; Anthoine Bourgeois Cc: dri-devel

[PATCH] drm/radeon/dpm: add debugfs support for RS780/RS880 (v2)

2013-07-17 Thread Anthoine Bourgeois
alexander.deuc...@amd.com Signed-off-by: Anthoine Bourgeois anthoine.bourge...@gmail.com --- drivers/gpu/drm/radeon/radeon_asic.c | 1 + drivers/gpu/drm/radeon/radeon_asic.h | 2 ++ drivers/gpu/drm/radeon/rs780_dpm.c | 23 +++ drivers/gpu/drm/radeon/rs780d.h | 3 +++ 4 files changed

Re: [PATCH] drm/radeon/dpm: add debugfs support for RS780/RS880 (v2)

2013-07-17 Thread Anthoine Bourgeois
and: # cat /sys/kernel/debug/dri/0/radeon_pm_info uvdvclk: 0 dclk: 0 power level 1sclk: 5 vddc_index: 2 when I play supertuxkart with sclk == 49762. Thanks for yesturday, I was in a wrong way, Anthoine Alex -Original Message- From: Anthoine Bourgeois

Re: [PATCH] drm/radeon/dpm: add debugfs support for RS780/RS880 (v2)

2013-07-17 Thread Anthoine Bourgeois
On Wed, Jul 17, 2013 at 09:44:00PM +, Deucher, Alexander wrote: -Original Message- From: Anthoine Bourgeois [mailto:anthoine.bourge...@gmail.com] Sent: Wednesday, July 17, 2013 5:23 PM To: Deucher, Alexander; Koenig, Christian; Jerome Glisse Cc: dri-devel@lists.freedesktop.org