Re: [Intel-gfx] [PATCH v2 01/10] drm/i915/dsi: Document the panel enable / disable sequences from the spec

2017-02-28 Thread Bob Paauwe
it more obvious any differences between the different sequences. Thanks Hans! The rest of the patches in this series look good too. So for the series: Reviewed-by: Bob Paauwe > --- > Changes in v2: > -Make the comment a table with 3 columns for easier comparison of the > 3 sequenc

[PATCH] drm: atomic: fix legacy gamma set helper

2016-04-11 Thread Bob Paauwe
ues stored in the crtc object. > > v2: Update non atomic values only if commit succeeds (Bob Paauwe) > > v3: Do not access crtc_state after commit, use crtc->state (Maarten > Lankhorst) > Reviewed-by: Bob Paauwe Tested-by; Bob Paauwe > Cc: Maarten Lankhorst &g

[PATCH] drm: atomic: fix legacy gamma set helper

2016-04-08 Thread Bob Paauwe
ues stored in the crtc object. > > Cc: Maarten Lankhorst > Cc: Bob Paauwe > Cc: > Signed-off-by: Lionel Landwerlin > --- > drivers/gpu/drm/drm_atomic_helper.c | 6 ++ > 1 file changed, 6 insertions(+) > > diff --git a/drivers/gpu/drm/drm_atomic_helper.c >

[Intel-gfx] [PATCH 2/2] drm/i915/skl: Add support for pipe background color

2015-11-18 Thread Bob Paauwe
not honoring the abstraction. What if black really needed to have alpha set or drm_rgba_t expands to more than 16 bits per color or we just want to initialize the background color to something other than black? > +} > + > static void intel_crtc_init(struct drm_device *dev, int pipe) > { > struct drm_i915_private *dev_priv = dev->dev_private; > @@ -13855,6 +13894,10 @@ static void intel_crtc_init(struct drm_device *dev, > int pipe) > drm_crtc_helper_add(&intel_crtc->base, &intel_helper_funcs); > > WARN_ON(drm_crtc_index(&intel_crtc->base) != intel_crtc->pipe); > + > + if (INTEL_INFO(dev)->gen >= 9) > + intel_create_background_color_property(dev, intel_crtc); > + > return; > > fail: -- -- Bob Paauwe Bob.J.Paauwe at intel.com IOTG / PED Software Organization Intel Corp. Folsom, CA (916) 356-6193

[PATCH 1/2] drm: Add infrastructure for CRTC background color property

2015-11-18 Thread Bob Paauwe
device *dev, > + int flags, const char *name); > struct drm_property_blob *drm_property_create_blob(struct drm_device *dev, > size_t length, > const void *data); > @@

[PATCH] drm/edid: Allow comma separated edid binaries. (v3)

2015-08-27 Thread Bob Paauwe
to make more readable (Jani) Updated kernel-parameters.txt to reflect changes (Jani) Reviewed-by: Jani Nikula Reviewed-by: Matt Roper Signed-off-by: Bob Paauwe --- Documentation/kernel-parameters.txt | 15 +++-- drivers/gpu/drm/drm_edid_load.c | 42

[PATCH] drm/edid: Allow comma separated edid binaries. (v2)

2015-08-26 Thread Bob Paauwe
: Bob Paauwe --- drivers/gpu/drm/drm_edid_load.c | 44 - 1 file changed, 35 insertions(+), 9 deletions(-) diff --git a/drivers/gpu/drm/drm_edid_load.c b/drivers/gpu/drm/drm_edid_load.c index c5605fe..93b9275 100644 --- a/drivers/gpu/drm/drm_edid_load.c +++ b

[PATCH 7/7] drm/i915: Drop unused position fields

2014-11-13 Thread Bob Paauwe
src,dst} fields in intel_plane_state. Drop them. > > Signed-off-by: Matt Roper Reviewed-by: Bob Paauwe > --- > drivers/gpu/drm/i915/intel_display.c | 16 > drivers/gpu/drm/i915/intel_drv.h | 6 -- > drivers/gpu/drm/i915/intel_sprite.c | 8 > 3 f

[PATCH 6/7] drm/i915: Switch plane handling to atomic helpers

2014-11-13 Thread Bob Paauwe
: igt/kms_universal_plane > Testcase: igt/kms_cursor_crc > Signed-off-by: Matt Roper With the above typo fixed this is Acknowledged-by: Bob Paauwe > --- > drivers/gpu/drm/i915/intel_display.c | 255 > +-- > drivers/gpu/drm/i915/intel_sprite.c | 122 ++

[PATCH 4/7] drm/i915: Make intel_crtc_has_pending_flip() non-static

2014-11-13 Thread Bob Paauwe
On Thu, 13 Nov 2014 10:43:23 -0800 Matt Roper wrote: > We'll want to use this from the atomic plane helpers, so ensure it can > be called outside intel_display.c. > > Signed-off-by: Matt Roper Reviewed-by: Bob Paauwe > --- > drivers/gpu/drm/i915/intel_display.c |

[Intel-gfx] [PATCH 3/7] drm/i915: Clarify sprite plane function names

2014-11-13 Thread Bob Paauwe
gt; call that intel_destroy_plane() did is unnecessary since the plane will > already be disabled due to framebuffer destruction by the point it gets > called. > > Signed-off-by: Matt Roper Reviewed-by: Bob Paauwe > --- > drivers/gpu/drm/i915/intel_display.c | 12 ++-

[PATCH 1/7] drm/i915: Make intel_plane_state subclass drm_plane_state

2014-11-13 Thread Bob Paauwe
On Thu, 13 Nov 2014 10:43:20 -0800 Matt Roper wrote: > Signed-off-by: Matt Roper Reviewed-by: Bob Paauwe > --- > drivers/gpu/drm/i915/intel_display.c | 28 ++-- > drivers/gpu/drm/i915/intel_drv.h | 3 +-- > drivers/gpu/drm/i915/intel

[PATCH 5/7] drm/i915: Prepare for atomic plane helpers

2014-11-13 Thread Bob Paauwe
On Thu, 13 Nov 2014 10:43:24 -0800 Matt Roper wrote: > Add the new driver entrypoints that will be called by the atomic plane > helpers. > > This patch does not actually switch over to the new plane helpers yet, > so there should be no functional change here. Also note that although > plane pro

[PATCH 2/7] drm/i915: Allow intel_plane_disable() to operate on all plane types

2014-11-13 Thread Bob Paauwe
On Thu, 13 Nov 2014 11:12:01 -0800 Matt Roper wrote: > On Thu, Nov 13, 2014 at 11:11:38AM -0800, Bob Paauwe wrote: > > On Thu, 13 Nov 2014 10:43:21 -0800 > > Matt Roper wrote: > > > > > We'll want to call this from the type-agnostic atomic plane helper

[PATCH 2/7] drm/i915: Allow intel_plane_disable() to operate on all plane types

2014-11-13 Thread Bob Paauwe
On Thu, 13 Nov 2014 10:43:21 -0800 Matt Roper wrote: > We'll want to call this from the type-agnostic atomic plane helper > hooks. Since it's not sprite-specific anymore, more it to > intel_display.c as well. > > Signed-off-by: Matt Roper > --- > drivers/gpu/drm/i915/intel_display.c | 21

[RFCv2 05/10] drm: Add plane type property

2014-03-11 Thread Bob Paauwe
On Fri, 7 Mar 2014 16:03:17 -0800 Matt Roper wrote: > Add a plane type property to allow userspace to distinguish plane types. > The type of the plane will now be established at drm_plane_init() time > (replacing the 'priv' parameter previously used). > > Signed-off-by: Matt Roper > --- > driv

Adding set_blob ioctl to DRM

2014-03-04 Thread Bob Paauwe
On Tue, 4 Mar 2014 09:35:57 +0100 Daniel Vetter wrote: > On Thu, Feb 20, 2014 at 11:24:40AM +1000, Dave Airlie wrote: > > > I am working on enabling a Color Enhancement block for primary display > > > for Exynos SoC. I need to > > > set a bunch of parameters like Color Conversion matrix, Contrast