Re: [PATCH v2 1/4] drm/mga: drop dependency on drm_os_linux.h

2019-07-01 Thread Emil Velikov
On Sun, 23 Jun 2019 at 11:36, Sam Ravnborg wrote: > -int mga_driver_fence_wait(struct drm_device *dev, unsigned int *sequence) > +void mga_driver_fence_wait(struct drm_device *dev, unsigned int *sequence) > { > drm_mga_private_t *dev_priv = (drm_mga_private_t *) dev->dev_private; >

Re: [PATCH v2 1/4] drm/mga: drop dependency on drm_os_linux.h

2019-06-30 Thread Sam Ravnborg
Hi Thomas. > >> v2: > >> - fixed timeout to 3000 msec (original value was 3 * Hz) > >> - drop unused return value from mga_driver_fence_wait() > > > > Thomas give his ack on v1 of this patch. > > But I am reluctant to apply it until someone has looked at this version. > > The main difference is

Re: [PATCH v2 1/4] drm/mga: drop dependency on drm_os_linux.h

2019-06-30 Thread Thomas Zimmermann
Hi Am 29.06.19 um 19:59 schrieb Sam Ravnborg: > Hi all. > >> Opencode all macros used from the deprecated drm_os_linux.h header file. >> The DRM_WAIT_ON used 3 * HZ as timeout. >> This was translated to 3000 msec. >> >> The return value of mga_driver_fence_wait() was not >> used, so make it

Re: [PATCH v2 1/4] drm/mga: drop dependency on drm_os_linux.h

2019-06-29 Thread Sam Ravnborg
Hi all. > Opencode all macros used from the deprecated drm_os_linux.h header file. > The DRM_WAIT_ON used 3 * HZ as timeout. > This was translated to 3000 msec. > > The return value of mga_driver_fence_wait() was not > used, so make it return void to simplify code a bit. > > v2: > - fixed

[PATCH v2 1/4] drm/mga: drop dependency on drm_os_linux.h

2019-06-23 Thread Sam Ravnborg
Opencode all macros used from the deprecated drm_os_linux.h header file. The DRM_WAIT_ON used 3 * HZ as timeout. This was translated to 3000 msec. The return value of mga_driver_fence_wait() was not used, so make it return void to simplify code a bit. v2: - fixed timeout to 3000 msec (original