[PATCH v8 14/19] phy: phy-mtk-dp: Add driver for DP phy

2022-02-18 Thread Guillaume Ranquet
From: Markus Schneider-Pargmann This is a new driver that supports the integrated DisplayPort phy for mediatek SoCs, especially the mt8195. The phy is integrated into the DisplayPort controller and will be created by the mtk-dp driver. This driver expects a struct regmap to be able to work on

[PATCH v8 13/19] drm/mediatek: dpi: Add dpintf support

2022-02-18 Thread Guillaume Ranquet
dpintf is the displayport interface hardware unit. This unit is similar to dpi and can reuse most of the code. This patch adds support for mt8195-dpintf to this dpi driver. Main differences are: - Some features/functional components are not available for dpintf which are now excluded from

[PATCH v8 16/19] drm/mediatek: Add mt8195 External DisplayPort support

2022-02-18 Thread Guillaume Ranquet
This patch adds External DisplayPort support to the mt8195 eDP driver. Signed-off-by: Guillaume Ranquet --- drivers/gpu/drm/mediatek/mtk_dp.c | 87 +++ 1 file changed, 64 insertions(+), 23 deletions(-) diff --git a/drivers/gpu/drm/mediatek/mtk_dp.c

[PATCH v8 12/19] drm/mediatek: dpi: move the csc_enable bit to board config

2022-02-18 Thread Guillaume Ranquet
Add flexibility by moving the csc_enable bit to board config Signed-off-by: Guillaume Ranquet --- drivers/gpu/drm/mediatek/mtk_dpi.c | 8 +++- 1 file changed, 7 insertions(+), 1 deletion(-) diff --git a/drivers/gpu/drm/mediatek/mtk_dpi.c b/drivers/gpu/drm/mediatek/mtk_dpi.c index

[PATCH v8 11/19] drm/mediatek: dpi: move the yuv422_en_bit to board config

2022-02-18 Thread Guillaume Ranquet
Add flexibility by moving the yuv422 en bit to board config Signed-off-by: Guillaume Ranquet --- drivers/gpu/drm/mediatek/mtk_dpi.c | 8 +++- 1 file changed, 7 insertions(+), 1 deletion(-) diff --git a/drivers/gpu/drm/mediatek/mtk_dpi.c b/drivers/gpu/drm/mediatek/mtk_dpi.c index

Re: [Intel-gfx] [PATCH v8 1/3] gpu: drm: separate panel orientation property creating and value setting

2022-02-18 Thread Alex Deucher
On Fri, Feb 18, 2022 at 7:13 AM Simon Ser wrote: > > On Friday, February 18th, 2022 at 12:54, Hans de Goede > wrote: > > > On 2/18/22 12:39, Simon Ser wrote: > > > On Friday, February 18th, 2022 at 11:38, Hans de Goede > > > wrote: > > > > > >> What I'm reading in the above is that it is

Re: [Intel-gfx] [PATCH v8 1/3] gpu: drm: separate panel orientation property creating and value setting

2022-02-18 Thread Harry Wentland
On 2022-02-18 07:12, Simon Ser wrote: > On Friday, February 18th, 2022 at 12:54, Hans de Goede > wrote: > >> On 2/18/22 12:39, Simon Ser wrote: >>> On Friday, February 18th, 2022 at 11:38, Hans de Goede >>> wrote: >>> What I'm reading in the above is that it is being considered to allow

[PATCH] drm/virtio: Add USE_INTERNAL blob flag

2022-02-18 Thread Rob Clark
From: Rob Clark With native userspace drivers in guest, a lot of GEM objects need to be neither shared nor mappable. And in fact making everything mappable and/or sharable results in unreasonably high fd usage in host VMM. Signed-off-by: Rob Clark --- This is for a thing I'm working on, a new

[PATCH v3] simplefb: Enable boot time VESA graphic mode selection.

2022-02-18 Thread Michal Suchanek
Since switch to simplefb/simpledrm VESA graphic modes are no longer available with legacy BIOS. The x86 realmode boot code enables the VESA graphic modes when option FB_BOOT_VESA_SUPPORT is enabled. To enable use of VESA modes with simplefb in legacy BIOS boot mode drop dependency of

Re: [PATCH 03/22] drm/amdgpu: Use drm_mode_init() for on-stack modes

2022-02-18 Thread Harry Wentland
On 2022-02-18 05:03, Ville Syrjala wrote: > From: Ville Syrjälä > > Initialize on-stack modes with drm_mode_init() to guarantee > no stack garbage in the list head, or that we aren't copying > over another mode's list head. > > Based on the following cocci script, with manual fixups: >

Re: [PATCH 01/22] drm: Add drm_mode_init()

2022-02-18 Thread Harry Wentland
On 2022-02-18 05:03, Ville Syrjala wrote: > From: Ville Syrjälä > > Add a variant of drm_mode_copy() that explicitly clears out > the list head of the destination mode. Helpful to guarantee > we don't have stack garbage left in there for on-stack modes. > > Signed-off-by: Ville Syrjälä

Re: [PATCH 1/4] drm/amdgpu: Fix compilation under UML

2022-02-18 Thread Alex Deucher
On Fri, Feb 18, 2022 at 11:39 AM Felix Kuehling wrote: > > > Am 2022-02-18 um 02:57 schrieb David Gow: > > From: Randy Dunlap > > > > cpuinfo_x86 and its associated macros are not available under ARCH=um, > > even though CONFIG_X86_64 is defined. > > > > This patch (and discussion) were

Re: [PATCH 02/22] drm/amdgpu: Remove pointless on stack mode copies

2022-02-18 Thread Harry Wentland
On 2022-02-18 05:03, Ville Syrjala wrote: > From: Ville Syrjälä > > These on stack copies of the modes appear to be pointless. > Just look at the originals directly. > > Cc: Harry Wentland > Cc: Leo Li > Cc: Rodrigo Siqueira > Cc: Alex Deucher > Cc: amd-...@lists.freedesktop.org > Cc:

Re: [PATCH] drm/amdkfd: Replace one-element array with flexible-array member

2022-02-18 Thread Christian König
Well in that case somebody could argue that we should probably remove the structure altogether. Regards, Christian. Am 18.02.22 um 17:15 schrieb Felix Kuehling: It looks like this structure isn't being used at all. So I'm OK with this change, in case we ever use it in the future. Regards,  

Re: [PATCH 1/4] drm/amdgpu: Fix compilation under UML

2022-02-18 Thread Felix Kuehling
Am 2022-02-18 um 02:57 schrieb David Gow: From: Randy Dunlap cpuinfo_x86 and its associated macros are not available under ARCH=um, even though CONFIG_X86_64 is defined. This patch (and discussion) were originally posted here: https://lkml.org/lkml/2022/1/24/1547 This produces the

Re: [PATCH] drm/amdkfd: Replace one-element array with flexible-array member

2022-02-18 Thread Felix Kuehling
It looks like this structure isn't being used at all. So I'm OK with this change, in case we ever use it in the future. Regards,   Felix Am 2022-02-18 um 02:47 schrieb Christian König: Felix need to comment as well, but I don't think that this will work that easily. By changing the entry

Re: [PATCH 04/22] drm/amdgpu: Use drm_mode_copy()

2022-02-18 Thread Harry Wentland
On 2022-02-18 05:03, Ville Syrjala wrote: > From: Ville Syrjälä > > struct drm_display_mode embeds a list head, so overwriting > the full struct with another one will corrupt the list > (if the destination mode is on a list). Use drm_mode_copy() > instead which explicitly preserves the list

Re: [PATCH] drm/virtio: Add USE_INTERNAL blob flag

2022-02-18 Thread Chia-I Wu
On Fri, Feb 18, 2022 at 7:57 AM Rob Clark wrote: > > From: Rob Clark > > With native userspace drivers in guest, a lot of GEM objects need to be > neither shared nor mappable. And in fact making everything mappable > and/or sharable results in unreasonably high fd usage in host VMM. > >

Re: [PATCH] drm/msm/dpu: Bind pingpong block to intf on active ctls in cmd encoder

2022-02-18 Thread Dmitry Baryshkov
On 02/02/2022 12:48, Marijn Suijten wrote: On 2022-01-20 02:12:51, Dmitry Baryshkov wrote: On 22/12/2021 13:55, Marijn Suijten wrote: As per the specification of DPU_CTL_ACTIVE_CFG the configuration of active blocks should be proactively specified, and the pingpong block is no different. The

Re: [PATCH V2 02/11] drm/bridge: tc358767: Change tc_ prefix to tc_edp_ for (e)DP specific functions

2022-02-18 Thread Lucas Stach
Am Freitag, dem 18.02.2022 um 02:00 +0100 schrieb Marek Vasut: > These functions are specific to (e)DP output initialization and > operation, add specific tc_edp_ prefix to those functions to > discern them from DPI output functions that will be added later > in this series. No functional change.

Re: [PATCH v2 2/2] drm/msm/dpu: Fix timeout issues on command mode panels

2022-02-18 Thread Dmitry Baryshkov
On 11/09/2021 19:39, AngeloGioacchino Del Regno wrote: In function dpu_encoder_phys_cmd_wait_for_commit_done we are always checking if the relative CTL is started by waiting for an interrupt to fire: it is fine to do that, but then sometimes we call this function while the CTL is up and has

Re: [PATCH 06/22] drm/bridge: Use drm_mode_copy()

2022-02-18 Thread Laurent Pinchart
Hi Ville, Thank you for the patch. On Fri, Feb 18, 2022 at 12:03:47PM +0200, Ville Syrjala wrote: > From: Ville Syrjälä > > struct drm_display_mode embeds a list head, so overwriting > the full struct with another one will corrupt the list > (if the destination mode is on a list). Use

Re: [PATCH V2 05/11] drm/bridge: tc358767: Move hardware init to enable callback

2022-02-18 Thread Lucas Stach
Am Freitag, dem 18.02.2022 um 02:00 +0100 schrieb Marek Vasut: > The TC358767/TC358867/TC9595 are all capable of operating either from > attached Xtal or from DSI clock lane clock. In case the later is used, > all I2C accesses will fail until the DSI clock lane is running and > supplying clock to

Re: [PATCH V2 07/11] drm/bridge: tc358767: Wrap (e)DP aux I2C registration into tc_aux_link_setup()

2022-02-18 Thread Lucas Stach
Am Freitag, dem 18.02.2022 um 02:00 +0100 schrieb Marek Vasut: > This bit of code is (e)DP and aux I2C link specific, move it into > tc_aux_link_setup() to permit cleaner addition of DSI-to-DPI mode. > No functional change. > > Signed-off-by: Marek Vasut > Cc: Jonas Karlman > Cc: Laurent

Re: [PATCH v8 5/5] drm/i915/uapi: document behaviour for DG2 64K support

2022-02-18 Thread Robert Beckett
On 18/02/2022 13:47, Ramalingam C wrote: On 2022-02-17 at 20:57:35 -0800, Jordan Justen wrote: Robert Beckett writes: From: Matthew Auld On discrete platforms like DG2, we need to support a minimum page size of 64K when dealing with device local-memory. This is quite tricky for various

Re: [PATCH V2 09/11] drm/bridge: tc358767: Detect bridge mode from connected endpoints in DT

2022-02-18 Thread Lucas Stach
Am Freitag, dem 18.02.2022 um 02:00 +0100 schrieb Marek Vasut: > The TC358767/TC358867/TC9595 are all capable of operating in multiple > modes, DPI-to-(e)DP, DSI-to-(e)DP, DSI-to-DPI. Only the first mode is > currently supported. It is possible to find out the mode in which the > bridge should be

Re: [PATCH V2 03/11] drm/bridge: tc358767: Convert to atomic ops

2022-02-18 Thread Lucas Stach
Am Freitag, dem 18.02.2022 um 02:00 +0100 schrieb Marek Vasut: > Use the atomic version of the enable/disable operations to continue the > transition to the atomic API. This will be needed to access the mode > from the atomic state. > > Signed-off-by: Marek Vasut > Cc: Jonas Karlman > Cc:

Re: [PATCH V2 04/11] drm/bridge: tc358767: Implement atomic_check callback

2022-02-18 Thread Lucas Stach
Am Freitag, dem 18.02.2022 um 02:00 +0100 schrieb Marek Vasut: > Implement .atomic_check callback which prevents user space from setting > unsupported mode. The tc_edp_common_atomic_check() variant is already > prepared for DSI-to-DPI mode addition, which has different frequency > limits. > >

[PATCH] drm/amdkfd: rework criu_restore_bos error handling

2022-02-18 Thread trix
From: Tom Rix Clang static analysis reports this problem kfd_chardev.c:2327:2: warning: 1st function call argument is an uninitialized value kvfree(bo_privs); ^~~~ If the copy_from_users(bo_buckets, ...) fails, there is a jump to the generic error handler at exit:. The

Re: [PATCH V2 06/11] drm/bridge: tc358767: Move (e)DP bridge endpoint parsing into dedicated function

2022-02-18 Thread Lucas Stach
Am Freitag, dem 18.02.2022 um 02:00 +0100 schrieb Marek Vasut: > The TC358767/TC358867/TC9595 are all capable of operating in multiple > modes, DPI-to-(e)DP, DSI-to-(e)DP, DSI-to-DPI. Only the first mode is > currently supported. In order to support the rest of the modes without > making the

Re: [PATCH] drm/virtio: Add USE_INTERNAL blob flag

2022-02-18 Thread Rob Clark
On Fri, Feb 18, 2022 at 8:42 AM Chia-I Wu wrote: > > On Fri, Feb 18, 2022 at 7:57 AM Rob Clark wrote: > > > > From: Rob Clark > > > > With native userspace drivers in guest, a lot of GEM objects need to be > > neither shared nor mappable. And in fact making everything mappable > > and/or

Re: [PATCH V2 08/11] drm/bridge: tc358767: Move bridge ops setup into tc_probe_edp_bridge_endpoint()

2022-02-18 Thread Lucas Stach
Am Freitag, dem 18.02.2022 um 02:00 +0100 schrieb Marek Vasut: > The bridge ops are specific to the bridge configuration, move them > into tc_probe_edp_bridge_endpoint() to permit cleaner addition of > DSI-to-DPI mode. No functional change. > > Signed-off-by: Marek Vasut > Cc: Jonas Karlman >

[pull] amdgpu, amdkfd, radeon drm-next-5.18

2022-02-18 Thread Alex Deucher
Hi Dave, Daniel, More new stuff for 5.18. The following changes since commit b9c7babe2c2e37a50aa42401b38d597ea78f506e: Backmerge tag 'v5.17-rc4' of git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux into drm-next (2022-02-14 10:52:27 +1000) are available in the Git repository at:

Re: [PATCH V2 10/11] drm/bridge: tc358767: Split tc_set_video_mode() into common and (e)DP part

2022-02-18 Thread Lucas Stach
Am Freitag, dem 18.02.2022 um 02:00 +0100 schrieb Marek Vasut: > The tc_set_video_mode() sets up both common and (e)DP video mode settings of > the bridge chip. Split the function into tc_set_common_video_mode() to set > the common settings and tc_set_edp_video_mode() to set the (e)DP specific >

Re: [Intel-gfx] [PATCH 1/2] drm/doc: remove rfc section for dg1

2022-02-18 Thread Lucas De Marchi
On Fri, Feb 18, 2022 at 11:22:41AM +, Matthew Auld wrote: We already completed the steps for this. Signed-off-by: Matthew Auld Cc: Thomas Hellström Cc: Jon Bloomfield Cc: Daniel Vetter Cc: Jordan Justen Cc: Kenneth Graunke Cc: mesa-...@lists.freedesktop.org I was indeed wondering

<    1   2   3