[PATCH 3/5] arm64: dts: qcom: qrb5165-rb5: add onboard USB-C redriver

2023-07-08 Thread Dmitry Baryshkov
Add the nb7vpq904m, onboard USB-C redriver / retimer. Signed-off-by: Dmitry Baryshkov --- arch/arm64/boot/dts/qcom/qrb5165-rb5.dts | 52 +++- 1 file changed, 50 insertions(+), 2 deletions(-) diff --git a/arch/arm64/boot/dts/qcom/qrb5165-rb5.dts

[PATCH 5/5] arm64: dts: qcom: qrb5165-rb5: enable DP altmode

2023-07-08 Thread Dmitry Baryshkov
Add displayport altmode declaration to the Type-C controller node to enable DP altmode negotiation. Signed-off-by: Dmitry Baryshkov --- arch/arm64/boot/dts/qcom/qrb5165-rb5.dts | 7 +++ 1 file changed, 7 insertions(+) diff --git a/arch/arm64/boot/dts/qcom/qrb5165-rb5.dts

[PATCH 4/5] arm64: dts: qcom: qrb5165-rb5: enable displayport controller

2023-07-08 Thread Dmitry Baryshkov
Enable the onboard displayport controller, connect it to QMP PHY. Signed-off-by: Dmitry Baryshkov --- arch/arm64/boot/dts/qcom/qrb5165-rb5.dts | 13 + 1 file changed, 13 insertions(+) diff --git a/arch/arm64/boot/dts/qcom/qrb5165-rb5.dts b/arch/arm64/boot/dts/qcom/qrb5165-rb5.dts

[PATCH 2/5] arm64: dts: qcom: sm8250: Add DisplayPort device node

2023-07-08 Thread Dmitry Baryshkov
Declare the displayport controller present on the Qualcomm SM8250 SoC. Signed-off-by: Dmitry Baryshkov --- arch/arm64/boot/dts/qcom/sm8250.dtsi | 93 1 file changed, 93 insertions(+) diff --git a/arch/arm64/boot/dts/qcom/sm8250.dtsi

[PATCH 0/5] arm64: dts: qcom: qrb5165-rb5: enable DP support

2023-07-08 Thread Dmitry Baryshkov
Implement DisplayPort support for the Qualcomm RB5 platform. Note: while testing this, I had link training issues with several dongles with DP connectors. Other DisplayPort-USB-C dongles (with HDMI or VGA connectors) work perfectly. Dependencies: [1] Soft-dependencies: [2], [3] [1]

[PATCH 1/5] dt-bindings: display: msm: dp-controller: document SM8250 compatible

2023-07-08 Thread Dmitry Baryshkov
It looks like DP controlled on SM8250 is the same as DP controller on SM8350. Use the SM8350 compatible as fallback for SM8250. Signed-off-by: Dmitry Baryshkov --- Documentation/devicetree/bindings/display/msm/dp-controller.yaml | 1 + 1 file changed, 1 insertion(+) diff --git

Re: [syzbot] [dri?] divide error in drm_mode_vrefresh

2023-07-08 Thread syzbot
Hello, syzbot has tested the proposed patch and the reproducer did not trigger any issue: Reported-and-tested-by: syzbot+622bba18029bcde67...@syzkaller.appspotmail.com Tested on: commit: 1c7873e3 mm: lock newly mapped VMA with corrected orde.. git tree:

[PATCH v5 2/3] drm/bridge_connector: stop filtering events in drm_bridge_connector_hpd_cb()

2023-07-08 Thread Dmitry Baryshkov
In some cases the bridge drivers would like to receive hotplug events even in the case new status is equal to the old status. In the DP case this is used to deliver "attention" messages to the DP host. Stop filtering the events in the drm_bridge_connector_hpd_cb() and let drivers decide whether

[PATCH v5 3/3] drm/bridge_connector: implement oob_hotplug_event

2023-07-08 Thread Dmitry Baryshkov
Implement the oob_hotplug_event() callback. Translate it to the HPD notification sent to the HPD bridge in the chain. Signed-off-by: Dmitry Baryshkov --- drivers/gpu/drm/drm_bridge_connector.c | 29 +++--- 1 file changed, 26 insertions(+), 3 deletions(-) diff --git

[PATCH v5 1/3] drm: Add HPD state to drm_connector_oob_hotplug_event()

2023-07-08 Thread Dmitry Baryshkov
From: Bjorn Andersson In some implementations, such as the Qualcomm platforms, the display driver has no way to query the current HPD state and as such it's impossible to distinguish between disconnect and attention events. Add a parameter to drm_connector_oob_hotplug_event() to pass the HPD

[PATCH v5 0/3] drm/bridge_connector: implement OOB HPD handling

2023-07-08 Thread Dmitry Baryshkov
Note, this is sent as v5, since there were several revisions for this patchset under a different series title ([1]). USB altmodes code would send OOB notifications to the drm_connector specified in the device tree. However as the MSM DP driver uses drm_bridge_connector, there is no way to receive

Re: [PATCH v1 4/5] drm/msm/dp: move relevant dp initialization code from bind() to probe()

2023-07-08 Thread Bjorn Andersson
On Fri, Jul 07, 2023 at 04:52:22PM -0700, Kuogee Hsieh wrote: > In preparation of moving edp of_dp_aux_populate_bus() to > dp_display_probe(), move dp_display_request_irq(), > dp->parser->parse() and dp_power_client_init() to dp_display_probe() > too. > > Signed-off-by: Kuogee Hsieh > --- >

Re: [PATCH v1 2/5] drm/msm/dp: incorporate pm_runtime framework into DP driver

2023-07-08 Thread Bjorn Andersson
On Fri, Jul 07, 2023 at 04:52:20PM -0700, Kuogee Hsieh wrote: > Incorporating pm runtime framework into DP driver so that power > and clock resource handling can be centralized allowing easier > control of these resources in preparation of registering aux bus > uring probe. > > Signed-off-by:

Re: [PATCH v1 1/5] drm/msm/dp: remove pm_runtime_xxx() from dp_power.c

2023-07-08 Thread Bjorn Andersson
On Fri, Jul 07, 2023 at 04:52:19PM -0700, Kuogee Hsieh wrote: > Since both pm_runtime_resume() and pm_runtime_suspend() are not > populated at dp_pm_ops. Those pm_runtime_get/put() functions within > dp_power.c will not have any effects in addition to increase/decrease > power counter. Also

[PATCH v5] drm/vkms: Add support to 1D gamma LUT

2023-07-08 Thread Arthur Grillo
Support a 1D gamma LUT with interpolation for each color channel on the VKMS driver. Add a check for the LUT length by creating vkms_atomic_check(). Enable VKMS to run the test igt@kms_plane@pixel-format. Tested with: igt@kms_color@gamma igt@kms_color@legacy-gamma

Re: [PATCH 2/2] drm/bridge: lt9611: Do not generate HFP/HBP/HSA and EOT packet

2023-07-08 Thread Abhinav Kumar
On 7/7/2023 1:47 AM, Neil Armstrong wrote: On 07/07/2023 09:18, Neil Armstrong wrote: Hi, On 06/07/2023 11:20, Amit Pundir wrote: On Wed, 5 Jul 2023 at 11:09, Dmitry Baryshkov wrote: [Adding freedreno@ to cc list] On Wed, 5 Jul 2023 at 08:31, Jagan Teki wrote: Hi Amit, On Wed, Jul

[drm-misc:drm-misc-next 1/14] drivers/video/fbdev/hyperv_fb.c:1033:24: error: 'screen_info' undeclared

2023-07-08 Thread kernel test robot
tree: git://anongit.freedesktop.org/drm/drm-misc drm-misc-next head: b63f5e5ca945e1c0341a2c3278575bb82bf8b890 commit: 8b0d13545b091729e0aa05ff9981e2d06c1e2ee5 [1/14] efi: Do not include from EFI header config: arm64-allyesconfig

Re: [PATCH] drm/nouveau/nvkm/dp: Add hack to fix DP 1.3+ DPCD issues

2023-07-08 Thread Karol Herbst
On Fri, Jul 7, 2023 at 11:58 PM Lyude Paul wrote: > > Currently we use the drm_dp_dpcd_read_caps() helper in the DRM side of > nouveau in order to read the DPCD of a DP connector, which makes sure we do > the right thing and also check for extended DPCD caps. However, it turns > out we're not

Re: [PATCH v2 1/2] drm/msm/dpu: fix DSC 1.2 block lengths

2023-07-08 Thread Abhinav Kumar
On 7/8/2023 6:00 AM, Dmitry Baryshkov wrote: All DSC_BLK_1_2 declarations incorrectly pass 0x29c as the block length. This includes the common block itself, enc subblocks and some empty space around. Change that to pass 0x4 instead, the length of common register block itself. Fixes:

Re: [PATCH 2/2] drm/bridge: lt9611: Do not generate HFP/HBP/HSA and EOT packet

2023-07-08 Thread Marek Vasut
On 7/8/23 21:40, Dmitry Baryshkov wrote: On Sat, 8 Jul 2023 at 22:39, Marek Vasut wrote: On 7/8/23 17:53, Dmitry Baryshkov wrote: On 08/07/2023 18:40, Marek Vasut wrote: On 7/7/23 10:47, Neil Armstrong wrote: On 07/07/2023 09:18, Neil Armstrong wrote: Hi, On 06/07/2023 11:20, Amit Pundir

Re: [PATCH 2/2] drm/bridge: lt9611: Do not generate HFP/HBP/HSA and EOT packet

2023-07-08 Thread Dmitry Baryshkov
On Sat, 8 Jul 2023 at 22:39, Marek Vasut wrote: > > On 7/8/23 17:53, Dmitry Baryshkov wrote: > > On 08/07/2023 18:40, Marek Vasut wrote: > >> On 7/7/23 10:47, Neil Armstrong wrote: > >>> On 07/07/2023 09:18, Neil Armstrong wrote: > Hi, > > On 06/07/2023 11:20, Amit Pundir wrote: >

Re: [PATCH 2/2] drm/bridge: lt9611: Do not generate HFP/HBP/HSA and EOT packet

2023-07-08 Thread Marek Vasut
On 7/8/23 17:53, Dmitry Baryshkov wrote: On 08/07/2023 18:40, Marek Vasut wrote: On 7/7/23 10:47, Neil Armstrong wrote: On 07/07/2023 09:18, Neil Armstrong wrote: Hi, On 06/07/2023 11:20, Amit Pundir wrote: On Wed, 5 Jul 2023 at 11:09, Dmitry Baryshkov wrote: [Adding freedreno@ to cc

Re: [PATCH 3/9] drm/verisilicon: Add basic drm driver

2023-07-08 Thread Thomas Zimmermann
Hi Am 07.07.23 um 20:09 schrieb Nicolas Dufresne: [...] +config DRM_VERISILICON + tristate "DRM Support for VeriSilicon" Can you rename the driver and files? 'VeriSilicon' seems unpronounceable. Simply 'StarFive' and starfive/ would be fine. Are you sure you want to request this ? If

Re: [PATCH 2/2] drm: bridge: tc358767: give VSDELAY some positive value

2023-07-08 Thread Marek Vasut
On 6/8/23 10:11, Lucas Stach wrote: Am Mittwoch, dem 07.06.2023 um 15:54 +0200 schrieb Marek Vasut: On 6/7/23 14:53, Lucas Stach wrote: Am Freitag, dem 02.06.2023 um 23:34 +0200 schrieb Marek Vasut: On 6/2/23 21:15, Lucas Stach wrote: From: David Jander The documentation is not clear about

Re: [PATCH 1/2] drm: bridge: tc358767: increase PLL lock time delay

2023-07-08 Thread Marek Vasut
On 6/2/23 21:15, Lucas Stach wrote: From: David Jander The PLL often fails to lock with this delay. The new value was determined by trial and error increasing the delay bit by bit until the error did not occurr anymore even after several tries. Then double that value was taken as the minimum

Re: [PATCH 2/2] drm/bridge: lt9611: Do not generate HFP/HBP/HSA and EOT packet

2023-07-08 Thread Dmitry Baryshkov
On 08/07/2023 18:40, Marek Vasut wrote: On 7/7/23 10:47, Neil Armstrong wrote: On 07/07/2023 09:18, Neil Armstrong wrote: Hi, On 06/07/2023 11:20, Amit Pundir wrote: On Wed, 5 Jul 2023 at 11:09, Dmitry Baryshkov wrote: [Adding freedreno@ to cc list] On Wed, 5 Jul 2023 at 08:31, Jagan

Re: [PATCH 2/2] drm/bridge: lt9611: Do not generate HFP/HBP/HSA and EOT packet

2023-07-08 Thread Marek Vasut
On 7/7/23 10:47, Neil Armstrong wrote: On 07/07/2023 09:18, Neil Armstrong wrote: Hi, On 06/07/2023 11:20, Amit Pundir wrote: On Wed, 5 Jul 2023 at 11:09, Dmitry Baryshkov wrote: [Adding freedreno@ to cc list] On Wed, 5 Jul 2023 at 08:31, Jagan Teki wrote: Hi Amit, On Wed, Jul 5,

Re: [PATCH 2/4] vgacon: rework screen_info #ifdef checks

2023-07-08 Thread Thomas Bogendoerfer
On Fri, Jul 07, 2023 at 11:52:24AM +0200, Arnd Bergmann wrote: > diff --git a/arch/mips/jazz/setup.c b/arch/mips/jazz/setup.c > index ee044261eb223..3c14548353e47 100644 > --- a/arch/mips/jazz/setup.c > +++ b/arch/mips/jazz/setup.c > @@ -76,7 +76,7 @@ void __init plat_mem_setup(void) > >

Re: [PATCH 2/2] drm/bridge: lt9611: Do not generate HFP/HBP/HSA and EOT packet

2023-07-08 Thread Linux regression tracking (Thorsten Leemhuis)
[TLDR: I'm adding this report to the list of tracked Linux kernel regressions; the text you find below is based on a few templates paragraphs you might have encountered already in similar form. See link in footer if these mails annoy you.] On 05.07.23 06:45, Amit Pundir wrote: > > On Wed, 5 Jul

[PATCH v2 2/2] drm/msm/dpu: fix DSC 1.2 enc subblock length

2023-07-08 Thread Dmitry Baryshkov
Both struct dpu_dsc_sub_blks instances declare enc subblock length to be 0x100, while the actual length is 0x9c (last register having offset 0x98). Reduce subblock length to remove the empty register space from being dumped. Fixes: 0d1b10c63346 ("drm/msm/dpu: add DSC 1.2 hw blocks for relevant

[PATCH v2 1/2] drm/msm/dpu: fix DSC 1.2 block lengths

2023-07-08 Thread Dmitry Baryshkov
All DSC_BLK_1_2 declarations incorrectly pass 0x29c as the block length. This includes the common block itself, enc subblocks and some empty space around. Change that to pass 0x4 instead, the length of common register block itself. Fixes: 0d1b10c63346 ("drm/msm/dpu: add DSC 1.2 hw blocks for

Re: [PATCH v4 3/3] drm/panel-fannal-c3004: Add fannal c3004 DSI panel

2023-07-08 Thread Marek Vasut
On 7/7/23 17:26, Paulo Pavacic wrote: Hello Marek, Hi, čet, 6. srp 2023. u 17:26 Marek Vasut napisao je: On 7/6/23 17:18, Paulo Pavacic wrote: Hello Linus, čet, 22. lip 2023. u 10:22 Linus Walleij napisao je: On Wed, Jun 21, 2023 at 5:09 PM Paulo Pavacic wrote: A lot of

Re: [PATCH] drm/nouveau/disp/g94: enable HDMI

2023-07-08 Thread Markus Elfring
Would a corresponding imperative description be helpful also for such a small change? See also: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v6.4#n94 Regards, Markus

Re: [PATCH v2 0/3] Galaxy S2 (i9100) panel updates v2

2023-07-08 Thread Sam Ravnborg
Hi Paul. On Sat, Jul 08, 2023 at 10:40:24AM +0200, Paul Cercueil wrote: > Hi, > > Follow-up on my patchset that fixes the display of the Samsung Galaxy S2 > when running PostmarketOS. > > The first two patches update the LD9040 panel driver so that it looks > much better, and supports setting

Re: [PATCH 01/13] drm/msm/dpu: cleanup dpu_kms_hw_init error path

2023-07-08 Thread Konrad Dybcio
On 8.07.2023 01:48, Dmitry Baryshkov wrote: > On 08/07/2023 02:25, Konrad Dybcio wrote: >> On 7.07.2023 22:37, Dmitry Baryshkov wrote: >>> It was noticed that dpu_kms_hw_init()'s error path contains several >>> labels which point to the same code path. Replace all of them with a >>> single label.

[PATCH v2 3/3] ARM: dts: exynos/i9100: Fix LCD screen's physical size

2023-07-08 Thread Paul Cercueil
The previous values were completely bogus, and resulted in the computed DPI ratio being much lower than reality, causing applications and UIs to misbehave. The new values were measured by myself with a ruler. Signed-off-by: Paul Cercueil Fixes: 8620cc2f99b7 ("ARM: dts: exynos: Add devicetree

[PATCH v2 2/3] drm/panel: ld9040: Register a backlight device

2023-07-08 Thread Paul Cercueil
Register a backlight device to be able to switch between all the gamma levels. v2: Remove .get_brightness() callback, use bl_get_data() and backlight_get_brightness() Signed-off-by: Paul Cercueil --- drivers/gpu/drm/panel/panel-samsung-ld9040.c | 32 +++- 1 file changed, 31

[PATCH v2 1/3] drm/panel: ld9040: Use better magic values

2023-07-08 Thread Paul Cercueil
I have no idea what the prior magic values mean, and I have no idea what my replacement (extracted from [1]) magic values mean. What I do know, is that these new values result in a much better picture, where the blacks are really black (as you would expect on an AMOLED display) instead of

[PATCH v2 0/3] Galaxy S2 (i9100) panel updates v2

2023-07-08 Thread Paul Cercueil
Hi, Follow-up on my patchset that fixes the display of the Samsung Galaxy S2 when running PostmarketOS. The first two patches update the LD9040 panel driver so that it looks much better, and supports setting the backlight. The third patch fixes the size of the panel in the Device Tree. The

Re: [PATCH v4 3/3] drm/panel-fannal-c3004: Add fannal c3004 DSI panel

2023-07-08 Thread Jagan Teki
On Thu, 22 Jun 2023 at 13:52, Linus Walleij wrote: > > On Wed, Jun 21, 2023 at 5:09 PM Paulo Pavacic wrote: > > > A lot of modifications to st7701 are required. I believe it would > > result in a driver that doesn't look or work the same. e.g compare > > delays between initialization sequences

Re: [PATCH v4 3/3] drm/panel-fannal-c3004: Add fannal c3004 DSI panel

2023-07-08 Thread Paulo Pavačić
Hello Marek, Jul 6, 2023 5:26:15 PM Marek Vasut : > On 7/6/23 17:18, Paulo Pavacic wrote: >> Hello Linus, >> čet, 22. lip 2023. u 10:22 Linus Walleij napisao >> je: >>> >>> On Wed, Jun 21, 2023 at 5:09 PM Paulo Pavacic wrote: >>> A lot of modifications to st7701 are required. I believe

Re: [PATCH drm-next v6 02/13] drm: manager to keep track of GPUs VA mappings

2023-07-08 Thread Matthew Brost
On Fri, Jul 07, 2023 at 02:52:41PM +0200, Boris Brezillon wrote: > On Fri, 7 Jul 2023 14:41:23 +0200 > Danilo Krummrich wrote: > > > >> + va__ && (va__->va.addr < (end__)) && \ > > >> + !list_entry_is_head(va__, &(mgr__)->rb.list, rb.entry); \ > > >> + va__ =

[PATCH v3] drm/bridge: tc358767: Use devm_clk_get_enabled() helper

2023-07-08 Thread Christophe JAILLET
The devm_clk_get_enabled() helper: - calls devm_clk_get() - calls clk_prepare_enable() and registers what is needed in order to call clk_disable_unprepare() when needed, as a managed resource. This simplifies the code and avoids the need of a dedicated function used with