[PATCH 1/1] GPU-DRM-GMA500: Deletion of unnecessary checks before two function calls

2014-10-26 Thread Arthur Borsboom
webpages, changing resolution, and run a 2D benchmark. Greetings, Arthur Borsboom On 26 Oct 2014 13:10, "SF Markus Elfring" wrote: > > What platforms have you tested the code on at this point ? > > None. - My "test computer" does not provide the corresponding hard

[PATCH 1/1] drm/gma500: Code cleanup - styling

2014-03-20 Thread Arthur Borsboom
Removed line return in the middle of function argument list. Signed-off-by: Arthur Borsboom --- drivers/gpu/drm/gma500/psb_intel_display.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/gpu/drm/gma500/psb_intel_display.c b/drivers/gpu/drm/gma500

[PATCH 1/1] drm/gma500: Code cleanup - inline documentation

2014-03-20 Thread Arthur Borsboom
Mainly styling fixes of inline documentation Signed-off-by: Arthur Borsboom --- drivers/gpu/drm/gma500/framebuffer.c | 36 ++-- drivers/gpu/drm/gma500/psb_intel_display.c | 35 ++-- drivers/gpu/drm/gma500/psb_intel_reg.h | 259 + drivers/gpu/drm/gma500

[PATCH 1/1] drm/gma500: Code cleanup - remove double variable assignment

2014-03-20 Thread Arthur Borsboom
The same assignment has already been taken place before in the drm_driver struct Signed-off-by: Arthur Borsboom --- drivers/gpu/drm/gma500/psb_drv.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/gpu/drm/gma500/psb_drv.c b/drivers/gpu/drm/gma500/psb_drv.c index b686e56..edb903b

[PATCH 3/3] drm/gma500: Code cleanup - inline documentation

2014-03-15 Thread Arthur Borsboom
Improve readability by adding/changing inline documentation Signed-off-by: Arthur Borsboom --- drivers/gpu/drm/gma500/psb_drv.c | 33 ++--- drivers/gpu/drm/gma500/psb_drv.h | 146 ++- 2 files changed, 58 insertions(+), 121 deletions(-) diff --git

[PATCH 2/3] drm/gma500: Code cleanup - style fixes

2014-03-15 Thread Arthur Borsboom
Code cleanup by following i915 constant/variable names and ordering Code cleanup by following directions from kernel doc: Codingstyle Code cleanup by following directions from kernel doc: DRM Signed-off-by: Arthur Borsboom --- drivers/gpu/drm/gma500/psb_drv.c | 135

[PATCH 1/3] drm/gma500: Code cleanup - removal of centralized exiting of function

2014-03-15 Thread Arthur Borsboom
Removed centralized exiting of function (goto statement), since it was the only used in one single location with only a return statement. Signed-off-by: Arthur Borsboom --- drivers/gpu/drm/gma500/psb_drv.c | 7 +-- 1 file changed, 1 insertion(+), 6 deletions(-) diff --git a/drivers/gpu/drm

[PATCH 1/3] drm/gma500: Code cleanup - inline documentation

2014-03-15 Thread Arthur Borsboom
. Will fix. * SGU MMX comment will be merged. * The 72 column git commit makes sense. Maybe this explains why my editor was predefined with this number. ;) Will fix. Be prepared for three new patches. On 15 March 2014 00:04, Patrik Jakobsson wrote: > On Thu, Mar 13, 2014 at 10:49 PM, Arthur Borsb

[PATCH 3/3] drm/gma500: Code cleanup - removal of centralized exiting of function

2014-03-13 Thread Arthur Borsboom
Removed centralized exiting of function (goto statement), since it was the only used in one single location with only a return statement. Signed-off-by: Arthur Borsboom --- drivers/gpu/drm/gma500/psb_drv.c | 7 +-- 1 file changed, 1 insertion(+), 6 deletions(-) diff --git a/drivers/gpu

[PATCH 2/3] drm/gma500: Code cleanup - style fixes

2014-03-13 Thread Arthur Borsboom
Cleanup of code by following i915 constant/variable names and ordering Cleanup of code by following directions from kernel documentation: Codingstyle Cleanup of code by following directions from kernel documentation: DRM Signed-off-by: Arthur Borsboom --- drivers/gpu/drm/gma500/psb_drv.c | 132

[PATCH 1/3] drm/gma500: Code cleanup - inline documentation

2014-03-13 Thread Arthur Borsboom
Improve readability by adding/changing inline documentation Signed-off-by: Arthur Borsboom --- drivers/gpu/drm/gma500/psb_drv.c | 56 +--- drivers/gpu/drm/gma500/psb_drv.h | 24 +++-- 2 files changed, 63 insertions(+), 17 deletions(-) diff --git

[PATCH 1/1] drm/gma500: Code cleanup and adding inline documentation

2014-03-11 Thread Arthur Borsboom
by adding inline documentation drm/gma500: Removed centralized exiting of function (goto statement), since it was the only used in one single location with only a return statement. CC: Patrik Jakobsson Signed-off-by: Arthur Borsboom --- drivers/gpu/drm/gma500/psb_drv.c | 162