Re: [PATCH v5 00/25] drm: Kirin driver cleanups to prep for Kirin960 support

2019-08-21 Thread John Stultz
On Wed, Aug 21, 2019 at 11:04 AM Sam Ravnborg  wrote:
>
> Hi John.
>
> On Tue, Aug 20, 2019 at 11:06:01PM +, John Stultz wrote:
> > Sending this out again (apologies!), to address a few issues Sam
> > found.
> >
> > This patchset contains one fix (in the front, so its easier to
> > eventually backport), and a series of changes from YiPing to
> > refactor the kirin drm driver so that it can be used on both
> > kirin620 based devices (like the original HiKey board) as well
> > as kirin960 based devices (like the HiKey960 board).
> >
> > The full kirin960 drm support is still being refactored, but as
> > this base kirin rework was getting to be substantial, I wanted
> > to send out the first chunk, so that the review burden wasn't
> > overwhelming.
> >
> > The full HiKey960 patch stack can be found here:
> >   
> > https://git.linaro.org/people/john.stultz/android-dev.git/log/?h=dev/hikey960-mainline-WIP
>
> Applied from the mails - as this is what my tooling expect.

Oh yes, that URL was just for reference if anyone wanted to see what
all the churn here was for.

> Pushed to drm-misc-next.

Great! Thanks so much for all the review and fedback! I really
appreciate your time helping!
-john


Re: [PATCH v5 00/25] drm: Kirin driver cleanups to prep for Kirin960 support

2019-08-21 Thread Sam Ravnborg
Hi John.

On Tue, Aug 20, 2019 at 11:06:01PM +, John Stultz wrote:
> Sending this out again (apologies!), to address a few issues Sam
> found.
> 
> This patchset contains one fix (in the front, so its easier to
> eventually backport), and a series of changes from YiPing to
> refactor the kirin drm driver so that it can be used on both
> kirin620 based devices (like the original HiKey board) as well
> as kirin960 based devices (like the HiKey960 board).
> 
> The full kirin960 drm support is still being refactored, but as
> this base kirin rework was getting to be substantial, I wanted
> to send out the first chunk, so that the review burden wasn't
> overwhelming.
> 
> The full HiKey960 patch stack can be found here:
>   
> https://git.linaro.org/people/john.stultz/android-dev.git/log/?h=dev/hikey960-mainline-WIP

Applied from the mails - as this is what my tooling expect.
Pushed to drm-misc-next.

Sam


[PATCH v5 00/25] drm: Kirin driver cleanups to prep for Kirin960 support

2019-08-20 Thread John Stultz
Sending this out again (apologies!), to address a few issues Sam
found.

This patchset contains one fix (in the front, so its easier to
eventually backport), and a series of changes from YiPing to
refactor the kirin drm driver so that it can be used on both
kirin620 based devices (like the original HiKey board) as well
as kirin960 based devices (like the HiKey960 board).

The full kirin960 drm support is still being refactored, but as
this base kirin rework was getting to be substantial, I wanted
to send out the first chunk, so that the review burden wasn't
overwhelming.

The full HiKey960 patch stack can be found here:
  
https://git.linaro.org/people/john.stultz/android-dev.git/log/?h=dev/hikey960-mainline-WIP

thanks
-john


New in v5:
* Whitespace changes and few logic simplifications to get
  checkpatch.pl --strict to pass, as noted by Sam
* Fix for one of my patches which broke building the kirin
  driver as a module. Again noted by Sam.

Cc: Rongrong Zou 
Cc: Xinliang Liu 
Cc: David Airlie 
Cc: Daniel Vetter 
Cc: dri-devel 
Cc: Sam Ravnborg 

Da Lv (1):
  drm: kirin: Fix for hikey620 display offset problem

John Stultz (3):
  drm: kirin: Remove HISI_KIRIN_DW_DSI config option
  drm: kirin: Remove unreachable return
  drm: kirin: Move workqueue to ade_hw_ctx structure

Xu YiPing (21):
  drm: kirin: Remove uncessary parameter indirection
  drm: kirin: Remove out_format from ade_crtc
  drm: kirin: Rename ade_plane to kirin_plane
  drm: kirin: Rename ade_crtc to kirin_crtc
  drm: kirin: Dynamically allocate the hw_ctx
  drm: kirin: Move request irq handle in ade hw ctx alloc
  drm: kirin: Move kirin_crtc, kirin_plane, kirin_format to
kirin_drm_drv.h
  drm: kirin: Reanme dc_ops to kirin_drm_data
  drm: kirin: Move ade crtc/plane help functions to driver_data
  drm: kirin: Move channel formats to driver data
  drm: kirin: Move mode config function to driver_data
  drm: kirin: Move plane number and primay plane in driver data
  drm: kirin: Move config max_width and max_height to driver data
  drm: kirin: Move drm driver to driver data
  drm: kirin: Add register connect helper functions in drm init
  drm: kirin: Rename plane_init and crtc_init
  drm: kirin: Fix dev->driver_data setting
  drm: kirin: Make driver_data variable non-global
  drm: kirin: Add alloc_hw_ctx/clean_hw_ctx ops in driver data
  drm: kirin: Pass driver data to crtc init and plane init
  drm: kirin: Move ade drm init to kirin drm drv

 drivers/gpu/drm/hisilicon/kirin/Kconfig   |  10 +-
 drivers/gpu/drm/hisilicon/kirin/Makefile  |   3 +-
 .../gpu/drm/hisilicon/kirin/kirin_ade_reg.h   |   1 +
 .../gpu/drm/hisilicon/kirin/kirin_drm_ade.c   | 351 +++---
 .../gpu/drm/hisilicon/kirin/kirin_drm_drv.c   | 250 +
 .../gpu/drm/hisilicon/kirin/kirin_drm_drv.h   |  48 ++-
 6 files changed, 367 insertions(+), 296 deletions(-)

-- 
2.17.1