[pull] amdgpu, amdkfd drm-next-5.3

2019-07-18 Thread Alex Deucher
Hi Dave, Daniel,

Fixes for 5.3, mostly for Navi.

The following changes since commit 7f963d9f69bf28d639013630da30d7a4c95edd5d:

  drm/amdgpu/navi10: add uclk activity sensor (2019-07-09 17:43:36 -0500)

are available in the Git repository at:

  git://people.freedesktop.org/~agd5f/linux tags/drm-next-5.3-2019-07-18

for you to fetch changes up to 41a5a2a8531f95d18bb4efddea581ccb469e8ee5:

  drm/amd/display: init res_pool dccg_ref, dchub_ref with xtalin_freq 
(2019-07-18 14:12:08 -0500)


drm-next-5.3-2019-07-18:

amdgpu:
- Navi DC fix for secondary adapters
- Fix Navi flickering with high res panels
- Navi SMU fixes
- Vega20 SMU fixes
- Fixes for audio hotplug on HG systems
- Fix for potential integer overflows on large buffer
  migrations
- debugfs fixes for umr
- Various other small fixes

amdkfd:
- Apply noretry setting consistently
- Fix hang in eviction
- Properly clean up GWS on uninit

UAPI:
- clarify a comment on ctx priority


Alex Deucher (4):
  drm/amdgpu/psp: add a mutex to protect access to the psp ring
  drm/amdgpu: enable IP discovery by default on navi
  drm/amdgpu: drop dead header
  drm/amdgpu/pm: remove check for pp funcs in freq sysfs handlers

Arnd Bergmann (3):
  drm/amd/display: Support clang option for stack alignment
  drm/amd/display: return 'NULL' instead of 'false' from 
dcn20_acquire_idle_pipe_for_layer
  drm/amd/amdgpu: hide #warning for missing DC config

Emil Velikov (1):
  drm/amdgpu: extend AMDGPU_CTX_PRIORITY_NORMAL comment

Eric Huang (1):
  drm/amdkfd: fix cp hang in eviction

Evan Quan (7):
  drm/amd/powerplay: increase the SMU msg response waiting time
  drm/amd/powerplay: fix memory allocation failure check V2
  drm/amd/powerplay: avoid access before allocation
  drm/amd/powerplay: fix deadlock around smu_handle_task V2
  drm/amd/powerplay: correct smu_update_table usage
  drm/amd/powerplay: maintain SMU FW backward compatibility
  drm/amd/powerplay: update vega20 driver if to fit latest SMU firmware

Felix Kuehling (4):
  drm/amdgpu: Fix potential integer overflows
  drm/amdkfd: Consistently apply noretry setting
  drm/amdgpu: Fix unaligned memory copies
  drm/amdgpu: Fix silent amdgpu_bo_move failures

Fuqian Huang (1):
  drm/amdgpu: remove memset after kzalloc

Hawking Zhang (3):
  drm/amdgpu: switch to macro for psp bootloader command
  drm/amdgpu: support key database loading for navi10
  drm/amdgpu: check kdb_bin_size to exclude kdb loading sequence

Joseph Greathouse (1):
  drm/amdkfd: Remove GWS from process during uninit

Kenneth Feng (2):
  drm/amd/powerplay: bug fix for sysfs
  drm/amd/powerplay: enable fw ctf,apcc dfll and gfx ss

Kent Russell (1):
  drm/amdgpu: Fix Vega20 Perf counter for pcie_bw

Kevin Wang (7):
  drm/amd/powerplay: fix smu clock type change miss error
  drm/amd/powerplay: add pstate mclk(uclk) support for navi10
  drm/amd/powerplay: add socclk profile dpm support.
  drm/amd/powerplay: add standard profile dpm support for smu
  drm/amd/powerplay: avoid double check feature enabled
  drm/amd/powerplay: fix save dpm level error for smu
  drm/amd/powerplay: add helper of smu_clk_dpm_is_enabled for smu

Nathan Chancellor (1):
  drm/amd/powerplay: Use proper enums in vega20_print_clk_levels

Nicholas Kazlauskas (3):
  drm/amd/display: Expose audio inst from DC to DM
  drm/amd/display: Add drm_audio_component support to amdgpu_dm
  drm/amd/display: Force uclk to max for every state

Nicolai Hähnle (1):
  drm/amdgpu/gfx10: set SH_MEM_CONFIG.INITIAL_INST_PREFETCH

Paul Menzel (1):
  drm/amdgpu: Print out voltage in DM_PPLIB

Tom St Denis (3):
  drm/amd/amdgpu: Add VMID to SRBM debugfs bank selection
  drm/amd/amdgpu: Add missing select_me_pipe_q() for gfx10
  drm/amd/amdgpu: Fix offset for vmid selection in debugfs interface

Wang Xiayang (1):
  drm/amdgpu: replace simple_strtol() by kstrtou32()

hersen wu (1):
  drm/amd/display: init res_pool dccg_ref, dchub_ref with xtalin_freq

tiancyin (1):
  drm/amdgpu/discovery: fix DCE_HWIP mapping error in hw_id_map array

 drivers/gpu/drm/amd/amdgpu/amdgpu.h|   1 +
 drivers/gpu/drm/amd/amdgpu/amdgpu_debugfs.c|   9 +-
 drivers/gpu/drm/amd/amdgpu/amdgpu_device.c |   1 +
 drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c  |   2 +-
 drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c|  19 +-
 drivers/gpu/drm/amd/amdgpu/amdgpu_gfx.h|   4 +-
 drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c |  13 --
 drivers/gpu/drm/amd/amdgpu/amdgpu_psp.c|  25 ++-
 drivers/gpu/drm/amd/amdgpu/amdgpu_psp.h|  12 ++
 drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c|  51 -
 drivers/gpu/drm/amd/amdgpu/amdgpu_ucode.c  |   6 +
 drivers/g

[pull] amdgpu, amdkfd drm-next-5.3

2019-07-09 Thread Alex Deucher
Hi Dave, Daniel,

Fixes for 5.3.  Mostly fixes for Navi10 and a few other odds and ends.
Also contains a patch to ease the merge with hmm.  Trivial merge fix
when the trees are merged:

diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c 
b/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c
@@ -783,7 +783,7 @@ int amdgpu_ttm_tt_get_user_pages(struct ttm_tt *ttm, struct 
page **pages)
0 : range->flags[HMM_PFN_WRITE];
range->pfn_flags_mask = 0;
range->pfns = pfns;
 - hmm_range_register(range, mm, start,
 + hmm_range_register(range, mirror, start,
   start + ttm->num_pages * PAGE_SIZE, PAGE_SHIFT);


The following changes since commit 440e80ce02cde7b810e4eb555768c2d77e7a27c8:

  drm/amd/display: fix a couple of spelling mistakes (2019-06-27 11:22:57 -0500)

are available in the Git repository at:

  git://people.freedesktop.org/~agd5f/linux tags/drm-next-5.3-2019-07-09

for you to fetch changes up to 7f963d9f69bf28d639013630da30d7a4c95edd5d:

  drm/amdgpu/navi10: add uclk activity sensor (2019-07-09 17:43:36 -0500)


drm-next-5.3-2019-07-09:

amdgpu:
- GPU reset for navi10
- Powerplay fixes for navi10
- GFX fixes for navi10
- Prepare for hmm_range_register API change
- XGMI fixes
- clang warning fixes
- Fixes for various kconfig scenarios
- Misc fixes and cleanups

amdkfd:
- Add workaround for soft hangs with oversubscribed runlists
- Remove duplicated pcie atomics request


Alex Deucher (8):
  drm/amdgpu/gfx9: use reset default for PA_SC_FIFO_SIZE
  drm/amdgpu/gfx10: use reset default for PA_SC_FIFO_SIZE
  drm/amdgpu/display: fix interrupt client id for navi
  drm/amdgpu: properly guard DC support in navi code
  drm/amdgpu/psp11: simplify the ucode register logic
  drm/amdgpu: add missing documentation on new module parameters
  drm/amdgpu: properly guard the generic discovery code
  drm/amdgpu/navi10: add uclk activity sensor

Arnd Bergmann (4):
  amdgpu: make pmu support optional
  drm/amd/display: dcn20: include linux/delay.h
  drm/amd/powerplay: vega20: fix uninitialized variable use
  drm/amd/display: avoid 64-bit division

Evan Quan (2):
  drm/amdgpu: fix MGPU fan boost enablement for XGMI reset
  drm/amd/powerplay: use hardware fan control if no powerplay fan table

Felix Kuehling (5):
  drm/amdkfd: Print a warning when the runlist becomes oversubscribed
  drm/amdgpu: Use FENCE_OWNER_KFD in process_sync_pds_resv
  drm/amdgpu: Fix tracking of invalid userptrs
  drm/amdkfd: Add chained_runlist_idle_disable flag to pm4_mes_runlist
  drm/amdkfd: Disable idle optimization for chained runlist

Flora Cui (1):
  drm/amdgpu: fix scheduler timeout calc

Fuqian Huang (1):
  drm/amdgpu: Use kmemdup rather than duplicating its implementation

Jack Xiao (5):
  drm/amdgpu: add field indicating if has PCIE atomics support
  drm/amdgpu: enable PCIE atomics ops support
  drm/amdkfd: remove duplicated PCIE atomics request
  drm/amdkfd: remove an unused variable
  drm/amd/powerplay: increase waiting time for smu response

Kevin Wang (3):
  drm/amd/powerplay: add baco smu reset function for smu11
  drm/amdgpu: add mode1 (psp) reset for navi asic
  drm/amd/powerplay: add temperature sensor support for navi10

Lyude Paul (1):
  drm/amdgpu: Don't skip display settings in hwmgr_resume()

Marek Olšák (3):
  drm/amdgpu: fix transform feedback GDS hang on gfx10 (v2)
  drm/amdgpu: handle AMDGPU_IB_FLAG_RESET_GDS_MAX_WAVE_ID on gfx10
  drm/amdgpu: don't invalidate caches in RELEASE_MEM, only do the writeback

Nathan Chancellor (4):
  drm/amdgpu/mes10.1: Fix header guard
  drm/amd/powerplay: Use memset to initialize metrics structs
  drm/amd/powerplay: Zero initialize freq in smu_v11_0_get_current_clk_freq
  drm/amd/powerplay: Zero initialize current_rpm in 
vega20_get_fan_speed_percent

Philip Yang (1):
  drm/amdgpu: Prepare for hmm_range_register API change (v2)

Yrjan Skrimstad (1):
  drm/amd/powerplay/smu7_hwmgr: replace blocking delay with non-blocking

tiancyin (1):
  drm/amd/powerplay: update smu11_driver_if_navi10.h

xinhui pan (1):
  drm/amdgpu: Disable ras features on all IPs before gpu reset

 drivers/gpu/drm/amd/amdgpu/Makefile|  4 +-
 drivers/gpu/drm/amd/amdgpu/amdgpu.h|  5 ++
 drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.c |  7 ++
 drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.h |  1 +
 drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c   | 13 ++-
 drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c |  2 +-
 drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 38 -
 drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c| 26 +-
 drivers/gpu/drm/amd/amdgpu/amdgpu_gds.h|  3 +-
 drivers/gpu/drm/amd/amdgpu/amdgp

Re: [pull] amdgpu, amdkfd drm-next-5.3

2019-06-04 Thread Daniel Vetter
On Tue, Jun 4, 2019 at 4:46 PM Alex Deucher  wrote:
>
> On Mon, Jun 3, 2019 at 11:36 AM Daniel Vetter  wrote:
> >
> > On Thu, May 30, 2019 at 12:09 AM Alex Deucher  wrote:
> > >
> > > Hi Dave, Daniel,
> > >
> > > New stuff for 5.3:
> > > - Add new thermal sensors for vega asics
> > > - Various RAS fixes
> > > - Add sysfs interface for memory interface utilization
> > > - Use HMM rather than mmu notifier for user pages
> > > - Expose xgmi topology via kfd
> > > - SR-IOV fixes
> > > - Fixes for manual driver reload
> > > - Add unique identifier for vega asics
> > > - Clean up user fence handling with UVD/VCE/VCN blocks
> > > - Convert DC to use core bpc attribute rather than a custom one
> > > - Add GWS support for KFD
> > > - Vega powerplay improvements
> > > - Add CRC support for DCE 12
> > > - SR-IOV support for new security policy
> > > - Various cleanups
> >
> > > Chunming Zhou (1):
> > >   drm/amdgpu: add DRIVER_SYNCOBJ_TIMELINE to amdgpu
> >
> > This unconditionally enables timeline syncobj support, Which I thought
> > we've decided to hold back behind some module_param_named_unsafe or
> > experimental Kconfig, at least until KHR ratifies the extensions and
> > everyone can publish the mesa patches. This is kinda uapi without
> > userspace as-is ... also not on your summary, or I'm blind.
>
> Sorry, for some reason I had it in my head that we were going to start
> enabling this is 5.3.  Maybe I was mixing it up with something else.
> I need to re-read the thread.  I can send an updated pull with a
> revert.

Yeah I think the idea was to get this in, but somewhere hidden until
it's released by khr. I think Kconfig/module option/ifdef or just not
yet merging the patch with the driver flag where discussed. Last one I
think is what Lionel plans to do for i915. Dave already merged your
pull, but it's -next and far from merge window so totally fine if you
only take care of this on the next regular feature pull imo.
-Daniel
-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Re: [pull] amdgpu, amdkfd drm-next-5.3

2019-06-04 Thread Alex Deucher
On Mon, Jun 3, 2019 at 11:36 AM Daniel Vetter  wrote:
>
> On Thu, May 30, 2019 at 12:09 AM Alex Deucher  wrote:
> >
> > Hi Dave, Daniel,
> >
> > New stuff for 5.3:
> > - Add new thermal sensors for vega asics
> > - Various RAS fixes
> > - Add sysfs interface for memory interface utilization
> > - Use HMM rather than mmu notifier for user pages
> > - Expose xgmi topology via kfd
> > - SR-IOV fixes
> > - Fixes for manual driver reload
> > - Add unique identifier for vega asics
> > - Clean up user fence handling with UVD/VCE/VCN blocks
> > - Convert DC to use core bpc attribute rather than a custom one
> > - Add GWS support for KFD
> > - Vega powerplay improvements
> > - Add CRC support for DCE 12
> > - SR-IOV support for new security policy
> > - Various cleanups
>
> > Chunming Zhou (1):
> >   drm/amdgpu: add DRIVER_SYNCOBJ_TIMELINE to amdgpu
>
> This unconditionally enables timeline syncobj support, Which I thought
> we've decided to hold back behind some module_param_named_unsafe or
> experimental Kconfig, at least until KHR ratifies the extensions and
> everyone can publish the mesa patches. This is kinda uapi without
> userspace as-is ... also not on your summary, or I'm blind.

Sorry, for some reason I had it in my head that we were going to start
enabling this is 5.3.  Maybe I was mixing it up with something else.
I need to re-read the thread.  I can send an updated pull with a
revert.

Alex
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Re: [pull] amdgpu, amdkfd drm-next-5.3

2019-06-03 Thread Daniel Vetter
On Thu, May 30, 2019 at 12:09 AM Alex Deucher  wrote:
>
> Hi Dave, Daniel,
>
> New stuff for 5.3:
> - Add new thermal sensors for vega asics
> - Various RAS fixes
> - Add sysfs interface for memory interface utilization
> - Use HMM rather than mmu notifier for user pages
> - Expose xgmi topology via kfd
> - SR-IOV fixes
> - Fixes for manual driver reload
> - Add unique identifier for vega asics
> - Clean up user fence handling with UVD/VCE/VCN blocks
> - Convert DC to use core bpc attribute rather than a custom one
> - Add GWS support for KFD
> - Vega powerplay improvements
> - Add CRC support for DCE 12
> - SR-IOV support for new security policy
> - Various cleanups

> Chunming Zhou (1):
>   drm/amdgpu: add DRIVER_SYNCOBJ_TIMELINE to amdgpu

This unconditionally enables timeline syncobj support, Which I thought
we've decided to hold back behind some module_param_named_unsafe or
experimental Kconfig, at least until KHR ratifies the extensions and
everyone can publish the mesa patches. This is kinda uapi without
userspace as-is ... also not on your summary, or I'm blind.
-Daniel
-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

drop drmP.h usage? [Was: [pull] amdgpu, amdkfd drm-next-5.3]

2019-05-29 Thread Sam Ravnborg
Hi Alex et all.

> - Various cleanups

Any chance to persuade one of you guys to sweep through the amd / raedeon
tree and drop use of the deprecated header drmP.h?

Status at the moment (drm-misc-next):
$git grep drmP | cut -d '/' -f 1  | uniq -c | sort -n | tail -n 10
 11 meson
 12 mediatek
 13 vmwgfx
 15 rockchip
 16 sti
 18 sun4i
 24 exynos
 27 nouveau
103 radeon
110 amd

nouveau is already taken care of, the cleanup is in their tree.
amd and radeon are the two "worst" drivers in this respect at the
moment.

Thanks,
Sam
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

[pull] amdgpu, amdkfd drm-next-5.3

2019-05-29 Thread Alex Deucher
Hi Dave, Daniel,

New stuff for 5.3:
- Add new thermal sensors for vega asics
- Various RAS fixes
- Add sysfs interface for memory interface utilization
- Use HMM rather than mmu notifier for user pages
- Expose xgmi topology via kfd
- SR-IOV fixes
- Fixes for manual driver reload
- Add unique identifier for vega asics
- Clean up user fence handling with UVD/VCE/VCN blocks
- Convert DC to use core bpc attribute rather than a custom one
- Add GWS support for KFD
- Vega powerplay improvements
- Add CRC support for DCE 12
- SR-IOV support for new security policy
- Various cleanups

The following changes since commit a188339ca5a396acc588e5851ed7e19f66b0ebd9:

  Linux 5.2-rc1 (2019-05-19 15:47:09 -0700)

are available in the Git repository at:

  git://people.freedesktop.org/~agd5f/linux drm-next-5.3

for you to fetch changes up to cf401e2856b27b2deeada498eab864e2a50cf219:

  drm/amdkfd: fix null pointer dereference on dev (2019-05-29 16:50:09 -0500)


Alex Deucher (3):
  drm/amdgpu/vega20: use mode1 reset for RAS and XGMI
  drm/amdgpu: use pcie_bandwidth_available rather than open coding it
  drm/amdgpu/soc15: skip reset on init

Amber Lin (1):
  drm/amdkfd: Add domain number into gpu_id

Anthony Koo (1):
  drm/amd/display: fix multi display seamless boot case

Aric Cyr (5):
  drm/amd/display: 3.2.28
  drm/amd/display: 3.2.29
  drm/amd/display: 3.2.30
  drm/amd/display: Use VCP for extended colorimetry
  drm/amd/display: 3.2.31

Bhawanpreet Lakha (1):
  drm/amd/powerplay: Fix maybe-uninitialized in get_ppfeature_status

Charlene Liu (5):
  drm/amd/display: add SW_USE_I2C_REG request.
  drm/amd/display: color space ycbcr709 support
  drm/amd/display: reset retimer/redriver below 340Mhz
  drm/amd/display: define v_total_min and max parameters
  drm/amd/display: enabling stream after HPD low to high happened

Chengming Gui (2):
  drm/amd/powerplay: Enable "disable dpm" feature to support swSMU debug 
(v2)
  drm/amd/powerplay: Fix code error for translating int type to bool type 
correctly

Chris Park (2):
  drm/amd/display: Support AVI InfoFrame V3 and V4
  drm/amd/display: Define Byte 14 on AVI InfoFrame

Christian König (2):
  drm/amdgpu: rename amdgpu_prime.[ch] into amdgpu_dma_buf.[ch]
  drm/amdgpu: remove static GDS, GWS and OA allocation

Chunming Zhou (1):
  drm/amdgpu: add DRIVER_SYNCOBJ_TIMELINE to amdgpu

Colin Ian King (2):
  drm/amdgpu: fix spelling mistake "retrived" -> "retrieved"
  drm/amdkfd: fix null pointer dereference on dev

Dmytro Laktyushkin (4):
  drm/amd/display: move signal type out of otg dlg params
  drm/amd/display: stop external access to internal optc sync params
  drm/amd/display: fix acquire_first_split_pipe function
  drm/amd/display: add null checks and set update flags

Emily Deng (2):
  drm/amdgpu: fix unload driver fail
  drm/amdgpu: Need to set the baco cap before baco reset

Eric Yang (2):
  drm/amd/display: Set dispclk and dprefclock directly
  drm/amd/display: move back vbios cmd table for set dprefclk

Evan Quan (26):
  drm/amd/powerplay: support hotspot/memory critical limit values
  drm/amd/powerplay: support temperature emergency max values
  drm/amd/powerplay: support SMU metrics table on Vega12
  drm/amd/powerplay: expose current hotspot and memory temperatures V2
  drm/amd/powerplay: support hwmon temperature channel labels V2
  drm/amd/powerplay: expose Vega12 current power
  drm/amd/powerplay: expose Vega12 current gpu activity
  drm/amd/powerplay: expose Vega20 realtime memory utilization
  drm/amd/powerplay: expose Vega12 realtime memory utilization
  drm/amd/powerplay: expose SMU7 asics realtime memory utilization
  drm/amdgpu: add new sysfs interface for memory realtime utilization
  drm/amdgpu: enable separate timeout setting for every ring type V4
  drm/amd/powerplay: fix Vega10 mclk/socclk voltage link setup
  drm/amd/powerplay: valid Vega10 DPMTABLE_OD_UPDATE_VDDC settings V2
  drm/amd/powerplay: avoid repeat AVFS enablement/disablement
  drm/amd/powerplay: update Vega10 power state on OD
  drm/amd/powerplay: force to update all clock tables on OD reset
  drm/amd/powerplay: update Vega10 ACG Avfs Gb parameters
  drm/amd/powerplay: drop unnecessary sw smu check
  drm/amd/powerplay: drop redundant smu call
  drm/amd/powerplay: support ppfeatures sysfs interface on sw smu routine
  drm/amd/powerplay: honor hw limit on fetching metrics data
  drm/amd/powerplay: support uclk activity retrieve on sw smu routine
  drm/amd/powerplay: support sw smu hotspot and memory temperature retrieval
  drm/amd/powerplay: fix sw SMU wrong UVD/VCE powergate setting
  drm/amd/powerplay: enable ppfeaturemask module parameter support on Vega20

Felix Kuehling (3):
  drm/amdgpu: Rese