[Bug 26195] Green screen on HDMI with RV730

2010-04-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=26195 --- Comment #26 from Andy Green a...@warmcat.com 2010-04-13 13:56:48 PDT --- Created an attachment (id=34978) -- (https://bugs.freedesktop.org/attachment.cgi?id=34978) Xorg log with overscanned HDMI out (no green cast!) on Aspire 8935 Did you

[Bug 27634] New: [r300g] 0 AD graphic problem and crash

2010-04-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27634 Summary: [r300g] 0 AD graphic problem and crash Product: Mesa Version: git Platform: Other OS/Version: All Status: NEW Severity: normal Priority: medium

[Bug 27634] [r300g] 0 AD graphic problem and crash

2010-04-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27634 --- Comment #1 from adr...@gmail.com 2010-04-14 08:06:46 PDT --- Created an attachment (id=35008) -- (https://bugs.freedesktop.org/attachment.cgi?id=35008) Log 2 -- Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email

[Bug 27634] [r300g] 0 AD graphic problem and crash

2010-04-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27634 --- Comment #2 from adr...@gmail.com 2010-04-14 08:07:16 PDT --- Created an attachment (id=35009) -- (https://bugs.freedesktop.org/attachment.cgi?id=35009) Xorg log -- Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email

[Bug 27634] [r300g] 0 AD graphic problem and crash

2010-04-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27634 --- Comment #3 from adr...@gmail.com 2010-04-14 08:07:38 PDT --- Created an attachment (id=35010) -- (https://bugs.freedesktop.org/attachment.cgi?id=35010) Graphic problem -- Configure bugmail:

[Bug 27634] [r300g] 0 AD graphic problem and crash

2010-04-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27634 --- Comment #4 from Marek Olšák mar...@gmail.com 2010-04-14 09:50:26 PDT --- I've hopefully fixed the issue with dummy shaders causing crashes in git. However, I don't think we can do anything with the failing shader right now because it

[Bug 27644] New: radeon KMS causes corrupt VGA output on X1400

2010-04-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27644 Summary: radeon KMS causes corrupt VGA output on X1400 Product: DRI Version: unspecified Platform: x86 (IA32) OS/Version: Linux (All) Status: NEW Severity: normal

[Bug 27644] radeon KMS causes corrupt VGA output on X1400

2010-04-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27644 --- Comment #1 from Alex Deucher ag...@yahoo.com 2010-04-14 11:59:07 PDT --- does radeon.new_pll=0 also fix the problem? -- Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email --- You are receiving this mail because:

[Bug 27644] radeon KMS causes corrupt VGA output on X1400

2010-04-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27644 --- Comment #2 from Cameron Gorrie sastr...@gmail.com 2010-04-14 12:26:43 PDT --- (In reply to comment #1) does radeon.new_pll=0 also fix the problem? Alex, it does not. I replaced radeon.modeset=0 vga=771 with radeon.new_pll=0. Cam --

[Bug 27652] ctx-Meta-Save is NULL in _mesa_meta_begin

2010-04-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27652 Tormod Volden bugzi09.fdo.tor...@xoxy.net changed: What|Removed |Added URL|

[Bug 27644] radeon KMS causes corrupt VGA output on X1400

2010-04-14 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27644 --- Comment #4 from Cameron Gorrie sastr...@gmail.com 2010-04-14 22:49:24 PDT --- Created an attachment (id=35049) -- (https://bugs.freedesktop.org/attachment.cgi?id=35049) avivotool regs all output UMS -- Configure bugmail:

[Bug 27524] linux-2.6.33.2 radeondrm_fb, rv350, garbled console on PowerBook G4

2010-04-15 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27524 --- Comment #13 from Michel Dänzer mic...@daenzer.net 2010-04-15 01:27:05 PDT --- (In reply to comment #12) Ok, tell me what you want me to dump, when you want me to dump it, and how. Build radeontool from

[Bug 27644] radeon KMS causes corrupt VGA output on X1400

2010-04-15 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27644 --- Comment #8 from willjcroz willjc...@yahoo.co.uk 2010-04-15 02:14:17 PDT --- Created an attachment (id=35053) -- (https://bugs.freedesktop.org/attachment.cgi?id=35053) avitool regs all ums.regs -- Configure bugmail:

[Bug 27644] radeon KMS causes corrupt VGA output on X1400

2010-04-15 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27644 --- Comment #9 from willjcroz willjc...@yahoo.co.uk 2010-04-15 02:15:00 PDT --- Created an attachment (id=35054) -- (https://bugs.freedesktop.org/attachment.cgi?id=35054) avitool regs all kms.regs -- Configure bugmail:

[Bug 26639] [radeon KMS] switching to res 1024x768 kills output

2010-04-15 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=26639 --- Comment #16 from Tobias Jakobi liquid.a...@gmx.net 2010-04-15 15:47:54 PDT --- Yesterday I updated libdrm, mesa and xf86-video-ati to git master tip and also pulled the latest stuff from drm-radeon-testing. Issue is still there. --

[Bug 27702] New: [KMS] rv280 segfaults in texdown becnhmark

2010-04-16 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27702 Summary: [KMS] rv280 segfaults in texdown becnhmark Product: Mesa Version: git Platform: x86 (IA32) OS/Version: Linux (All) Status: NEW Severity: normal Priority:

[Bug 27702] [KMS] rv280 segfaults in texdown becnhmark

2010-04-16 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27702 --- Comment #5 from Andrew Randrianasulu rand...@mail.ru 2010-04-16 12:57:37 PDT --- n00b b was for border. Thanks to MrCooper on IRC. -- Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email --- You are

[Bug 27708] New: [KMS] Repeated EDID errors despite everything working

2010-04-16 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27708 Summary: [KMS] Repeated EDID errors despite everything working Product: DRI Version: XOrg CVS Platform: x86-64 (AMD64) OS/Version: Linux (All) Status: NEW Severity: minor

[Bug 24047] s3tc broken on r600

2010-04-17 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=24047 jonathan bioinfornat...@gmail.com changed: What|Removed |Added Status|VERIFIED|REOPENED

[Bug 27452] Evergreen KMS DRM sets bizarre 1922x1200 resolution

2010-04-17 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27452 --- Comment #6 from Dave Witbrodt dawit...@sbcglobal.net 2010-04-17 17:08:10 PDT --- Created an attachment (id=35137) -- (https://bugs.freedesktop.org/attachment.cgi?id=35137) dmesg from 2.6.34-rc4 (+ recent drm-radeon-testing) with drm.debug=7

[Bug 27723] New: Vtx endian setup error under big endain CPU

2010-04-18 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27723 Summary: Vtx endian setup error under big endain CPU Product: Mesa Version: unspecified Platform: PowerPC OS/Version: other Status: NEW Severity: normal Priority:

[Bug 27402] [r300g] Earth textures in celestia are partially corrupted in all rendering paths

2010-04-18 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27402 Chris Rankin ranki...@googlemail.com changed: What|Removed |Added Status|NEW |RESOLVED

[Bug 27452] Evergreen KMS DRM sets bizarre 1922x1200 resolution

2010-04-19 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27452 --- Comment #7 from Christian S. m...@apexo.de 2010-04-19 04:57:20 PDT --- Created an attachment (id=35158) -- (https://bugs.freedesktop.org/attachment.cgi?id=35158) /sys/class/drm/card0-HDMI Type A-1/edid -- Configure bugmail:

[Bug 27739] New: build in a separate directory includes config.h from build directory

2010-04-19 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27739 Summary: build in a separate directory includes config.h from build directory Product: DRI Version: DRI CVS Platform: x86-64 (AMD64) OS/Version: Linux (All)

[Bug 27739] build in a separate directory includes config.h from source directory

2010-04-19 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27739 Michal Suchanek hramr...@centrum.cz changed: What|Removed |Added Summary|build in a separate |build in a separate

[Bug 26926] [KMS][RV635] broken colors/fonts on DVI-0 (DVI-1 is OK)

2010-04-19 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=26926 --- Comment #10 from Rafał Miłecki zaj...@gmail.com 2010-04-19 11:48:24 PDT --- Created an attachment (id=35168) -- (https://bugs.freedesktop.org/attachment.cgi?id=35168) RV635 ROM -- Configure bugmail:

[Bug 26926] [KMS][RV635] broken colors/fonts on DVI-0 (DVI-1 is OK)

2010-04-19 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=26926 --- Comment #11 from Rafał Miłecki zaj...@gmail.com 2010-04-19 11:50:48 PDT --- Can be duplicate of bug #27478, will try to check if I'll get access to this RV635. -- Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email

[Bug 22576] [KMS] mesa demo spectex broken on rv280

2010-04-19 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=22576 --- Comment #6 from Andrew Randrianasulu rand...@mail.ru 2010-04-19 22:51:34 PDT --- Guess i can mark bug 22575 ( [KMS] mesa demo projtex broken on rv280 ) as duplicate of this, because projtex works after same run UMS/glxgears first fix?

[Bug 27756] New: [KMS] sauerbraten crash with drmRadeonCmdBuffer: -22 - Texture of unit 0 needs 8320 bytes but is 8192

2010-04-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27756 Summary: [KMS] sauerbraten crash with drmRadeonCmdBuffer: -22 - Texture of unit 0 needs 8320 bytes but is 8192 Product: Mesa Version: git Platform: x86 (IA32) OS/Version:

[Bug 27507] [KMS] 0ad crashes with drmRadeonCmdBuffer: -22 - Buffer too small for color buffer 0

2010-04-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27507 Fabio Pedretti fabio@libero.it changed: What|Removed |Added Summary|OpenGL applications crash |[KMS] 0ad crashes

[Bug 27759] Celestia 1.6.0 misplaces letters in text in window, odd misrendering of planet features

2010-04-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27759 --- Comment #1 from Alex Buell alex.bu...@munted.org.uk 2010-04-20 12:28:39 PDT --- Created an attachment (id=35184) -- (https://bugs.freedesktop.org/attachment.cgi?id=35184) Screenshot #2 -- Configure bugmail:

[Bug 27759] Celestia 1.6.0 misplaces letters in text in window, odd misrendering of planet features

2010-04-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27759 --- Comment #2 from Alex Buell alex.bu...@munted.org.uk 2010-04-20 12:29:15 PDT --- Created an attachment (id=35185) -- (https://bugs.freedesktop.org/attachment.cgi?id=35185) X11 configuration file -- Configure bugmail:

[Bug 27759] Celestia 1.6.0 odd misrendering of planet features

2010-04-21 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27759 --- Comment #4 from Alex Buell alex.bu...@munted.org.uk 2010-04-21 01:45:07 PDT --- Unfortunately, Celestia 1.6.0 (exact same tarball, exact same program) works perfectly on another of my computers) but I will check with the Celestia people,

[Bug 27443] radeonFreeTexImageData: Assertion `!image-base.Data' failed when running Ogre3D samples

2010-04-21 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27443 --- Comment #3 from Laurent carlier lordhea...@gmail.com 2010-04-21 06:12:26 PDT --- I've commented the assert, and now all is fine. -- Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email --- You are receiving this mail

[Bug 26428] [KMS] doom3-demo aborts early on rv280

2010-04-21 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=26428 --- Comment #9 from Andrew Randrianasulu rand...@mail.ru 2010-04-21 08:27:36 PDT --- Same error with drm-radeon-testing kernel up to commit 10fd883ce384706f88554a0b08cc4d63345e7d8b Author: Dave Airlie airl...@redhat.com Date: Tue Apr 20

[Bug 25297] R600: glEdgeFlag doesn't work

2010-04-21 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=25297 Alain Perrot alain.per...@gmail.com changed: What|Removed |Added CC|

[Bug 22576] [KMS] mesa demo spectex broken on rv280

2010-04-21 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=22576 --- Comment #8 from Andrew Randrianasulu rand...@mail.ru 2010-04-21 17:48:49 PDT --- Well, no need for 2.6.32 or something like this, 2.6.34-rc5 (current drm-radeon-testing) works just fine, as fix for this bug. But UMS itself seems broken, i

[Bug 22575] [KMS] mesa demo projtex broken on rv280

2010-04-21 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=22575 Andrew Randrianasulu rand...@mail.ru changed: What|Removed |Added Status|NEW |RESOLVED

[Bug 27810] R600: using =2.6.34-rc4 JackKeane and Ankh2 crash at start, after (rendered) intro sequences

2010-04-23 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27810 --- Comment #1 from Nils Kneuper crazy-ivano...@gmx.net 2010-04-23 03:32:32 PDT --- Created an attachment (id=35250) -- (https://bugs.freedesktop.org/attachment.cgi?id=35250) dmesg output for my system -- Configure bugmail:

[Bug 27517] KMS breaks 3D on R200

2010-04-23 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27517 --- Comment #6 from Pekka Oinas burne...@gmail.com 2010-04-23 15:46:16 PDT --- I am also affected by this. It is caused by incorrect fake texture handling in CS checker or something. More and a possible fix (it just disables texture checking)

[Bug 27822] [REGR] Soft lockup with [TTM] Buffer eviction failed on resume

2010-04-24 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27822 --- Comment #1 from Alex Deucher ag...@yahoo.com 2010-04-24 09:21:56 PDT --- Any chance you can bisect the problematic commit? Try drm-linus as well; if the bug is not there it will be easier to track down since it's likely something in

[Bug 26541] flickering texture and chirring on OpenArena with highest texture

2010-04-24 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=26541 --- Comment #5 from Alex Deucher ag...@yahoo.com 2010-04-24 09:25:03 PDT --- Have you changed the mesa version installed? This is likely a bug in the 3D driver rather than the ddx (xf86-video-ati). -- Configure bugmail:

[Bug 27729] [r300g - RV530] main/mipmap.c:144: do_row: Assertion `comps = 1' failed

2010-04-26 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27729 --- Comment #4 from Fabio Pedretti fabio@libero.it 2010-04-26 02:14:33 PDT --- Created an attachment (id=35288) -- (https://bugs.freedesktop.org/attachment.cgi?id=35288) swrastg backtrace -- Configure bugmail:

[Bug 27851] Major slowdowns in Heroes of Newerth with r300g driver.

2010-04-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27851 --- Comment #1 from Pavel Ondračka dra...@centrum.cz 2010-04-27 02:17:58 PDT --- Created an attachment (id=35303) -- (https://bugs.freedesktop.org/attachment.cgi?id=35303) console output -- Configure bugmail:

[Bug 27851] Major slowdowns in Heroes of Newerth with r300g driver.

2010-04-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27851 Pavel Ondračka dra...@centrum.cz changed: What|Removed |Added Keywords||regression --

[Bug 27851] Major slowdowns in Heroes of Newerth with r300g driver.

2010-04-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27851 --- Comment #2 from Marek Olšák mar...@gmail.com 2010-04-27 03:02:18 PDT --- Please attach the dmesg output. -- Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email --- You are receiving this mail because: --- You are

[Bug 27851] Major slowdowns in Heroes of Newerth with r300g driver.

2010-04-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27851 --- Comment #3 from Pavel Ondračka dra...@centrum.cz 2010-04-27 03:11:08 PDT --- Created an attachment (id=35305) -- (https://bugs.freedesktop.org/attachment.cgi?id=35305) dmesg -- Configure bugmail:

[Bug 27851] Major slowdowns in Heroes of Newerth with r300g driver.

2010-04-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27851 Marek Olšák mar...@gmail.com changed: What|Removed |Added Status|NEW |RESOLVED

[Bug 27858] New: [r300g] wine game crashes

2010-04-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27858 Summary: [r300g] wine game crashes Product: Mesa Version: git Platform: x86 (IA32) OS/Version: Linux (All) Status: NEW Severity: major Priority: medium

[Bug 27729] [r300g - RV530] main/mipmap.c:144: do_row: Assertion `comps = 1' failed

2010-04-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27729 --- Comment #6 from Brian Paul brian.e.p...@gmail.com 2010-04-27 07:30:15 PDT --- I think I have this fixed now. Can you re-test with mesa commit db14a8022a2a957c83b1fe33a84af3cdb1952d68 or later? -- Configure bugmail:

[Bug 27729] [r300g - RV530] main/mipmap.c:144: do_row: Assertion `comps = 1' failed

2010-04-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27729 --- Comment #7 from Fabio Pedretti fabio@libero.it 2010-04-27 08:31:26 PDT --- (In reply to comment #6) I think I have this fixed now. Can you re-test with mesa commit db14a8022a2a957c83b1fe33a84af3cdb1952d68 or later? With

[Bug 27729] [r300g - RV530] main/mipmap.c:144: do_row: Assertion `comps = 1' failed

2010-04-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27729 --- Comment #8 from Brian Paul brian.e.p...@gmail.com 2010-04-27 08:43:18 PDT --- Created an attachment (id=35312) View: https://bugs.freedesktop.org/attachment.cgi?id=35312 Review: https://bugs.freedesktop.org/review?bug=27729attachment=35312

[Bug 27729] [r300g - RV530] main/mipmap.c:144: do_row: Assertion `comps = 1' failed

2010-04-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27729 --- Comment #9 from Fabio Pedretti fabio@libero.it 2010-04-27 09:03:57 PDT --- (In reply to comment #8) Created an attachment (id=35312) View: https://bugs.freedesktop.org/attachment.cgi?id=35312 Review:

[Bug 27729] [r300g - RV530] main/mipmap.c:144: do_row: Assertion `comps = 1' failed

2010-04-27 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27729 --- Comment #10 from Fabio Pedretti fabio@libero.it 2010-04-27 09:13:58 PDT --- (gdb) p index $2 = 1 (gdb) p t-psizoutindex $3 = -1 (gdb) p t-prevInstWrotePsiz $4 = 0 '\000' (gdb) p t-outputMapping[index] $5 = 19828484 Other vars?

[Bug 27729] [r300g - RV530] main/mipmap.c:144: do_row: Assertion `comps = 1' failed

2010-04-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27729 --- Comment #12 from Fabio Pedretti fabio@libero.it 2010-04-28 01:16:27 PDT --- Created an attachment (id=35316) -- (https://bugs.freedesktop.org/attachment.cgi?id=35316) swrastg debug output with ST_DEBUG=mesa,tgsi (In reply to comment

[Bug 27866] New: d-r-t crashes at radeon_bo_unref()

2010-04-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27866 Summary: d-r-t crashes at radeon_bo_unref() Product: DRI Version: XOrg CVS Platform: x86-64 (AMD64) OS/Version: Linux (All) Status: NEW Severity: normal Priority:

[Bug 27868] New: [r600] on new campaign, Vegastrike crashes or freezes Xorg

2010-04-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27868 Summary: [r600] on new campaign, Vegastrike crashes or freezes Xorg Product: Mesa Version: unspecified Platform: x86-64 (AMD64) OS/Version: Linux (All) Status: NEW

[Bug 27868] [r600] on new campaign, Vegastrike crashes or freezes Xorg

2010-04-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27868 --- Comment #2 from Nicolas Kaiser ni...@nikai.net 2010-04-28 05:41:29 PDT --- Created an attachment (id=35320) -- (https://bugs.freedesktop.org/attachment.cgi?id=35320) Xorg.0.log -- Configure bugmail:

[Bug 27576] NWN text is only partially rendered (KMS only)

2010-04-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27576 Stephen E. Baker cyco...@hotmail.com changed: What|Removed |Added Summary|NWN text is only partially |NWN text is only

[Bug 27729] [r300g - RV530] main/mipmap.c:144: do_row: Assertion `comps = 1' failed

2010-04-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27729 --- Comment #13 from Brian Paul brian.e.p...@gmail.com 2010-04-28 09:27:29 PDT --- I've moved some of the debug code to get more useful info from ST_DEBUG=mesa,tgsi. Can you repeat the test with the latest Mesa code (commit

[Bug 27822] [REGR] Soft lockup with [TTM] Buffer eviction failed on resume

2010-04-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27822 --- Comment #2 from Rafał Miłecki zaj...@gmail.com 2010-04-28 11:11:57 PDT --- (In reply to comment #1) Any chance you can bisect the problematic commit? Try drm-linus as well; if the bug is not there it will be easier to track down since it's

[Bug 27822] [REGR] Soft lockup with [TTM] Buffer eviction failed on resume

2010-04-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27822 --- Comment #3 from Rafał Miłecki zaj...@gmail.com 2010-04-28 12:38:29 PDT --- I've manually checkouted: commit 6b8b1786a8c29ce6e32298b93ac8d4a18a2b11c4 Author: Jerome Glisse jgli...@redhat.com Date: Wed Apr 7 10:21:31 2010 +

[Bug 27822] [REGR] Soft lockup with [TTM] Buffer eviction failed on resume

2010-04-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27822 --- Comment #4 from Rafał Miłecki zaj...@gmail.com 2010-04-28 12:40:12 PDT --- Created an attachment (id=35324) -- (https://bugs.freedesktop.org/attachment.cgi?id=35324) dmesg using drm/radeon/kms: enable use of unmappable VRAM V2 With

[Bug 27866] d-r-t crashes at radeon_bo_unref()

2010-04-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27866 --- Comment #1 from Aidan Marks ai...@cisco.com 2010-04-28 14:05:53 PDT --- seems stable without radeon.dynpm=1. -- Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email --- You are receiving this mail because: --- You

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

2010-04-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27866 --- Comment #2 from Andy Furniss li...@andyfurniss.entadsl.com 2010-04-28 16:12:54 PDT --- (In reply to comment #1) seems stable without radeon.dynpm=1. I've just had one of these crashes - same trace, current drt, RV670 AGP 32 bit system

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

2010-04-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27866 --- Comment #4 from Andy Furniss li...@andyfurniss.entadsl.com 2010-04-28 16:44:19 PDT --- (In reply to comment #2) (In reply to comment #1) seems stable without radeon.dynpm=1. I've just had one of these crashes - same trace, current drt,

[Bug 27729] [r300g, mesa] gallium compressed texture problems

2010-04-29 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27729 --- Comment #16 from Marek Olšák mar...@gmail.com 2010-04-29 05:11:00 PDT --- (In reply to comment #15) In the meantime 95bfc8f32571751c5c9ec6d8e84f5e3c28d1b20e has been committed from Marek Olšák which is a subset of attached patch for r300g

[Bug 27887] New: r300g: depth textures + fbo = broken glClear()

2010-04-29 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27887 Summary: r300g: depth textures + fbo = broken glClear() Product: Mesa Version: git Platform: x86-64 (AMD64) OS/Version: Linux (All) Status: NEW Severity: normal

[Bug 27901] New: GLSL cos/sin functions broken on Mesa R600 driver

2010-04-29 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27901 Summary: GLSL cos/sin functions broken on Mesa R600 driver Product: Mesa Version: git Platform: All OS/Version: All Status: NEW Severity: normal Priority: medium

[Bug 27822] [REGR] Soft lockup with [TTM] Buffer eviction failed on resume

2010-04-29 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27822 --- Comment #5 from Rafał Miłecki zaj...@gmail.com 2010-04-29 14:20:21 PDT --- Result of first git bisect: There are only 'skip'ped commits left to test. The first bad commit could be any of: 82c5da6bf8b55a931b042fb531083863d26c8020

[Bug 27904] New: r300g segfaults on M56GL

2010-04-29 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27904 Summary: r300g segfaults on M56GL Product: Mesa Version: git Platform: Other OS/Version: All Status: NEW Severity: normal Priority: medium Component:

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

2010-04-29 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27866 --- Comment #5 from Andy Furniss li...@andyfurniss.entadsl.com 2010-04-29 16:16:27 PDT --- (In reply to comment #4) I can't (so far) crash with today's d-r-t. Could just be luck I suppose, but it only took 20 mins of openarena to get two

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

2010-04-29 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27866 --- Comment #6 from Alex Deucher ag...@yahoo.com 2010-04-29 16:46:19 PDT --- should be fixed with this commit: http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git;a=commitdiff;h=7a1ffce50373c177d3f6eecce52badc40c90e1dd -- Configure

[Bug 26570] [r6xx DRI] KMS enabled: GLSL white washing corruption (seen in Second Life)

2010-04-29 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=26570 --- Comment #6 from Shawn Starr shawn.st...@rogers.com 2010-04-29 20:05:07 PDT --- Still happening, its not compiling the GLSL shader programs. If it is it seems to take a very, very long time. It shows pretty much all white in game. --

[Bug 26570] [r6xx DRI] KMS enabled: GLSL white washing corruption (seen in Second Life)

2010-04-29 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=26570 --- Comment #7 from Shawn Starr shawn.st...@rogers.com 2010-04-29 20:05:33 PDT --- 2.6.34-rc5 + airlied drm branches, libdrm git master, mesa git master, ati DDX git master -- Configure bugmail:

[Bug 27822] [REGR] Soft lockup with [TTM] Buffer eviction failed on resume

2010-04-30 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27822 --- Comment #6 from Christian Schmidt schm...@digadd.de 2010-04-30 06:51:54 PDT --- Hi Rafał, Can you eleborate on what you see if resume fails? I do have some issues on my RV635, and testing with various kernels has shown me: == rc5 resume

[Bug 27822] [REGR] Soft lockup with [TTM] Buffer eviction failed on resume

2010-04-30 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27822 --- Comment #7 from Christian Schmidt schm...@digadd.de 2010-04-30 06:53:20 PDT --- Created an attachment (id=35344) -- (https://bugs.freedesktop.org/attachment.cgi?id=35344) dmesg of kernel where resume fails -- Configure bugmail:

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

2010-04-30 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27866 --- Comment #7 from Aidan Marks ai...@cisco.com 2010-04-30 16:24:38 PDT --- yes the crash appears gone thank you, however I am seeing a new issue after the pull. every now and again there is screen flicker. it is extremely fast, if you blink

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

2010-04-30 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27866 --- Comment #8 from Alex Deucher ag...@yahoo.com 2010-04-30 16:32:52 PDT --- (In reply to comment #7) yes the crash appears gone thank you, however I am seeing a new issue after the pull. every now and again there is screen flicker. it is

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

2010-05-01 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27866 --- Comment #9 from Andrew Randrianasulu rand...@mail.ru 2010-05-01 09:55:14 PDT --- It seems i have same issue (with d-r-t up to commit 7a1ffce50373c177d3f6eecce52badc40c90e1dd Author: Dave Airlie airl...@redhat.com Date: Thu Apr 29 18:37:59

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

2010-05-01 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27866 --- Comment #10 from Andrew Randrianasulu rand...@mail.ru 2010-05-01 09:59:04 PDT --- Created an attachment (id=35365) -- (https://bugs.freedesktop.org/attachment.cgi?id=35365) my /var/log/syslog Has some unrelated/old oopses, but anything

[Bug 27904] r300g segfaults on M56GL

2010-05-01 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27904 --- Comment #1 from Marek Olšák mar...@gmail.com 2010-05-01 16:02:04 PDT --- Could you please make realclean and rebuild the driver? The line numbers from the backtrace don't make sense, also the maxtemps parameter cannot possibly be 1, it should

[Bug 27904] r300g segfaults on M56GL

2010-05-01 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27904 Pavel Rojtberg pa...@rojtberg.net changed: What|Removed |Added Status|NEW |RESOLVED

[Bug 27904] r300g segfaults on M56GL

2010-05-01 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27904 --- Comment #3 from Marek Olšák mar...@gmail.com 2010-05-01 17:23:09 PDT --- Or you may install makedepend to avoid such issues (xutils-dev in deb-based distros). -- Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email

[Bug 27904] r300g segfaults on M56GL

2010-05-02 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27904 --- Comment #4 from Pavel Rojtberg pa...@rojtberg.net 2010-05-02 02:51:18 PDT --- I have makedepend installed. Is it called by the makefile automatically or have I to call it myself? -- Configure bugmail:

[Bug 27904] r300g segfaults on M56GL

2010-05-02 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27904 --- Comment #5 from Marek Olšák mar...@gmail.com 2010-05-02 03:32:25 PDT --- It's called automatically. I think we shouldn't chat like that in a bug report. If you have any questions, send me an email. -- Configure bugmail:

[Bug 27937] SEGV in r700_assembler.c next_ins() with RV670 kms

2010-05-02 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27937 --- Comment #2 from Andre Heider a.hei...@gmail.com 2010-05-02 04:34:15 PDT --- Created an attachment (id=35376) -- (https://bugs.freedesktop.org/attachment.cgi?id=35376) Xorg.0.log -- Configure bugmail:

[Bug 27704] [KMS] fbo_firecube broken on rv280 and current mesa

2010-05-03 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27704 --- Comment #1 from Andrew Randrianasulu rand...@mail.ru 2010-05-03 01:16:19 PDT --- mesa debug build from git master up to commit 738cb502371097fa6fb25f397a3cbcd6a5db020c Author: Dave Airlie airl...@redhat.com Date: Mon May 3 17:09:17 2010

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

2010-05-03 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27866 --- Comment #11 from Andrew Randrianasulu rand...@mail.ru 2010-05-03 02:51:00 PDT --- Created an attachment (id=35386) -- (https://bugs.freedesktop.org/attachment.cgi?id=35386) my .config May be this bug is config-dependent, i was unable to

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

2010-05-03 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27866 Jerome Glisse gli...@freedesktop.org changed: What|Removed |Added Status|NEW |RESOLVED

[Bug 8732] Composite breaks OpenGL

2010-05-03 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=8732 Dotan Cohen freedesktop-...@dotancohen.com changed: What|Removed |Added CC|

[Bug 8732] Composite breaks OpenGL

2010-05-03 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=8732 Dotan Cohen freedesktop-...@dotancohen.com changed: What|Removed |Added Status|RESOLVED|REOPENED

[Bug 8732] Composite breaks OpenGL

2010-05-03 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=8732 Alex Deucher ag...@yahoo.com changed: What|Removed |Added Status|REOPENED|RESOLVED

[Bug 8732] Composite breaks OpenGL

2010-05-03 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=8732 --- Comment #28 from Dotan Cohen freedesktop-...@dotancohen.com 2010-05-03 12:19:42 PDT --- One of the main points of DRI2 was to fix GL + composite. It will only work as expected with a DRI2 capable driver. DRI2 is not a workaround, it is the

[Bug 8732] Composite breaks OpenGL

2010-05-03 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=8732 --- Comment #29 from Julien Cristau jcris...@debian.org 2010-05-03 13:10:39 PDT --- --- Comment #28 from Dotan Cohen freedesktop-...@dotancohen.com 2010-05-03 12:19:42 PDT --- I will reopen that bug as a request to enable DRI in radeonhd.

[Bug 27887] r300g: depth textures + fbo = broken glClear()

2010-05-04 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27887 --- Comment #1 from Wiktor Janas wixorp...@gmail.com 2010-05-04 08:22:25 PDT --- Created an attachment (id=35412) View: https://bugs.freedesktop.org/attachment.cgi?id=35412 Review: https://bugs.freedesktop.org/review?bug=27887attachment=35412

[Bug 22758] Glest falls back to software rendering on radeon (rs690)

2010-05-04 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=22758 --- Comment #5 from Martin Garbolinski val-g...@wp.pl 2010-05-04 10:24:04 PDT --- (In reply to comment #4) Is this still an issue with mesa from mesa_7_7_branch? Sorry for late reply ... It seems to work ok with 7.7 and 7.8 ... However by ok

[Bug 27887] r300g: depth textures + fbo = broken glClear()

2010-05-04 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27887 Marek Olšák mar...@gmail.com changed: What|Removed |Added Status|NEW |RESOLVED

[Bug 27744] atombios stuck in loop - during suspend

2010-05-04 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27744 wessam wbaghd...@gmail.com changed: What|Removed |Added Platform|x86-64 (AMD64) |x86 (IA32) --- Comment #1

[Bug 27729] [r300g, mesa] gallium compressed texture problems

2010-05-05 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=27729 Fabio Pedretti fabio@libero.it changed: What|Removed |Added Attachment #35287|0 |1 is

  1   2   3   4   5   6   7   8   9   10   >