[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #18 from Timothee Besset --- https://github.com/EpicGames/UnrealEngine/pull/3901 -- You are receiving this mail because: You are the assignee for the bug.___ dri-devel

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #17 from Dave Airlie --- Enabling the UE4 linker script fixes this also. (It got disabled for 4.17). It appears that versions the symbols on the UE side. -- You are receiving this mail because: You are

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #16 from Timothee Besset --- Thanks for the help and thorough investigation! I will follow up from there with Epic to get this addressed UE4 side. -- You are receiving this mail because: You are the assignee for

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 Marek Olšák changed: What|Removed |Added Resolution|--- |NOTOURBUG

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #14 from Dave Airlie --- Yup once I hid the libelf symbols, it all works. -- You are receiving this mail because: You are the assignee for the bug.___ dri-devel

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #13 from Dave Airlie --- llvm seems fine, it seems to be libelf that is broken. I've noticed UE4 exports it's own libelf symbols but I haven't determined that is the problem yet. -- You are receiving this

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #12 from Marek Olšák --- .AMDGPU.config coming from LLVM is empty with UE4Editor. This assertion fails: diff --git a/src/amd/common/ac_binary.c b/src/amd/common/ac_binary.c index 618b5cf..2fbb575 100644 ---

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #11 from Marek Olšák --- Samuel, can you share here what you found out when you were looking into the issue? Thanks. -- You are receiving this mail because: You are the assignee for the

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #10 from Timothee Besset --- A similar crash happens if UE4 is started in Vulkan mode: https://gist.github.com/TTimo/28fa434142fb59e66ae469ed7f7ef034 SIGFPE happens because pipeline->shaders[4]->config.num_vgprs

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #9 from Timothee Besset --- (In reply to Samuel Pitoiset from comment #6) > The issue can't be reproduced with the traces here as well. But if you build > the UE4 editor from github, the issue can be reproduced with

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #8 from Samuel Pitoiset --- Yes for both. -- You are receiving this mail because: You are the assignee for the bug.___ dri-devel mailing list

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #7 from Marek Olšák --- Does the issue occur with any of these: R600_DEBUG=mono R600_DEBUG=nooptvariant -- You are receiving this mail because: You are the assignee for the

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #6 from Samuel Pitoiset --- The issue can't be reproduced with the traces here as well. But if you build the UE4 editor from github, the issue can be reproduced with LLVM6.0svn. -- You are receiving this

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-08 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #5 from Marek Olšák --- This can't be reproduce with LLVM 6.0svn and Radeon Fury. Trying LLVM 3.9... -- You are receiving this mail because: You are the assignee for the

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-07 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #4 from Timothee Besset --- Created attachment 133373 --> https://bugs.freedesktop.org/attachment.cgi?id=133373=edit apitrace FBlackCubeArrayTexture::InitRHI Another trace: same crash, but initializing a

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-07 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #3 from Timothee Besset --- Created attachment 133372 --> https://bugs.freedesktop.org/attachment.cgi?id=133372=edit apitrace Stepped through and commented out code until I could narrow down the last GL call that

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-02 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 --- Comment #2 from Timothee Besset --- hakzsam on irc was able to reproduce the issue on his system. also to note, hakzam uses a different LLVM version than I do. problem does not reproduce with nouveau driver, only radeonsi

[Bug 101977] UE4 4.17 causes Assertion `G_0286CC_LINEAR_CENTER_ENA(shader->config.spi_ps_input_addr)' failed

2017-08-02 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=101977 Timothee Besset changed: What|Removed |Added Summary|UE4 4.17 causes hang in |UE4 4.17 causes