[PATCH 00/11] sync framework de-staging: part 1 - clean up

2016-01-29 Thread Gustavo Padovan
Hi,

2016-01-25 Maarten Lankhorst :

> Hey,
> 
> Op 21-01-16 om 13:49 schreef Gustavo Padovan:
> > From: Gustavo Padovan 
> >
> > Hi,
> >
> > The following patches are some clean ups on the sync framework before
> > we start the actual de-staging. The main changes here are the move of
> > SW_SYNC_USER to debugfs. Removal of struct sync_pt in favor of direct
> > use of struct fence. And the rename of sync_fence to sync_file, a name
> > to better reflect what it is for, a struct that connects struct fence(s)
> > to a file.
> >
> > Please review. Thanks.
> >
> > Gustavo Padovan (11):
> >   staging/android: fix sync framework documentation
> >   staging/android: sync: remove interfaces that are not used
> >   staging/android: remove not used sync_timeline ops
> >   staging/android: create a 'sync' dir for debugfs information
> >   staging/android: move SW_SYNC_USER to a debugfs file
> >   staging/android: rename sync_fence to sync_file
> >   staging/android: rename 'sync_pt' to 'fence' in struct sync_fence_cb
> >   staging/android: remove struct sync_pt
> >   staging/android: remove unused var from sync_timeline_signal()
> >   staging/android: remove pointless sync_timeline_signal at destroy
> > phase
> >   staging/android: remove sync_fence_create_dma()
> >
> For whole series:
> Reviewed-by: Maarten Lankhorst 
> 
> Renaming sync_fence to sync_file makes sense, it should hopefully reduce 
> confusion.

Poke. What is missing for this to go upstream? Do I need more review
here? Thanks.

Gustavo


[PATCH 00/11] sync framework de-staging: part 1 - clean up

2016-01-29 Thread Greg Kroah-Hartman
On Fri, Jan 29, 2016 at 12:47:20PM -0200, Gustavo Padovan wrote:
> Hi,
> 
> 2016-01-25 Maarten Lankhorst :
> 
> > Hey,
> > 
> > Op 21-01-16 om 13:49 schreef Gustavo Padovan:
> > > From: Gustavo Padovan 
> > >
> > > Hi,
> > >
> > > The following patches are some clean ups on the sync framework before
> > > we start the actual de-staging. The main changes here are the move of
> > > SW_SYNC_USER to debugfs. Removal of struct sync_pt in favor of direct
> > > use of struct fence. And the rename of sync_fence to sync_file, a name
> > > to better reflect what it is for, a struct that connects struct fence(s)
> > > to a file.
> > >
> > > Please review. Thanks.
> > >
> > > Gustavo Padovan (11):
> > >   staging/android: fix sync framework documentation
> > >   staging/android: sync: remove interfaces that are not used
> > >   staging/android: remove not used sync_timeline ops
> > >   staging/android: create a 'sync' dir for debugfs information
> > >   staging/android: move SW_SYNC_USER to a debugfs file
> > >   staging/android: rename sync_fence to sync_file
> > >   staging/android: rename 'sync_pt' to 'fence' in struct sync_fence_cb
> > >   staging/android: remove struct sync_pt
> > >   staging/android: remove unused var from sync_timeline_signal()
> > >   staging/android: remove pointless sync_timeline_signal at destroy
> > > phase
> > >   staging/android: remove sync_fence_create_dma()
> > >
> > For whole series:
> > Reviewed-by: Maarten Lankhorst 
> > 
> > Renaming sync_fence to sync_file makes sense, it should hopefully reduce 
> > confusion.
> 
> Poke. What is missing for this to go upstream? Do I need more review
> here? Thanks.

You just sent this, give me a chance to get to it, my staging patch
queue is over 1000 patches at the moment :(

greg k-h


[PATCH 00/11] sync framework de-staging: part 1 - clean up

2016-01-25 Thread Maarten Lankhorst
Hey,

Op 21-01-16 om 13:49 schreef Gustavo Padovan:
> From: Gustavo Padovan 
>
> Hi,
>
> The following patches are some clean ups on the sync framework before
> we start the actual de-staging. The main changes here are the move of
> SW_SYNC_USER to debugfs. Removal of struct sync_pt in favor of direct
> use of struct fence. And the rename of sync_fence to sync_file, a name
> to better reflect what it is for, a struct that connects struct fence(s)
> to a file.
>
> Please review. Thanks.
>
> Gustavo Padovan (11):
>   staging/android: fix sync framework documentation
>   staging/android: sync: remove interfaces that are not used
>   staging/android: remove not used sync_timeline ops
>   staging/android: create a 'sync' dir for debugfs information
>   staging/android: move SW_SYNC_USER to a debugfs file
>   staging/android: rename sync_fence to sync_file
>   staging/android: rename 'sync_pt' to 'fence' in struct sync_fence_cb
>   staging/android: remove struct sync_pt
>   staging/android: remove unused var from sync_timeline_signal()
>   staging/android: remove pointless sync_timeline_signal at destroy
> phase
>   staging/android: remove sync_fence_create_dma()
>
For whole series:
Reviewed-by: Maarten Lankhorst 

Renaming sync_fence to sync_file makes sense, it should hopefully reduce 
confusion.


[PATCH 00/11] sync framework de-staging: part 1 - clean up

2016-01-21 Thread Gustavo Padovan
From: Gustavo Padovan 

Hi,

The following patches are some clean ups on the sync framework before
we start the actual de-staging. The main changes here are the move of
SW_SYNC_USER to debugfs. Removal of struct sync_pt in favor of direct
use of struct fence. And the rename of sync_fence to sync_file, a name
to better reflect what it is for, a struct that connects struct fence(s)
to a file.

Please review. Thanks.

Gustavo Padovan (11):
  staging/android: fix sync framework documentation
  staging/android: sync: remove interfaces that are not used
  staging/android: remove not used sync_timeline ops
  staging/android: create a 'sync' dir for debugfs information
  staging/android: move SW_SYNC_USER to a debugfs file
  staging/android: rename sync_fence to sync_file
  staging/android: rename 'sync_pt' to 'fence' in struct sync_fence_cb
  staging/android: remove struct sync_pt
  staging/android: remove unused var from sync_timeline_signal()
  staging/android: remove pointless sync_timeline_signal at destroy
phase
  staging/android: remove sync_fence_create_dma()

 drivers/staging/android/Kconfig  |   9 -
 drivers/staging/android/sw_sync.c| 181 ++--
 drivers/staging/android/sw_sync.h|   8 +-
 drivers/staging/android/sync.c   | 406 ++-
 drivers/staging/android/sync.h   | 237 ++--
 drivers/staging/android/sync_debug.c | 228 +++-
 drivers/staging/android/trace/sync.h |  24 +--
 drivers/staging/android/uapi/sync.h  |  14 +-
 include/linux/fence.h|   2 +
 9 files changed, 438 insertions(+), 671 deletions(-)

-- 
2.5.0