Re: [PATCH v3 1/7] drm/msm: adreno: add defines for gpu & gmu frequency table sizes

2024-11-30 Thread Akhil P Oommen
On 11/28/2024 3:55 PM, Neil Armstrong wrote:
> Even if the code uses ARRAY_SIZE() to fill those tables,
> it's still a best practice to not use magic values for
> tables in structs.
> 
> Suggested-by: Dmitry Baryshkov 
> Signed-off-by: Neil Armstrong 

Reviewed-by: Akhil P Oommen 

-Akhil

> ---
>  drivers/gpu/drm/msm/adreno/a6xx_gmu.h | 11 +++
>  1 file changed, 7 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/gpu/drm/msm/adreno/a6xx_gmu.h 
> b/drivers/gpu/drm/msm/adreno/a6xx_gmu.h
> index 
> b4a79f88ccf45cfe651c86d2a9da39541c5772b3..88f18ea6a38a08b5b171709e5020010947a5d347
>  100644
> --- a/drivers/gpu/drm/msm/adreno/a6xx_gmu.h
> +++ b/drivers/gpu/drm/msm/adreno/a6xx_gmu.h
> @@ -19,6 +19,9 @@ struct a6xx_gmu_bo {
>   u64 iova;
>  };
>  
> +#define GMU_MAX_GX_FREQS 16
> +#define GMU_MAX_CX_FREQS 4
> +
>  /*
>   * These define the different GMU wake up options - these define how both the
>   * CPU and the GMU bring up the hardware
> @@ -79,12 +82,12 @@ struct a6xx_gmu {
>   int current_perf_index;
>  
>   int nr_gpu_freqs;
> - unsigned long gpu_freqs[16];
> - u32 gx_arc_votes[16];
> + unsigned long gpu_freqs[GMU_MAX_GX_FREQS];
> + u32 gx_arc_votes[GMU_MAX_GX_FREQS];
>  
>   int nr_gmu_freqs;
> - unsigned long gmu_freqs[4];
> - u32 cx_arc_votes[4];
> + unsigned long gmu_freqs[GMU_MAX_CX_FREQS];
> + u32 cx_arc_votes[GMU_MAX_CX_FREQS];
>  
>   unsigned long freq;
>  
> 



Re: [PATCH v3 1/7] drm/msm: adreno: add defines for gpu & gmu frequency table sizes

2024-11-28 Thread Dmitry Baryshkov
On Thu, Nov 28, 2024 at 11:25:41AM +0100, Neil Armstrong wrote:
> Even if the code uses ARRAY_SIZE() to fill those tables,
> it's still a best practice to not use magic values for
> tables in structs.
> 
> Suggested-by: Dmitry Baryshkov 
> Signed-off-by: Neil Armstrong 
> ---
>  drivers/gpu/drm/msm/adreno/a6xx_gmu.h | 11 +++
>  1 file changed, 7 insertions(+), 4 deletions(-)
> 

Reviewed-by: Dmitry Baryshkov 

-- 
With best wishes
Dmitry


[PATCH v3 1/7] drm/msm: adreno: add defines for gpu & gmu frequency table sizes

2024-11-28 Thread Neil Armstrong
Even if the code uses ARRAY_SIZE() to fill those tables,
it's still a best practice to not use magic values for
tables in structs.

Suggested-by: Dmitry Baryshkov 
Signed-off-by: Neil Armstrong 
---
 drivers/gpu/drm/msm/adreno/a6xx_gmu.h | 11 +++
 1 file changed, 7 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/msm/adreno/a6xx_gmu.h 
b/drivers/gpu/drm/msm/adreno/a6xx_gmu.h
index 
b4a79f88ccf45cfe651c86d2a9da39541c5772b3..88f18ea6a38a08b5b171709e5020010947a5d347
 100644
--- a/drivers/gpu/drm/msm/adreno/a6xx_gmu.h
+++ b/drivers/gpu/drm/msm/adreno/a6xx_gmu.h
@@ -19,6 +19,9 @@ struct a6xx_gmu_bo {
u64 iova;
 };
 
+#define GMU_MAX_GX_FREQS   16
+#define GMU_MAX_CX_FREQS   4
+
 /*
  * These define the different GMU wake up options - these define how both the
  * CPU and the GMU bring up the hardware
@@ -79,12 +82,12 @@ struct a6xx_gmu {
int current_perf_index;
 
int nr_gpu_freqs;
-   unsigned long gpu_freqs[16];
-   u32 gx_arc_votes[16];
+   unsigned long gpu_freqs[GMU_MAX_GX_FREQS];
+   u32 gx_arc_votes[GMU_MAX_GX_FREQS];
 
int nr_gmu_freqs;
-   unsigned long gmu_freqs[4];
-   u32 cx_arc_votes[4];
+   unsigned long gmu_freqs[GMU_MAX_CX_FREQS];
+   u32 cx_arc_votes[GMU_MAX_CX_FREQS];
 
unsigned long freq;
 

-- 
2.34.1