Re: Linux Kernel 5.2.8 (uvc or i915? <<<)

2019-08-16 Thread Nathaniel Russell
Kernel is the dmesg from the kernel I run on a daily basis.

On 8/16/19, Laurent Pinchart  wrote:
> Hi Randy,
>
> On Thu, Aug 15, 2019 at 08:10:03PM -0700, Randy Dunlap wrote:
>> [adding mailing lists etc. with Nathaniel's test info]
>>
>> On 8/15/19 7:21 PM, Nathaniel Russell wrote:
>> > Well i surpressed the uvcvideo driver and you are right Randy it
>> > definitely is not the uvcvideo driver. There is something going on in
>> > the i915 driver.
>> >
>> > On 8/15/19, Randy Dunlap  wrote:
>> >> On 8/15/19 6:15 PM, Nathaniel Russell wrote:
>> >>> I would really like help with the kernel error with my uvcvideo
>> >>> driver.
>> >>
>> >> Hi again.
>> >>
>> >> What makes you think that the problem is related to the uvcvideo
>> >> driver?
>> >> Does some previous kernel version work correctly?  If so, what
>> >> version(s)?
>> >>
>> >>
>> >> Does this warning message only happen when the uvcvideo driver is
>> >> being
>> >> loaded?
>> >> Can you suppress loading of the uvcvideo driver to find out?
>> >>
>> >> Most of the problems/errors/warnings that I see are related to the
>> >> i915
>> >> driver:
>> >>
>> >> [   13.032341] timed out waiting for port C ready: got 0x20, expected
>> >> 0xe0
>> >> [   13.032872] WARNING: CPU: 1 PID: 239 at
>> >> drivers/gpu/drm/i915/intel_display.c:1597
>> >> vlv_wait_port_ready+0x99/0xe0
>> >> [i915]
>> >> [   13.033632] RIP: 0010:vlv_wait_port_ready+0x99/0xe0 [i915]
>> >>
>> >> although there are a few uvcvideo warnings:
>> >> [   13.039305] uvcvideo 1-5:1.0: Entity type for entity Extension 4 was
>> >> not
>> >> initialized!
>> >> [   13.039318] uvcvideo 1-5:1.0: Entity type for entity Extension 3 was
>> >> not
>> >> initialized!
>> >> [   13.039330] uvcvideo 1-5:1.0: Entity type for entity Processing 2
>> >> was not
>> >> initialized!
>> >> [   13.039339] uvcvideo 1-5:1.0: Entity type for entity Camera 1 was
>> >> not
>> >> initialized!
>> >>
>> >> Laurent, do you see any uvc issues here?  Any ideas/suggestions?
>
> No, uvcvideo seems completely reunlated.
>
>> >> @intel-gfx:  any ideas about what is going on here with the i915
>> >> driver?
>> >>
>> >> Original message to lkml:
>> >> https://lore.kernel.org/lkml/CAONH+Jm-O6=dq+k2n5pntnmg2sq1kcvnfluwevh6w82opef...@mail.gmail.com/T/#u
>> >>
>> >> Previous message for 5.1.21 kernel:
>> >> https://lore.kernel.org/lkml/CAONH+JkTFujY9vEyNNuem+9rJ2qBKkf-PbKk9=DBSVEp6kW=y...@mail.gmail.com/
>
> --
> Regards,
>
> Laurent Pinchart
>


kernel
Description: Binary data


Re: Linux Kernel 5.2.8 (uvc or i915? <<<)

2019-08-16 Thread Laurent Pinchart
Hi Randy,

On Thu, Aug 15, 2019 at 08:10:03PM -0700, Randy Dunlap wrote:
> [adding mailing lists etc. with Nathaniel's test info]
> 
> On 8/15/19 7:21 PM, Nathaniel Russell wrote:
> > Well i surpressed the uvcvideo driver and you are right Randy it
> > definitely is not the uvcvideo driver. There is something going on in
> > the i915 driver.
> > 
> > On 8/15/19, Randy Dunlap  wrote:
> >> On 8/15/19 6:15 PM, Nathaniel Russell wrote:
> >>> I would really like help with the kernel error with my uvcvideo driver.
> >>
> >> Hi again.
> >>
> >> What makes you think that the problem is related to the uvcvideo driver?
> >> Does some previous kernel version work correctly?  If so, what version(s)?
> >>
> >>
> >> Does this warning message only happen when the uvcvideo driver is being
> >> loaded?
> >> Can you suppress loading of the uvcvideo driver to find out?
> >>
> >> Most of the problems/errors/warnings that I see are related to the i915
> >> driver:
> >>
> >> [   13.032341] timed out waiting for port C ready: got 0x20, expected 0xe0
> >> [   13.032872] WARNING: CPU: 1 PID: 239 at
> >> drivers/gpu/drm/i915/intel_display.c:1597 vlv_wait_port_ready+0x99/0xe0
> >> [i915]
> >> [   13.033632] RIP: 0010:vlv_wait_port_ready+0x99/0xe0 [i915]
> >>
> >> although there are a few uvcvideo warnings:
> >> [   13.039305] uvcvideo 1-5:1.0: Entity type for entity Extension 4 was not
> >> initialized!
> >> [   13.039318] uvcvideo 1-5:1.0: Entity type for entity Extension 3 was not
> >> initialized!
> >> [   13.039330] uvcvideo 1-5:1.0: Entity type for entity Processing 2 was 
> >> not
> >> initialized!
> >> [   13.039339] uvcvideo 1-5:1.0: Entity type for entity Camera 1 was not
> >> initialized!
> >>
> >> Laurent, do you see any uvc issues here?  Any ideas/suggestions?

No, uvcvideo seems completely reunlated.

> >> @intel-gfx:  any ideas about what is going on here with the i915 driver?
> >>
> >> Original message to lkml:
> >> https://lore.kernel.org/lkml/CAONH+Jm-O6=dq+k2n5pntnmg2sq1kcvnfluwevh6w82opef...@mail.gmail.com/T/#u
> >>
> >> Previous message for 5.1.21 kernel:
> >> https://lore.kernel.org/lkml/CAONH+JkTFujY9vEyNNuem+9rJ2qBKkf-PbKk9=DBSVEp6kW=y...@mail.gmail.com/

-- 
Regards,

Laurent Pinchart
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Re: Linux Kernel 5.2.8 (uvc or i915? <<<)

2019-08-15 Thread Randy Dunlap
[adding mailing lists etc. with Nathaniel's test info]


On 8/15/19 7:21 PM, Nathaniel Russell wrote:
> Well i surpressed the uvcvideo driver and you are right Randy it
> definitely is not the uvcvideo driver. There is something going on in
> the i915 driver.
> 
> 
> On 8/15/19, Randy Dunlap  wrote:
>> On 8/15/19 6:15 PM, Nathaniel Russell wrote:
>>> I would really like help with the kernel error with my uvcvideo driver.
>>>
>>
>> Hi again.
>>
>> What makes you think that the problem is related to the uvcvideo driver?
>> Does some previous kernel version work correctly?  If so, what version(s)?
>>
>>
>> Does this warning message only happen when the uvcvideo driver is being
>> loaded?
>> Can you suppress loading of the uvcvideo driver to find out?
>>
>> Most of the problems/errors/warnings that I see are related to the i915
>> driver:
>>
>> [   13.032341] timed out waiting for port C ready: got 0x20, expected 0xe0
>> [   13.032872] WARNING: CPU: 1 PID: 239 at
>> drivers/gpu/drm/i915/intel_display.c:1597 vlv_wait_port_ready+0x99/0xe0
>> [i915]
>> [   13.033632] RIP: 0010:vlv_wait_port_ready+0x99/0xe0 [i915]
>>
>> although there are a few uvcvideo warnings:
>> [   13.039305] uvcvideo 1-5:1.0: Entity type for entity Extension 4 was not
>> initialized!
>> [   13.039318] uvcvideo 1-5:1.0: Entity type for entity Extension 3 was not
>> initialized!
>> [   13.039330] uvcvideo 1-5:1.0: Entity type for entity Processing 2 was not
>> initialized!
>> [   13.039339] uvcvideo 1-5:1.0: Entity type for entity Camera 1 was not
>> initialized!
>>
>>
>> Laurent, do you see any uvc issues here?  Any ideas/suggestions?
>>
>>
>> @intel-gfx:  any ideas about what is going on here with the i915 driver?
>>
>>
>>
>> Original message to lkml:
>> https://lore.kernel.org/lkml/CAONH+Jm-O6=dq+k2n5pntnmg2sq1kcvnfluwevh6w82opef...@mail.gmail.com/T/#u
>>
>> Previous message for 5.1.21 kernel:
>> https://lore.kernel.org/lkml/CAONH+JkTFujY9vEyNNuem+9rJ2qBKkf-PbKk9=DBSVEp6kW=y...@mail.gmail.com/
>>
>>
>> thanks.
>> --
>> ~Randy
>>


-- 
~Randy


Re: Linux Kernel 5.2.8 (uvc or i915?)

2019-08-15 Thread Randy Dunlap
On 8/15/19 6:15 PM, Nathaniel Russell wrote:
> I would really like help with the kernel error with my uvcvideo driver.
> 

Hi again.

What makes you think that the problem is related to the uvcvideo driver?
Does some previous kernel version work correctly?  If so, what version(s)?


Does this warning message only happen when the uvcvideo driver is being loaded?
Can you suppress loading of the uvcvideo driver to find out?

Most of the problems/errors/warnings that I see are related to the i915 driver:

[   13.032341] timed out waiting for port C ready: got 0x20, expected 0xe0
[   13.032872] WARNING: CPU: 1 PID: 239 at 
drivers/gpu/drm/i915/intel_display.c:1597 vlv_wait_port_ready+0x99/0xe0 [i915]
[   13.033632] RIP: 0010:vlv_wait_port_ready+0x99/0xe0 [i915]

although there are a few uvcvideo warnings:
[   13.039305] uvcvideo 1-5:1.0: Entity type for entity Extension 4 was not 
initialized!
[   13.039318] uvcvideo 1-5:1.0: Entity type for entity Extension 3 was not 
initialized!
[   13.039330] uvcvideo 1-5:1.0: Entity type for entity Processing 2 was not 
initialized!
[   13.039339] uvcvideo 1-5:1.0: Entity type for entity Camera 1 was not 
initialized!


Laurent, do you see any uvc issues here?  Any ideas/suggestions?


@intel-gfx:  any ideas about what is going on here with the i915 driver?



Original message to lkml:
https://lore.kernel.org/lkml/CAONH+Jm-O6=dq+k2n5pntnmg2sq1kcvnfluwevh6w82opef...@mail.gmail.com/T/#u

Previous message for 5.1.21 kernel:
https://lore.kernel.org/lkml/CAONH+JkTFujY9vEyNNuem+9rJ2qBKkf-PbKk9=DBSVEp6kW=y...@mail.gmail.com/


thanks.
-- 
~Randy