[r300] Scrambled fonts (was: undefined symbol: __driUtilCreateScreen)

2005-07-26 Thread Sebastien Cevey
begin Ian Romanick quotation of Mon, Jul 25, 2005 at 07:28:17PM -0700:

Hi again,

 So, that's like taking the Diesel fuel only sticker off your gas tank
 to make it work with regular gas. :)  The name changed because the
 interface changed.  Use *all* DRI drivers *and* libGL.so from Mesa CVS.

Oh right, sorry :-)

Now I did install the libGL* Mesa drivers and checked with ldd that
they are indeed used.

r300 now seems to work:

==
# LIBGL_DEBUG=verbose glxinfo
libGL: XF86DRIGetClientDriverName: 4.0.1 r300 (screen 0)
libGL: OpenDriver: trying /usr/X11R6/lib/modules/dri/r300_dri.so
drmOpenByBusid: Searching for BusID pci::00:10.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 5, (OK)
drmOpenByBusid: drmOpenMinor returns 5
drmOpenByBusid: drmGetBusid reports pci::00:10.0
libGL error: 
Can't open configuration file /etc/drirc: No such file or directory.
libGL error: 
Can't open configuration file /root/.drirc: No such file or directory.
*WARN_ONCE*
File r300_state.c'est function r300Enable line 456
TODO - double side stencil !
***
No ctx-FragmentProgram._Current!!
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
==

Although with a few warnings as above.  They also happen with
glxgears, but at least I get 10x more FPS than before!

==
$ glxgears
*WARN_ONCE*
File r300_state.c'est function r300Enable line 456
TODO - double side stencil !
***
No ctx-FragmentProgram._Current!!
*WARN_ONCE*
File r300_render.c'est function r300_get_num_verts line 188
user error: Need more than 2 vertices to draw primitive QS !
***
4829 frames in 5.0 seconds = 965.687 FPS
4815 frames in 5.0 seconds = 962.935 FPS
4792 frames in 5.0 seconds = 958.335 FPS
==

The problem is that Xorg is unusable because the fonts are scrambled
in the xterm (and other such terms).  All fonts are not, for instance
fonts appear correctly in Firefox, but not in the titlebar (fluxbox)
of the same program.  I guess it depends who handles the font
rendering..

I cannot find any error about that in the Xorg logs either.  Anyone
has seen this before?


Thank you!


PS: Does this belong to this ML or to dri-user?

-- 
S├ębastien Cevey [EMAIL PROTECTED] | http://sirius.cine7.net/ | GPG: AEE9D6B9
Jabber: [EMAIL PROTECTED] | ICQ: 48895760 | MSN: [EMAIL PROTECTED]

 Emacs: It's a nice OS, but to compete with Linux or Windows it needs a better 
text editor. 
Alexander Duscheleit 


---
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_idt77alloc_id492op=click
--
___
Dri-devel mailing list
Dri-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/dri-devel


Re: [r300] Scrambled fonts (was: undefined symbol: __driUtilCreateScreen)

2005-07-26 Thread Alex Deucher
On 7/26/05, Sebastien Cevey [EMAIL PROTECTED] wrote:
 begin Ian Romanick quotation of Mon, Jul 25, 2005 at 07:28:17PM -0700:
 
 Hi again,
 
  So, that's like taking the Diesel fuel only sticker off your gas tank
  to make it work with regular gas. :)  The name changed because the
  interface changed.  Use *all* DRI drivers *and* libGL.so from Mesa CVS.
 
 Oh right, sorry :-)
 
 Now I did install the libGL* Mesa drivers and checked with ldd that
 they are indeed used.
 
 r300 now seems to work:
 
 ==
 # LIBGL_DEBUG=verbose glxinfo
 libGL: XF86DRIGetClientDriverName: 4.0.1 r300 (screen 0)
 libGL: OpenDriver: trying /usr/X11R6/lib/modules/dri/r300_dri.so
 drmOpenByBusid: Searching for BusID pci::00:10.0
 drmOpenDevice: node name is /dev/dri/card0
 drmOpenDevice: open result is 5, (OK)
 drmOpenByBusid: drmOpenMinor returns 5
 drmOpenByBusid: drmGetBusid reports pci::00:10.0
 libGL error:
 Can't open configuration file /etc/drirc: No such file or directory.
 libGL error:
 Can't open configuration file /root/.drirc: No such file or directory.
 *WARN_ONCE*
 File r300_state.c'est function r300Enable line 456
 TODO - double side stencil !
 ***
 No ctx-FragmentProgram._Current!!
 name of display: :0.0
 display: :0  screen: 0
 direct rendering: Yes
 ==
 
 Although with a few warnings as above.  They also happen with
 glxgears, but at least I get 10x more FPS than before!
 
 ==
 $ glxgears
 *WARN_ONCE*
 File r300_state.c'est function r300Enable line 456
 TODO - double side stencil !
 ***
 No ctx-FragmentProgram._Current!!
 *WARN_ONCE*
 File r300_render.c'est function r300_get_num_verts line 188
 user error: Need more than 2 vertices to draw primitive QS !
 ***
 4829 frames in 5.0 seconds = 965.687 FPS
 4815 frames in 5.0 seconds = 962.935 FPS
 4792 frames in 5.0 seconds = 958.335 FPS
 ==
 
 The problem is that Xorg is unusable because the fonts are scrambled
 in the xterm (and other such terms).  All fonts are not, for instance
 fonts appear correctly in Firefox, but not in the titlebar (fluxbox)
 of the same program.  I guess it depends who handles the font
 rendering..
 
 I cannot find any error about that in the Xorg logs either.  Anyone
 has seen this before?
 
 
 Thank you!
 

try:
XaaNoScanlineImageWriteRect
XaaNoScanlineCPUToScreenColorExpandFill

via Dave Airlie's blog:
http://www.livejournal.com/users/airlied/

Alex

 
 PS: Does this belong to this ML or to dri-user?
 
 --
 S├ębastien Cevey [EMAIL PROTECTED] | http://sirius.cine7.net/ | GPG: AEE9D6B9
 Jabber: [EMAIL PROTECTED] | ICQ: 48895760 | MSN: [EMAIL PROTECTED]
 
  Emacs: It's a nice OS, but to compete with Linux or Windows it needs a 
 better text editor. 
 Alexander Duscheleit
 



---
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_idt77alloc_id492op=click
--
___
Dri-devel mailing list
Dri-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/dri-devel