[patch 1/2] staging: vt6655: buffer overflow in ioctl

2014-09-19 Thread Dan Carpenter
-u.generic_elem.len is a user controlled number between 0-255. We should limit it to avoid memory corruption. Signed-off-by: Dan Carpenter dan.carpen...@oracle.com diff --git a/drivers/staging/vt6655/hostap.c b/drivers/staging/vt6655/hostap.c index 0dd87d4..73429f4 100644 ---

[PATCH v3 1/8] staging: comedi: ni_usb6501: add counter commands

2014-09-19 Thread Luca Ellero
Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 29 ++- 1 file changed, 28 insertions(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501.c

[PATCH v3 0/8] comedi: ni_usb6501: add counter support

2014-09-19 Thread Luca Ellero
This series of patches add counter support for NI USB-6501. I tested it on my device and it works fine. Changes for v2: - rewrite patch 3/9 changelog: replace fix with cleanup - avoid sparse warnings - add SDF_LSAMPL flag to counter subdevice Changes for v3: - remove useless checks - remove

[PATCH v3 7/8] staging: comedi: ni_usb6501: rename ni6501_send_command()

2014-09-19 Thread Luca Ellero
Rename ni6501_send_command to ni6501_port_command Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c |8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c

[PATCH v3 8/8] staging: comedi: ni_usb6501: add counter subdevice

2014-09-19 Thread Luca Ellero
Add counter support for NI USB-6501. The following functions are introduced: - ni6501_counter_command() - ni6501_cnt_insn_config() - ni6501_cnt_insn_read() - ni6501_cnt_insn_write() Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 167

[PATCH v3 4/8] staging: comedi: ni_usb6501: replace spaces with tabs

2014-09-19 Thread Luca Ellero
ni6501_auto_attach(): replace spaces with tabs to get proper alignment Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c

[PATCH v3 6/8] staging: comedi: ni_usb6501: remove empty lines

2014-09-19 Thread Luca Ellero
ni6501_send_command(): remove empty lines in case statements Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 15 --- 1 file changed, 15 deletions(-) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c

Re: [PATCH] staging: lustre: llite: Use kzalloc and rewrite null tests

2014-09-19 Thread Drokin, Oleg
On Sep 19, 2014, at 5:11 AM, Dan Carpenter wrote: On Fri, Sep 19, 2014 at 02:57:03AM +, Drokin, Oleg wrote: 4. Sometimes we need large allocations. general kmalloc is less reliable as system lives on and memory fragmentation worsens. So we have this allocations over 2-4 pages get

Re: [HPDD-discuss] [PATCH] staging: lustre: llite: Use kzalloc and rewrite null tests

2014-09-19 Thread Drokin, Oleg
Hello! First, thanks for your patches and efforts spent on these cleanups. On Sep 19, 2014, at 12:45 AM, Julia Lawall wrote: With respect to the upper case lower case issue, does the thing need to be a macro? I think that the lowercase is more or less fine, but only if what is behind it

Re: [HPDD-discuss] [PATCH] staging: lustre: llite: Use kzalloc and rewrite null tests

2014-09-19 Thread Julia Lawall
On Fri, 19 Sep 2014, Drokin, Oleg wrote: Hello! First, thanks for your patches and efforts spent on these cleanups. On Sep 19, 2014, at 12:45 AM, Julia Lawall wrote: With respect to the upper case lower case issue, does the thing need to be a macro? I think that the lowercase is

RE: [PATCH v3 0/8] comedi: ni_usb6501: add counter support

2014-09-19 Thread Hartley Sweeten
On Friday, September 19, 2014 4:51 AM, Luca Ellero wrote: This series of patches add counter support for NI USB-6501. I tested it on my device and it works fine. Changes for v2: - rewrite patch 3/9 changelog: replace fix with cleanup - avoid sparse warnings - add SDF_LSAMPL flag to counter

Re: [PATCH 07/12] staging: et131x: Fix indenting using mixed tabs and spaces

2014-09-19 Thread Greg KH
On Sun, Sep 14, 2014 at 04:59:03PM +0100, Mark Einon wrote: Fix two lines where mixed tabs and spaces were used for indenting. Signed-off-by: Mark Einon mark.ei...@gmail.com --- drivers/staging/et131x/et131x.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git