[RFCv2 1/3] staging: ion: shrink page-pool by page unit

2014-10-24 Thread Gioh Kim
This patch shrink page-pool by page unit. Signed-off-by: Gioh Kim gioh@lge.com --- drivers/staging/android/ion/ion_page_pool.c |5 +++-- drivers/staging/android/ion/ion_system_heap.c |7 +-- 2 files changed, 8 insertions(+), 4 deletions(-) diff --git

[RFCv2 0/3] enable pool shrinking in page unit

2014-10-24 Thread Gioh Kim
Hello, Current shrinking is not page unit, block unit. But shrinker returns the pool size in page unit, so it is confused. And there is no way to control pool size and shrink pool directly. I have 3 patches: 1. Patch 1/3: make pool be shrinked by page unit This patch trys to shrink pool in

[RFCv2 3/3] staging: ion: limit pool size

2014-10-24 Thread Gioh Kim
This patch limits pool size by page unit. Signed-off-by: Gioh Kim gioh@lge.com --- drivers/staging/android/ion/Kconfig |4 drivers/staging/android/ion/ion_page_pool.c | 26 -- 2 files changed, 20 insertions(+), 10 deletions(-) diff --git

[RFCv2 2/3] staging: ion: debugfs to shrink pool

2014-10-24 Thread Gioh Kim
This patch creates debugfs files, /sys/kernel/debug/ion/heaps/system_shrink, to shrink pool or get pool size. Reading the file returns pool size and writing occurs to shrink pool. Signed-off-by: Gioh Kim gioh@lge.com --- drivers/staging/android/ion/ion.c | 31

Re: [PATCH 46/55] staging: comedi: drivers: handle SDF_PACKED in comedi_inc_scan_progress()

2014-10-24 Thread Ian Abbott
On 23/10/14 17:35, Hartley Sweeten wrote: On Thursday, October 23, 2014 4:28 AM, Ian Abbott wrote: On 22/10/14 23:37, H Hartley Sweeten wrote: Subdevices that set the SDF_PACKED flag return all the scan data in a single sample. The cmd-chanlist_len is used to pass the DIO channel information

Re: [PATCH] staging: comedi: me4000: fix firmware downloading

2014-10-24 Thread Ian Abbott
On 23/10/14 20:19, H Hartley Sweeten wrote: Convert this driver to use comedi_load_firmware() to download the firmware to the board. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org ---

[PATCH v4 1/7] staging: skein: Collapses threefish module

2014-10-24 Thread Eric Rost
Collapses threefish module into skein module. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Kconfig | 22 +++--- drivers/staging/skein/Makefile | 11 +-- 2 files changed, 8 insertions(+), 25 deletions(-) diff --git

[PATCH v4 2/7] staging: skein: Renames skein to skein_base

2014-10-24 Thread Eric Rost
Renames skein.c to skein_base.c and skein.h to skein_base.h Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Makefile| 2 +- drivers/staging/skein/skein.c | 883 - drivers/staging/skein/skein.h | 346

[PATCH v4 4/7] staging: skein: Adds Loadable Module Support

2014-10-24 Thread Eric Rost
Adds loadable module support to the Skein Hashing Algorithm driver. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Kconfig | 2 +- drivers/staging/skein/Makefile| 13 +++-- drivers/staging/skein/skein_generic.c | 19 ++- 3

[PATCH v4 5/7] staging: skein: Inlines rotl_64

2014-10-24 Thread Eric Rost
Inlines the rotl_64 macro. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/skein_base.h | 19 ++- 1 file changed, 10 insertions(+), 9 deletions(-) diff --git a/drivers/staging/skein/skein_base.h b/drivers/staging/skein/skein_base.h index

[PATCH v4 6/7] staging: skein: Removes unneeded #define

2014-10-24 Thread Eric Rost
Removes unneeded #define SKEIN_PORT_CODE since skein_port.h is nonexistent. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/skein_base.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/skein/skein_base.c b/drivers/staging/skein/skein_base.c index

[PATCH v4 7/7] staging: skein: Removes skein_debug include

2014-10-24 Thread Eric Rost
Removes skein_debug.h include since skein_debug.h is nonexistent. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/skein_base.h | 9 + 1 file changed, 1 insertion(+), 8 deletions(-) diff --git a/drivers/staging/skein/skein_base.h

Re: [PATCH v4 0/7] staging: skein: CryptoAPI and Module Support

2014-10-24 Thread Eric Rost
On Fri, 2014-10-24 at 06:16 -0500, Eric Rost wrote: Adds CryptoAPI and Module support to Skein Hash Algorithm. Also inlines rotl_64 macro, and removes nonexistent header references. This should be [PATCH v5], sorry. ___ devel mailing list

[PATCH v4 0/7] staging: skein: CryptoAPI and Module Support

2014-10-24 Thread Eric Rost
Adds CryptoAPI and Module support to Skein Hash Algorithm. Also inlines rotl_64 macro, and removes nonexistent header references. Eric Rost (7): staging: skein: Collapses threefish module staging: skein: Renames skein to skein_base staging: skein: Adds CryptoAPI Support staging: skein:

[PATCH v4 3/7] staging: skein: Adds CryptoAPI Support

2014-10-24 Thread Eric Rost
Adds CryptoAPI support to the Skein Hashing Algorithm driver. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Makefile| 3 +- drivers/staging/skein/skein_generic.c | 191 ++ 2 files changed, 193 insertions(+), 1 deletion(-)

[PATCH v5 1/7] staging: skein: Collapses threefish module

2014-10-24 Thread Eric Rost
Collapses threefish module into skein module. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Kconfig | 22 +++--- drivers/staging/skein/Makefile | 11 +-- 2 files changed, 8 insertions(+), 25 deletions(-) diff --git

[PATCH v5 0/7] staging: skein: CryptoAPI and Module Support

2014-10-24 Thread Eric Rost
Adds CryptoAPI and Module support to Skein Hash Algorithm. Also inlines rotl_64 macro, and removes nonexistent header references. Eric Rost (7): staging: skein: Collapses threefish module staging: skein: Renames skein to skein_base staging: skein: Adds CryptoAPI Support staging: skein:

[PATCH v5 2/7] staging: skein: Renames skein to skein_base

2014-10-24 Thread Eric Rost
Renames skein.c to skein_base.c and skein.h to skein_base.h Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Makefile| 2 +- drivers/staging/skein/skein.c | 883 - drivers/staging/skein/skein.h | 346

[PATCH v5 5/7] staging: skein: Inlines rotl_64

2014-10-24 Thread Eric Rost
Inlines the rotl_64 macro. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/skein_base.h | 19 ++- 1 file changed, 10 insertions(+), 9 deletions(-) diff --git a/drivers/staging/skein/skein_base.h b/drivers/staging/skein/skein_base.h index

[PATCH v5 6/7] staging: skein: Removes unneeded #define

2014-10-24 Thread Eric Rost
Removes unneeded #define SKEIN_PORT_CODE since skein_port.h is nonexistent. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/skein_base.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/skein/skein_base.c b/drivers/staging/skein/skein_base.c index

[PATCH v5 4/7] staging: skein: Adds Loadable Module Support

2014-10-24 Thread Eric Rost
Adds loadable module support to the Skein Hashing Algorithm driver. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Kconfig | 2 +- drivers/staging/skein/Makefile| 13 +++-- drivers/staging/skein/skein_generic.c | 19 ++- 3

[PATCH v5 7/7] staging: skein: Removes skein_debug include

2014-10-24 Thread Eric Rost
Removes skein_debug.h include since skein_debug.h is nonexistent. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/skein_base.h | 9 + 1 file changed, 1 insertion(+), 8 deletions(-) diff --git a/drivers/staging/skein/skein_base.h

[PATCH v5 3/7] staging: skein: Adds CryptoAPI Support

2014-10-24 Thread Eric Rost
Adds CryptoAPI support to the Skein Hashing Algorithm driver. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Makefile| 3 +- drivers/staging/skein/skein_generic.c | 191 ++ 2 files changed, 193 insertions(+), 1 deletion(-)

Re: [PATCH v5 2/7] staging: skein: Renames skein to skein_base

2014-10-24 Thread Jason Cooper
On Fri, Oct 24, 2014 at 06:55:16AM -0500, Eric Rost wrote: Renames skein.c to skein_base.c and skein.h to skein_base.h It's worth a mention in here that this is in preparation for skein.ko. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Makefile| 2 +-

Re: [PATCH v5 3/7] staging: skein: Adds CryptoAPI Support

2014-10-24 Thread Jason Cooper
Eric, We're almost there... :) On Fri, Oct 24, 2014 at 06:55:33AM -0500, Eric Rost wrote: Adds CryptoAPI support to the Skein Hashing Algorithm driver. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Makefile| 3 +-

RE: [PATCH 46/55] staging: comedi: drivers: handle SDF_PACKED in comedi_inc_scan_progress()

2014-10-24 Thread Hartley Sweeten
On Friday, October 24, 2014 1:49 AM, Ian Abbott wrote: On 23/10/14 17:35, Hartley Sweeten wrote: On Thursday, October 23, 2014 4:28 AM, Ian Abbott wrote: On 22/10/14 23:37, H Hartley Sweeten wrote: Subdevices that set the SDF_PACKED flag return all the scan data in a single sample. The

[PATCH 0/3] staging: comedi: addi_apci_1564: fix timer subdevice

2014-10-24 Thread H Hartley Sweeten
This driver currently passes the timer channel in a manner that violates the comedi API. Fix the timer subdevice so that the timers channels are correctly used from the insn-chanspec. H Hartley Sweeten (3): staging: comedi: addi_apci_1564: remove APCI1564_COUNTER[1234] defines staging:

[PATCH 2/3] staging: comedi: addi_apci_1564: remove private data 'mode_select_register'

2014-10-24 Thread H Hartley Sweeten
This driver currently passes the timer channel as the data[5] element to the timer (*insn_config) function. This is stored in the private data and use in the timer (*insn_read) and (*insn_write) functions to read/write the timer. This is just wrong, comedi passes the channel number in the

[PATCH 1/3] staging: comedi: addi_apci_1564: remove APCI1564_COUNTER[1234] defines

2014-10-24 Thread H Hartley Sweeten
These defines don't add any significant clarity to the driver. Remove them. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org --- drivers/staging/comedi/drivers/addi-data/hwdrv_apci1564.c | 12

[PATCH 3/3] staging: comedi: addi_apci_1564: board has 3 timers

2014-10-24 Thread H Hartley Sweeten
According to ADDI-DATA, the APCI-1564 only has 3 timers. There are some customer specific boards with 4 timers but they use out of tree drivers. Now that the timer 'channels' are handled correctly in the subdevice functions, fix the number of timer channels for the subdevice and remove the code

Re: [PATCH 46/55] staging: comedi: drivers: handle SDF_PACKED in comedi_inc_scan_progress()

2014-10-24 Thread Ian Abbott
On 24/10/14 17:34, Hartley Sweeten wrote: On Friday, October 24, 2014 1:49 AM, Ian Abbott wrote: On 23/10/14 17:35, Hartley Sweeten wrote: On Thursday, October 23, 2014 4:28 AM, Ian Abbott wrote: [snip] Is this patch even necessary? comedi_bytes_per_scan() assumes digital samples will be

Re: [RFCv2 1/3] staging: ion: shrink page-pool by page unit

2014-10-24 Thread Laura Abbott
Hi, On 10/23/2014 11:47 PM, Gioh Kim wrote: This patch shrink page-pool by page unit. Can you explain a bit more about what this patch is fixing? The description in the cover letter would be helpful here. Thanks, Laura -- Qualcomm Innovation Center, Inc. Qualcomm Innovation Center, Inc. is

[PATCH 2/3] staging: gs_fpgpaboot: fix compiler warning with make W=1

2014-10-24 Thread Devendra Naga
the following compiler warning has been fixed: drivers/staging/gs_fpgaboot/gs_fpgaboot.c: In function ‘gs_read_bitstream’: drivers/staging/gs_fpgaboot/gs_fpgaboot.c:160:6: warning: variable ‘size’ set but not used [-Wunused-but-set-variable] CC drivers/staging/gs_fpgaboot/io.o LD

[PATCH 1/3] staging: gs_fpgaboot: cleanup in gs_fpgaboot_init function

2014-10-24 Thread Devendra Naga
the error path is cleanup to return the correct (function call return value) error code. Signed-off-by: Devendra Naga devendrana...@gmail.com --- drivers/staging/gs_fpgaboot/gs_fpgaboot.c | 15 +-- 1 file changed, 5 insertions(+), 10 deletions(-) diff --git

[PATCH 3/3] staging: gs_fpgaboot: fix a compiler warning with make W=2

2014-10-24 Thread Devendra Naga
The below warning is fixed: drivers/staging/gs_fpgaboot/gs_fpgaboot.c: In function ‘gs_load_image’: drivers/staging/gs_fpgaboot/gs_fpgaboot.c:196:58: warning: declaration of ‘file’ shadows a global declaration [-Wshadow] drivers/staging/gs_fpgaboot/gs_fpgaboot.c:45:14: warning: shadowed

Re: [RFCv2 2/3] staging: ion: debugfs to shrink pool

2014-10-24 Thread Laura Abbott
Hi, On 10/23/2014 11:47 PM, Gioh Kim wrote: This patch creates debugfs files, /sys/kernel/debug/ion/heaps/system_shrink, to shrink pool or get pool size. Reading the file returns pool size and writing occurs to shrink pool. Can you clarify here that you are updating the existing debugfs

Re: [RFCv2 3/3] staging: ion: limit pool size

2014-10-24 Thread Laura Abbott
Hi, On 10/23/2014 11:47 PM, Gioh Kim wrote: This patch limits pool size by page unit. This looks useful. Might be nice to add a debugfs option to change this at runtime as well. Signed-off-by: Gioh Kim gioh@lge.com --- drivers/staging/android/ion/Kconfig |4

[PATCH v6 0/7] staging: skein: CryptoAPI and Module Support

2014-10-24 Thread Eric Rost
Adds CryptoAPI and loadable module support to the Skein Hashing Algorithm. Collapses threefish module into skein module. Renames skein.c and skein.h to skein_base.c and skein_base.h so module can be named skein.ko. Inlines rotl_64 macro. Removes unneeded #define and skein_debug.h include. Eric

[PATCH v6 2/7] staging: skein: Renames skein to skein_base

2014-10-24 Thread Eric Rost
Renames skein.c to skein_base.c and skein.h to skein_base.h in preparation for naming loadable module skein.ko Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Makefile | 2 +- drivers/staging/skein/skein_api.h | 2 +-

[PATCH v6 3/7] staging: skein: Adds CryptoAPI Support

2014-10-24 Thread Eric Rost
Adds CryptoAPI support to the Skein Hashing Algorithm driver. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Makefile| 3 +- drivers/staging/skein/skein_base.h| 5 + drivers/staging/skein/skein_generic.c | 199 ++ 3

[PATCH v6 4/7] staging: skein: Adds Loadable Module Support

2014-10-24 Thread Eric Rost
Adds loadable module support to the Skein Hashing Algorithm driver. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/Kconfig | 2 +- drivers/staging/skein/Makefile| 13 +++-- drivers/staging/skein/skein_generic.c | 19 ++- 3

[PATCH v6 5/7] staging: skein: Inlines rotl_64

2014-10-24 Thread Eric Rost
Inlines the rotl_64 macro. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/skein_base.h | 19 ++- 1 file changed, 10 insertions(+), 9 deletions(-) diff --git a/drivers/staging/skein/skein_base.h b/drivers/staging/skein/skein_base.h index

[PATCH v6 7/7] staging: skein: Removes skein_debug include

2014-10-24 Thread Eric Rost
Removes skein_debug.h include since skein_debug.h is nonexistent. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/skein_base.h | 9 + 1 file changed, 1 insertion(+), 8 deletions(-) diff --git a/drivers/staging/skein/skein_base.h

[PATCH v6 6/7] staging: skein: Removes unneeded #define

2014-10-24 Thread Eric Rost
Removes unneeded #define SKEIN_PORT_CODE since skein_port.h is nonexistent. Signed-off-by: Eric Rost eric.r...@mybabylon.net --- drivers/staging/skein/skein_base.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/skein/skein_base.c b/drivers/staging/skein/skein_base.c index

[PATCH] Staging:rtl8723au:core brace issue

2014-10-24 Thread Paul McQuade
ERROR: that open brace { should be on the previous line Signed-off-by: Paul McQuade paulmcq...@gmail.com --- drivers/staging/rtl8723au/core/rtw_ap.c | 137 ++-- 1 file changed, 43 insertions(+), 94 deletions(-) diff --git a/drivers/staging/rtl8723au/core/rtw_ap.c

[PATCH] Staging:rtl8723au: open/closed brace issue

2014-10-24 Thread Paul McQuade
ERROR: that open brace { should be on the previous line Signed-off-by: Paul McQuade paulmcq...@gmail.com --- drivers/staging/rtl8723au/core/rtw_ap.c | 130 ++-- 1 file changed, 40 insertions(+), 90 deletions(-) diff --git a/drivers/staging/rtl8723au/core/rtw_ap.c

[PATCH 0/2] staging: lustre: Minor lnet module cleanup

2014-10-24 Thread Mariusz Gorski
These patches fix some sparse warnings and apply __init and __exit markers to module's init and exit functions. Mariusz Gorski (2): staging: lustre: Reduce function visibility staging: lustre: Use __init and __exit markers for lifecycle functions drivers/staging/lustre/lnet/lnet/module.c |

[PATCH 1/2] staging: lustre: Reduce function visibility

2014-10-24 Thread Mariusz Gorski
This patch fixes the following sparse warnings: drivers/staging/lustre/lnet/lnet/module.c:47:1: warning: symbol 'lnet_configure' was not declared. Should it be static? drivers/staging/lustre/lnet/lnet/module.c:67:1: warning: symbol 'lnet_unconfigure' was not declared. Should it be static?

[PATCH 2/2] staging: lustre: Use __init and __exit markers for lifecycle functions

2014-10-24 Thread Mariusz Gorski
Apply __init marker to module's init function and __exit to module's exit function as they both have no other usage. --- drivers/staging/lustre/lnet/lnet/module.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/lustre/lnet/lnet/module.c

[PATCH v2 0/2] staging: lustre: Minor lnet module cleanup

2014-10-24 Thread Mariusz Gorski
These patches fix some sparse warnings and apply __init and __exit markers to module's init and exit functions. v2: Add missing commit sign-offs Mariusz Gorski (2): staging: lustre: Reduce function visibility staging: lustre: Use __init and __exit markers for lifecycle functions

[PATCH v2 2/2] staging: lustre: Use __init and __exit markers for lifecycle functions

2014-10-24 Thread Mariusz Gorski
Apply __init marker to module's init function and __exit to module's exit function as they both have no other usage. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com --- drivers/staging/lustre/lnet/lnet/module.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH v2 1/2] staging: lustre: Reduce function visibility

2014-10-24 Thread Mariusz Gorski
This patch fixes the following sparse warnings: drivers/staging/lustre/lnet/lnet/module.c:47:1: warning: symbol 'lnet_configure' was not declared. Should it be static? drivers/staging/lustre/lnet/lnet/module.c:67:1: warning: symbol 'lnet_unconfigure' was not declared. Should it be static?

Re: [PATCH 01/10] staging: unisys: fix blank lines virthba

2014-10-24 Thread Greg KH
On Wed, Oct 22, 2014 at 05:52:21PM -0400, Erik Arfvidson wrote: This patch removes unnecessary blanks lines and adds necessary blank lines in virthba. Signed-off-by: Erik Arfvidson erik.arfvid...@unisys.com Signed-off-by: Benjamin Romer benjamin.ro...@unisys.com ---

Re: [PATCH] Staging:rtl8723au: open/closed brace issue

2014-10-24 Thread Sudip Mukherjee
On Sat, Oct 25, 2014 at 01:05:13AM +0100, Paul McQuade wrote: ERROR: that open brace { should be on the previous line Signed-off-by: Paul McQuade paulmcq...@gmail.com --- drivers/staging/rtl8723au/core/rtw_ap.c | 130 ++-- 1 file changed, 40 insertions(+), 90

Re: [PATCH] Staging:rtl8723au:core brace issue

2014-10-24 Thread Sudip Mukherjee
On Sat, Oct 25, 2014 at 12:22:32AM +0100, Paul McQuade wrote: ERROR: that open brace { should be on the previous line patch is corrupt. thanks sudip Signed-off-by: Paul McQuade paulmcq...@gmail.com --- drivers/staging/rtl8723au/core/rtw_ap.c | 137 ++-- 1