[PATCH staging] rtl8188eu : BIT() macro cleanup

2015-10-18 Thread Anish Bhatt
Use the BIT(x) macro directly instead using multiple BITX defines. Signed-off-by: Anish Bhatt --- drivers/staging/rtl8188eu/core/rtw_efuse.c | 48 +-- drivers/staging/rtl8188eu/hal/bb_cfg.c | 2 +- drivers/staging/rtl8188eu/hal/odm.c| 24 +- drivers/stagin

[PATCH] staging: rtl8712: Add device ID for Sitecom WLA2100

2015-10-18 Thread Larry Finger
This adds the USB ID for the Sitecom WLA2100. The Windows 10 inf file was checked to verify that the addition is correct. Reported-by: Frans van de Wiel Signed-off-by: Larry Finger Cc: Frans van de Wiel Cc: Stable [All stable versions] --- drivers/staging/rtl8712/usb_intf.c | 1 + 1 file chan

Re: [PATCH v2 4/4] Staging: rtl8712: fix warning for placing constant on the right side of test

2015-10-18 Thread Larry Finger
On 10/18/2015 09:00 PM, Greg KH wrote: On Sun, Oct 18, 2015 at 12:02:53PM +0530, punit vara wrote: One more thing I would like suggestion how can start switching this driver to LIB80211 ,MAC80211 ? Which is the first file I should focus ? Simultaneously I am trying to understand the flow of driv

Re: [PATCH 03/16] staging: wilc1000: rename g_linux_wlan to wl

2015-10-18 Thread Tony Cho
On 2015년 10월 17일 13:33, Greg KH wrote: On Wed, Oct 14, 2015 at 08:46:31PM +0900, Tony Cho wrote: This patch renames g_linux_wlan to wl. Why? What's wrong with g_linux_wlan? You will need to delete this entire variable soon anyway, might as well leave it alone until then. The reason why I

Re: [PATCH v2 4/4] Staging: rtl8712: fix warning for placing constant on the right side of test

2015-10-18 Thread Greg KH
On Sun, Oct 18, 2015 at 12:02:53PM +0530, punit vara wrote: > On Sat, Oct 17, 2015 at 10:46 AM, Greg KH wrote: > > On Wed, Oct 14, 2015 at 11:55:55PM +0530, Punit Vara wrote: > >> Put constant on the right side of a test.Problem found using checkpatch: > >> > >> Warning:Comparisons should place th

Re: [PATCH 35/40] staging: wilc1000: rename variable s32Error

2015-10-18 Thread Tony Cho
On 2015년 10월 17일 13:56, Greg KH wrote: On Thu, Oct 15, 2015 at 01:25:16PM +0900, Tony Cho wrote: From: Leo Kim This patch renames variable s32Error to result to avoid CamelCase naming convention. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.

Re: [PATCH V2 01/40] staging: wilc1000: rename ssidLen of struct join_bss_param

2015-10-18 Thread Tony Cho
On 2015년 10월 17일 13:59, Greg KH wrote: On Fri, Oct 16, 2015 at 01:37:31PM +0900, Tony Cho wrote: From: Leo Kim This patch renames ssidLen of struct join_bss_param to ssid_len to avoid CamelCase naming convention. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc100

Re: [PATCH V2] staging: wilc1000: wilc_msgqueue.c : remove the goto ERRORHANDER

2015-10-18 Thread Tony Cho
On 2015년 10월 17일 13:28, Greg KH wrote: On Wed, Oct 14, 2015 at 05:52:55PM +0900, Tony Cho wrote: On 2015년 10월 14일 17:32, Mike Rapoport wrote: On Wed, Oct 14, 2015 at 02:55:43PM +0900, Tony Cho wrote: From: Leo Kim This patch removes goto ERRORHANDER and the result variable in wilc_mq_send

Re: [PATCHv5] staging: vme_user: provide DMA functionality

2015-10-18 Thread Martyn Welch
On 18/10/15 18:53, Dmitry Kalinkin wrote: On Sun, Oct 18, 2015 at 10:31 AM, Martyn Welch wrote: On 11/10/15 01:13, Dmitry Kalinkin wrote: This introduces a new dma device that provides a single ioctl call that provides DMA read and write functionality to the user space. Signed-off-by: Dmit

[PATCH] staging: emxx_udc: Remove boolean comparisons

2015-10-18 Thread Luis de Bethencourt
Boolean tests do not need explicit comparison to true or false. Signed-off-by: Luis de Bethencourt --- drivers/staging/emxx_udc/emxx_udc.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/emxx_udc/emxx_udc.c b/drivers/staging/emxx_udc/emxx_udc.c ind

[PATCH] staging: ft1000: Remove boolean comparisons

2015-10-18 Thread Luis de Bethencourt
Boolean tests do not need explicit comparison to true or false. Signed-off-by: Luis de Bethencourt --- drivers/staging/ft1000/ft1000-pcmcia/ft1000_hw.c | 4 ++-- drivers/staging/ft1000/ft1000-usb/ft1000_hw.c| 2 +- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/stagin

[PATCH] staging: rtl8712: Remove boolean comparisons

2015-10-18 Thread Luis de Bethencourt
Boolean tests do not need explicit comparison to true or false. Signed-off-by: Luis de Bethencourt --- drivers/staging/rtl8712/os_intfs.c| 4 +- drivers/staging/rtl8712/rtl8712_cmd.c | 9 +- drivers/staging/rtl8712/rtl8712_efuse.c | 49 drivers/staging/rtl

Re: [PATCH 1/2 v3] drivers: staging: rtl8723au: Changed rssi_cmd to little-endian param

2015-10-18 Thread Jacob Kiefer
> I am fine with this code in principle, but has it been tested? This > stuff will break the driver miserably if it's wrong. > > Thanks, > Jes > This patchset has not been tested. Unfortunately, I don't have to proper card to test this patch on my local. It built for me, and that's as far as I w

Re: [PATCH v2 4/4] Staging: rtl8712: fix warning for placing constant on the right side of test

2015-10-18 Thread Tillmann Heidsieck
On Sun, Oct 18, 2015 at 08:54:57PM +0200, Tillmann Heidsieck wrote: > Hi, [...] > Greg is probably trying to apply this series to the staging-next branch of > his staging tree[0] > so you need to clone that one, or add it as an additional remote[1] to your > clone of the kernel tree (much better

Re: [PATCH v2 4/4] Staging: rtl8712: fix warning for placing constant on the right side of test

2015-10-18 Thread Tillmann Heidsieck
Hi, On 2015-10-18 08:32, punit vara wrote: On Sat, Oct 17, 2015 at 10:46 AM, Greg KH wrote: On Wed, Oct 14, 2015 at 11:55:55PM +0530, Punit Vara wrote: Put constant on the right side of a test.Problem found using checkpatch: Warning:Comparisons should place the constant on the right side of

The World Bank

2015-10-18 Thread The
The World Bank 1818 H Street, NW Washington, DC 20433. United States Phone: + 1 252 8481 269 Fax:+ 1 477 6391 October 17, 2015. Dear Sir/Madam, The World Bank operates day-to-day under the leadership and direction of the president, management and senior staff, and the vice presidents in cha

Re: [PATCH] vme: 8-bit status/id takes 256 values, not 255

2015-10-18 Thread Martyn Welch
On 18/10/15 18:07, Dmitry Kalinkin wrote: On Sun, Oct 18, 2015 at 9:30 AM, Martyn Welch wrote: On 10 October 2015 at 23:00, Dmitry Kalinkin wrote: Fixes an off by one array size. The Status/ID is an 8-bit value (OK, the standard states it can be a 8, 16 or 32-bit value, however both of th

[PATCHv6] staging: vme_user: provide DMA functionality

2015-10-18 Thread Dmitry Kalinkin
This introduces a new dma device that provides a single ioctl call that provides DMA read and write functionality to the user space. Signed-off-by: Dmitry Kalinkin Cc: Igor Alekseev --- v5: Added a validation for dma_op argument in vme_user_sg_to_dma_list(). It is already checked in caller but

Re: [PATCHv5] staging: vme_user: provide DMA functionality

2015-10-18 Thread Dmitry Kalinkin
On Sun, Oct 18, 2015 at 10:31 AM, Martyn Welch wrote: > > > On 11/10/15 01:13, Dmitry Kalinkin wrote: >> >> This introduces a new dma device that provides a single ioctl call that >> provides DMA read and write functionality to the user space. >> >> Signed-off-by: Dmitry Kalinkin >> Cc: Igor Alek

Re: [PATCH] vme: 8-bit status/id takes 256 values, not 255

2015-10-18 Thread Dmitry Kalinkin
On Sun, Oct 18, 2015 at 9:30 AM, Martyn Welch wrote: > On 10 October 2015 at 23:00, Dmitry Kalinkin > wrote: >> Fixes an off by one array size. >> > > The Status/ID is an 8-bit value (OK, the standard states it can be a > 8, 16 or 32-bit value, however both of the chipsets we support at this > p

[PATCH 5/9] staging: wilc1000: fix trivial typos

2015-10-18 Thread Geliang Tang
s/regsiter/register/ Signed-off-by: Geliang Tang --- drivers/staging/wilc1000/linux_wlan.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/wilc1000/linux_wlan.c b/drivers/staging/wilc1000/linux_wlan.c index ccab89f..6dc5faf 100644 --- a/drivers/staging/wi

[PATCH 2/3] staging: lustre: make sptlrpc_flavor_has_bulk return boolean

2015-10-18 Thread Geliang Tang
This patch makes sptlrpc_flavor_has_bulk return boolean, since this function only uses either one or zero as its return value. Signed-off-by: Geliang Tang --- drivers/staging/lustre/lustre/include/lustre_sec.h | 2 +- drivers/staging/lustre/lustre/ptlrpc/sec.c | 6 +++--- 2 files changed

[PATCH 3/3] staging: xgifb: make XGIfb_has_VB return boolean

2015-10-18 Thread Geliang Tang
This patch makes XGIfb_has_VB return boolean, since this function only uses either one or zero as its return value. Signed-off-by: Geliang Tang --- drivers/staging/xgifb/XGI_main_26.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/xgifb/XGI_main_26.c b

[PATCH 1/3] staging: comedi: make ni_tio_has_gate2_registers return boolean

2015-10-18 Thread Geliang Tang
This patch makes ni_tio_has_gate2_registers return boolean, since this function only uses either one or zero as its return value. Signed-off-by: Geliang Tang --- drivers/staging/comedi/drivers/ni_tio.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/come

Re: [PATCHv5] staging: vme_user: provide DMA functionality

2015-10-18 Thread Martyn Welch
On 11/10/15 01:13, Dmitry Kalinkin wrote: This introduces a new dma device that provides a single ioctl call that provides DMA read and write functionality to the user space. Signed-off-by: Dmitry Kalinkin Cc: Igor Alekseev ---

[PATCH v2 2/2] staging: IB/ipath: remove sched.h header

2015-10-18 Thread Geliang Tang
sched.h header in ipath_*.c is now unnecessary, since I have added sched.h in ipath_kernel.h. So remove it. Signed-off-by: Geliang Tang --- Changes in v2: - split it into two patches. --- drivers/staging/rdma/ipath/ipath_driver.c | 1 - drivers/staging/rdma/ipath/ipath_intr.c| 1 -

[PATCH v2 1/2] staging: IB/ipath: use TASK_COMM_LEN in ipath_portdata

2015-10-18 Thread Geliang Tang
Use comm[TASK_COMM_LEN] instead of comm[16] in ipath_kernel.h. And add sched.h header in it. Signed-off-by: Geliang Tang --- Changes in v2: - split it into two patches. --- drivers/staging/rdma/ipath/ipath_kernel.h | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/st

Re: [PATCH] vme: 8-bit status/id takes 256 values, not 255

2015-10-18 Thread Martyn Welch
On 10 October 2015 at 23:00, Dmitry Kalinkin wrote: > Fixes an off by one array size. > The Status/ID is an 8-bit value (OK, the standard states it can be a 8, 16 or 32-bit value, however both of the chipsets we support at this point in time support an 8-bit value), why do we need a 256th entry i

[PATCH v2 5/5] staging: lustre: libcfs.h: remove IS_PO2 and __is_po2

2015-10-18 Thread Aya Mahfouz
Removes IS_PO2 and __is_po2 since the uses of IS_PO2 have been replaced by is_power_of_2 Signed-off-by: Aya Mahfouz --- v2: -became patch number 5 in the series drivers/staging/lustre/include/linux/libcfs/libcfs.h | 7 --- 1 file changed, 7 deletions(-) diff --git a/drivers/staging

[PATCH v2 4/5] staging: lustre: selftest.h: replace IS_PO2 by is_power_of_2

2015-10-18 Thread Aya Mahfouz
Replaces IS_PO2 by is_power_of_2. It is more accurate to use is_power_of_2 since it returns 1 for numbers that are powers of 2 only whereas IS_PO2 returns 1 for 0 and numbers that are powers of 2. Signed-off-by: Aya Mahfouz --- v2: -added new patch in patch set for selftest.h drivers/st

[PATCH v2 3/5] staging: lustre: workitem.c: replace IS_PO2 by is_power_of_2

2015-10-18 Thread Aya Mahfouz
Replaces IS_PO2 by is_power_of_2. It is more accurate to use is_power_of_2 since it returns 1 for numbers that are powers of 2 only whereas IS_PO2 returns 1 for 0 and numbers that are powers of 2. Reviewed-by: Andreas Dilger Signed-off-by: Aya Mahfouz --- v2: -changed commit message

[PATCH v2 2/5] staging: lustre: hash.c: Replace IS_PO2 by is_power_of_2

2015-10-18 Thread Aya Mahfouz
Replaces IS_PO2 by is_power_of_2. It is more accurate to use is_power_of_2 since it returns 1 for numbers that are powers of 2 only whereas IS_PO2 returns 1 for 0 and numbers that are powers of 2. Reviewed-by: Andreas Dilger Signed-off-by: Aya Mahfouz --- v2: -changed commit message

[PATCH v2 1/5] staging: lustre: ldlm_extent.c: replace IS_PO2 by is_power_of_2

2015-10-18 Thread Aya Mahfouz
Replaces IS_PO2 by is_power_of_2. It is more accurate to use is_power_of_2 since it returns 1 for numbers that are powers of 2 only whereas IS_PO2 returns 1 for 0 and numbers that are powers of 2. Signed-off-by: Aya Mahfouz --- v2: -changed commit message drivers/staging/lustre/lustre/l

[PATCH v2 0/5] Remove uses and definition of IS_PO2

2015-10-18 Thread Aya Mahfouz
Concerned with the removal of IS_PO2 by replacing its uses with is_power_of_2 and then removing the definition. This is the second version of the patch set. The commit messages were changed and a new patch was added for a use of IS_PO2 indicated by kbuild test robot. Aya Mahfouz (5): staging: l

Re: [PATCH 4/4] staging: lustre: remove IS_PO2 and __is_po2

2015-10-18 Thread Aya Mahfouz
On Fri, Oct 16, 2015 at 10:21:05PM -0700, Greg KH wrote: > On Sat, Oct 17, 2015 at 12:07:28AM +0200, Aya Mahfouz wrote: > > Removes IS_PO2 and __is_po2 since the uses of IS_PO2 have > > been replaced by is_power_of_2 > > > > Signed-off-by: Aya Mahfouz > > --- > > drivers/staging/lustre/include/l

Re: [PATCH] staging: wilc1000: restore wilc_spi_dev variable

2015-10-18 Thread Stanislav Kholmanskikh
Hi! On 16.10.2015 23:05, Arnd Bergmann wrote: > A recent change to wilc1000 accidentally deleted an important > variable, so we now get a build error when the SPI mode is > selected: > > ERROR: "wilc_spi_dev" [drivers/staging/wilc1000/wilc1000.ko] undefined! > > This partially reverts the broken