[PATCH 01/30] staging: sm750fb: formatPllReg: rename ulPllReg to reg

2016-02-10 Thread Mike Rapoport
Remove HungarianCamelCase notation Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_chip.c b/drivers/staging/sm750fb/ddk750_chip.c index

[PATCH 10/30] staging: sm750fb: programModeRegisters: rename local vairables

2016-02-10 Thread Mike Rapoport
Remove HungarianCamelCase notation. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_mode.c | 28 1 file changed, 16 insertions(+), 12 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_mode.c

[PATCH 19/30] staging: sm750fb: change definition of PANEL_FB_ADDRESS fields

2016-02-10 Thread Mike Rapoport
Use BIT() macro for single-bit fields of PANEL_FB_ADDRESS register and define PANEL_FB_ADDRESS_ADDRESS_MASK for masking the address bits. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_reg.h | 10 +++--- drivers/staging/sm750fb/sm750_hw.c | 8

[PATCH 20/30] staging: sm750fb: change definition of PANEL_FB_WIDTH fields

2016-02-10 Thread Mike Rapoport
Use stratight-forward defintion of PANEL_FB_WIDTH register fields and use open-coded implementation for register manipulations Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_reg.h | 5 +++-- drivers/staging/sm750fb/sm750_hw.c | 8 2 files

[PATCH 24/30] staging: sm750fb: change definition of PANEL_PLANE_BR fields

2016-02-10 Thread Mike Rapoport
Use stratight-forward defintion of PANEL_PLANE_BR register fields and use open-coded implementation for register manipulations Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_reg.h | 5 +++-- drivers/staging/sm750fb/sm750_hw.c | 7 --- 2 files

[PATCH 23/30] staging: sm750fb: change definition of PANEL_PLANE_TL fields

2016-02-10 Thread Mike Rapoport
Use stratight-forward defintion of PANEL_PLANE_TL register fields Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_reg.h | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_reg.h

[PATCH 25/30] staging: sm750fb: use BIT macro for DMA_ABORT_INTERRUPT single-bit fields

2016-02-10 Thread Mike Rapoport
Replace complex definition of DMA_ABORT_INTERRUPT register fields with BIT() macro and use open-coded implementation for register manipulation Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 2 +- drivers/staging/sm750fb/ddk750_reg.h | 20

[PATCH 21/30] staging: sm750fb: change definition of PANEL_WINDOW_WIDTH fields

2016-02-10 Thread Mike Rapoport
Use stratight-forward defintion of PANEL_WINDOW_WIDTH register fields and use open-coded implementation for register manipulations Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_reg.h | 5 +++-- drivers/staging/sm750fb/sm750_hw.c | 7 --- 2 files

[PATCH 27/30] staging: sm750fb: change definition of CRT_DISPLAY_CTRL multi-bit fields

2016-02-10 Thread Mike Rapoport
Use more straight-forward definitions for multi-bit fields of CRT_DISPLAY_CTRL register and use open-coded implementation for register manipulation Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_display.c | 4 ++- drivers/staging/sm750fb/ddk750_mode.c

[PATCH 22/30] staging: sm750fb: change definition of PANEL_WINDOW_HEIGHT fields

2016-02-10 Thread Mike Rapoport
Use stratight-forward defintion of PANEL_WINDOW_HEIGHT register fields and use open-coded implementation for register manipulations Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_reg.h | 5 +++-- drivers/staging/sm750fb/sm750_hw.c | 8 +--- 2

[PATCH 29/30] staging: sm750fb: use BIT macro for I2C_STATUS fields

2016-02-10 Thread Mike Rapoport
Replace complex definition of I2C_STATUS register fields with BIT() macro and use open-coded implementation for register manipulation Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_hwi2c.c | 4 +--- drivers/staging/sm750fb/ddk750_reg.h | 18

[PATCH 28/30] staging: sm750fb: use BIT macro for I2C_CTRL fields

2016-02-10 Thread Mike Rapoport
Replace complex definition of I2C_CTRL register fields with BIT() macro and use open-coded implementation for register manipulation Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_hwi2c.c | 19 +++ drivers/staging/sm750fb/ddk750_reg.h |

[PATCH 30/30] staging: sm750fb: change definition of PANEL_HORIZONTAL_TOTAL fields

2016-02-10 Thread Mike Rapoport
Use stratight-forward defintion of PANEL_HORIZONTAL_TOTAL register fields and use open-coded implementation for register manipulations Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_mode.c | 9 ++--- drivers/staging/sm750fb/ddk750_reg.h | 5 +++--

[PATCH 26/30] staging: sm750fb: use BIT macro for CRT_DISPLAY_CTRL single-bit fields

2016-02-10 Thread Mike Rapoport
Replace complex definition of CRT_DISPLAY_CTRL register fields with BIT() macro and use open-coded implementation for register manipulation Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_display.c | 2 +- drivers/staging/sm750fb/ddk750_mode.c| 3

[PATCH 02/30] staging: sm750fb: formatPllReg: fix comment formatting

2016-02-10 Thread Mike Rapoport
Fix comment alignment and formatting to follow kernel coding style Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 10 ++ 1 file changed, 6 insertions(+), 4 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_chip.c

[PATCH 03/30] staging: sm750fb: rename PANEL_PLL_CTRL_* fields to PLL_CTRL_*

2016-02-10 Thread Mike Rapoport
Several PLL control registers have the same layout and therefore the field definitions may be shared for those registers. Renaming definitions of PANEL_PLL_CTRL_* fields to more generic PLL_CTRL_* will allow reusing these definitions for other PLL control registers. Signed-off-by: Mike Rapoport

[PATCH 06/30] staging: sm750fb: change defintion of PANEL_PLL_CTRL multi-bit fields

2016-02-10 Thread Mike Rapoport
Use more straight-forward definitions for multi-bit field of PANEL_PLL_CTRL register and use open-coded implementation for register manipulations. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 24 +++-

[PATCH 07/30] staging: sm750fb: drop redundant defines for PLL_CTRL fields

2016-02-10 Thread Mike Rapoport
The PLL_CTRL fields have common defines for several PLL control registers and re-defining the same values per register is not needed. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_reg.h | 64 1 file changed, 64

[PATCH 04/30] staging: sm750fb: use PLL_CTRL_POWER defines for CRT_PLL_CTRL

2016-02-10 Thread Mike Rapoport
Use PLL_CTRL_POWER definitions for CRT_PLL_CTRL register access Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_display.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_display.c

[PATCH 12/30] staging: sm750fb: share common bits in display control registers

2016-02-10 Thread Mike Rapoport
The display control registers for primary and secondary display share some of the bits and those bits can be defined in a single place and then used for manipulations of the relevant registers. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c|

[PATCH 05/30] staging: sm750fb: use BIT macro for PLL_CTRL single-bit fields

2016-02-10 Thread Mike Rapoport
Replace complex defintion of PLL_CTRL fields with BIT() macro and use open-coded implementation for PLL register manipulations. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c| 5 + drivers/staging/sm750fb/ddk750_display.c | 6 ++

[PATCH 09/30] staging: sm750fb: change definition of VGA_CONFIGURATION multi-bit field

2016-02-10 Thread Mike Rapoport
Use more straight-forward definitions for multi-bit field of VGA_CONFIGURATION register. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_reg.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/sm750fb/ddk750_reg.h

[PATCH 11/30] staging: sm750fb: setDisplayControl: rename local vairables

2016-02-10 Thread Mike Rapoport
Remove HungarianCamelCase notation. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_display.c | 50 1 file changed, 25 insertions(+), 25 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_display.c

[PATCH 08/30] staging: sm750fb: use BIT macro for VGA_CONFIGURATION single-bit fields

2016-02-10 Thread Mike Rapoport
Replace complex defintion of VGA_CONFIGURATION register fields with BIT() macro and use open-coded implementation for VGA_CONFIGURATION manipulations. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 3 +-- drivers/staging/sm750fb/ddk750_reg.h |

[PATCH 14/30] staging: sm750fb: refactor setDisplayControl function

2016-02-10 Thread Mike Rapoport
The enable/disbable sequence in setDisplayControl function is duplicated for primary and secondary display controllers. The function can be refactored so that the common part of register access will be shared for both controllers. Signed-off-by: Mike Rapoport ---

[PATCH 15/30] staging: sm750fb: hw_sm750_setBLANK: reduce printk verbosity

2016-02-10 Thread Mike Rapoport
pr_debug would be enough Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/sm750_hw.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/sm750fb/sm750_hw.c b/drivers/staging/sm750fb/sm750_hw.c index c0c2f1c..52fd250 100644

[PATCH 16/30] staging: sm750fb: use BIT macro for PANEL_DISPLAY_CTRL single-bit fields

2016-02-10 Thread Mike Rapoport
Replace complex definition of PANEL_DISPLAY_CTRL register fields with BIT() macro and use open-coded implementation for register manipulations. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c| 6 +-- drivers/staging/sm750fb/ddk750_display.c |

[PATCH 17/30] staging: sm750fb: remove PANEL_DISPLAY_CTRL_TFT_DISP defines

2016-02-10 Thread Mike Rapoport
The PANEL_DISPLAY_CTRL_TFT_DISP definitions artificially encode PANEL_DISPLAY_CTRL_DUAL_DISPLAY and PANEL_DISPLAY_CTRL_DOUBLE_PIXEL bits combinations. Replace the PANEL_DISPLAY_CTRL_TFT_DISP usage with direct use of the bits defined in the datasheet. Signed-off-by: Mike Rapoport

[PATCH 18/30] staging: sm750fb: change definition of PANEL_DISPLAY_CTRL multi-bit fields

2016-02-10 Thread Mike Rapoport
Use more straight-forward definitions for multi-bit fields of PANEL_DISPLAY_CTRL register and use open-coded implementation for register manipulation Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_display.c | 4 +++-

[PATCH 00/30] staging: sm750fb: change some register fields defines

2016-02-10 Thread Mike Rapoport
Hi, This is the second set of patches that aim to replace custom defines for register fields. The ultimate goal is to have MSB:LSB notation for register fields and FIELD_* macros removed. Mike Rapoport (30): staging: sm750fb: formatPllReg: rename ulPllReg to reg staging: sm750fb:

[PATCH 2/5] staging/lustre/obdecho: Better handle invalid create requests

2016-02-10 Thread green
From: Oleg Drokin When gettng an invalid create request in echo code (wrong group, or no group at all), just return an error instead of crashing. Signed-off-by: Oleg Drokin --- drivers/staging/lustre/lustre/obdecho/echo_client.c | 11 --- 1

Re: [PATCH v2 7/9] Staging: rts5208: rtsx_transport.c: Remove unnecessary parentheses

2016-02-10 Thread Shaun Ren
On Tue 2016-02-09 at 21:26 (-0800), Sudip Mukherjee wrote: > On Mon, Feb 08, 2016 at 05:31:23PM -0800, Shaun Ren wrote: >> This patch removes all unnecessary parentheses found by checkpatch.pl. >> >> Signed-off-by: Shaun Ren > > This will not apply anymore because of some

[PATCH 5/5] staging/lustre: Remove unused LUSTRE_VERSION_ALLOWED_OFFSET define

2016-02-10 Thread green
From: Oleg Drokin LUSTRE_VERSION_ALLOWED_OFFSET is only used on the server to disallow connection of old userspace clients. Signed-off-by: Oleg Drokin --- drivers/staging/lustre/lustre/include/lustre_ver.h | 9 +++-- 1 file changed, 3

[PATCH 3/5] staging/lustre: Adjust import state history output format

2016-02-10 Thread green
From: Oleg Drokin New test scripts expect spaces around state names and square brackets when parsing debugfs output, so add them to avoid false failures. Signed-off-by: Oleg Drokin --- drivers/staging/lustre/lustre/obdclass/lprocfs_status.c | 14

[PATCH 1/5] staging/lustre/obdecho: Remove always true condition

2016-02-10 Thread green
From: Oleg Drokin Dan Carpenter noticed that since we already checked for (oa->o_valid & OBD_MD_FLID) == 0, that means (oa->o_valid & OBD_MD_FLID) is always true after that so no point in checking for it. Signed-off-by: Oleg Drokin Reported-by: Dan

[PATCH 0/5] Few misc Lustre fixes

2016-02-10 Thread green
From: Oleg Drokin This patchset fixes some minor Lustre problems and also updates the internal version. Please consider. Oleg Drokin (5): staging/lustre/obdecho: Remove always true condition staging/lustre/obdecho: Better handle invalid create requests

[PATCH 4/5] staging/lustre: Update internal client version.

2016-02-10 Thread green
From: Oleg Drokin While initial code drop was corresponding to 2.3.64, lots of different changes went in since then, and also quite a bunch of fixes, but almost none of the new features. Code-wise we are almost at 2.5.0, so let's call it 2.4.60 - this is a version that was

Fwd: Re: wilc1000 staging driver initialization failure

2016-02-10 Thread Andrew Boyce
Sorry for the mass forward, I was instructed to email more than just the linux-wireless mailing list. Any help would be appreciated. Thanks! -Andrew Forwarded Message Subject: Re: wilc1000 staging driver initialization failure Date: Thu, 4 Feb 2016 13:26:04 -0500

[PATCH v2] Staging: fix coding style in rtl8188eu/core

2016-02-10 Thread Colin Vidal
Set constant operand on right of test, and refactor the code in a more compact and readable way. Signed-off-by: Colin Vidal --- drivers/staging/rtl8188eu/core/rtw_iol.c | 13 + 1 file changed, 5 insertions(+), 8 deletions(-) diff --git

[PATCH V2 2/4] staging: wilc1000: use int type for counter variable

2016-02-10 Thread Chaehyun Lim
counter is used as for-loop control variable and indicating index of struct wid array so that it is better to use int type. There is no need to set to 0 when it is declared at the top of this function. It is initialized as 0 in for-loop statement. Signed-off-by: Chaehyun Lim

[PATCH V2 4/4] staging: wilc1000: rename counter in wilc_send_config_pkt

2016-02-10 Thread Chaehyun Lim
This patch renames the name of counter variable to i. This change makes more readability because wilc_send_config_pkt has a similar argument name as count. Signed-off-by: Chaehyun Lim --- v2: rebase latest staging-testing drivers/staging/wilc1000/wilc_wlan.c | 31

[PATCH V2 3/4] staging: wilc1000: remove initialization code of counter variable

2016-02-10 Thread Chaehyun Lim
There is no need to set to 0 for counter variable before entering next for-loop statement because counter is initialized again in for-loop statement, so just remove it. Signed-off-by: Chaehyun Lim --- v2: rebase latest staging-testing

[PATCH V2 1/4] staging: wilc1000: fix return type of wilc_send_config_pkt

2016-02-10 Thread Chaehyun Lim
wilc_send_config_pkt is returned 0 or -ETIMEDOUT according to return value of wilc_wlan_cfg_set or wilc_wlan_cfg_set. It is better to use int type to represent linux standard error code. Signed-off-by: Chaehyun Lim --- v2: rebase latest staging-testing

Re: [patch] staging: wilc1000: fix mgmt_tx()

2016-02-10 Thread walter harms
Am 10.02.2016 10:05, schrieb Dan Carpenter: > There was a missing curly brace so this function returns failure instead > of succeeding. > > Fixes: 06fb9336acdc ('staging: wilc1000: wilc_wfi_cfgoperations.c: replaces > PRINT_ER with netdev_err') > Signed-off-by: Dan Carpenter

Re: [PATCH net] hv_netvsc: Restore needed_headroom request

2016-02-10 Thread Vitaly Kuznetsov
Vitaly Kuznetsov writes: > Commit c0eb454034aa ("hv_netvsc: Don't ask for additional head room in the > skb") got rid of needed_headroom setting for the driver. With the change I > hit the following issue trying to use ptkgen module: > > [ 57.522021] kernel BUG at

Re: [PATCH net] hv_netvsc: Restore needed_headroom request

2016-02-10 Thread David Miller
From: Vitaly Kuznetsov Date: Wed, 10 Feb 2016 11:05:50 +0100 > I'm sorry for the ping but this is kind of a regression and it would be > nice to have it fixed in 4.5. In case you can't figure it out, I'm several days backlogged and busy conferencing, travelling, etc. so

[patch] staging: wilc1000: fix mgmt_tx()

2016-02-10 Thread Dan Carpenter
There was a missing curly brace so this function returns failure instead of succeeding. Fixes: 06fb9336acdc ('staging: wilc1000: wilc_wfi_cfgoperations.c: replaces PRINT_ER with netdev_err') Signed-off-by: Dan Carpenter diff --git

网络推广专员SEM

2016-02-10 Thread 网络推广专员SEM
你的老朋友邀你来Q群:343257759 ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Business Partnership

2016-02-10 Thread EYADEMA
Hello, I am Mr. LAURENT EYADEMA from Republic of Togo.please read the attached proposal. Thanks in anticipation of your urgent response, LAURENT EYADEMA proposal.docx Description: Binary data ___ devel mailing list de...@linuxdriverproject.org

Business Partnership

2016-02-10 Thread EYADEMA
Hello, I am Mr. LAURENT EYADEMA from Republic of Togo.please read the attached proposal. Thanks in anticipation of your urgent response, LAURENT EYADEMA proposal.docx Description: Binary data ___ devel mailing list de...@linuxdriverproject.org