RE: [PATCH] pci-hyperv: use kmalloc to allocate hypercall params buffer

2016-11-23 Thread KY Srinivasan
> -Original Message- > From: Bjorn Helgaas [mailto:helg...@kernel.org] > Sent: Wednesday, November 23, 2016 3:20 PM > To: Long Li > Cc: KY Srinivasan ; Haiyang Zhang > ; Bjorn Helgaas ; >

Re: [PATCH] pci-hyperv: use kmalloc to allocate hypercall params buffer

2016-11-23 Thread Bjorn Helgaas
On Tue, Nov 08, 2016 at 02:04:38PM -0800, Long Li wrote: > From: Long Li > > hv_do_hypercall assumes that we pass a segment from a physically > continuous buffer. Buffer allocated on the stack may not work if > CONFIG_VMAP_STACK=y is set. > > Change to use kmalloc to

[PATCH v2] staging: lustre: osc: Performance tune for LRU

2016-11-23 Thread James Simmons
From: Jinshan Xiong Early launch page LRU work in osc_io_rw_iter_init(); Change the page LRU shrinking policy by OSC attributes; Delete the contented lock osc_object::oo_seatbelt Signed-off-by: Jinshan Xiong Intel-bug-id:

[PATCH 0/4] staging: lustre: obd: reserve connection flags

2016-11-23 Thread James Simmons
Reserve several OBD_CONNECT_* flags for future use. Fan Yong (4): staging: lustre: obd: reserve connection flag OBD_CONNECT_SUBTREE staging: lustre: obd: reserve connection flag OBD_CONNECT_LOCK_AHEAD staging: lustre: obd: reserve connection flag OBD_CONNECT_OBDOPACK staging: lustre: obd:

[PATCH 1/5] staging: lustre: ldlm: remove ldlm_policy_data_t typedef usage from code

2016-11-23 Thread James Simmons
From: Andreas Dilger Replace usage of ldlm_policy_data_t with named enums to conform to upstream coding style. Signed-off-by: Andreas Dilger Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on:

[PATCH 3/4] staging: lustre: obd: reserve connection flag OBD_CONNECT_OBDOPACK

2016-11-23 Thread James Simmons
From: Fan Yong The connection flag OBD_CONNECT_OBDOPACK will be used for the following the patch: LU-4215 optimize OUT protocol http://review.whamcloud.com/15336 Land the connection flags to upstream client earlier for reserving the slot to avoid potential conflict with

[PATCH 1/4] staging: lustre: obd: reserve connection flag OBD_CONNECT_SUBTREE

2016-11-23 Thread James Simmons
From: Fan Yong The connection flag OBD_CONNECT_SUBTREE will be used for the following the patch: LU-28 mounting of filesystem from MDS http://review.whamcloud.com/5007 Land the connection flags to master earlier for reserving the slot to avoid potential conflict with others.

[PATCH 4/4] staging: lustre: obd: reserve connection flag OBD_CONNECT_FLAGS2

2016-11-23 Thread James Simmons
From: Fan Yong This is a feature for the client and server to use obd_connect_flags2 to communicate future feature flags. The client should set this flag whenever any flags in that field are requested, and the server should mask unsupported features from this field (assuming

[PATCH 2/4] staging: lustre: obd: reserve connection flag OBD_CONNECT_LOCK_AHEAD

2016-11-23 Thread James Simmons
From: Fan Yong The connection flag OBD_CONNECT_LOCK_AHEAD will be used for the following the patch: LU-6917 LDLM lock ahead http://review.whamcloud.com/13564 Land the connection flags to upstream client earlier for reserving the slot to avoid potential conflict with others.

[PATCH 4/5] staging: lustre: ldlm: rename LDLM_CANCEL_* flags

2016-11-23 Thread James Simmons
From: Andreas Dilger Rename LDLM_CANCEL_* flags (used with enum ldlm_lru_flags) to LDLM_LRU_FLAGS_* to avoid confusion with enum ldlm_cancel_flags. Signed-off-by: Andreas Dilger Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142

[PATCH 2/5] staging: lustre: ldlm: remove ldlm_side_t typedef usage from code

2016-11-23 Thread James Simmons
From: Andreas Dilger Replace usage of ldlm_side_t with named enums to conform to upstream coding style. Signed-off-by: Andreas Dilger Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: http://review.whamcloud.com/15300

[PATCH 0/5] staging: lustre: ldlm: remove ldlm typedef usage from code

2016-11-23 Thread James Simmons
Replace usage of ldlm_policy_data_t, ldlm_wire_policy_t, ldlm_side_t with named enums to conform to upstream coding style. Fix users of flags that were using "int" instead of named enum. Rename some "flags" variables to distinguish between different flags. Rename LDLM_CANCEL_* flags (used with

[PATCH 3/5] staging: lustre: ldlm: remove ldlm_wire_policy_data_t typedef usage from code

2016-11-23 Thread James Simmons
From: Andreas Dilger Replace usage of ldlm_wire_policy_data_t with named enums to conform to upstream coding style. Signed-off-by: Andreas Dilger Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on:

[PATCH 5/5] staging: lustre: ldlm: change "int" to proper enum type

2016-11-23 Thread James Simmons
From: Andreas Dilger Fix users of flags that were using "int" instead of named enum. Rename some "flags" variables to distinguish between different flags. Signed-off-by: Andreas Dilger Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142

Re: [PATCH 2/2] staging: slicoss: replace UPDATE_STATS_GB macro into an inline function

2016-11-23 Thread Markus Böhme
On 11/23/2016 08:00 PM, Markus Böhme wrote: > On 11/23/2016 07:10 PM, Sergio Paracuellos wrote: >> This patch replaces UPDATE_STATS_GB macro in slic.h header file >> into an inline function. This provides type safety and readability. >> >> Signed-off-by: Sergio Paracuellos

[PATCH] staging: octeon-usb: fix code style warnings

2016-11-23 Thread Andrea Ghittino
This patch fix two code style warnings related to "line over 80 characters" in drivers/staging/octeon-usb/octeon-hcd.c file. Signed-off-by: Andrea Ghittino --- diff --git a/drivers/staging/octeon-usb/octeon-hcd.c b/drivers/staging/octeon-usb/octeon-hcd.c index

Re: [PATCH 2/2] staging: slicoss: replace UPDATE_STATS_GB macro into an inline function

2016-11-23 Thread Markus Böhme
On 11/23/2016 07:10 PM, Sergio Paracuellos wrote: > This patch replaces UPDATE_STATS_GB macro in slic.h header file > into an inline function. This provides type safety and readability. > > Signed-off-by: Sergio Paracuellos > --- > drivers/staging/slicoss/slic.h

[PATCH 1/2] staging: slicoss: remove not used UPDATE_STATS macro

2016-11-23 Thread Sergio Paracuellos
This patch remove UPDATE_STATS macro from header slic.h which is not being used. Signed-off-by: Sergio Paracuellos --- drivers/staging/slicoss/slic.h | 8 1 file changed, 8 deletions(-) diff --git a/drivers/staging/slicoss/slic.h

[PATCH 2/2] staging: slicoss: replace UPDATE_STATS_GB macro into an inline function

2016-11-23 Thread Sergio Paracuellos
This patch replaces UPDATE_STATS_GB macro in slic.h header file into an inline function. This provides type safety and readability. Signed-off-by: Sergio Paracuellos --- drivers/staging/slicoss/slic.h| 6 ++--- drivers/staging/slicoss/slicoss.c | 56

[PATCH 0/2] staging: slicoss: minor changes to clean some code

2016-11-23 Thread Sergio Paracuellos
This patchset clean some code in slicoss driver: * Removes not used macro. * Replaces a macro with an inline function. Sergio Paracuellos (2): staging: slicoss: remove not used UPDATE_STATS macro staging: slicoss: replace UPDATE_STATS_GB macro into an inline function

Re: [PATCH v2 0/6] staging: speakup: speakup_soft.c checkpatch modifications

2016-11-23 Thread Walt Feasel
On Wed, Nov 23, 2016 at 04:56:32PM +0100, Greg KH wrote: > On Wed, Nov 23, 2016 at 05:52:25AM -0500, Fleetwood Farm wrote: > > On Nov 23, 2016 4:08 AM, "Greg KH" wrote: > > > > > > On Mon, Nov 21, 2016 at 10:19:19AM -0500, Walt Feasel wrote: > > > > Make Linux kernel

Re: [PATCH v2 0/6] staging: speakup: speakup_soft.c checkpatch modifications

2016-11-23 Thread Greg KH
On Wed, Nov 23, 2016 at 05:52:25AM -0500, Fleetwood Farm wrote: > On Nov 23, 2016 4:08 AM, "Greg KH" wrote: > > > > On Mon, Nov 21, 2016 at 10:19:19AM -0500, Walt Feasel wrote: > > > Make Linux kernel style modifications for speak_soft.c to include: > > > > > > Space

[PATCH v2] [hv] storvsc: Payload buffer incorrectly sized for 32 bit kernels.

2016-11-23 Thread Cathy Avery
On a 32 bit kernel sizeof(void *) is not 64 bits as hv_mpb_array requires. Also the buffer needs to be cleared or the upper bytes will contain junk. Suggested-by: Vitaly Kuznetsov Signed-off-by: Cathy Avery ChangeLog: v1) Initial submission v2) Remove

[bug report] staging: add Lustre file system client support

2016-11-23 Thread Dan Carpenter
Hi Lustre Devs, The patch d7e09d0397e8: "staging: add Lustre file system client support" from May 2, 2013, leads to the following static checker warning: drivers/staging/lustre/lnet/selftest/console.c:1336 lstcon_test_add() error: 'paramlen' from user is not capped properly The

Re: [PATCH] Staging: iio: adc: fix sysfs files modes in ad7192.c

2016-11-23 Thread Joe Perches
On Tue, 2016-11-22 at 23:25 -0800, Boyan Vladinov wrote: > Fixes sysfs entries user/group modes and coding style warnings > found by checkpatch.pl tool [] > diff --git a/drivers/staging/iio/adc/ad7192.c > b/drivers/staging/iio/adc/ad7192.c [] > static ssize_t ad7192_show_ac_excitation(struct

Re: [PATCH v2 0/6] staging: speakup: speakup_soft.c checkpatch modifications

2016-11-23 Thread Greg KH
On Mon, Nov 21, 2016 at 10:19:19AM -0500, Walt Feasel wrote: > Make Linux kernel style modifications for speak_soft.c to include: > > Space around operator > Logical continuation > Multiple blank lines > Blank line after { > comment modifications > Align parenthesis Ok, now that you have a bunch

Re: [PATCH v2 14/14] staging: unisys: visorbus: bus_configure add error handling

2016-11-23 Thread Greg KH
On Mon, Nov 21, 2016 at 12:15:53PM -0500, David Kershner wrote: > Add proper error handling to bus_configure and have it propagate errors > back up the stack. This helped to streamline the function as well. > > Signed-off-by: David Kershner > Reported-by: Greg

Re: [PATCH] staging: rtl8712: Replace blank spaces with tabstops

2016-11-23 Thread vijai
On Mon, Nov 21, 2016 at 11:23:57AM +0100, Greg KH wrote: > On Sun, Nov 20, 2016 at 05:20:08PM -0800, Vijai Kumar K wrote: > > Fix checkpatch warning: > > WARNING: Statements should start on a tabstop > > > > Signed-off-by: Vijai Kumar K > > --- > >