Re: [greybus-dev] [PATCH v2] staging: greybus: arche: wrap over-length lines

2017-07-10 Thread Joe Perches
On Mon, 2017-07-10 at 15:01 +0530, Viresh Kumar wrote: > On 10-07-17, 11:30, Frans Klaver wrote: > > On Mon, Jul 10, 2017 at 6:46 AM, Viresh Kumar > > wrote: > > > Hi Mitchell, > > > > > > On 09-07-17, 20:25, Mitchell Tasman wrote: > > > > Adjust formatting of various

[PATCH] staging: unisys: visorbus: fix function open braces

2017-07-10 Thread Mitchell Tasman
Resolve multiple checkpatch errors by relocating open braces following function definitions to the next line. Signed-off-by: Mitchell Tasman --- drivers/staging/unisys/visorbus/visorbus_main.c | 18 -- 1 file changed, 12 insertions(+), 6 deletions(-) diff

[PATCH v2] staging: media: atomisp: Use kvfree() instead of kfree()/vfree()

2017-07-10 Thread Amitoj Kaur Chawla
Conditionally calling kfree()/vfree() can be replaced by a call to kvfree() which handles both kmalloced memory and vmalloced memory. The resulting wrapper function has been replaced with direct calls to kvfree(). This change was made with the help of the following Coccinelle semantic patch: //

[PATCH 2/2] staging: atomisp2: hmm: Alignment code

2017-07-10 Thread Philipp Guendisch
This patch fixed code alignment to open paranthesis. Semantic should not be affected by this patch. Signed-off-by: Philipp Guendisch Signed-off-by: Chris Baller --- .../staging/media/atomisp/pci/atomisp2/hmm/hmm.c | 79 +++--- 1

[PATCH 1/2] staging: atomisp2: hmm: Fixed comment style

2017-07-10 Thread Philipp Guendisch
This patch fixed comment style. Semantic should not be affected. There are also two warnings left about too long lines, which reduce readability if changed. Signed-off-by: Philipp Guendisch Signed-off-by: Chris Baller ---

[PATCH] Staging: wlan-ng: hfa384x.h: fixed sparse warning

2017-07-10 Thread Vitali Liaukovich
Fields of hfa384x_commsquality were used as __le16 but defined as u16. Type is changed to __le16. Signed-off-by: Vitali Liaukovich --- drivers/staging/wlan-ng/hfa384x.h | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git

Re: [patch 0/3] Re: tty contention resulting from tty_open_by_device export

2017-07-10 Thread Okash Khawaja
On Mon, Jul 10, 2017 at 01:33:07PM +0100, Okash Khawaja wrote: > > If the tty counts are being misreported then it would be better to fix > > the code to actually manage the counts properly. The core tty code is > > telling you that the tty is not in a valid state. While this is of > > itself a

Re: [patch 1/3] tty: resolve tty contention between kernel and user space

2017-07-10 Thread Okash Khawaja
On Mon, Jul 10, 2017 at 06:21:37PM +0300, Andy Shevchenko wrote: > On Mon, Jul 10, 2017 at 11:31 AM, Okash Khawaja > wrote: > > On Sun, Jul 09, 2017 at 06:04:17PM +0300, Andy Shevchenko wrote: > >> On Sun, Jul 9, 2017 at 2:41 PM, Okash Khawaja

Re: [patch 1/3] tty: resolve tty contention between kernel and user space

2017-07-10 Thread Andy Shevchenko
On Mon, Jul 10, 2017 at 11:31 AM, Okash Khawaja wrote: > On Sun, Jul 09, 2017 at 06:04:17PM +0300, Andy Shevchenko wrote: >> On Sun, Jul 9, 2017 at 2:41 PM, Okash Khawaja >> wrote: >> >> > +struct tty_struct *tty_kopen(dev_t device) >> > +{ >> >

Re: [PATCH] Staging:ks7010:ks_wlan_net.c: unneeded type casting removed

2017-07-10 Thread Joe Perches
On Mon, 2017-07-10 at 10:09 +0300, AndyS wrote: > removed undesired type casting. Warning was raised by checkpatch.pl > This patch is for eudyptula challenge False positive in checkpatch. checkpatch does not handle floating point values. > diff --git a/drivers/staging/ks7010/ks_wlan_net.c >

Re: [PATCH v2 2/9] staging: iio: tsl2x7x: add device tree documentation

2017-07-10 Thread Rob Herring
On Thu, Jul 06, 2017 at 06:56:19PM -0400, Brian Masney wrote: > Add device tree documentation for the tsl2x7x IIO driver. > > Signed-off-by: Brian Masney > CC: Rob Herring > CC: Mark Rutland > CC: devicet...@vger.kernel.org > ---

Re: [PATCH] Staging:ks7010:ks_wlan_net.c: unneeded type casting removed

2017-07-10 Thread Joe Perches
A floating point constant cast to an int was giving a false positive warning about unneeded cast to int. e.g.: (fwrq->m >= (int)2.412e8) && (fwrq->m <= (int)2.487e8)) Fix it. Though it's probably better to avoid float/double values that are cast to int at all. Signed-off-by: Joe

[PATCH v2] staging: rtl8192u: reduce stack frame size in ieee80211_rx_mgt_rsl

2017-07-10 Thread Arnd Bergmann
I ran into a stack frame size warning in code that hasn't changed much recently, no idea why I didn't spot this earlier despite build many thousand randconfigs. drivers/staging/rtl8192u/ieee80211/ieee80211_rx.c: In function 'ieee80211_rx_mgt_rsl':

Re: [PATCH] staging: rtl8192u: reduce stack frame size in ieee80211_rx_mgt_rsl

2017-07-10 Thread Arnd Bergmann
On Mon, Jul 10, 2017 at 3:35 PM, Dan Carpenter wrote: > You should add some kfree calls as well. Oops, thanks for pointing out my mistake. I'll resend a fixed version. Arnd ___ devel mailing list

Re: [PATCH] staging: rtl8192u: reduce stack frame size in ieee80211_rx_mgt_rsl

2017-07-10 Thread Dan Carpenter
You should add some kfree calls as well. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

[PATCH] staging: rtl8192u: reduce stack frame size in ieee80211_rx_mgt_rsl

2017-07-10 Thread Arnd Bergmann
I ran into a stack frame size warning in code that hasn't changed much recently, no idea why I didn't spot this earlier despite build many thousand randconfigs. drivers/staging/rtl8192u/ieee80211/ieee80211_rx.c: In function 'ieee80211_rx_mgt_rsl':

[PATCH] lustre: check copy_from_iter/copy_to_iter return code

2017-07-10 Thread Arnd Bergmann
We now get a helpful warning for code that calls copy_{from,to}_iter without checking the return value, introduced by commit aa28de275a24 ("iov_iter/hardening: move object size checks to inlined part"). drivers/staging/lustre/lnet/klnds/o2iblnd/o2iblnd_cb.c: In function 'kiblnd_send':

Re: [patch 0/3] Re: tty contention resulting from tty_open_by_device export

2017-07-10 Thread Okash Khawaja
On Mon, Jul 10, 2017 at 12:52:33PM +0100, Alan Cox wrote: > On Sun, 09 Jul 2017 12:41:53 +0100 > Okash Khawaja wrote: > > > On Sat, Jul 08, 2017 at 10:38:03AM +0200, Greg Kroah-Hartman wrote: > > > Overall, the idea looks sane to me. Keeping userspace from opening a > >

Re: [patch] staging: speakup: safely close tty

2017-07-10 Thread Alan Cox
On Fri, 7 Jul 2017 20:13:01 +0100 Okash Khawaja wrote: > Speakup opens tty using tty_open_by_driver. When closing, it calls > tty_ldisc_release but doesn't close and remove the tty itself. As a > result, that tty cannot then be opened from user space. This patch calls >

Re: [patch 0/3] Re: tty contention resulting from tty_open_by_device export

2017-07-10 Thread Alan Cox
On Sun, 09 Jul 2017 12:41:53 +0100 Okash Khawaja wrote: > On Sat, Jul 08, 2017 at 10:38:03AM +0200, Greg Kroah-Hartman wrote: > > Overall, the idea looks sane to me. Keeping userspace from opening a > > tty that the kernel has opened internally makes sense, hopefully >

Re: [PATCH] Staging:ks7010:ks_wlan_net.c: unneeded type casting removed

2017-07-10 Thread kbuild test robot
Hi AndyS, [auto build test ERROR on staging/staging-testing] [also build test ERROR on v4.12 next-20170710] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci/linux/commits/AndyS/Staging-ks7010-ks_wlan_net-c

Re: [PATCH] Staging:ks7010:ks_wlan_net.c: unneeded type casting removed

2017-07-10 Thread kbuild test robot
Hi AndyS, [auto build test ERROR on staging/staging-testing] [also build test ERROR on v4.12 next-20170710] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci/linux/commits/AndyS/Staging-ks7010-ks_wlan_net-c

Re: [PATCH] Staging:ks7010:ks_wlan_net.c: unneeded type casting removed

2017-07-10 Thread Frans Klaver
On Mon, Jul 10, 2017 at 9:09 AM, AndyS wrote: > Subject: [PATCH] Staging:ks7010:ks_wlan_net.c: unneeded type casting removed [PATCH] staging: ks7010: remove unneeded type casting > removed undesired type casting. Warning was raised by checkpatch.pl > This patch is for eudyptula

Re: [greybus-dev] [PATCH v2] staging: greybus: arche: wrap over-length lines

2017-07-10 Thread Viresh Kumar
On 10-07-17, 11:30, Frans Klaver wrote: > On Mon, Jul 10, 2017 at 6:46 AM, Viresh Kumar wrote: > > Hi Mitchell, > > > > On 09-07-17, 20:25, Mitchell Tasman wrote: > >> Adjust formatting of various statements to keep line length within > >> the 80 column limit preferred by

Re: [greybus-dev] [PATCH v2] staging: greybus: arche: wrap over-length lines

2017-07-10 Thread Frans Klaver
On Mon, Jul 10, 2017 at 6:46 AM, Viresh Kumar wrote: > Hi Mitchell, > > On 09-07-17, 20:25, Mitchell Tasman wrote: >> Adjust formatting of various statements to keep line length within >> the 80 column limit preferred by the Linux kernel coding style. > > We try to follow

[PATCH] drivers/staging/wilc1000: fix sparse warning: right shift by bigger than source value

2017-07-10 Thread Rui Teng
This patch sets memory to zero directly to avoid unnecessary shift and bitwise operations on bool type, which can fix a sparse warning and also improve performance. Signed-off-by: Rui Teng --- drivers/staging/wilc1000/host_interface.c | 7 +++ 1 file changed, 3

Re: [patch 1/3] tty: resolve tty contention between kernel and user space

2017-07-10 Thread Okash Khawaja
On Sun, Jul 09, 2017 at 06:04:17PM +0300, Andy Shevchenko wrote: > On Sun, Jul 9, 2017 at 2:41 PM, Okash Khawaja wrote: > > > +struct tty_struct *tty_kopen(dev_t device) > > +{ > > + struct tty_struct *tty; > > + struct tty_driver *driver = NULL; > > +

[PATCH] Staging:ks7010:ks_wlan_net.c: unneeded type casting removed

2017-07-10 Thread AndyS
removed undesired type casting. Warning was raised by checkpatch.pl This patch is for eudyptula challenge Signed-off-by: AndyS --- drivers/staging/ks7010/ks_wlan_net.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/ks7010/ks_wlan_net.c

Re: [PATCH v2] staging: atomisp: use kstrdup to replace kmalloc and memcpy

2017-07-10 Thread hari prasath
On 10 July 2017 at 01:22, Sakari Ailus wrote: > On Sun, Jul 09, 2017 at 05:56:15PM +0530, hari prasath wrote: >> On 8 July 2017 at 16:31, Sakari Ailus wrote: >> > Hi Hari, >> > >> > On Fri, Jul 07, 2017 at 08:15:21PM +0530, Hari Prasath wrote: >> >>

[PATCHv3] staging: atomisp: use kstrdup to replace kmalloc and memcpy

2017-07-10 Thread Hari Prasath
kstrdup kernel primitive can be used to replace kmalloc followed by string copy. This was reported by coccinelle tool. Signed-off-by: Hari Prasath --- v1: Replace kmalloc followed by memcpy with kmemdup. Based on review comments from Alan Cox, this