[PATCH 1/3] staging: Android: vsoc: Create wc kernel mapping for region shm.

2018-05-02 Thread Alistair Strachan
Map the region shm as write-combining instead of uncachable. Cc: Greg Kroah-Hartman Cc: Arve Hjønnevåg Cc: Todd Kjos Cc: Martijn Coenen Cc: Greg Hartman Cc: de...@driverdev.osuosl.org Cc:

[PATCH 2/3] staging: Android: vsoc: Fix a i386-randconfig warning.

2018-05-02 Thread Alistair Strachan
Fix "warning: cast to pointer from integer of different size" when printing the region shm physical address. Use the %pa conversion specifier and pass the resource by reference. Cc: Greg Kroah-Hartman Cc: Arve Hjønnevåg Cc: Todd Kjos

[PATCH 3/3] staging: Android: Fix sparse warnings in vsoc driver.

2018-05-02 Thread Alistair Strachan
Cc: Greg Kroah-Hartman Cc: Arve Hjønnevåg Cc: Todd Kjos Cc: Martijn Coenen Cc: Greg Hartman Cc: de...@driverdev.osuosl.org Cc: kernel-t...@android.com Signed-off-by: Alistair Strachan

Re: [PATCH v2 10/15] ARM: dts: imx7s: add multiplexer controls

2018-05-02 Thread Shawn Guo
On Mon, Apr 23, 2018 at 02:47:45PM +0100, Rui Miguel Silva wrote: > The IOMUXC General Purpose Register has bitfield to control video bus > multiplexer to control the CSI input between the MIPI-CSI2 and parallel > interface. Add that register and mask. > > Signed-off-by: Rui Miguel Silva

Re: [PATCH v2 07/15] ARM: dts: increase default cma size to 40MB

2018-05-02 Thread Shawn Guo
On Mon, Apr 23, 2018 at 02:47:42PM +0100, Rui Miguel Silva wrote: > To support camera in i.MX7 the cma heap is used to allocate frame buffers. The > default size of CMA is 16MB which is not enough for higher resolutions (ex: > 1600x1200). > > So, increase the default CMA size to 40MB. > >

Re: [PATCH v2 04/15] clk: imx7d: reset parent for mipi csi root

2018-05-02 Thread Shawn Guo
On Mon, Apr 23, 2018 at 02:47:39PM +0100, Rui Miguel Silva wrote: > To guarantee that we do not get Overflow in image FIFO the outer bandwidth has > to be faster than inputer bandwidth. For that it must be possible to set a > faster frequency clock. So set new parent to sys_pfd3 clock for the mipi

RE: [PATCH v2 03/15] clk: imx7d: fix mipi dphy div parent

2018-05-02 Thread A.s. Dong
> -Original Message- > From: Shawn Guo [mailto:shawn...@kernel.org] > Sent: Thursday, May 3, 2018 9:08 AM > To: Rui Miguel Silva ; Anson Huang > > Cc: mche...@kernel.org; sakari.ai...@linux.intel.com; Steve Longerbeam > ;

[PATCH] media: staging: atomisp: fix a potential missing-check bug

2018-05-02 Thread Wenwen Wang
At the end of atomisp_subdev_set_selection(), the function atomisp_subdev_get_rect() is invoked to get the pointer to v4l2_rect. Since this function may return a NULL pointer, it is firstly invoked to check the returned pointer. If the returned pointer is not NULL, then the function is invoked

[PATCH 0/2] staging: wlan-ng: fix coding style issues in hfa384x_usb.c

2018-05-02 Thread Tim Collier
Fix two checkpatch issues in hfa384x_usb.c. One warning for a line over 80 characters remains (due to a long macro name). Tim Collier (2): staging: wlan-ng: add missing parameter name to prototype staging: wlan-ng: fix line-break style issue drivers/staging/wlan-ng/hfa384x_usb.c | 5 ++---

[PATCH 1/2] staging: wlan-ng: add missing parameter name to prototype

2018-05-02 Thread Tim Collier
Fix checkpatch warning for missing parameter name for function prototype. Signed-off-by: Tim Collier --- drivers/staging/wlan-ng/hfa384x_usb.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/wlan-ng/hfa384x_usb.c

[PATCH 2/2] staging: wlan-ng: fix line-break style issue

2018-05-02 Thread Tim Collier
Fix checkpatch warning due to line break after '(', leaving an over 80 character warning due to long macro name. Signed-off-by: Tim Collier --- drivers/staging/wlan-ng/hfa384x_usb.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git

[PATCH 0/4] staging: lustre: obdclass: missing lu_object fixes

2018-05-02 Thread James Simmons
With the work going for lu_object by Neil I noticed him solving the same problem as the Intel developers in a very similar approach. Also with the changes we don't want to lose these important changes. This is more mean for a basic review since in the end Neil and this work will be combined in

[PATCH 4/4] staging: lustre: obdclass: change object lookup to no wait mode

2018-05-02 Thread James Simmons
From: Lai Siyao Currently we set LU_OBJECT_HEARD_BANSHEE on object when we want to remove object from cache, but this may lead to deadlock, because when other process lookup such object, it needs to wait for this object until release (done at last refcount put), while that

[PATCH 1/4] staging: lustre: obdclass: change spinlock of key to rwlock

2018-05-02 Thread James Simmons
From: Li Xi Most of the time, keys are never changed. So rwlock might be better for the concurrency of key read. Signed-off-by: Li Xi Signed-off-by: Gu Zheng Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6800 Reviewed-on:

Re: [lustre_init] BUG: unable to handle kernel NULL pointer dereference at 0000000000000004

2018-05-02 Thread James Simmons
> Hello, > > FYI this happens in mainline kernel 4.17.0-rc3. > It looks like a new regression since v4.17-rc1. > > It occurs in 2 out of 2 boots. > > [ 54.222599] Magic number: 14:276:994 > [ 54.223261] tty ttyd7: hash matches > [ 54.223841] tty ttyaa: hash matches > [ 54.227288]

[PATCH] ANDROID: binder: fix binder work return error is wrongly consumed

2018-05-02 Thread gityuan
From: yuanhuihui transaction consume mismatched binder work. as follow: 1) Client send transaction when left binder work in the thread->todo list. 2) in kernel space, client consumed BC_TRANSACTION, and produced BINDER_WORK_RETURN_ERROR into thread->todo list as target

[PATCH][media-next][V2] media: davinci_vpfe: fix memory leaks of params

2018-05-02 Thread Colin King
From: Colin Ian King There are memory leaks of params; when copy_to_user fails and also the exit via the label 'error'. Also, there is a bogos memory allocation check on pointer 'to' when memory allocation fails on params. Fix this by kfree'ing params in error exit

Re: [PATCH v2] staging: greybus: Use gpio_is_valid()

2018-05-02 Thread Arvind Yadav
On Wednesday 02 May 2018 03:27 PM, Johan Hovold wrote: On Wed, May 02, 2018 at 03:15:05PM +0530, Arvind Yadav wrote: On Wednesday 02 May 2018 02:13 PM, Johan Hovold wrote: On Sat, Apr 28, 2018 at 10:05:39AM +0530, Arvind Yadav wrote: Replace the manual validity checks for the GPIO with the

Re: [PATCH v2] staging: greybus: Use gpio_is_valid()

2018-05-02 Thread Johan Hovold
On Wed, May 02, 2018 at 03:15:05PM +0530, Arvind Yadav wrote: > On Wednesday 02 May 2018 02:13 PM, Johan Hovold wrote: > > On Sat, Apr 28, 2018 at 10:05:39AM +0530, Arvind Yadav wrote: > >> Replace the manual validity checks for the GPIO with the > >> gpio_is_valid(). > >> > >> Signed-off-by:

Re: [PATCH v2] staging: greybus: Use gpio_is_valid()

2018-05-02 Thread Arvind Yadav
On Wednesday 02 May 2018 02:13 PM, Johan Hovold wrote: On Sat, Apr 28, 2018 at 10:05:39AM +0530, Arvind Yadav wrote: Replace the manual validity checks for the GPIO with the gpio_is_valid(). Signed-off-by: Arvind Yadav --- chnage in v2 : Returning

Re: [PATCH] staging: wilc1000: fix infinite loop and out-of-bounds access

2018-05-02 Thread Ajay Singh
On Wed, 2 May 2018 11:39:36 +0300 Dan Carpenter wrote: > We're mainly discussing readability, right? > > To me when people use "int" that tells me as a reader that we don't > need to think about the type. It's going to be a small number. > > Say you have data which

[PATCH][media-next] media: davinci_vpfe: fix memory leaks of params

2018-05-02 Thread Colin King
From: Colin Ian King There are memory leaks of params; when copy_to_user fails and also the exit via the label 'error'. Fix this by kfree'ing params in error exit path and jumping to this on the copy_to_user failure path. Detected by CoverityScan, CID#1467966

Re: [PATCH v2] staging: greybus: Use gpio_is_valid()

2018-05-02 Thread Johan Hovold
On Sat, Apr 28, 2018 at 10:05:39AM +0530, Arvind Yadav wrote: > Replace the manual validity checks for the GPIO with the > gpio_is_valid(). > > Signed-off-by: Arvind Yadav > --- > chnage in v2 : > Returning invalid gpio as error instead of -ENODEV. > >

Re: [PATCH] staging: wilc1000: fix infinite loop and out-of-bounds access

2018-05-02 Thread Dan Carpenter
We're mainly discussing readability, right? To me when people use "int" that tells me as a reader that we don't need to think about the type. It's going to be a small number. Say you have data which the user can control, then it's super important to focus on the data types. We don't focus on

Re: [PATCH v2] staging/wilc1000: fix wilc_mac_xmit()'s return type

2018-05-02 Thread Claudiu Beznea
On 26.04.2018 23:54, Luc Van Oostenryck wrote: > The method ndo_start_xmit() is defined as returning an 'netdev_tx_t', > which is a typedef for an enum type, but the implementation in this > driver returns an 'int'. > > Fix this by returning 'netdev_tx_t' in this driver too > and accordingly

[PATCH 17/21] staging: wilc1000: remove unnecessary header file inclusion for wilc

2018-05-02 Thread Ajay Singh
Remove the unnecessary file inclusion in the source code. Also follow the convension to first include the system header then project specific header files. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/coreconfigurator.c | 5 +

[PATCH 20/21] staging: wilc1000: rename 'during_ip_time' macro to have uppercase name for macro

2018-05-02 Thread Ajay Singh
Rename 'during_ip_time' to 'DURING_IP_TIME_OUT' to have uppercase letter for macros(#define). Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH 18/21] staging: wilc1000: move macro after the #include file in wilc_wfi_netdevice

2018-05-02 Thread Ajay Singh
Cleanup patch to organize macro in a file together after #include statements. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_netdevice.h | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git

[PATCH 08/21] staging: wilc1000: rename WILC_WFI_monitor_rx to avoid uppercase for function name

2018-05-02 Thread Ajay Singh
Cleanup patch to follow names as per linux coding style. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/linux_mon.c | 2 +- drivers/staging/wilc1000/linux_wlan.c | 2 +- drivers/staging/wilc1000/wilc_wfi_cfgoperations.h | 2 +- 3 files

[PATCH 06/21] staging: wilc1000: use 'else if' condition in get_station()

2018-05-02 Thread Ajay Singh
Use 'else if' in get_station(), as only one condition will statisfy. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git

[PATCH 19/21] staging: wilc1000: use is_broadcast_ether_addr check for broadcast address

2018-05-02 Thread Ajay Singh
Make use of is_broadcast_ether_addr() to check if mac address is broadcast address. Remove static 'broadcast', as its not needed after use of is_broadcast_ether_addr(). Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/linux_mon.c | 3 +-- 1 file changed, 1

[PATCH 14/21] staging: wilc1000: remove the use of cur_byte variable in functions

2018-05-02 Thread Ajay Singh
Instead of using the intermediate variable to hold the value, now directly using the allocated variable. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 8 +--- 1 file changed, 1 insertion(+), 7 deletions(-) diff --git

[PATCH 05/21] staging: wilc1000: fix line over 80 chars in remove_network_from_shadow()

2018-05-02 Thread Ajay Singh
Added changes to avoid line over 80 character issue in remove_network_from_shadow(). Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git

[PATCH 11/21] staging: wilc1000: rename WILC_WFI_init_mon_interface to avoid uppercase in function name

2018-05-02 Thread Ajay Singh
Changes to avoid the use of uppercase for function name. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/linux_mon.c | 2 +- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 2 +- drivers/staging/wilc1000/wilc_wfi_cfgoperations.h | 3 ++- 3

[PATCH 16/21] staging: wilc1000: remove unnecessary static function defination in wilc_spi

2018-05-02 Thread Ajay Singh
Cleanup patch to remove the unnecessary code. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_spi.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/staging/wilc1000/wilc_spi.c b/drivers/staging/wilc1000/wilc_spi.c index c17f5d2..1f2dde1

[PATCH 07/21] staging: wilc1000: remove unnecessary file and function header comments

2018-05-02 Thread Ajay Singh
Cleanup patch to remove the unnecessary comments used for file and functions header. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/coreconfigurator.h | 10 -- drivers/staging/wilc1000/linux_mon.c | 44 ---

[PATCH 21/21] staging: wilc1000: rename WILC_WFI_band_2ghz variable to avoid mixedcase

2018-05-02 Thread Ajay Singh
Rename 'WILC_WFI_band_2ghz' to avoid mixedcase for variable name. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git

[PATCH 15/21] staging: wilc1000: remove unused macros in host_interface

2018-05-02 Thread Ajay Singh
Cleanup patch to remove the unused macro mentioned below. Also move macro up along with other macro declaration. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git

[PATCH 00/21] staging: wilc1000: code cleanup & checkpatch fixes

2018-05-02 Thread Ajay Singh
This patch series contains fixes to remove unused code and changes for checkpatch.pl script reported issues. Ajay Singh (21): staging: wilc1000: remove inner block in wilc_netdev_init() staging: wilc1000: remove unnecessary 'out of memory' message in handle_key() staging: wilc1000:

[PATCH 12/21] staging: wilc1000: rename WILC_WFI_deinit_mon_interface to avoid uppercase for function name

2018-05-02 Thread Ajay Singh
Changes to avoid the use of uppercase for function name. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/linux_mon.c | 2 +- drivers/staging/wilc1000/linux_wlan.c | 2 +- drivers/staging/wilc1000/wilc_wfi_cfgoperations.h | 2 +- 3 files

[PATCH 03/21] staging: wilc1000: modified NULL check used for 'if' condition in delete_key()

2018-05-02 Thread Ajay Singh
Fix below issue reported by checkpatch.pl script. 'Comparison to NULL could be written "priv->wilc_gtk[key_index]"' 'Comparison to NULL could be written "priv->wilc_ptk[key_index]"' Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 4

[PATCH 10/21] staging: wilc1000: rename WILC_WFI_mon_xmit to avoid uppercase for function name

2018-05-02 Thread Ajay Singh
Changes to avoid the use of uppercase for function name. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/linux_mon.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/wilc1000/linux_mon.c

[PATCH 13/21] staging: wilc1000: remove static variable 'del_beacon' and null check

2018-05-02 Thread Ajay Singh
Using local variable instead of static varible 'del_beacon'. Also removed the unnecessary 'if' check in handle_del_beacon(). Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git

[PATCH 02/21] staging: wilc1000: remove unnecessary 'out of memory' message in handle_key()

2018-05-02 Thread Ajay Singh
Fix "Possible unnecessary 'out of memory' message" issue reported by checkpatch.pl script. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/wilc1000/host_interface.c

[PATCH 09/21] staging: wilc1000: rename WILC_WFI_mon_priv to avoid uppercase for struct name

2018-05-02 Thread Ajay Singh
Cleanup patch to avoid 'struct' name with uppercase letters. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/linux_mon.c | 6 +++--- drivers/staging/wilc1000/wilc_wfi_netdevice.h | 2 +- 2 files changed, 4 insertions(+), 4 deletions(-) diff --git

[PATCH 01/21] staging: wilc1000: remove inner block in wilc_netdev_init()

2018-05-02 Thread Ajay Singh
Cleanup patch to remove unnecessary inner block ( {/**/} ) in wilc_netdev_init(). Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/linux_wlan.c | 34 -- 1 file changed, 16 insertions(+), 18 deletions(-) diff --git

[PATCH 04/21] staging: wilc1000: remove unnecessary bracket used in switch in wilc_mgmt_frame_register()

2018-05-02 Thread Ajay Singh
Cleanup patch to remove the curly braces used in 'case' statement to follow as per linux standard. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 10 ++ 1 file changed, 2 insertions(+), 8 deletions(-) diff --git