Re: [PATCH] staging:iio:adc:ad7280a: Use GFP_ATOMIC in interrupt handler

2018-06-28 Thread Lars-Peter Clausen
On 06/29/2018 01:55 AM, Karim Eshapa wrote: > Use GFP_ATOMIC rather GFP_KERNEL in interrupt handler, > as GFP_KERNEL may sleep according to slab allocator. This is a threaded interrupt. Sleeping is OK. > > Signed-off-by: Karim Eshapa > --- > drivers/staging/iio/adc/ad7280a.c | 2 +- > 1 file

[PATCH] staging:iio:adc:ad7280a: Use GFP_ATOMIC in interrupt handler

2018-06-28 Thread Karim Eshapa
Use GFP_ATOMIC rather GFP_KERNEL in interrupt handler, as GFP_KERNEL may sleep according to slab allocator. Signed-off-by: Karim Eshapa --- drivers/staging/iio/adc/ad7280a.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/iio/adc/ad7280a.c

[PATCH] staging:iio:adc:ad7280a: Use GFP_ATOMIC in interrupt handler

2018-06-28 Thread Karim Eshapa
Use GFP_ATOMIC rather GFP_KERNEL in interrupt handler, as GFP_KERNEL may sleep according to slab allocator. Signed-off-by: Karim Eshapa --- drivers/staging/iio/adc/ad7280a.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/iio/adc/ad7280a.c

[PATCH 4/4] staging:iio:adc:ad7280a: Use GFP_ATOMIC in interrupt handler

2018-06-28 Thread Karim Eshapa
Use GFP_ATOMIC rather GFP_KERNEL in interrupt handler, as GFP_KERNEL may sleep according to slab allocator. Signed-off-by: Karim Eshapa --- drivers/staging/iio/adc/ad7280a.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/iio/adc/ad7280a.c

Re: staging: rtl8723bs: bug or pointless if else ?

2018-06-28 Thread Joe Perches
On Thu, 2018-06-28 at 11:34 +0200, Bastien Nocera wrote: > On Thu, 2018-06-28 at 10:22 +0200, Hans de Goede wrote: > > On 28-06-18 09:43, Michael Straube wrote: > > > ret = rtw_resume_process(padapter) > > > Is this a bug or is the if else construct just pointless? > > It probably is just

Re: [PATCH 2/2] staging: goldfish: Add goldfish sync driver

2018-06-28 Thread Greg KH
On Thu, Jun 28, 2018 at 11:39:53AM -0700, Roman Kiryanov wrote: > Hi Greg, > > we wanted to include our changes into this year LTS. Great, then get the audio driver cleaned up this week and all is fine, it shouldn't take you very long, right? > > get the existing code cleaned up and out of the

[PATCH 13/13] staging: mt7621-pinctrl: replace core_initcall_sync with builtin_platform_driver

2018-06-28 Thread Sergio Paracuellos
We don't really need initialization of this at such an early stage. Just use builtin_platform_driver to initialize this driver. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 7 +-- 1 file changed, 1 insertion(+), 6 deletions(-) diff --git

[PATCH 11/13] staging: mt7621-pinctrl: use ternary operator return in rt2880_get_group_name

2018-06-28 Thread Sergio Paracuellos
Trivial change to have only one return in 'rt2880_get_group_name' function using a ternary operator instead of an if statement and two returns. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff

[PATCH 10/13] staging: mt7621-pinctrl: refactor rt2880_pinctrl_dt_node_to_map function

2018-06-28 Thread Sergio Paracuellos
Using 'function' and 'group' bindings in the device tree give the posibility of refactor 'rt2880_pinctrl_dt_node_to_map' and simplify it a lot. Make use of 'for_each_node_with_property' function to count number of groups for the node and iterate over the groups using 'of_property_for_each_string'

[PATCH 06/13] staging: mt7621-pinctrl: make use of pinctrl_utils_free_map

2018-06-28 Thread Sergio Paracuellos
There was a custom 'rt2880_pinctrl_dt_free_map' function which it was doing the same as pinctrl_utils_free_map defined in 'pinctrl-utils.h' header file. Use it instead avoiding code duplications. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 16

[PATCH 12/13] staging: mt7621-pinctrl: remove 'rt2880_pinctrl_pin_dbg_show' callback

2018-06-28 Thread Sergio Paracuellos
The debug information provided by this function does not make sense at all, so just remove it. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 8 1 file changed, 8 deletions(-) diff --git a/drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c

[PATCH 09/13] staging: mt7621-dts: use 'function' and 'group' for pinctrl bindings

2018-06-28 Thread Sergio Paracuellos
According to documentation 'pinctrl-bindings.txt' bindings 'group' and 'function' can be used directly. So replace all of them. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-dts/mt7621.dtsi | 48 +- 1 file changed, 24 insertions(+), 24 deletions(-)

[PATCH 08/13] staging: mt7621-pinctrl: make use of pinctrl_utils_reserve_map

2018-06-28 Thread Sergio Paracuellos
Function rt2880_pinctrl_dt_node_to_map was using 'kzalloc' to reserve map memory. There is a 'pinctrl_utils_reserve_map' to do this function. Just use it. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 12 +--- 1 file changed, 9 insertions(+), 3

[PATCH 07/13] staging: mt7621-pinctrl: replace uint8_t type with u8 for 'gpio' field

2018-06-28 Thread Sergio Paracuellos
Struct 'rt2880_priv' contains a field 'gpio' which is defined as uint8_t and should be defined with 'u8' which is preferred. Update some cast along the code related with this new change. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 7 +++ 1 file

[PATCH 02/13] staging: mt7621-pinctrl: avoid lines over 80 chars

2018-06-28 Thread Sergio Paracuellos
This commit silence checkpatch warnings about lines which exceeds 80 chars. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 26 ++--- 1 file changed, 15 insertions(+), 11 deletions(-) diff --git

[PATCH 05/13] staging: mt7621-pinctrl: use tabs instead of spaces in some indentations

2018-06-28 Thread Sergio Paracuellos
Kernel coding style use tabs for indent code instead of spaces. Fix some places where spaces were being used silencing also checkpatch script complains. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 6 +++--- 1 file changed, 3 insertions(+), 3

[PATCH 04/13] staging: mt7621-pinctrl: align function parameters in some functions

2018-06-28 Thread Sergio Paracuellos
Function parameters along the code has different alignment styles. Just unify all of them making style consistent. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 29 - 1 file changed, 14 insertions(+), 15 deletions(-) diff --git

[PATCH 03/13] staging: mt7621-pinctrl: replace seq_printf with seq_puts

2018-06-28 Thread Sergio Paracuellos
For a constant format without additional arguments, use seq_puts() instead of seq_printf() fixing also the following checkpatch.pl warning: 'Prefer seq_puts to seq_printf' Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 2 +- 1 file changed, 1

[PATCH 01/13] staging: mt7621-pinctrl: avoid space after if condition

2018-06-28 Thread Sergio Paracuellos
Adding spaces between if condition and parenthesis are not needed at all and checkpatch script complains about them. Fix one in driver code. Signed-off-by: Sergio Paracuellos --- drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH 00/13] staging: mt7621-pinctrl: some cleanups

2018-06-28 Thread Sergio Paracuellos
This patch series add remaining cleanups from previous series which had problems to applied from here: http://driverdev.linuxdriverproject.org/pipermail/driverdev-devel/2018-June/121744.html Just send remaining patches in a new patch serie. Hope this helps. Best regards, Sergio Paracuellos

Re: [PATCH 2/2] staging: goldfish: Add goldfish sync driver

2018-06-28 Thread Roman Kiryanov
Hi Greg, we wanted to include our changes into this year LTS. > get the existing code cleaned up and out of the staging tree? Is this drivers/staging/goldfish? After I deleted the nand driver I see only goldfish_audio there. > Also, this code causes a bunch of build warnings, I could not take

Re: [PATCH] PCI: hv: fix spelling mistake: "reqquest" -> "request"

2018-06-28 Thread Lorenzo Pieralisi
On Tue, May 08, 2018 at 10:49:46PM +0100, Colin King wrote: > From: Colin Ian King > > Trivial fix to spelling mistake in dev_err error message > > Signed-off-by: Colin Ian King > --- > drivers/pci/host/pci-hyperv.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) Hi Colin, patch

[PATCH] staging: rtl8723bs: remove pointless if else in rtw_sdio_resume()

2018-06-28 Thread Michael Straube
Whether any of the conditions is true or not, the return variable is always set to rtw_resume_process(padapter). Replace the if else construct with a single call to rtw_resume_process(). Also remove the now unused local variable pwrpriv. Signed-off-by: Michael Straube ---

Re: [PATCH 0/4] x86/hyper-v: optimize PV IPIs

2018-06-28 Thread Vitaly Kuznetsov
Vitaly Kuznetsov writes: > Wanpeng Li writes: > >> Hi Vitaly, (fix my reply mess this time) >> On Sat, 23 Jun 2018 at 01:09, Vitaly Kuznetsov wrote: >>> >>> When reviewing my "x86/hyper-v: use cheaper HVCALL_FLUSH_VIRTUAL_ADDRESS_ >>> {LIST,SPACE} hypercalls when possible" patch Michael

Re: [PATCH 2/2] staging: goldfish: Add goldfish sync driver

2018-06-28 Thread Dan Carpenter
Try building this on a 32 bit system. I bet that's the build warnings which Greg saw... On Wed, Jun 27, 2018 at 02:50:52PM -0700, r...@google.com wrote: > From: Roman Kiryanov > > This is kernel driver for controlling the Goldfish sync > device on the host. It is used to maintain ordering > in

Re: [PATCH 2/2] staging: goldfish: Add goldfish sync driver

2018-06-28 Thread Greg KH
On Wed, Jun 27, 2018 at 02:50:52PM -0700, r...@google.com wrote: > From: Roman Kiryanov > > This is kernel driver for controlling the Goldfish sync > device on the host. It is used to maintain ordering > in critical OpenGL state changes while using > GPU emulation. Why are you adding new

Re: [PATCH 1/2] goldfish: Add functions to simplify goldfish related MMIO

2018-06-28 Thread Greg KH
On Wed, Jun 27, 2018 at 02:47:55PM -0700, r...@google.com wrote: > From: Roman Kiryanov > > Add functions > * to read and write u64 to be used in the goldfish sync driver. Why not just keep these in the sync driver? No need to put them in a .h file if only one .c file uses it, right? thanks,

Re: [PATCH] Staging: comedi: fix operator '=' coding style issue

2018-06-28 Thread Greg KH
On Tue, Jun 19, 2018 at 06:23:52PM +0200, Vitor Fernandes Ferreira wrote: > Signed-off-by: Vitor Fernandes Ferreira > --- > drivers/staging/comedi/comedi_fops.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) Hi, This is the friendly patch-bot of Greg Kroah-Hartman. You have sent

Re: staging: rtl8723bs: bug or pointless if else ?

2018-06-28 Thread Hans de Goede
Hi, On 28-06-18 17:00, Michael Straube wrote: On 06/28/18 11:34, Bastien Nocera wrote: On Thu, 2018-06-28 at 10:22 +0200, Hans de Goede wrote: Hi, On 28-06-18 09:43, Michael Straube wrote: Hi, I stumbled upon the following if else construct in

Re: staging: rtl8723bs: bug or pointless if else ?

2018-06-28 Thread Michael Straube
On 06/28/18 11:34, Bastien Nocera wrote: On Thu, 2018-06-28 at 10:22 +0200, Hans de Goede wrote: Hi, On 28-06-18 09:43, Michael Straube wrote: Hi, I stumbled upon the following if else construct in drivers/staging/rtl8723bs/os_dep/sdio_intf.c:618 if (pwrpriv->bInternalAutoSuspend)

Re: [PATCH v3 5/8] staging: rtl8192u: Use %s and __func__ instead of hardcoded string - Style

2018-06-28 Thread Greg KH
On Thu, Jun 28, 2018 at 01:32:41PM +0100, John Whitmore wrote: > On Thu, Jun 28, 2018 at 10:38:28AM +0300, Dan Carpenter wrote: > > On Wed, Jun 27, 2018 at 09:22:50PM +0100, John Whitmore wrote: > > > On Tue, Jun 26, 2018 at 11:56:24AM +0800, Greg KH wrote: > > > > On Sun, Jun 24, 2018 at

Re: [PATCH v2 05/18] staging: mt7621-pinctrl: avoid space after if condition

2018-06-28 Thread Greg KH
On Fri, Jun 08, 2018 at 02:16:35PM +0200, Sergio Paracuellos wrote: > Adding spaces between if condition and parenthesis are not > needed at all and checkpatch script complains about them. > Fix one in driver code. > > Signed-off-by: Sergio Paracuellos > --- >

Re: [PATCH v3 5/8] staging: rtl8192u: Use %s and __func__ instead of hardcoded string - Style

2018-06-28 Thread John Whitmore
On Thu, Jun 28, 2018 at 10:38:28AM +0300, Dan Carpenter wrote: > On Wed, Jun 27, 2018 at 09:22:50PM +0100, John Whitmore wrote: > > On Tue, Jun 26, 2018 at 11:56:24AM +0800, Greg KH wrote: > > > On Sun, Jun 24, 2018 at 04:34:51PM +0100, John Whitmore wrote: > > > > Changed a number of hard coded

Re: staging: rtl8723bs: bug or pointless if else ?

2018-06-28 Thread Greg Kroah-Hartman
On Thu, Jun 28, 2018 at 09:43:47AM +0200, Michael Straube wrote: > Hi, > > I stumbled upon the following if else construct in > drivers/staging/rtl8723bs/os_dep/sdio_intf.c:618 > > if (pwrpriv->bInternalAutoSuspend) > { > ret = rtw_resume_process(padapter); >

Re: staging: rtl8723bs: bug or pointless if else ?

2018-06-28 Thread Bastien Nocera
On Thu, 2018-06-28 at 10:22 +0200, Hans de Goede wrote: > Hi, > > On 28-06-18 09:43, Michael Straube wrote: > > Hi, > > > > I stumbled upon the following if else construct in > > drivers/staging/rtl8723bs/os_dep/sdio_intf.c:618 > > > > if (pwrpriv->bInternalAutoSuspend) > > {

Re: staging: rtl8723bs: bug or pointless if else ?

2018-06-28 Thread Hans de Goede
Hi, On 28-06-18 09:43, Michael Straube wrote: Hi, I stumbled upon the following if else construct in drivers/staging/rtl8723bs/os_dep/sdio_intf.c:618     if (pwrpriv->bInternalAutoSuspend)     {     ret = rtw_resume_process(padapter);     }     else     {

staging: rtl8723bs: bug or pointless if else ?

2018-06-28 Thread Michael Straube
Hi, I stumbled upon the following if else construct in drivers/staging/rtl8723bs/os_dep/sdio_intf.c:618 if (pwrpriv->bInternalAutoSuspend) { ret = rtw_resume_process(padapter); } else { if (pwrpriv->wowlan_mode ||

Re: [PATCH v3 5/8] staging: rtl8192u: Use %s and __func__ instead of hardcoded string - Style

2018-06-28 Thread Dan Carpenter
On Wed, Jun 27, 2018 at 09:22:50PM +0100, John Whitmore wrote: > On Tue, Jun 26, 2018 at 11:56:24AM +0800, Greg KH wrote: > > On Sun, Jun 24, 2018 at 04:34:51PM +0100, John Whitmore wrote: > > > Changed a number of hard coded function names to use %s and __func__ > > > > > > Mailing list response