[PATCH] staging: mt7621-pci: Fix compiler error 'slot' may be used uninitialized

2019-07-05 Thread René van Dorst
In commit 802a2f7b2fe3 ("staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function"), slot = port->slot; line was removed. Also other dev_err() print parameter was changed from slot to port->slot. So the same should be done here. This also fixes compiler error:

Re: [PATCH 0/4] staging: mt7621-pci: Handle minor issues

2019-07-05 Thread Brett Neumeier
On Wed, Jun 26, 2019 at 7:45 AM Sergio Paracuellos wrote: > No problem, I also miss them rewritting code. That is bad :((. > > BTW, I applied that on top of your other recent fixes (that ones > > you pushed to gregkh for staging). So I tested with the > > updated GPIO reset code. > Ok, anyway..

Re: [PATCH v2] PCI: hv: Fix a use-after-free bug in hv_eject_device_work()

2019-07-05 Thread Lorenzo Pieralisi
On Fri, Jun 21, 2019 at 11:45:23PM +, Dexuan Cui wrote: > > The commit 05f151a73ec2 itself is correct, but it exposes this > use-after-free bug, which is caught by some memory debug options. > > Add a Fixes tag to indicate the dependency. > > Fixes: 05f151a73ec2 ("PCI: hv: Fix a memory leak

[PATCH] staging: greybus: Replace function gb_i2c_device_setup()

2019-07-05 Thread Nishka Dasgupta
Remove function gb_i2c_device_setup as all it does is call gb_i2c_functionality_operation. Rename gb_i2c_functionality_operation to gb_i2c_device_setup to maintain compatibility with call sites. Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta --- drivers/staging/greybus/i2c.c | 22

Re: [PATCH 2/2] staging: media: sunxi: Replace function cedrus_check_format()

2019-07-05 Thread Nishka Dasgupta
On 05/07/19 3:56 PM, Paul Kocialkowski wrote: Hi, On Wed 03 Jul 19, 13:43, Nishka Dasgupta wrote: Remove function cedrus_check_format as all it does is call cedrus_find_format. Rename cedrus_find_format to cedrus_check_format to maintain compatibility with call sites. Issue found with

Re: [PATCH 1/2] staging: media: sunxi: Change return type of cedrus_find_format()

2019-07-05 Thread Nishka Dasgupta
On 05/07/19 3:56 PM, Paul Kocialkowski wrote: Hi, On Wed 03 Jul 19, 13:43, Nishka Dasgupta wrote: Change return type of cedrus_find_format to bool as it is only called once, by a function whose return value is bool, and the return value of cedrus_find_format is returned as-is at the call-site.

[driver-core:debugfs_cleanup 185/194] drivers//iommu/omap-iommu-debug.c:254:44: error: 'rtlb_fops' undeclared; did you mean 'tlb_fops'?

2019-07-05 Thread kbuild test robot
tree: https://kernel.googlesource.com/pub/scm/linux/kernel/git/gregkh/driver-core.git debugfs_cleanup head: 8c54807642d011014627c0187798950d30c3abf4 commit: aab8ab1a5aaec133532b9fba30b1da24c08dbac3 [185/194] omap-iommu: no need to check return value of debugfs_create functions config:

Re: [PATCH 2/2] staging: media: sunxi: Replace function cedrus_check_format()

2019-07-05 Thread Paul Kocialkowski
Hi, On Wed 03 Jul 19, 13:43, Nishka Dasgupta wrote: > Remove function cedrus_check_format as all it does is call > cedrus_find_format. > Rename cedrus_find_format to cedrus_check_format to maintain > compatibility with call sites. > Issue found with Coccinelle. Maybe we could have a !! or a bool

Re: [PATCH 1/2] staging: media: sunxi: Change return type of cedrus_find_format()

2019-07-05 Thread Paul Kocialkowski
Hi, On Wed 03 Jul 19, 13:43, Nishka Dasgupta wrote: > Change return type of cedrus_find_format to bool as it is only called > once, by a function whose return value is bool, and the return value of > cedrus_find_format is returned as-is at the call-site. > Issue found with Coccinelle. The

[PATCH] staging: rtl8712: remove redundant assignment to variable res

2019-07-05 Thread Colin King
From: Colin Ian King The variable res is being initialized with a value that is never read and it is being updated later with a new value. The initialization is redundant and can be removed. Addresses-Coverity: ("Unused value") Signed-off-by: Colin Ian King ---

Re: [OSSNA] Intro to kernel hacking tutorial

2019-07-05 Thread loïc tourlonias
Hi, On Fri, Jul 5, 2019 at 4:51 AM Tobin C. Harding wrote: > > Hi, > > I am doing a tutorial at OSSNA in San Diego on getting into kernel > hacking. I'm only a couple of years deep into kernel hacking so I > wanted to reach out to those more experienced than myself (and those > less

[PATCH] staging: media: davinci_vpfe: Replace function vpfe_isif_cleanup()

2019-07-05 Thread Nishka Dasgupta
Rename function isif_remove to vpfe_isif_cleanup, as vpfe_isif_cleanup does nothing but call isif_remove. Change type of new vpfe_isif_cleanup from static to non-static to match the old function definition. Remove the original vpfe_isif_cleanup. Modify calls to isif_remove to vpfe_isif_cleanup.