[staging:staging-testing 314/401] ERROR: "__udivdi3" [drivers/iio/common/hid-sensors/hid-sensor-iio-common.ko] undefined!

2019-09-03 Thread kbuild test robot
tree: https://kernel.googlesource.com/pub/scm/linux/kernel/git/gregkh/staging.git staging-testing head: 74eb9c06b1d722468db397595ac6834b9e4ac235 commit: 473d12f7638c93acbd9296a8cd455b203d5eb528 [314/401] iio: hid-sensor-attributes: Convert to use int_pow() config: m68k-allmodconfig

[staging:staging-testing 314/401] drivers/iio/common/hid-sensors/hid-sensor-attributes.c:312: undefined reference to `__udivdi3'

2019-09-03 Thread kbuild test robot
tree: https://kernel.googlesource.com/pub/scm/linux/kernel/git/gregkh/staging.git staging-testing head: 74eb9c06b1d722468db397595ac6834b9e4ac235 commit: 473d12f7638c93acbd9296a8cd455b203d5eb528 [314/401] iio: hid-sensor-attributes: Convert to use int_pow() config:

Re: [PATCH v2 00/25] erofs: patchset addressing Christoph's comments

2019-09-03 Thread Chao Yu
On 2019/9/4 10:08, Gao Xiang wrote: > Hi, > > This patchset is based on the following patch by Pratik Shinde, > https://lore.kernel.org/linux-erofs/20190830095615.10995-1-pratikshinde...@gmail.com/ > > All patches addressing Christoph's comments on v6, which are trivial, > most deleted code are

Re: [PATCH] erofs: using switch-case while checking the inode type.

2019-09-03 Thread Gao Xiang
Hi Greg, On Fri, Aug 30, 2019 at 10:22:33PM +0800, Gao Xiang wrote: > On Fri, Aug 30, 2019 at 07:59:48PM +0800, Gao Xiang wrote: > > Hi Pratik, > > > > The subject line could be better as '[PATCH v2] xx'... > > > > On Fri, Aug 30, 2019 at 03:26:15PM +0530, Pratik Shinde wrote: > > > while

[PATCH v2 18/25] erofs: add "erofs_" prefix for common and short functions

2019-09-03 Thread Gao Xiang
Add erofs_ prefix to free_inode, alloc_inode, ... Reported-by: Christoph Hellwig Signed-off-by: Gao Xiang --- fs/erofs/data.c | 4 ++-- fs/erofs/decompressor.c | 22 +++--- fs/erofs/inode.c| 8 fs/erofs/internal.h | 2 +- fs/erofs/namei.c

[PATCH v2 20/25] erofs: kill use_vmap module parameter

2019-09-03 Thread Gao Xiang
As Christoph said [1], "vm_map_ram is supposed to generally behave better. So if it doesn't please report that that to the arch maintainer and linux-mm so that they can look into the issue. Having user make choices of deep down kernel internals is just a horrible interface. Please talk to

[PATCH v2 22/25] erofs: rename errln/infoln/debugln to erofs_{err, info, dbg}

2019-09-03 Thread Gao Xiang
Add prefix "erofs_" to these functions and print sb->s_id as a prefix to erofs_{err, info} so that the user knows which file system is affected. Reported-by: Christoph Hellwig Signed-off-by: Gao Xiang --- fs/erofs/data.c | 10 +++-- fs/erofs/decompressor.c | 5 +-- fs/erofs/dir.c

[PATCH v2 25/25] erofs: use read_cache_page_gfp for erofs_get_meta_page

2019-09-03 Thread Gao Xiang
As Christoph said [1], "I'd much prefer to just use read_cache_page_gfp, and live with the fact that this allocates bufferheads behind you for now. I'll try to speed up my attempts to get rid of the buffer heads on the block device mapping instead. " This simplifies the code a lot and a minor

[PATCH v2 16/25] erofs: kill prio and nofail of erofs_get_meta_page()

2019-09-03 Thread Gao Xiang
As Christoph pointed out [1], "Why is there __erofs_get_meta_page with the two weird booleans instead of a single erofs_get_meta_page that gets and gfp_t for additional flags and an unsigned int for additional bio op flags." And since all callers can handle errors, let's kill prio and nofail and

[PATCH v2 09/25] erofs: use erofs_inode naming

2019-09-03 Thread Gao Xiang
As Christoph suggested [1], "Why is this called vnode instead of inode? That seems like a rather odd naming for a Linux file system." [1] https://lore.kernel.org/r/20190829101545.gc20...@infradead.org/ Reported-by: Christoph Hellwig Signed-off-by: Gao Xiang --- fs/erofs/data.c |

[PATCH v2 17/25] erofs: kill __submit_bio()

2019-09-03 Thread Gao Xiang
As Christoph pointed out [1], " Why is there __submit_bio which really just obsfucates what is going on? Also why is __submit_bio using bio_set_op_attrs instead of opencode it as the comment right next to it asks you to? " Let's use submit_bio directly instead. [1]

[PATCH v2 24/25] erofs: always use iget5_locked

2019-09-03 Thread Gao Xiang
As Christoph said [1] [2], "Just use the slightly more complicated 32-bit version everywhere so that you have a single actually tested code path. And then remove this helper. " [1] https://lore.kernel.org/r/20190829102426.ge20...@infradead.org/ [2]

[PATCH v2 23/25] erofs: use read_mapping_page instead of sb_bread

2019-09-03 Thread Gao Xiang
As Christoph said [1], "This seems to be your only direct use of buffer heads, which while not deprecated are a bit of an ugly step child. So if you can easily avoid creating a buffer_head dependency in a new filesystem I think you should avoid it. " [1]

[PATCH v2 19/25] erofs: kill all erofs specific fault injection

2019-09-03 Thread Gao Xiang
As Christoph suggested [1], "Please just use plain kmalloc everywhere and let the normal kernel error injection code take care of injeting any errors." [1] https://lore.kernel.org/r/20190829102426.ge20...@infradead.org/ Reported-by: Christoph Hellwig Signed-off-by: Gao Xiang ---

[PATCH v2 15/25] erofs: localize erofs_grab_bio()

2019-09-03 Thread Gao Xiang
As Christoph pointed out [1], "erofs_grab_bio tries to handle a bio_alloc failure, except that the function will not actually fail due the mempool backing it." Sorry about useless code, fix it now and localize erofs_grab_bio [2]. [1]

[PATCH v2 21/25] erofs: save one level of indentation

2019-09-03 Thread Gao Xiang
As Christoph said [1], ".. and save one level of indentation." [1] https://lore.kernel.org/r/20190829102426.ge20...@infradead.org/ Reported-by: Christoph Hellwig Signed-off-by: Gao Xiang --- fs/erofs/inode.c | 65 1 file changed, 33

[PATCH v2 01/25] erofs: remove all the byte offset comments

2019-09-03 Thread Gao Xiang
As Christoph suggested [1], "Please remove all the byte offset comments. that is something that can easily be checked with gdb or pahole." [1] https://lore.kernel.org/r/20190829095954.gb20...@infradead.org/ Reported-by: Christoph Hellwig Signed-off-by: Gao Xiang --- fs/erofs/erofs_fs.h | 105

[PATCH v2 14/25] erofs: kill verbose debug info in erofs_fill_super

2019-09-03 Thread Gao Xiang
As Christoph said [1], "That is some very verbose debug info. We usually don't add that and let people trace the function instead. " [1] https://lore.kernel.org/r/20190829101545.gc20...@infradead.org/ Reported-by: Christoph Hellwig Signed-off-by: Gao Xiang --- fs/erofs/super.c | 9 ++---

[PATCH v2 02/25] erofs: on-disk format should have explicitly assigned numbers

2019-09-03 Thread Gao Xiang
As Christoph suggested [1], on-disk format should have explicitly assigned numbers. [1] https://lore.kernel.org/r/20190829095954.gb20...@infradead.org/ Reported-by: Christoph Hellwig Signed-off-by: Gao Xiang --- fs/erofs/erofs_fs.h | 18 +- 1 file changed, 9 insertions(+), 9

[PATCH v2 10/25] erofs: update erofs_fs.h comments

2019-09-03 Thread Gao Xiang
As Christoph said [1] [2], update it now. [1] https://lore.kernel.org/r/20190902124521.ga22...@infradead.org/ [2] https://lore.kernel.org/r/20190902120548.gb15...@infradead.org/ Reported-by: Christoph Hellwig Signed-off-by: Gao Xiang --- fs/erofs/erofs_fs.h | 9 + 1 file changed, 5

[PATCH v2 11/25] erofs: update comments in inode.c

2019-09-03 Thread Gao Xiang
As Christoph suggested [1], update them all. [1] https://lore.kernel.org/r/20190829102426.ge20...@infradead.org/ Reported-by: Christoph Hellwig Signed-off-by: Gao Xiang --- fs/erofs/inode.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/fs/erofs/inode.c

[PATCH v2 13/25] erofs: use dsb instead of layout for ondisk super_block

2019-09-03 Thread Gao Xiang
As Christoph pointed out [1], "Why is the variable name for the on-disk subperblock layout? We usually still calls this something with sb in the name, e.g. dsb. for disksuper block. " Let's fix it. [1] https://lore.kernel.org/r/20190829101545.gc20...@infradead.org/ Signed-off-by: Gao Xiang ---

[PATCH v2 12/25] erofs: better erofs symlink stuffs

2019-09-03 Thread Gao Xiang
Fix as Christoph suggested [1] [2], "remove is_inode_fast_symlink and just opencode it in the few places using it" and "Please just set the ops directly instead of obsfucating that in a single caller, single line inline function. And please set it instead of the normal symlink iops in the same

[PATCH v2 05/25] erofs: update erofs_inode_is_data_compressed helper

2019-09-03 Thread Gao Xiang
As Christoph said, "This looks like a really obsfucated way to write: return datamode == EROFS_INODE_FLAT_COMPRESSION || datamode == EROFS_INODE_FLAT_COMPRESSION_LEGACY; " Although I had my own consideration, it's the right way for now. [1]

[PATCH v2 06/25] erofs: use feature_incompat rather than requirements

2019-09-03 Thread Gao Xiang
As Christoph said [1], "This is only cosmetic, why not stick to feature_compat and feature_incompat?" In my thought, requirements means "incompatible" instead of "feature" though. [1] https://lore.kernel.org/r/20190902125109.ga9...@infradead.org/ Reported-by: Christoph Hellwig Signed-off-by:

[PATCH v2 03/25] erofs: some macros are much more readable as a function

2019-09-03 Thread Gao Xiang
As Christoph suggested [1], these macros are much more readable as a function. [1] https://lore.kernel.org/r/20190829095954.gb20...@infradead.org/ Reported-by: Christoph Hellwig Signed-off-by: Gao Xiang --- fs/erofs/erofs_fs.h | 22 ++ fs/erofs/inode.c| 4 ++--

[PATCH v2 08/25] erofs: kill erofs_{init,exit}_inode_cache

2019-09-03 Thread Gao Xiang
As Christoph said [1] "having this function seems entirely pointless", let's kill those. filesystem function name ext2,f2fs,ext4,isofs,squashfs,cifs,... init_inodecache In addition, add a necessary "rcu_barrier()" on exit_fs(); [1]

[PATCH v2 00/25] erofs: patchset addressing Christoph's comments

2019-09-03 Thread Gao Xiang
Hi, This patchset is based on the following patch by Pratik Shinde, https://lore.kernel.org/linux-erofs/20190830095615.10995-1-pratikshinde...@gmail.com/ All patches addressing Christoph's comments on v6, which are trivial, most deleted code are from erofs specific fault injection, which was

[PATCH v2 04/25] erofs: kill __packed for on-disk structures

2019-09-03 Thread Gao Xiang
As Christoph suggested "Please don't add __packed" [1], remove all __packed except struct erofs_dirent here. Note that all on-disk fields except struct erofs_dirent (12 bytes with a 8-byte nid) in EROFS are naturally aligned. [1] https://lore.kernel.org/r/20190829095954.gb20...@infradead.org/

[PATCH v2] staging: exfat: cleanup explicit comparisons to NULL

2019-09-03 Thread Valentin Vidic
Fixes checkpatch.pl warnings: CHECK: Comparison to NULL could be written "expr" CHECK: Comparison to NULL could be written "!expr" Signed-off-by: Valentin Vidic --- v2: fix gcc warning in strsep call drivers/staging/exfat/exfat_core.c | 34 -

Re: [PATCH] staging: exfat: cleanup explicit comparisons to NULL

2019-09-03 Thread Greg Kroah-Hartman
On Tue, Sep 03, 2019 at 07:13:37PM +0200, Valentin Vidic wrote: > Fixes checkpatch.pl warnings: > > CHECK: Comparison to NULL could be written "expr" > CHECK: Comparison to NULL could be written "!expr" > > Signed-off-by: Valentin Vidic > --- > drivers/staging/exfat/exfat_core.c | 34

[PATCH] staging: exfat: drop local TRUE/FALSE defines

2019-09-03 Thread Valentin Vidic
Replace with bool where it makes sense. Also drop unused local variable lossy in fat_find_dir_entry. Signed-off-by: Valentin Vidic --- drivers/staging/exfat/exfat.h | 3 -- drivers/staging/exfat/exfat_core.c | 81 +++-- drivers/staging/exfat/exfat_nls.c | 2 +-

Re: [PATCH] staging: exfat: cleanup braces for if/else statements

2019-09-03 Thread Greg Kroah-Hartman
On Tue, Sep 03, 2019 at 06:32:49PM +0100, Al Viro wrote: > On Tue, Sep 03, 2019 at 06:47:32PM +0200, Valentin Vidic wrote: > > + } else if (uni == 0x) { > > skip = TRUE; > > While we are at it, could you get rid of that 'TRUE' macro? > Or added >

Re: [PATCH] staging: exfat: cleanup braces for if/else statements

2019-09-03 Thread Valentin Vidić
On Tue, Sep 03, 2019 at 06:32:49PM +0100, Al Viro wrote: > On Tue, Sep 03, 2019 at 06:47:32PM +0200, Valentin Vidic wrote: > > + } else if (uni == 0x) { > > skip = TRUE; > > While we are at it, could you get rid of that 'TRUE' macro? Sure, but

Re: [PATCH] staging: exfat: cleanup braces for if/else statements

2019-09-03 Thread Al Viro
On Tue, Sep 03, 2019 at 06:47:32PM +0200, Valentin Vidic wrote: > + } else if (uni == 0x) { > skip = TRUE; While we are at it, could you get rid of that 'TRUE' macro? Or added #define THE_TRUTH_AND_THATS_CUTTIN_ME_OWN_THROAT true if you want

[PATCH] staging: exfat: cleanup explicit comparisons to NULL

2019-09-03 Thread Valentin Vidic
Fixes checkpatch.pl warnings: CHECK: Comparison to NULL could be written "expr" CHECK: Comparison to NULL could be written "!expr" Signed-off-by: Valentin Vidic --- drivers/staging/exfat/exfat_core.c | 34 - drivers/staging/exfat/exfat_super.c | 58

[PATCH] staging: exfat: fix spelling errors in comments

2019-09-03 Thread Valentin Vidic
Fixes checkpatch.pl warnings: CHECK: 'consistancy' may be misspelled - perhaps 'consistency'? CHECK: 'stuct' may be misspelled - perhaps 'struct'? Signed-off-by: Valentin Vidic --- drivers/staging/exfat/exfat_core.c | 2 +- drivers/staging/exfat/exfat_super.c | 2 +- 2 files changed, 2

[PATCH] staging: exfat: cleanup braces for if/else statements

2019-09-03 Thread Valentin Vidic
Fixes checkpatch.pl warnings: CHECK: Unbalanced braces around else statement CHECK: braces {} should be used on all arms of this statement Signed-off-by: Valentin Vidic --- drivers/staging/exfat/exfat_core.c | 12 ++-- drivers/staging/exfat/exfat_super.c | 16 +--- 2

[PATCH AUTOSEL 4.19 127/167] staging: wilc1000: fix error path cleanup in wilc_wlan_initialize()

2019-09-03 Thread Sasha Levin
From: Ajay Singh [ Upstream commit 6419f818ababebc1116fb2d0e220bd4fe835d0e3 ] For the error path in wilc_wlan_initialize(), the resources are not cleanup in the correct order. Reverted the previous changes and use the correct order to free during error condition. Fixes: b46d68825c2d ("staging:

[PATCH v3 0/4] Add binder state and statistics to binderfs

2019-09-03 Thread Hridya Valsaraju
Currently, the only way to access binder state and statistics is through debugfs. We need a way to access the same even when debugfs is not mounted. These patches add a mount option to make this information available in binderfs without affecting its presence in debugfs. The following debugfs

Re: [PATCH 00/21] erofs: patchset addressing Christoph's comments

2019-09-03 Thread Gao Xiang
Hi Christoph, On Tue, Sep 03, 2019 at 08:37:04AM -0700, Christoph Hellwig wrote: > On Tue, Sep 03, 2019 at 04:17:49PM +0800, Gao Xiang wrote: > > I implement a prelimitary version, but I have no idea it is a really > > cleanup for now. > > The fact that this has to guess the block device

Re: [PATCH 00/21] erofs: patchset addressing Christoph's comments

2019-09-03 Thread Christoph Hellwig
On Tue, Sep 03, 2019 at 04:17:49PM +0800, Gao Xiang wrote: > I implement a prelimitary version, but I have no idea it is a really > cleanup for now. The fact that this has to guess the block device address_space implementation is indeed pretty ugly. I'd much prefer to just use

Re: [PATCH v6 01/24] erofs: add on-disk layout

2019-09-03 Thread Pavel Machek
Hi! > > No. gdb tells you what the actual offsets _are_. > > Ok, reading your reply twice, I think we have different perspectives. I > don't trust the comments. > > The tool I had in mind is pahole that parses dwarf information about the > structures, the same as gdb does. The actual value of

Re: [PATCH] staging: rts5208: Modified nested if blocks.

2019-09-03 Thread Greg KH
On Tue, Sep 03, 2019 at 02:32:40PM +0530, Prakhar Sinha wrote: > This patch solves the following checkpatch.pl's messages in > drivers/staging/rts5208/sd.c > > WARNING: line over 80 characters > 4517: FILE: drivers/staging/rts5208/sd.c:4517: > +

[PATCH] staging: rts5208: Modified nested if blocks.

2019-09-03 Thread Prakhar Sinha
This patch solves the following checkpatch.pl's messages in drivers/staging/rts5208/sd.c WARNING: line over 80 characters 4517: FILE: drivers/staging/rts5208/sd.c:4517: + sd_card->sd_lock_status &= ~(SD_UNLOCK_POW_ON | SD_SDR_RST); WARNING: line over

Re: [PATCH 00/21] erofs: patchset addressing Christoph's comments

2019-09-03 Thread Gao Xiang
Hi Christoph, On Mon, Sep 02, 2019 at 11:58:03PM -0700, Christoph Hellwig wrote: > On Mon, Sep 02, 2019 at 11:50:38PM +0800, Gao Xiang wrote: > > > > You means killing erofs_get_meta_page or avoid erofs_read_raw_page? > > > > > > > > - For killing erofs_get_meta_page, here is the current > > >

Re: [PATCH] staging: rts5208: Fixed checkpatch warning.

2019-09-03 Thread Greg KH
On Sat, Aug 31, 2019 at 01:10:55PM +0530, Prakhar Sinha wrote: > This patch solves the following checkpatch.pl's messages in > drivers/staging/rts5208/sd.c > > WARNING: line over 80 characters > 4517: FILE: drivers/staging/rts5208/sd.c:4517: > +

Re: [PATCH] staging: rts5208: Fix checkpath warning

2019-09-03 Thread Greg KH
On Sat, Aug 31, 2019 at 01:02:24PM +0530, P SAI PRASANTH wrote: > This patch fixes the following checkpath warning > in file drivers/staging/rts5208/xd.c:1754 > > WARNING: line over 80 characters > + index, offset, DMA_TO_DEVICE, > chip->xd_timeout); > >

Re: [PATCH 00/21] erofs: patchset addressing Christoph's comments

2019-09-03 Thread Christoph Hellwig
On Mon, Sep 02, 2019 at 11:50:38PM +0800, Gao Xiang wrote: > > > You means killing erofs_get_meta_page or avoid erofs_read_raw_page? > > > > > > - For killing erofs_get_meta_page, here is the current > > > erofs_get_meta_page: > > > > > I think it is simple enough. read_cache_page need write a

Re: [PATCH v8 11/24] erofs: introduce xattr & posixacl support

2019-09-03 Thread Chao Yu
On 2019/9/2 22:20, David Sterba wrote: > Oh right, I think the reasons are historical and that we can remove the > options nowadays. From the compatibility POV this should be safe, with > ACLs compiled out, no tool would use them, and no harm done when the > code is present but not used. > >