[driver-core:driver-core-testing] BUILD SUCCESS fbc35b45f9f6a971341b9462c6e94c257e779fb5

2020-04-25 Thread kbuild test robot
randconfig-a001-20200426 h8300randconfig-a001-20200426 sparc64 randconfig-a001-20200426 microblaze randconfig-a001-20200426 nios2randconfig-a001-20200425 c6x randconfig-a001-20200425 h8300randconfig

[staging:staging-testing] BUILD SUCCESS 41aef04524d3dc8c2a5d9652cccc1f567356b5fd

2020-04-25 Thread kbuild test robot
randconfig-a001-20200425 c6x randconfig-a001-20200425 h8300randconfig-a001-20200425 sparc64 randconfig-a001-20200425 microblaze randconfig-a001-20200425 sh randconfig-a001-20200426 csky randconfig-a001-20200426

[staging:staging-linus] BUILD SUCCESS 664ba5180234593b4b8517530e8198bf2f7359e2

2020-04-25 Thread kbuild test robot
randconfig-a001-20200425 ia64 randconfig-a001-20200425 powerpc randconfig-a001-20200425 arm randconfig-a001-20200425 arc randconfig-a001-20200425 sparcrandconfig-a001-20200423 ia64 randconfig-a001

[staging:staging-next] BUILD SUCCESS bf42304b55f59af5e71c86e46291705023dce62e

2020-04-25 Thread kbuild test robot
microblaze randconfig-a001-20200426 nios2randconfig-a001-20200425 c6x randconfig-a001-20200425 h8300randconfig-a001-20200425 sparc64 randconfig-a001-20200425 microblaze randconfig-a001-20200425 sh

[PATCH v2 0/3] Refactor the vnt_rf_table_download function

2020-04-25 Thread Oscar Carter
This patch series refactors the vnt_rf_table_download function through tree patches. The first one removes the local variable "array" and all the memcpy function calls because this copy operation from different arrays to this variable is unnecessary. The second patch replaces the "goto"

[PATCH v2 3/3] staging: vt6656: Remove duplicate code in vnt_rf_table_download

2020-04-25 Thread Oscar Carter
Replace three while loops with three calls to the vnt_control_out_blocks function. This way avoid repeat a functionality that already exists. Also remove the variables that now are not used. Signed-off-by: Oscar Carter --- drivers/staging/vt6656/rf.c | 65 +++--

[PATCH v2 1/3] staging: vt6656: Remove the local variable "array"

2020-04-25 Thread Oscar Carter
Remove the local variable "array" and all the memcpy function calls because this copy operation from different arrays to this variable is unnecessary. The vnt_control_out function already does a kmemdup copy of its const char *buffer argument and this was made unnecessary by: commit 12ecd24ef932

[PATCH v2 2/3] staging: vt6656: Use return instead of goto

2020-04-25 Thread Oscar Carter
Replace the "goto" statements with a direct "return ret" as the jump label only returns the ret variable. Also, remove the unnecessary variable initialization because the ret variable is set a few lines later. Signed-off-by: Oscar Carter --- drivers/staging/vt6656/rf.c | 15 +++ 1

Re: [PATCH 1/3] staging: vt6656: Remove the local variable "array"

2020-04-25 Thread Oscar Carter
On Sat, Apr 25, 2020 at 05:50:39AM -0700, Joe Perches wrote: > On Sat, 2020-04-25 at 14:38 +0200, Oscar Carter wrote: > > Remove the local variable "array" and all the memcpy function calls > > because this copy operation from different arrays to this variable is > > unnecessary. > > You might

[PATCH v3] staging: vt6656: Add formula to the vnt_rf_addpower function

2020-04-25 Thread Oscar Carter
Use a formula to calculate the return value of the vnt_rf_addpower function instead of the "if" statement with literal values for every case. Signed-off-by: Oscar Carter --- Changelog v1 -> v2 - Change the type of "base" variable from s32 to int as Dan Carpenter suggested. - Remove the "--"

Re: [PATCH v2] staging: vt6656: Add formula to the vnt_rf_addpower function

2020-04-25 Thread Oscar Carter
On Sat, Apr 25, 2020 at 12:57:14PM +0200, Greg Kroah-Hartman wrote: > On Thu, Apr 23, 2020 at 07:05:57PM +0200, Oscar Carter wrote: > > Use a formula to calculate the return value of the vnt_rf_addpower > > function instead of the "if" statement with literal values for every > > case. > > > >

[PATCH v4 2/2] staging: vt6656: Remove functions' documentation

2020-04-25 Thread Oscar Carter
Remove the functions' documentation as the names of the functions are clear enought. Also, the actual documentation it's not correct in all cases. Signed-off-by: Oscar Carter --- drivers/staging/vt6656/card.c | 79 -- drivers/staging/vt6656/mac.c | 52

[PATCH v4 1/2] staging: vt6656: Check the return value of vnt_control_out_* calls

2020-04-25 Thread Oscar Carter
Check the return value of vnt_control_out_* function calls. When necessary modify the function prototype to be able to return the new checked error code. It's safe to modify all the function prototypes without fix the call because the only change is the return value from void to int. If before

[PATCH v4 0/2] staging: vt6656: Check the return value of vnt_control_out_* calls

2020-04-25 Thread Oscar Carter
This patch series checks the return value of vnt_control_out_* function calls. The first patch checks the return value and when necessary modify the function prototype to be able to return the new checked error code. The second patch removes the documentation of functions that their prototype

Re: [PATCH v3 0/2] staging: vt6656: Check the return value of vnt_control_out_* calls

2020-04-25 Thread Oscar Carter
On Sat, Apr 25, 2020 at 12:56:26PM +0200, Greg Kroah-Hartman wrote: > On Thu, Apr 23, 2020 at 05:38:34PM +0200, Oscar Carter wrote: > > This patch series checks the return value of vnt_control_out_* function > > calls. > > > > The first patch checks the return value and when necessary modify the >

Re: [PATCH 1/3] staging: vt6656: Remove the local variable "array"

2020-04-25 Thread Joe Perches
On Sat, 2020-04-25 at 14:38 +0200, Oscar Carter wrote: > Remove the local variable "array" and all the memcpy function calls > because this copy operation from different arrays to this variable is > unnecessary. You might write here that vnt_control_out already does a kmemdup copy of its const

[PATCH 1/3] staging: vt6656: Remove the local variable "array"

2020-04-25 Thread Oscar Carter
Remove the local variable "array" and all the memcpy function calls because this copy operation from different arrays to this variable is unnecessary. The same result can be achieved using the arrays directly. Signed-off-by: Oscar Carter --- drivers/staging/vt6656/rf.c | 21

[PATCH 3/3] staging: vt6656: Remove duplicate code in vnt_rf_table_download

2020-04-25 Thread Oscar Carter
Replace three while loops with three calls to the vnt_control_out_blocks function. This way avoid repeat a functionality that already exists. Also remove the variables that now are not used. Signed-off-by: Oscar Carter --- drivers/staging/vt6656/rf.c | 65 +++--

[PATCH 2/3] staging: vt6656: Use return instead of goto

2020-04-25 Thread Oscar Carter
Replace the "goto" statements with a direct "return ret" as the jump label only returns the ret variable. Also, remove the unnecessary variable initialization because the ret variable is set a few lines later. Signed-off-by: Oscar Carter --- drivers/staging/vt6656/rf.c | 15 +++ 1

[PATCH 0/3] Refactor the vnt_rf_table_download function

2020-04-25 Thread Oscar Carter
This patch series refactors the vnt_rf_table_download function through tree patches. The first one removes the local variable "array" and all the memcpy function calls because this copy operation from different arrays to this variable is unnecessary. The second patch replaces the "goto"

[PATCH v4] staging: wfx: cleanup long lines in data_tx.c

2020-04-25 Thread Suraj Upadhyay
Break lines with length over 80 characters to conform to the linux coding style and refactor wherever necessary. Signed-off-by: Suraj Upadhyay --- Changes in v4: - Added a space after declaration in wfx_get_hw_rate(). - A checkpatch warning for this commit is retained at line

Re: [PATCH v2] staging: vt6656: Add formula to the vnt_rf_addpower function

2020-04-25 Thread Greg Kroah-Hartman
On Thu, Apr 23, 2020 at 07:05:57PM +0200, Oscar Carter wrote: > Use a formula to calculate the return value of the vnt_rf_addpower > function instead of the "if" statement with literal values for every > case. > > Signed-off-by: Oscar Carter > --- > Changelog v1 -> v2 > - Change the type of

Re: [PATCH v3 0/2] staging: vt6656: Check the return value of vnt_control_out_* calls

2020-04-25 Thread Greg Kroah-Hartman
On Thu, Apr 23, 2020 at 05:38:34PM +0200, Oscar Carter wrote: > This patch series checks the return value of vnt_control_out_* function > calls. > > The first patch checks the return value and when necessary modify the > function prototype to be able to return the new checked error code. > > The

Re: [PATCH v3] staging: wfx: cleanup long lines in data_tx.c

2020-04-25 Thread Greg KH
On Fri, Apr 24, 2020 at 07:18:34PM +0530, Suraj Upadhyay wrote: > Break lines with length over 80 characters to conform > to the linux coding style and refactor wherever necessary. > > Signed-off-by: Suraj Upadhyay > --- > > Changes in v3: > - Changed the temporary variable name for the

[PATCH v2] staging: vt6656: rxtx: remove duration_id and void returns.

2020-04-25 Thread Malcolm Priestley
duration_id is not used by driver anymore so remove the returns and set all functions in patch to void. Signed-off-by: Malcolm Priestley --- v1 had missing returns in vnt_generate_tx_parameter and vnt_rxtx_ab drivers/staging/vt6656/rxtx.c | 84 +-- 1 file

Re: [PATCH] staging: vt6656: rxtx: remove duration_id and void returns.

2020-04-25 Thread Malcolm Priestley
Drop this patch there is a mistake in it. Regards Malcolm ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

[PATCH] staging: rtl8188eu: remove some superfluous comments

2020-04-25 Thread Michael Straube
Remove some obviously superflous comments. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm.c | 2 -- drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 2 -- drivers/staging/rtl8188eu/hal/rtl8188e_dm.c | 3 --- 3 files changed, 7 deletions(-) diff --git

[PATCH v3] Staging: gasket: fix typo in gasket_page_table.c comments.

2020-04-25 Thread Kyoungho Koo
I have found double typed comments "the the". So i modified it to one "the". Signed-off-by: Kyoungho Koo --- Changes in v3: - Modify the first letter of the name to uppercase. drivers/staging/gasket/gasket_page_table.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH] Staging: gasket: fix typo in gasket_page_table.c comments.

2020-04-25 Thread Kyoungho Koo
I have found double typed comments "the the". So i modified it to one "the". Signed-off-by: Kyoungho Koo --- Changes in v3: - Modify the first letter of the name to uppercase. drivers/staging/gasket/gasket_page_table.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [PATCH v2] Staging: gasket: fix typo in gasket_page_table.c comments.

2020-04-25 Thread Greg KH
On Sat, Apr 25, 2020 at 12:32:51PM +0900, Kyoungho Koo wrote: > I have found double typed comments "the the". So i modified it to > one "the". > > Signed-off-by: Kyoungho Koo > --- > drivers/staging/gasket/gasket_page_table.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) What changed