[staging:staging-linus] BUILD SUCCESS faaff9765664009c1c7c65551d32e9ed3b1dda8f

2020-07-22 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git staging-linus branch HEAD: faaff9765664009c1c7c65551d32e9ed3b1dda8f staging: wlan-ng: properly check endpoint types elapsed time: 722m configs tested: 132 configs skipped: 3 The following configs have been built

Re: [PATCH v8 08/12] device core: Introduce DMA range map, supplanting dma_pfn_offset

2020-07-22 Thread Jim Quinlan
On Tue, Jul 21, 2020 at 8:51 AM Christoph Hellwig wrote: > > On Wed, Jul 15, 2020 at 10:35:11AM -0400, Jim Quinlan wrote: > > The new field 'dma_range_map' in struct device is used to facilitate the > > use of single or multiple offsets between mapping regions of cpu addrs and > > dma addrs. It

[PATCH v2] media: cedrus: Add support for VP8 decoding

2020-07-22 Thread Jernej Skrabec
VP8 in Cedrus shares same engine as H264. Note that it seems necessary to call bitstream parsing functions, to parse frame header, otherwise decoded image is garbage. This is contrary to what is driver supposed to do. However, values are not really used, so this might be acceptable. It's possible

Re: [PATCH] staging: octeon: Indent with tabs instead of spaces

2020-07-22 Thread Joe Perches
On Wed, 2020-07-22 at 22:19 +0500, Muhammad Usama Anjum wrote: > Remove a coding style error. It makes code more readable. [] > diff --git a/drivers/staging/octeon/ethernet-defines.h > b/drivers/staging/octeon/ethernet-defines.h [] > @@ -27,14 +27,14 @@ > #define REUSE_SKBUFFS_WITHOUT_FREE 1 >

[PATCH] staging: octeon: Indent with tabs instead of spaces

2020-07-22 Thread Muhammad Usama Anjum
Remove a coding style error. It makes code more readable. Signed-off-by: Muhammad Usama Anjum --- drivers/staging/octeon/ethernet-defines.h | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/octeon/ethernet-defines.h

[PATCH] staging: wlan-ng: properly check endpoint types

2020-07-22 Thread Rustam Kovhaev
As syzkaller detected, wlan-ng driver does not do sanity check of endpoints in prism2sta_probe_usb(), add check for xfer direction and type Reported-and-tested-by: syzbot+c2a1fa67c02faa0de...@syzkaller.appspotmail.com Link: https://syzkaller.appspot.com/bug?extid=c2a1fa67c02faa0de723

[PATCH v5 9/9] arm64: dts: rockchip: add isp and sensors for Scarlet

2020-07-22 Thread Helen Koike
From: Eddie Cai Enable ISP and camera sensor ov2685 and ov5695 for Scarlet Chromebook Verified with: make ARCH=arm64 dtbs_check Signed-off-by: Shunqian Zheng Signed-off-by: Eddie Cai Signed-off-by: Tomasz Figa Signed-off-by: Helen Koike --- This patch is based on:

[PATCH v5 8/9] arm64: dts: rockchip: add isp0 node for rk3399

2020-07-22 Thread Helen Koike
From: Shunqian Zheng RK3399 has two ISPs, but only isp0 was tested. Add isp0 node in rk3399 dtsi Verified with: make ARCH=arm64 dtbs_check DT_SCHEMA_FILES=Documentation/devicetree/bindings/media/rockchip-isp1.yaml Signed-off-by: Shunqian Zheng Signed-off-by: Jacob Chen Signed-off-by: Helen

[PATCH v5 7/9] media: MAINTAINERS: rkisp1: add path to dt-bindings

2020-07-22 Thread Helen Koike
The Rockchip ISP bindings was moved out of staging. Update MAINTAINERS file with the new path. Fields sorted according to output of ./scripts/parse-maintainers.pl --input=MAINTAINERS --output=MAINTAINERS --order Signed-off-by: Helen Koike --- V3: - Add line: L:

[PATCH v5 6/9] dt-bindings: media: rkisp1: move rockchip-isp1 bindings out of staging

2020-07-22 Thread Helen Koike
Move rkisp1 bindings to Documentation/devicetree/bindings/media Verified with: make ARCH=arm64 dt_binding_check DT_SCHEMA_FILES=Documentation/devicetree/bindings/media/rockchip-isp1.yaml Signed-off-by: Helen Koike Acked-by: Rob Herring --- .../devicetree/bindings/media/rockchip-isp1.yaml

[PATCH v5 2/9] media: staging: dt-bindings: rkisp1: drop i2c unit address

2020-07-22 Thread Helen Koike
Add missing required items in Rockchip ISP1 dt-bindings example for a complete i2c node. Drop unit address to Fix error: /example-0/parent/i2c@ff16: node has a unit name, but no reg or ranges property Remove unecessary fields for the example. Signed-off-by: Helen Koike --- Changes in v5: -

[PATCH v5 1/9] media: staging: dt-bindings: rkisp1: add missing required nodes

2020-07-22 Thread Helen Koike
Add missing required nodes in json-schema yaml file for Rockchip ISP1 dt-bindings. Signed-off-by: Helen Koike Acked-by: Rob Herring --- Changes in v2: - New patch in the series --- .../devicetree/bindings/media/rockchip-isp1.yaml | 8 1 file changed, 8 insertions(+) diff

[PATCH v5 5/9] media: staging: rkisp1: remove unecessary clocks

2020-07-22 Thread Helen Koike
aclk_isp_wrap is a child of aclk_isp, and hclk_isp_wrap is a child of hclk_isp, thus we can remove parents from the list. Also, for the isp0, we only need the ISP clock, ACLK and HCLK. In the future we'll need a pixel clock for RK3288 and RK3399, and a JPEG clock for RK3288. So with the goal to

[PATCH v5 4/9] media: staging: dt-bindings: rkisp1: drop parent unit address

2020-07-22 Thread Helen Koike
Fix the following error found with make ARCH=arm64 dt_binding_check: Documentation/devicetree/bindings/media/rockchip-isp1.example.dts:24.27-101.11: Warning (unit_address_vs_reg): /example-0/parent@0: node has a unit name, but no reg or ranges property Reported-by: Johan Jonker Signed-off-by:

[PATCH v5 3/9] media: staging: dt-bindings: rkisp1: re-order properties

2020-07-22 Thread Helen Koike
Organize properties order in dt-bindings to move it out of staging. On top: compatible, reg and interrupts. Then alphabetical order, then properties starting with '#'. Signed-off-by: Helen Koike Acked-by: Rob Herring --- V5: - s/binbings/bindings V2: - this is a new patch in the series ---

[PATCH v5 0/9] move Rockchip ISP bindings out of staging / add ISP DT nodes for RK3399

2020-07-22 Thread Helen Koike
Move the bindings out of drivers/staging and place them in Documentation/devicetree/bindings instead. Also, add DT nodes for RK3399 and verify with make ARCH=arm64 dtbs_check and make ARCH=arm64 dt_binding_check. Tested by verifying images streamed from Scarlet Chromebook Changes in v5: - Drop

[PATCH] staging: octeon: Add the license identifier

2020-07-22 Thread Muhammad Usama Anjum
This patch fixes the checkpatch.pl warning: WARNING: Missing or malformed SPDX-License-Identifier tag Add a the SPDX-License-Identifier tag on line 1 Signed-off-by: Muhammad Usama Anjum --- drivers/staging/octeon/octeon-stubs.h | 2 ++ 1 file changed, 2 insertions(+) diff --git

[PATCH] staging: rtl8188eu: Fix an indent coding style issue

2020-07-22 Thread Mrinal Pandey
Only a single tab space is required after the if statement. Fix this issue by running scripts/checkpatch.pl on the file. Signed-off-by: Mrinal Pandey --- drivers/staging/rtl8188eu/core/rtw_recv.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH v3 2/2] media: atomisp: Fix coding style issue - correct multiline comments

2020-07-22 Thread Rahul Gottipati
This fixes some coding style issues of multiline comments to correct a few checkpatch.pl warnings. Signed-off-by: Rahul Gottipati --- Changes in v3: Made changes to keep first line blank in multiline comments. Changes in v2: Distributed changes across 2 patches instead of the

[PATCH v3 1/2] media: atomisp: Fix coding style issue - remove beginning whitespaces

2020-07-22 Thread Rahul Gottipati
This removes whitespaces at the beginning of a few lines to fix some checkpatch.pl warnings. Signed-off-by: Rahul Gottipati --- Changes in v3: Changed style of function headers in response to review comments Changes in v2: Distributed changes across 2 patches instead of the

[PATCH v3 0/2] General coding style clean-up

2020-07-22 Thread Rahul Gottipati
This patchset fixes several checkpatch.pl warnings in atomisp_ioctl.c that have been distributed across 2 patches logically. Rahul Gottipati (2): media: atomisp: Fix coding style issue - remove beginning whitespaces media: atomisp: Fix coding style issue - correct multiline comments

Re: [PATCH v2 1/2] media: atomisp: Fix coding style issue - remove beginning whitespaces

2020-07-22 Thread Mauro Carvalho Chehab
Em Wed, 22 Jul 2020 16:58:31 +0530 Rahul Gottipati escreveu: > This removes whitespaces at the beginning of a few lines to fix > some checkpatch.pl warnings. > > Signed-off-by: Rahul Gottipati > --- > Changes in v2: > Distributed changes across 2 patches instead of the previous 1 > >

Re: [PATCH v2 2/2] media: atomisp: Fix coding style issue - correct multiline comments

2020-07-22 Thread Mauro Carvalho Chehab
Em Wed, 22 Jul 2020 17:00:52 +0530 Rahul Gottipati escreveu: > This fixes some coding style issues of multiline comments to > correct a few checkpatch.pl warnings. > > Signed-off-by: Rahul Gottipati > --- > Changes in v2: > Distributed changes across 2 patches instead of the previous 1.

Re: [PATCH][next][V2] media: allegro: fix potential null dereference on header

2020-07-22 Thread Michael Tretter
On Wed, 22 Jul 2020 14:09:03 +0100, Colin King wrote: > From: Colin Ian King > > The pointer header is an alias to msg and msg is being null checked. > However, if msg is null then header is also null and this can lead to > a null pointer dereference on the assignment type = header->type. Fix >

[PATCH] staging: vchiq: Fix refcounting bug in buffer_from_host()

2020-07-22 Thread Dan Carpenter
If we fail to queue the buffer then it can never be dequeued. This can lead to a forever loop in stop_streaming() when we wait for everything to finish. Fixes: 70ec64ccdaac ("staging: bcm2835-camera: Ensure all buffers are returned on disable") Signed-off-by: Dan Carpenter --- >From static

[PATCH][next][V2] media: allegro: fix potential null dereference on header

2020-07-22 Thread Colin King
From: Colin Ian King The pointer header is an alias to msg and msg is being null checked. However, if msg is null then header is also null and this can lead to a null pointer dereference on the assignment type = header->type. Fix this just using header->type after the null check and removing the

Re: [PATCH] media: allegro: fix an error pointer vs NULL check

2020-07-22 Thread Michael Tretter
On Wed, 22 Jul 2020 15:38:48 +0300, Dan Carpenter wrote: > The allegro_mbox_init() function returns error pointers, it never > returns NULL. > > Fixes: 94dc76560261 ("media: allegro: rework mbox handling") > Signed-off-by: Dan Carpenter Reviewed-by: Michael Tretter > --- >

Re: [PATCH][next] media: allegro: fix potential null dereference on header

2020-07-22 Thread Michael Tretter
On Mon, 20 Jul 2020 17:38:04 +0100, Colin King wrote: > From: Colin Ian King > > The pointer header is an alias to msg and msg is being null checked. > However, if msg is null then header is also null and this can lead to > a null pointer dereference on the assignment type = header->type. Fix >

[PATCH] media: allegro: fix an error pointer vs NULL check

2020-07-22 Thread Dan Carpenter
The allegro_mbox_init() function returns error pointers, it never returns NULL. Fixes: 94dc76560261 ("media: allegro: rework mbox handling") Signed-off-by: Dan Carpenter --- drivers/staging/media/allegro-dvt/allegro-core.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH v2 2/2] media: atomisp: Fix coding style issue - correct multiline comments

2020-07-22 Thread Rahul Gottipati
This fixes some coding style issues of multiline comments to correct a few checkpatch.pl warnings. Signed-off-by: Rahul Gottipati --- Changes in v2: Distributed changes across 2 patches instead of the previous 1. drivers/staging/media/atomisp/pci/atomisp_ioctl.c | 14 +- 1

[PATCH v2 1/2] media: atomisp: Fix coding style issue - remove beginning whitespaces

2020-07-22 Thread Rahul Gottipati
This removes whitespaces at the beginning of a few lines to fix some checkpatch.pl warnings. Signed-off-by: Rahul Gottipati --- Changes in v2: Distributed changes across 2 patches instead of the previous 1 drivers/staging/media/atomisp/pci/atomisp_ioctl.c | 6 +++--- 1 file changed, 3

[PATCH v2 0/2] General coding style clean up

2020-07-22 Thread Rahul Gottipati
This patchset fixes several checkpatch.pl warnings in atomisp_ioctl.c that have been distributed across 2 patches logically. Rahul Gottipati (2): media: atomisp: Fix coding style issue - remove beginning whitespaces media: atomisp: Fix coding style issue - correct multiline comments

Re: [PATCH for v5.9] media: omap: Replace HTTP links with HTTPS ones

2020-07-22 Thread Laurent Pinchart
Hi Alexander, Thank you for the patch. On Sun, Jul 19, 2020 at 01:21:33PM +0200, Alexander A. Klimov wrote: > Rationale: > Reduces attack surface on kernel devs opening the links for MITM > as HTTPS traffic is much harder to manipulate. > > Deterministic algorithm: > For each file: > If not

[PATCH] staging: greybus: gpio: Use irqchip template

2020-07-22 Thread Linus Walleij
This makes the driver use the irqchip template to assign properties to the gpio_irq_chip instead of using the explicit calls to gpiochip_irqchip_add(). The irqchip is instead added while adding the gpiochip. Cc: Nishad Kamdar Cc: Johan Hovold Signed-off-by: Linus Walleij ---

Re: [PATCH] staging: gs_fpgaboot: get bus width input

2020-07-22 Thread Greg KH
On Wed, Jul 22, 2020 at 12:11:22PM +0530, Rahul Gottipati wrote: > On Wed, Jul 22, 2020 at 08:32:54AM +0200, Greg KH wrote: > > On Wed, Jul 22, 2020 at 11:57:11AM +0530, Rahul Gottipati wrote: > > > On Tue, Jul 21, 2020 at 08:05:33PM +0200, Greg KH wrote: > > > > On Tue, Jul 21, 2020 at 11:32:03PM

Re: [PATCH] staging: gs_fpgaboot: get bus width input

2020-07-22 Thread Rahul Gottipati
On Wed, Jul 22, 2020 at 08:32:54AM +0200, Greg KH wrote: > On Wed, Jul 22, 2020 at 11:57:11AM +0530, Rahul Gottipati wrote: > > On Tue, Jul 21, 2020 at 08:05:33PM +0200, Greg KH wrote: > > > On Tue, Jul 21, 2020 at 11:32:03PM +0530, Rahul Gottipati wrote: > > > > This adds a module parameter to

Re: [PATCH] staging: gs_fpgaboot: get bus width input

2020-07-22 Thread Greg KH
On Wed, Jul 22, 2020 at 11:57:11AM +0530, Rahul Gottipati wrote: > On Tue, Jul 21, 2020 at 08:05:33PM +0200, Greg KH wrote: > > On Tue, Jul 21, 2020 at 11:32:03PM +0530, Rahul Gottipati wrote: > > > This adds a module parameter to get the program bus width as an > > > input rather than hardcoding

Re: [PATCH] staging: gs_fpgaboot: get bus width input

2020-07-22 Thread Rahul Gottipati
On Tue, Jul 21, 2020 at 08:05:33PM +0200, Greg KH wrote: > On Tue, Jul 21, 2020 at 11:32:03PM +0530, Rahul Gottipati wrote: > > This adds a module parameter to get the program bus width as an > > input rather than hardcoding it, and checks off a TODO item. > > Ick, no, module parameters are from