[PATCH] staging:fwserial:Fix parentheses alignment in fwserial.c

2018-08-29 Thread Nicholas Krause
Fix a checkpatch warning for the file, fwserial.c that warns about alignment between parentheses and the line belows code not being properly aligned with each other. Signed-off-by: Nicholas Krause --- drivers/staging/fwserial/fwserial.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion

[PATCH] staging:ks7010:Fix warning about coding style spacing issue around asterisk in ks_wlan_net.c

2016-08-31 Thread Nicholas Krause
This fixes warning around a asterisk used in ks_wlan_net.c for the define statement used for this driver's transmit queue timeout value as defined by the marco, TX_TIMEOUT. Signed-off-by: Nicholas Krause <xerofo...@gmail.com> --- drivers/staging/ks7010/ks_wlan_net.c | 2 +- 1 file chan

Re: [PATCH] staging:rtl8192e: Change printk statements in rtllib_tx.c to use netdev_dev

2015-04-03 Thread Nicholas Krause
On April 3, 2015 1:05:59 PM EDT, Greg KH gre...@linuxfoundation.org wrote: On Fri, Apr 03, 2015 at 11:49:57AM -0400, Nicholas Krause wrote: On April 3, 2015 5:19:55 AM EDT, Dan Carpenter dan.carpen...@oracle.com wrote: @@ -582,7 +582,7 @@ int rtllib_xmit_inter(struct sk_buff *skb

Re: [PATCH] staging:rtl8192e: Change printk statements in rtllib_tx.c to use netdev_dev

2015-04-03 Thread Nicholas Krause
On April 3, 2015 2:30:01 PM EDT, Greg KH gre...@linuxfoundation.org wrote: On Fri, Apr 03, 2015 at 02:05:11PM -0400, Nicholas Krause wrote: On April 3, 2015 1:05:59 PM EDT, Greg KH gre...@linuxfoundation.org wrote: On Fri, Apr 03, 2015 at 11:49:57AM -0400, Nicholas Krause wrote

[PATCH] staging:rtl8192e: Change printk statements in rtllib_tx.c to use netdev_dev

2015-04-02 Thread Nicholas Krause
This changes the remaining printk statements with the log level of KERN_INFO to use the more appropriate netdev_info for print messages related to code using or part of the networking subsystem. Further more this was found by running checkpatch.pl on the file, rtllib_tx.c. Signed-off-by: Nicholas

Re: [PATCH 1/2] octeon-usb:Fix coding style issue with space between function name and opening bracket

2015-03-24 Thread Nicholas Krause
On March 24, 2015 3:08:09 AM EDT, Dan Carpenter dan.carpen...@oracle.com wrote: On Mon, Mar 23, 2015 at 05:08:52PM -0400, Nicholas Krause wrote: On March 23, 2015 9:06:26 AM EDT, Dan Carpenter dan.carpen...@oracle.com wrote: On Mon, Mar 23, 2015 at 08:53:19AM -0400, Nicholas Krause wrote

Re: [PATCH 1/2] octeon-usb:Fix coding style issue with space between function name and opening bracket

2015-03-23 Thread Nicholas Krause
On March 23, 2015 6:40:06 AM EDT, Dan Carpenter dan.carpen...@oracle.com wrote: On Sun, Mar 22, 2015 at 08:04:35PM -0400, Nicholas Krause wrote: Fixes the checkpath.pl error where the opening bracket has a unneeded space between it and the function name for a if statement in the marco

Re: [PATCH 1/2] octeon-usb:Fix coding style issue with space between function name and opening bracket

2015-03-23 Thread Nicholas Krause
On March 23, 2015 9:06:26 AM EDT, Dan Carpenter dan.carpen...@oracle.com wrote: On Mon, Mar 23, 2015 at 08:53:19AM -0400, Nicholas Krause wrote: On March 23, 2015 6:40:06 AM EDT, Dan Carpenter dan.carpen...@oracle.com wrote: On Sun, Mar 22, 2015 at 08:04:35PM -0400, Nicholas Krause wrote

[PATCH 2/2] octeon:Make of_device_id structure const in octeon-hcd.c

2015-03-22 Thread Nicholas Krause
This fixes the checkpatch.pl warning about recommending the of_device_id structure,octeon_usb_match to be defined const in octeon-hcd.c Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/octeon-usb/octeon-hcd.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH 1/2] octeon-usb:Fix coding style issue with space between function name and opening bracket

2015-03-22 Thread Nicholas Krause
Fixes the checkpath.pl error where the opening bracket has a unneeded space between it and the function name for a if statement in the marco,VMX_WAIT_FOR_FIELD32. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/octeon-usb/octeon-hcd.c | 2 +- 1 file changed, 1 insertion

[PATCH RESEND] staging:fbtft:Fix build warnings for incorrently using %d for size_t variables in dev_err statements

2015-03-10 Thread Nicholas Krause
Fixes the build warnings for using %d for a variable of type size_t in dev_err statements for the functions,fbtft_read_spi and fbtft_write_spi_emulate_9 respectfully by changing both dev_error calls to use the correct format specifier,zu for size_t instead. Signed-off-by: Nicholas Krause

[PATCHv2 2/2] rtl8192u:Remove commented declartions of the structure type, _STA_QOS in ieee80211.h and r8192U_dm.c

2015-03-06 Thread Nicholas Krause
This removes the commented declarations of the structure type, _STA_QOS due to us no longer having this structure declartion having now been removed from the header file,rtl819x_Qos.h due to no declartions of this type present anymore. Signed-off-by: Nicholas Krause xerofo...@gmail.com

[PATCHv2 1/2] iee80211:Remove no longer required strutucre defintion, _STA_QOS in rtl819x_Qos.h

2015-03-06 Thread Nicholas Krause
Removes the no longer required structure definition,_STA_QOS due to no functions using any structures of this type anymore. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 48 1 file changed, 48 deletions(-) diff

[PATCH] iee80211:Remove no longer required strutucre defintion, _STA_QOS in rtl819x_Qos.h

2015-03-06 Thread Nicholas Krause
Removes the no longer required structure definition,_STA_QOS due to no functions using any structures of this type anymore. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 48 1 file changed, 48 deletions(-) diff

Re: [PATCH] iee80211:Remove no longer required strutucre defintion, _STA_QOS in rtl819x_Qos.h

2015-03-06 Thread Nicholas Krause
# On March 6, 2015 5:13:09 PM EST, Giedrius Statkevičius giedrius.statkevic...@gmail.com wrote: On 2015.03.06 23:20, Nicholas Krause wrote: Removes the no longer required structure definition,_STA_QOS due to no functions using any structures of this type anymore. Signed-off-by: Nicholas

Re: [PATCH] comedi: Change error return code for if statement in the function, cb_pcimdas_ai_rinsn

2015-02-26 Thread Nicholas Krause
On February 26, 2015 6:09:56 AM EST, Ian Abbott abbo...@mev.co.uk wrote: On 25/02/15 21:37, Nicholas Krause wrote: On February 25, 2015 1:03:14 PM EST, Hartley Sweeten hartl...@visionengravers.com wrote: On Tuesday, February 24, 2015 9:13 PM, Nicholas Krause wrote: This changes us using

RE: [PATCH] comedi: Change error return code for if statement in the function, cb_pcimdas_ai_rinsn

2015-02-25 Thread Nicholas Krause
On February 25, 2015 1:03:14 PM EST, Hartley Sweeten hartl...@visionengravers.com wrote: On Tuesday, February 24, 2015 9:13 PM, Nicholas Krause wrote: This changes us using the incorrect error,-ETIMEOUT when checking if the channel we are allocating to on the device structure pointer passed

[PATCH] comedi: Change error return code for if statement in the function, cb_pcimdas_ai_rinsn

2015-02-24 Thread Nicholas Krause
-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/comedi/drivers/cb_pcimdas.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drivers/cb_pcimdas.c b/drivers/staging/comedi/drivers/cb_pcimdas.c index 70dd2c9..d91a6f3 100644 --- a/drivers/staging

[PATCH] staging:fbtft:Fix build warnings for incorrently using %d for size_t variables in dev_err statements

2015-02-16 Thread Nicholas Krause
Fixes the build warnings for using %d for a variable of type size_t in dev_err statements for the functions,fbtft_read_spi and fbtft_write_spi_emulate_9 respectfully by changing both dev_error calls to use the correct format specifier for size_t instead. Signed-off-by: Nicholas Krause xerofo

[PATCH 1/2] drivers:staging:rtl8192u: Change all C99 comments to standard style C comments in rtl819x_QOS.h

2014-12-25 Thread Nicholas Krause
This changes all C99 comments found in rtl819x_QOS.h to standard C style comments as found by running checkpatch on this file. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 352 +++ 1 file changed, 176 insertions

[PATCH] staging wlan-ng: Add missing a blank line after declarations

2014-09-15 Thread Nicholas Krause
Fixing trivial checkpatch warnings about missing line after declarations. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- Tested by compilation only. drivers/staging/wlan-ng/hfa384x.h | 3 +++ 1 file changed, 3 insertions(+) diff --git a/drivers/staging/wlan-ng/hfa384x.h b/drivers

[PATCH] staging wlan-ng: Add missing a blank line after declarations

2014-09-15 Thread Nicholas Krause
Fixing trivial checkpatch warnings about missing line after declarations. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- Tested by compilation only. drivers/staging/wlan-ng/hfa384x.h | 3 +++ 1 file changed, 3 insertions(+) diff --git a/drivers/staging/wlan-ng/hfa384x.h b/drivers

[PATCH] staging: Check against NULL in fw_download_code

2014-08-11 Thread Nicholas Krause
I am fixing the bug entry , https://bugzilla.kernel.org/show_bug.cgi?id=60461. This entry states that we are not checking the skb allocated in fw_download_code and after checking I fixed it to check for the NULL value before using the allocate skb. Signed-off-by: Nicholas Krause xerofo

[PATCHv2] staging: Check against NULL in fw_download_code

2014-08-11 Thread Nicholas Krause
I am fixing the bug entry , https://bugzilla.kernel.org/show_bug.cgi?id=60461. This entry states that we are not checking the skb allocated in fw_download_code and after checking I fixed it to check for the NULL value before using the allocate skb. Signed-off-by: Nicholas Krause xerofo

[PATCHv3] staging: Check for Null allocated skb in fw_download_code

2014-08-11 Thread Nicholas Krause
. In additon I removed the variable, rt_status as it's easier to read this function's return value with just true or false and rt status is a unneeded variable for the bool return of this function. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c

[PATCH] staging: Remove checkpatch errors in ion.c for android staging

2014-07-23 Thread Nicholas Krause
allocated in ion_dma_buf_kmap. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/android/ion/ion.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/staging/android/ion/ion.c b/drivers/staging/android/ion/ion.c index 389b8f6..934d55d 100644 --- a/drivers/staging/android

[PATCH] staging: Change kzalloc to kcalloc

2014-07-23 Thread Nicholas Krause
This changes the call to kzalloc to kcalloc in ion_dummy_driver for allocating the heap. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/android/ion/ion_dummy_driver.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/staging/android/ion

[PATCH] staging: Remove checkpatch error from ion.c

2014-07-23 Thread Nicholas Krause
This patch removes a checkpatch error by adding a line below the definitions of the character array buf and the pointer path. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/android/ion/ion.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/android/ion

[PATCH] staging: Add blank lines in sw_sync.c

2014-07-23 Thread Nicholas Krause
This adds two blank lines as stated by checkpatch before lines, 100 and 159 respectively. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/android/sw_sync.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/staging/android/sw_sync.c b/drivers/staging/android

[PATCH] staging: Fix space issues for header of headers.h

2014-07-23 Thread Nicholas Krause
This patch fixes the space errors checkpatch gives on this file for the header of this file. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/bcm/headers.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/bcm/headers.h b/drivers/staging

[PATCH] staging: Join lines in IntefaceIdleMode.c

2014-07-23 Thread Nicholas Krause
This joins two lines that need to be joined as this improves the coding style and makes it much easier to read. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/bcm/InterfaceIdleMode.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/bcm

[PATCH] staging: Remove checkpatch errors in InterfaceMarcos.h

2014-07-23 Thread Nicholas Krause
This removes the two errors I get when running checkpatch on this file. The first being not to use C99 comments and the second to remove spacing issues with the define statement on line 7. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/bcm/InterfaceMacros.h | 4 ++-- 1

[PATCH] staging: Fix a Fix me in tranzport.c

2014-07-18 Thread Nicholas Krause
This patch add a atomic lock in usb_tranzport_usb for preventing a tiny race in this function. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/frontier/tranzport.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/frontier/tranzport.c b

[PATCH] staging: rtl8192 Check for Null return from dev_skb_alloc

2014-06-20 Thread Nicholas Krause
Checks for Null return from dev_skb_alloc if it returns Null, fw_download returns false. Otherwise it returns true.Also removed rt_status due to returning true of false directly. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c | 7

[PATCH] staging:rtl8821ae: rewrite legacy wifi check in halbcoutsrc

2014-06-20 Thread Nicholas Krause
Rewrites the wireless check for legacy checking in function halbtc_legacy to check for both Mode A and B. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8821ae/btcoexist/halbtcoutsrc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging

[PATCH] Checks if dev_skb_alloc returns Null in function,

2014-06-19 Thread Nicholas Krause
--- drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c index 1a95d1f..d8a9427 100644 ---

[PATCH] staging: rtl8192e: check return value of dev_skb_alloc

2014-06-19 Thread Nicholas Krause
--- drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c index 1a95d1f..d8a9427 100644 ---

[PATCH] staging: rtl8192 Check for Null return from dev_skb_alloc

2014-06-19 Thread Nicholas Krause
Checks for Null return from dev_skb_alloc if it returns Null, fw_download returns false. Otherwise it returns true.Also removed rt_status due to returning true of false directly. Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c | 7

[PATCH] Checks for Null return of skb_alloc in function fw_download_code

2014-06-18 Thread Nicholas Krause
Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c index

[PATCH] Fixes no Null check of dev_skb_alloc in fw_download_code

2014-06-18 Thread Nicholas Krause
Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c | 4 1 file changed, 4 insertions(+) diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c index 1a95d1f..1a90546

[PATCH] Fixes no Null check of dev_skb_alloc in fw_download_code

2014-06-18 Thread Nicholas Krause
Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c | 4 1 file changed, 4 insertions(+) diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c index 1a95d1f..1a90546

[PATCHv2]staging:rtl8192e:check return value of dev_skb_alloc

2014-06-18 Thread Nicholas Krause
diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c index 11e915e..fde17ff 100644 --- a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c +++ b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c @@ -62,12 +62,15 @@ static bool

[PATCH 1/2] Fixes no Null check of dev_skb_alloc in fw_download_code

2014-06-18 Thread Nicholas Krause
diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c index 1a95d1f..1a90546 100644 --- a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c +++ b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c @@ -61,6 +61,10 @@ static bool

[PATCHv4]staging:rtl8192e: check return value of dev_skb_alloc

2014-06-18 Thread Nicholas Krause
diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c index 1a95d1f..1a90546 100644 --- a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c +++ b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c @@ -61,6 +61,10 @@ static bool

[PATCHv2] Check if skb_alloc returns Null in function fw_download_code

2014-06-17 Thread Nicholas Krause
Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c index 1a95d1f..11e915e 100644

[PATCHv2] Check if skb_alloc returns Null in function fw_download_code

2014-06-17 Thread Nicholas Krause
Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c index 1a95d1f..11e915e 100644

[PATCHv2] Fixes function fw_download_code to check for Null return from dev_skb_alloc

2014-06-17 Thread Nicholas Krause
Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c index

[PATCH] Check if skb_alloc returns Null in function fw_download_code

2014-06-16 Thread Nicholas Krause
Signed-off-by: Nicholas Krause xerofo...@gmail.com --- drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_firmware.c index 1a95d1f..11e915e 100644