On Mon, Dec 21, 2015 at 03:48:57PM -0800, Greg Kroah-Hartman wrote:
>
> That's 6 different things, shouldn't this be 6 different patches?
>
Not really. The patch could be described as just "change from using one
exit label to using several." Markus has sent a number of these patches
and I am C
On Mon, Dec 21, 2015 at 12:46:51AM +0300, Alexey Khoroshilov wrote:
> diff --git a/drivers/staging/wilc1000/wilc_wlan.c
> b/drivers/staging/wilc1000/wilc_wlan.c
> index a73e99f..4b7c8e9 100644
> --- a/drivers/staging/wilc1000/wilc_wlan.c
> +++ b/drivers/staging/wilc1000/wilc_wlan.c
> @@ -1459,15 +
On 22/12/15 05:41, maomao xu wrote:
Fix up block comments to make a trailing */ on a separate line
Signed-off-by: maomao xu
---
drivers/staging/comedi/comedi.h |3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/comedi.h b/drivers/staging/comedi/co
This patch renames some variables for better readability.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/aim-cdev/cdev.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/m
This patch unifies variable types to get less castings.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/aim-cdev/cdev.c |8 +++-
1 file changed, 3 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/most/aim-cd
This patchset is needed to have open issues of the MOST driver fixed
and the code cleaned up.
Christian Gromm (28):
staging: most: remove unnecessary keep_mbo variable
staging: most: rename variables
staging: most: simplify expression
staging: most: unify types
staging: most: use min_t
This patch increments mbo_offs by the number of bytes that have
been copied and resets it in case a complete mbo has been transferred
to user buffer.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/aim-cdev/cdev.c |5 ++---
The MBO pointer stacked_mbo and the boolean variable keep_mbo are
always changed together and therefore provide the same information.
This patch removes keep_mbo and uses stacked_mbo instead.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers
This patch makes use of functions readl and writel instead of
the __raw_* variants.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/hdm-dim2/dim2_hdm.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a
This patch replaces min with min_t.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/aim-cdev/cdev.c |4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/most/aim-cdev/cdev.c
b/drivers/stag
This patch replaces the ternary ?-operator with a way simpler subtraction.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/aim-cdev/cdev.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/
This patch fixes race conditions that might emerge from functions
aim_open, aim_close, aim_read, aim_write and aim_disconnect_channel
within module cdev.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/aim-cdev/cdev.c | 89 +
This patch fixes a potential MBO leak in case function aim_read()
exits right after the MBO has been fetched from kfifo and before
it has been saved to the variable stacked_mbo.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/
This patch adds two missing calls to function ida_simpel_remove.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/mostcore/core.c |2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/staging/most/mostcore/core.c
b/
This patch removes the function destroy_most_c_obj and executes its code
within function destroy_most_inst_obj.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/mostcore/core.c | 38 +-
1 file
This patch removes the unnecessary reference conter mod_ref.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/mostcore/core.c | 13 +
1 file changed, 1 insertion(+), 12 deletions(-)
diff --git a/drivers/staging/m
This patch prevents the cdev module from rousing the channel wait queue in
case the channel is about to be closed. It is safe to do so, because the
application can not be waiting within read or write and at the same time
be calling close.
Signed-off-by: Christian Gromm
---
This patch has been res
This patch makes function store_add_link initialize the pointer to an AIM
right before the channel is probed. It is needed, the AIM may already call
most_start_channel while probe_channel is still running. At this point the
pointer to the AIM must not be NULL.
Signed-off-by: Christian Gromm
---
T
This patch invokes AIM's disconnect_channel callback before the
corresponding pointers are re-initialized to NULL.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/mostcore/core.c |4 ++--
1 file changed, 2 insertions(+), 2
This patch changes the type of the access reference from atomit_t to int.
It is needed, because the reference variable is secured by synchronization
locks and does not need to be atomic anymore.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
driv
This patch removes unnecessary code to destroy channel objects. It is
needed, because function most_stop_channel, which is indirectly
triggered by function most_deregister_interface, already destroys the
channels.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kro
This patch removes mutex from code that doesn't need any locking.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/mostcore/core.c |3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/most/mo
This patch renames the variable 'channel' to 'c'. This is needed to have
the code look more homogeneous and to prevent format violations.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/aim-cdev/cdev.c | 216 +
This patch straightens and rearranges the code of function aim_write()
of module aim-cdev.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
v2: Implemented and followed advice of Dan Carpenter to keep common
error handling at the end of the functio
This patch adds a counter for dropped packets. It needed for statistical
analysis.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
v2: change type of skb_len to unsigned int. This has been demanded by
Dan Carpenter.
drivers/staging/most/aim-netw
This patch moves the code that disconnects linked channels. It is needed
to have cleaning things up done right.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/mostcore/core.c | 24 +++-
1 file changed, 1
This patch removes the second forwared declaration of struct most_aim.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/aim-cdev/cdev.c |2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/most/aim-cdev/cdev.
This patch makes use of kfifo_peek and kfifo_skip, which renders the
variable stacked_mbo useless. It is therefore removed.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/aim-cdev/cdev.c | 16 +++-
1 file change
This patch fixes the function channel_has_mbo that delivers the false
information in case two AIMs are using the same tx channel.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/aim-cdev/cdev.c | 12 ++--
drivers
This patch encapsulates shared code. It therefore creates the new functions
stop_channel and destroy_cdev.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/aim-cdev/cdev.c | 55 ++
1 file chang
This patch removes the atomic tainted flag. It is needed to get rid of
logical overhead.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/mostcore/core.c | 33 +
1 file changed, 1 insertion(+),
This patch removes the mutexes stop_task_mutex and deregister mutex,
since they can safely be left out.
Signed-off-by: Christian Gromm
---
This patch has been resent on behalf of Greg Kroah-Hartman
drivers/staging/most/mostcore/core.c |9 -
1 file changed, 9 deletions(-)
diff --g
From: Hari Prasath Gujulan Elango
Replace the pre-defined macro signifying the ethernet protocol type
defined in the kernel headers instead of the numerical constant
Signed-off-by: Hari Prasath Gujulan Elango
---
drivers/staging/wilc1000/wilc_wlan.c | 2 +-
1 file changed, 1 insertion(+), 1 de
On Thu, Dec 17, 2015 at 08:30:38PM +, Okash Khawaja wrote:
> This patch fixes following compiler warning:
>
> drivers/staging/rtl8192u/ieee80211/ieee80211_rx.c: In function
> ‘RxReorderIndicatePacket’:
> drivers/staging/rtl8192u/ieee80211/ieee80211_rx.c:758:1: warning: the
> frame size of 1064
On Tue, Dec 22, 2015 at 5:14 AM, Greg Kroah-Hartman
wrote:
> On Wed, Dec 09, 2015 at 10:38:13PM +0530, Niranjan Dighe wrote:
>> The third argument to function kportal_memhog_alloc is expected to
>> be gfp_t whereas the actual argument was unsigned int. Fix this by
>> explicitly typecasting to gfp_
Looks ok.
Greg is working through his inbox. It will take a little while for him
to get to your patch. Be patient.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/dri
From: Markus Elfring
Date: Tue, 22 Dec 2015 15:05:16 +0100
The return type "u32" was used by the slic_card_locate() function
even though it will eventually return a negative error code.
Improve this implementation detail by using the type "int" instead.
This issue was detected by using the Cocci
On Tue, Dec 22, 2015 at 06:35:21PM +0530, Niranjan Dighe wrote:
> On Tue, Dec 22, 2015 at 5:14 AM, Greg Kroah-Hartman
> wrote:
> > On Wed, Dec 09, 2015 at 10:38:13PM +0530, Niranjan Dighe wrote:
> >> The third argument to function kportal_memhog_alloc is expected to
> >> be gfp_t whereas the actua
Use to_spi_device() instead of open-coding it.
Signed-off-by: Geliang Tang
---
drivers/staging/fbtft/fbtft_device.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fbtft/fbtft_device.c
b/drivers/staging/fbtft/fbtft_device.c
index 071f79b..55a7307 100644
--- a
If hif_read_reg() or hif_write_reg() fail in wilc_wlan_cleanup(),
it calls release_bus() and continues execution. But it leads to double
release_bus() call that means double unlock of g_linux_wlan->hif_cs mutex.
Found by Linux Driver Verification project (linuxtesting.org).
Signed-off-by: Alexey
On Mon, Dec 21, 2015 at 05:01:48PM -0800, gre...@linuxfoundation.org wrote:
> On Mon, Dec 21, 2015 at 07:19:43PM -0500, ira.weiny wrote:
> > On Mon, Dec 21, 2015 at 02:02:35PM -0800, gre...@linuxfoundation.org wrote:
> > > On Mon, Dec 21, 2015 at 01:12:14AM -0500, ira.weiny wrote:
> > > > Greg, Dou
Only wake tx queue when driver queue is back within bounds.
The logic here was just reenabling the queue when any buffers had been
freed. the queue was stopped whenever the length exceeded 1000
(MAX_OUT_QUEUE_DEPTH), but then was essentially immediately started again.
On a congested link, the que
On 2015/12/22, 06:05, "Niranjan Dighe" wrote:
>On Tue, Dec 22, 2015 at 5:14 AM, Greg Kroah-Hartman
> wrote:
>> On Wed, Dec 09, 2015 at 10:38:13PM +0530, Niranjan Dighe wrote:
>>> The third argument to function kportal_memhog_alloc is expected to
>>> be gfp_t whereas the actual argument was unsign
CC [M] drivers/staging/lustre/lustre/libcfs/module.o
drivers/staging/lustre/lustre/libcfs/module.c: In function
'lustre_insert_debugfs':
drivers/staging/lustre/lustre/libcfs/module.c:670:17: warning: variable 'entry'
set but not used [-Wunused-but-set-variable]
struct dentry *entry;
drivers/staging/lustre/lustre/fid/../include/lustre_cfg.h: In function
'lustre_cfg_free':
drivers/staging/lustre/lustre/fid/../include/lustre_cfg.h:253:6: warning:
variable 'len' set but not used [-Wunused-but-set-variable]
int len;
Yep, we're just gonna call kfree, no need to calculate len. B
Start of a batch series to clean up the Lustre tree. Other people have
done some sparse and checkpatch cleanups, but I found a bunch of
stuff building with W=1. There's probably more, but this was the
really low-hanging obvious fruit.
Valdis Kletnieks (6):
drivers/staging/lustre: Silence warning
Clean up another case of the compiler remininding the programmer they
are an idiot:
drivers/staging/lustre/lustre/ptlrpc/sec_bulk.c:308:34: warning: comparison of
unsigned expression >= 0 is always true [-Wtype-limits]
LASSERT(page_pools.epp_waitqlen >= 0);
Just lose the assert, and save a pag
drivers/staging/lustre/lustre/fid/lproc_fid.c: In function
'ldebugfs_fid_write_common':
drivers/staging/lustre/lustre/fid/lproc_fid.c:67:6: warning: variable 'rc' set
but not used [-Wunused-but-set-variable]
int rc;
We fix it by *using* the return code to help bulletproof it. It says it's
tes
Writing asserts for almost-never-can-happen things can be valuable.
Writing an assert that tests that an "unsigned int" hasn't gone negative
isn't.
And it generates an *ugly* message:
drivers/staging/lustre/lustre/llite/rw.c:763:20: warning: comparison of
unsigned expression >= 0 is always true
Low-hanging fruit first:
CC [M] drivers/staging/lustre/lustre/fid/fid_request.o
In file included from
drivers/staging/lustre/lustre/fid/../include/lustre_net.h:66:0,
from
drivers/staging/lustre/lustre/fid/../include/lustre_lib.h:64,
from drivers/staging/lustr
On Tue, Dec 22, 2015 at 02:15:08PM -0500, ira.weiny wrote:
> On Mon, Dec 21, 2015 at 05:01:48PM -0800, gre...@linuxfoundation.org wrote:
> > On Mon, Dec 21, 2015 at 07:19:43PM -0500, ira.weiny wrote:
> > > On Mon, Dec 21, 2015 at 02:02:35PM -0800, gre...@linuxfoundation.org
> > > wrote:
> > > > On
wilc_sdio_init return always 1. It is needless, so just remove it and it's
related codes also.
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/wilc_sdio.c | 12
1 file changed, 12 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_sdio.c
b/drivers/staging/wilc1000/wilc_s
Dear Greg
I have sent my first patch (https://lkml.org/lkml/2015/11/18/239) to
linux-next tree.But I never received anything about it.So I sent it
again. You say "Doesn't apply to my tree :(".but it can be apply to
least linux-next branch .
I make n new patch and send it.I receive
review(https://
On 12/22/2015 09:27 PM, gre...@linuxfoundation.org wrote:
> On Tue, Dec 22, 2015 at 02:15:08PM -0500, ira.weiny wrote:
>> On Mon, Dec 21, 2015 at 05:01:48PM -0800, gre...@linuxfoundation.org wrote:
>>> On Mon, Dec 21, 2015 at 07:19:43PM -0500, ira.weiny wrote:
On Mon, Dec 21, 2015 at 02:02:35P
On Wed, Dec 23, 2015 at 10:51:11AM +0800, maoma king wrote:
> Dear Greg
> I have sent my first patch (https://lkml.org/lkml/2015/11/18/239) to
> linux-next tree.But I never received anything about it.So I sent it
> again. You say "Doesn't apply to my tree :(".but it can be apply to
> least linux-
On Wed, Dec 23, 2015 at 3:34 AM, Dilger, Andreas
wrote:
> On 2015/12/22, 06:05, "Niranjan Dighe" wrote:
>
>>On Tue, Dec 22, 2015 at 5:14 AM, Greg Kroah-Hartman
>> wrote:
>>> On Wed, Dec 09, 2015 at 10:38:13PM +0530, Niranjan Dighe wrote:
The third argument to function kportal_memhog_alloc is
56 matches
Mail list logo