[PATCH 1/1] scsi: storvsc: Fix a build issue reported by kbuild test robot

2016-02-26 Thread K. Y. Srinivasan
tree:

[PATCH 7/8] Drivers: hv: vmbus: Support handling messages on multiple CPUs

2016-02-26 Thread K. Y. Srinivasan
Starting with Windows 2012 R2, message inteerupts can be delivered on any VCPU in the guest. Support this functionality. Signed-off-by: K. Y. Srinivasan --- drivers/hv/hv.c | 10 ++ drivers/hv/hyperv_vmbus.h |4 +++- drivers/hv/vmbus_drv.c| 10

[PATCH 1/8] Drivers: hv: vmbus: don't loose HVMSG_TIMER_EXPIRED messages

2016-02-26 Thread K. Y. Srinivasan
From: Vitaly Kuznetsov We must handle HVMSG_TIMER_EXPIRED messages in the interrupt context and we offload all the rest to vmbus_on_msg_dpc() tasklet. This functions loops to see if there are new messages pending. In case we'll ever see HVMSG_TIMER_EXPIRED message there

[PATCH 2/8] Drivers: hv: vmbus: avoid wait_for_completion() on crash

2016-02-26 Thread K. Y. Srinivasan
From: Vitaly Kuznetsov wait_for_completion() may sleep, it enables interrupts and this is something we really want to avoid on crashes because interrupt handlers can cause other crashes. Switch to the recently introduced vmbus_wait_for_unload() doing busy wait instead.

[PATCH 4/8] Drivers: hv: vmbus: avoid unneeded compiler optimizations in vmbus_wait_for_unload()

2016-02-26 Thread K. Y. Srinivasan
From: Vitaly Kuznetsov Message header is modified by the hypervisor and we read it in a loop, we need to prevent compilers from optimizing accesses. There are no such optimizations at this moment, this is just a future proof. Suggested-by: Radim Krcmar

[PATCH 8/8] Drivers: hv: vmbus: Support kexec on ws2012 r2 and above

2016-02-26 Thread K. Y. Srinivasan
From: Alex Ng WS2012 R2 and above hosts can support kexec in that thay can support reconnecting to the host (as would be needed in the kexec path) on any CPU. Enable this. Pre ws2012 r2 hosts don't have this ability and consequently cannot support kexec. Signed-off-by:

[PATCH 6/8] Drivers: hv: utils: Remove util transport handler from list if registration fails

2016-02-26 Thread K. Y. Srinivasan
From: Alex Ng If util transport fails to initialize for any reason, the list of transport handlers may become corrupted due to freeing the transport handler without removing it from the list. Fix this by cleaning it up from the list. Signed-off-by: Alex Ng

[PATCH 5/8] Drivers: hv: util: Pass the channel information during the init call

2016-02-26 Thread K. Y. Srinivasan
Pass the channel information to the util drivers that need to defer reading the channel while they are processing a request. This would address the following issue reported by Vitaly: Commit 3cace4a61610 ("Drivers: hv: utils: run polling callback always in interrupt context") removed direct

[PATCH 0/8] Drivers: hv: Miscellaneous fixes

2016-02-26 Thread K. Y. Srinivasan
Some miscellaneous fixes and cleanup. Alex Ng (2): Drivers: hv: utils: Remove util transport handler from list if registration fails Drivers: hv: vmbus: Support kexec on ws2012 r2 and above K. Y. Srinivasan (2): Drivers: hv: util: Pass the channel information during the init call

[PATCH v3 1/1] staging: ion: debugfs invalid gfp mask

2016-02-26 Thread Derek Yerger
From drivers/staging/android TODO file - sparse errors. The current code attempts assignment of -1 to an unsigned type. Note that in a downstream function ion_page_pool_shrink this mask is only ever evaluated against __GFP_HIGHMEM (drivers/staging/android/ion/ion_page_pool.c, line 125).

Re: [PATCH v3 48/52] mtd: nand: vf610: switch to mtd_ooblayout_ops

2016-02-26 Thread Boris Brezillon
Hi Stephan, On Fri, 26 Feb 2016 11:43:46 -0800 Stefan Agner wrote: > Hi Boris, > > On 2016-02-25 16:57, Boris Brezillon wrote: > > Implementing the mtd_ooblayout_ops interface is the new way of exposing > > ECC/OOB layout to MTD users. > > > > Signed-off-by: Boris Brezillon

[PATCH 3/8] Drivers: hv: vmbus: remove code duplication in message handling

2016-02-26 Thread K. Y. Srinivasan
From: Vitaly Kuznetsov We have 3 functions dealing with messages and they all implement the same logic to finalize reads, move it to vmbus_signal_eom(). Suggested-by: Radim Krcmar Signed-off-by: Vitaly Kuznetsov Reviewed-by: Radim

Re: [PATCH 1/1] scsi: storvsc: Fix a build issue reported by kbuild test robot

2016-02-26 Thread James Bottomley
On Fri, 2016-02-26 at 15:45 -0800, K. Y. Srinivasan wrote: > tree: https://na01.safelinks.protection.outlook.com/?url=https%3a%2 > f%2fgit.kernel.org%2fpub%2fscm%2flinux%2fkernel%2fgit%2ftorvalds%2fli > nux.git=01%7c01%7ckys%40microsoft.com%7ce2e0622715844b79ad7108d3 >

[PATCH] staging/android: refactor SYNC_IOC_FILE_INFO

2016-02-26 Thread Gustavo Padovan
From: Gustavo Padovan Change SYNC_IOC_FILE_INFO behaviour to avoid future API breaks and optimize buffer allocation. In the new approach the ioctl needs to be called twice to retrieve the array of fence_infos pointed by info->sync_fence_info. The first call

Re: [PATCH v3 07/52] mtd: nand: core: use mtd_ooblayout_xxx() helpers where appropriate

2016-02-26 Thread Harvey Hunt
Hi Boris, On 26/02/16 00:57, Boris Brezillon wrote: The mtd_ooblayout_xxx() helper functions have been added to avoid direct accesses to the ecclayout field, and thus ease for future reworks. Use these helpers in all places where the oobfree[] and eccpos[] arrays where directly accessed.

Re: [PATCH v3 07/52] mtd: nand: core: use mtd_ooblayout_xxx() helpers where appropriate

2016-02-26 Thread Harvey Hunt
Hi Boris, On 26/02/16 15:10, Boris Brezillon wrote: Hi Harvey, On Fri, 26 Feb 2016 14:35:08 + Harvey Hunt wrote: [...] I'll look into this more later today, but wanted to run it by you in case you have any thoughts. Can you apply this patch [1], and let me know

REPLY

2016-02-26 Thread Dave
Good day to you, this email is to inform you that i and my wife have a donation check for you so please reply back for more details. Regards Dave Dawes ___ devel mailing list de...@linuxdriverproject.org

DISTRIBUTORS WANTED WORLDWIDE

2016-02-26 Thread Jason Allen
U.S. Manufacturer of Floor Safety Product Needs Exclusive Distributors Worldwide. 26 YEAR OLD U.S. COMPANY NEEDS DISTRIBUTORS IN MANY COUNTRIES for our amazing slip-resistant floor product. One 30 minute application with our Amazing Anti-Slip Floor Treatment will make floors slip-resistant and

Re: [PATCH v3 07/52] mtd: nand: core: use mtd_ooblayout_xxx() helpers where appropriate

2016-02-26 Thread Boris Brezillon
Hi Harvey, On Fri, 26 Feb 2016 14:35:08 + Harvey Hunt wrote: > Hi Boris, > > On 26/02/16 00:57, Boris Brezillon wrote: > > The mtd_ooblayout_xxx() helper functions have been added to avoid direct > > accesses to the ecclayout field, and thus ease for future reworks.

RE: [PATCH 5/5] hv: Track allocations of children of hv_vmbus in private resource tree

2016-02-26 Thread KY Srinivasan
> -Original Message- > From: ja...@microsoft.com [mailto:ja...@microsoft.com] > Sent: Wednesday, February 24, 2016 1:24 PM > To: linux-...@vger.kernel.org; gre...@linuxfoundation.org; KY Srinivasan > ; linux-ker...@vger.kernel.org; > de...@linuxdriverproject.org;

RE: [PATCH 1/1] scsi: storvsc: Fix a build issue reported by kbuild test robot

2016-02-26 Thread KY Srinivasan
> -Original Message- > From: James Bottomley [mailto:james.bottom...@hansenpartnership.com] > Sent: Friday, February 26, 2016 2:25 PM > To: KY Srinivasan ; linux-ker...@vger.kernel.org; > de...@linuxdriverproject.org; oher...@suse.com; > jbottom...@parallels.com;

Re: [PATCH v4 5/5] staging/android: add flags member to sync ioctl structs

2016-02-26 Thread Emil Velikov
Hi Gustavo, On 26 February 2016 at 18:31, Gustavo Padovan wrote: > From: Gustavo Padovan > > Play safe and add flags member to all structs. So we don't need to > break API or create new IOCTL in the future if new features that requires >

Re: [PATCH] staging/android: refactor SYNC_IOC_FILE_INFO

2016-02-26 Thread Emil Velikov
Hi Gustavo, On 26 February 2016 at 21:00, Gustavo Padovan wrote: > From: Gustavo Padovan > > Change SYNC_IOC_FILE_INFO behaviour to avoid future API breaks and > optimize buffer allocation. In the new approach the ioctl needs to be called >

[PATCH v4 1/1] scsi: storvsc: Fix a build issue reported by kbuild test robot

2016-02-26 Thread K. Y. Srinivasan
tree:

RE: [PATCH 1/1] scsi: storvsc: Fix a build issue reported by kbuild test robot

2016-02-26 Thread KY Srinivasan
> -Original Message- > From: James Bottomley [mailto:james.bottom...@hansenpartnership.com] > Sent: Friday, February 26, 2016 3:33 PM > To: KY Srinivasan ; linux-ker...@vger.kernel.org; > de...@linuxdriverproject.org; oher...@suse.com; > jbottom...@parallels.com;

Re: [PATCH 1/1] scsi: storvsc: Fix a build issue reported by kbuild test robot

2016-02-26 Thread James Bottomley
On Fri, 2016-02-26 at 23:22 +, KY Srinivasan wrote: > > > -Original Message- > > From: James Bottomley [mailto:james.bottom...@hansenpartnership.com > > ] > > Sent: Friday, February 26, 2016 2:25 PM > > To: KY Srinivasan ; linux-ker...@vger.kernel.org > > ; > >

RE: [PATCH 5/5] hv: Track allocations of children of hv_vmbus in private resource tree

2016-02-26 Thread Jake Oshins
> -Original Message- > From: KY Srinivasan > Sent: Friday, February 26, 2016 5:09 PM > To: Jake Oshins ; linux-...@vger.kernel.org; > gre...@linuxfoundation.org; linux-ker...@vger.kernel.org; > de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com; >

RECONFIRM YOUR DETAILS TO ME,,,,,

2016-02-26 Thread MR THOMAS JAMES
Dearest Beloved, I am Thomas James., A france national,I was browsing and I saw your e-mail, So i decided to write you if your e-mail is real, I have been diagnosed with esophageal cancer. It has defiled all forms of medical treatment, and right now I have only about a few months to live. I

RECONFIRM YOUR DETAILS TO ME,,,,,

2016-02-26 Thread MR THOMAS JAMES
Dearest Beloved, I am Thomas James., A france national,I was browsing and I saw your e-mail, So i decided to write you if your e-mail is real, I have been diagnosed with esophageal cancer. It has defiled all forms of medical treatment, and right now I have only about a few months to live. I

RE: [lustre-devel] [PATCH v2 0/6] staging: lustre: update modinfo data

2016-02-26 Thread Simmons, James A.
>On Fri, Feb 26, 2016 at 06:11:07AM +, Drokin, Oleg wrote: >> >> On Feb 26, 2016, at 1:03 AM, Greg Kroah-Hartman wrote: >> >> > On Thu, Feb 25, 2016 at 08:07:06PM -0500, James Simmons wrote: >> >> The module information for Lustre is stale or in some cases >> >> completely missing. This

Re: [lustre-devel] [PATCH v2 0/6] staging: lustre: update modinfo data

2016-02-26 Thread 'Greg Kroah-Hartman'
On Fri, Feb 26, 2016 at 03:46:02PM +, Simmons, James A. wrote: > >On Fri, Feb 26, 2016 at 06:11:07AM +, Drokin, Oleg wrote: > >> > >> On Feb 26, 2016, at 1:03 AM, Greg Kroah-Hartman wrote: > >> > >> > On Thu, Feb 25, 2016 at 08:07:06PM -0500, James Simmons wrote: > >> >> The module

[PATCH] [media] staging/davinci_vfpe: allow modular build

2016-02-26 Thread Arnd Bergmann
It has never been possible to actually build this driver as a loadable module, only built-in because the Makefile attempts to build each file into its own module and fails: ERROR: "mbus_to_pix" [drivers/staging/media/davinci_vpfe/vpfe_video.ko] undefined! ERROR: "vpfe_resizer_register_entities"

Re: [PATCH] staging: netlogic: Coding Style Fix Comparison to NULL could be written with !

2016-02-26 Thread Benjamin Young
On Sun, Feb 07, 2016 at 08:09:01PM -0800, Greg Kroah-Hartman wrote: > On Sat, Dec 12, 2015 at 06:45:59AM -0800, Benjamin Young wrote: > > Fixed coding style for null comparisons in netlogic driver to be more > > consistant > > with the rest of the kernel coding style > > > > Signed-off-by:

[PATCH] staging: unisys: visorinput depends on INPUT

2016-02-26 Thread Randy Dunlap
--- drivers/staging/unisys/visorinput/Kconfig |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) Found in linux-next but also applies to mainline. --- linux-next-20160226.orig/drivers/staging/unisys/visorinput/Kconfig +++ linux-next-20160226/drivers/staging/unisys/visorinput/Kconfig

[PATCH v3 0/6] staging: lustre: update modinfo data

2016-02-26 Thread James Simmons
The module information for Lustre is stale or in some cases completely missing. This collection of patches brings the modinfo up to date as well as filling in any missing information. This patch set has been redone to rebase it on Oleg's latest patch set to avoid collisons in merging. Changelog:

[PATCH v3 6/6] staging: lustre: update comment for lnet_lib_init/exit

2016-02-26 Thread James Simmons
From: Andreas Dilger The documentation about the return values for lnet_lib_init and lnet_lib_exit was in the old style format. Bring it in sync with the rest of the LNet core. Broken out of patch 16787. Signed-off-by: Andreas Dilger

[PATCH v3 1/6] staging: lustre: move module info to end of libcfs module.c file

2016-02-26 Thread James Simmons
Move the MODULE_* field in module.c that belongs to libcfs to the end of the file like it is done for other kernel drivers. Signed-off-by: James Simmons --- drivers/staging/lustre/lustre/libcfs/module.c |7 +++ 1 files changed, 3 insertions(+), 4 deletions(-)

[PATCH v3 5/6] staging: lustre: make module_init/exit naming consistent

2016-02-26 Thread James Simmons
From: Andreas Dilger Make the name of the module_init()/_exit() functions consistently {module_name}_init and {module_name}_exit. Signed-off-by: Andreas Dilger Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6204 Reviewed-on:

[PATCH v3 4/6] staging: lustre: update the MODULE_DESCRIPTION for all lustre modules

2016-02-26 Thread James Simmons
From: Andreas Dilger Fixup the MODULE_DESCRIPTION for several lustre modules. Some wrongly place the version in the string or they are not descriptive enough. Broken out of patch http://review.whamcloud.com/16787. Signed-off-by: Andreas Dilger

[PATCH v3 2/6] staging: lustre: add missing MODULE_AUTHOR for LNet selftest module

2016-02-26 Thread James Simmons
For several lustre modules the MODULE_VERSION has the wrong value, located in the wrong place in the source code, or completely missing. This patch brings it up to date. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6204 Reviewed-on:

[PATCH v3 2/6] staging: lustre: add missing MODULE_AUTHOR for LNet selftest module

2016-02-26 Thread James Simmons
From: Andreas Dilger For LNet selftest module the MODULE_AUTHOR was missing. Add proper OpenSFS authorship. Broken out of patch http://review.whamcloud.com/16787. Signed-off-by: Andreas Dilger Intel-bug-id:

Re: [PATCH RESEND 1/1] staging: ion: debugfs invalid gfp mask

2016-02-26 Thread Laura Abbott
On 02/25/2016 09:19 PM, Derek Yerger wrote: From drivers/staging/android TODO file - sparse errors. The current code attempts assignment of -1 to an unsigned type. Note that in a downstream function ion_page_pool_shrink this mask is only ever evaluated against __GFP_HIGHMEM

[PATCH v4 1/5] staging/android: add num_fences field to struct sync_file_info

2016-02-26 Thread Gustavo Padovan
From: Gustavo Padovan Inform userspace how many fences are in the sync_fence_info field. Signed-off-by: Gustavo Padovan --- drivers/staging/android/sync.c | 2 ++ drivers/staging/android/uapi/sync.h | 2 ++ 2 files

Re: [PATCH v3 07/52] mtd: nand: core: use mtd_ooblayout_xxx() helpers where appropriate

2016-02-26 Thread Boris Brezillon
Hi Harvey, On Fri, 26 Feb 2016 15:17:28 + Harvey Hunt wrote: > Hi Boris, > > On 26/02/16 15:10, Boris Brezillon wrote: > > Hi Harvey, > > > > On Fri, 26 Feb 2016 14:35:08 + > > Harvey Hunt wrote: > > > >> [...] > >> I'll look into this

[PATCH v4 3/5] staging/android: remove redundant comments on sync_merge_data

2016-02-26 Thread Gustavo Padovan
From: Gustavo Padovan struct sync_merge_data already have documentation on top of the struct definition. No need to duplicate it. Signed-off-by: Gustavo Padovan --- drivers/staging/android/uapi/sync.h | 6 +++--- 1 file

[PATCH v4 5/5] staging/android: add flags member to sync ioctl structs

2016-02-26 Thread Gustavo Padovan
From: Gustavo Padovan Play safe and add flags member to all structs. So we don't need to break API or create new IOCTL in the future if new features that requires flags arises. v2: check if flags are valid (zero, in this case) Signed-off-by: Gustavo Padovan

[PATCH v4 2/5] staging/android: rename SYNC_IOC_FENCE_INFO

2016-02-26 Thread Gustavo Padovan
From: Gustavo Padovan We don't use the 'fence' name to refer to sync_file anymore. So rename it to SYNC_IOC_FILE_INFO. Signed-off-by: Gustavo Padovan --- drivers/staging/android/sync.c | 2 +-

Re: [PATCH v3 48/52] mtd: nand: vf610: switch to mtd_ooblayout_ops

2016-02-26 Thread Stefan Agner
Hi Boris, On 2016-02-25 16:57, Boris Brezillon wrote: > Implementing the mtd_ooblayout_ops interface is the new way of exposing > ECC/OOB layout to MTD users. > > Signed-off-by: Boris Brezillon > --- > drivers/mtd/nand/vf610_nfc.c | 34