[PATCH] staging: wlan-ng: if statement style cleanup

2016-09-16 Thread Jon Eyolfson
Formatted code to follow coding style guidelines. Signed-off-by: Jon Eyolfson --- drivers/staging/wlan-ng/cfg80211.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/wlan-ng/cfg80211.c b/drivers/staging/wlan-ng/cfg80211.c index

Re: [PATCH] staging: lustre: lustre/ldlm: Fixed sparse warnings

2016-09-16 Thread Dilger, Andreas
On Sep 15, 2016, at 12:33, nayeem wrote: > On Wednesday 14 September 2016 10:44 AM, Dilger, Andreas wrote: >> On Sep 12, 2016, at 04:27, Greg KH wrote: >>> >>> On Fri, Sep 09, 2016 at 08:50:35PM +0530, Nayeemahmed Badebade wrote: Added

Re: [PATCH -next] staging: rtl8712: fix double lock bug in SetPSModeWorkItemCallback()

2016-09-16 Thread Greg KH
On Fri, Sep 16, 2016 at 10:01:47AM +0200, Greg KH wrote: > On Thu, Sep 15, 2016 at 10:12:05AM +, Wei Yongjun wrote: > > From: Wei Yongjun > > > > Fix a double lock bug in SetPSModeWorkItemCallback(). > > > > Fixes: 5c2ba8b85e35 ("rtl8712: pwrctrl_priv: Replace

Re: [PATCH -next] staging: rtl8712: fix double lock bug in SetPSModeWorkItemCallback()

2016-09-16 Thread Greg KH
On Thu, Sep 15, 2016 at 10:12:05AM +, Wei Yongjun wrote: > From: Wei Yongjun > > Fix a double lock bug in SetPSModeWorkItemCallback(). > > Fixes: 5c2ba8b85e35 ("rtl8712: pwrctrl_priv: Replace semaphore lock > with > mutex") I don't see that commit id in any tree

[PATCH v2] drivers: staging: vme: convert to octal notation for permission bits

2016-09-16 Thread Andrew Kanner
Ran checkpatch.pl -f vme_pio2_core.c Fixed: WARNING: Symbolic permissions are not preferred. Consider using octal permissions (0444) Signed-off-by: Andrew Kanner --- drivers/staging/vme/devices/vme_pio2_core.c | 12 ++-- 1 file changed, 6 insertions(+), 6

Re: [PATCH] android: binder: Disable preemption while holding the global binder lock

2016-09-16 Thread Todd Kjos
Thanks Peter. We'll give that patch a try as part of our refactoring. Looking at finer-grained locking and we'll try going back to rt_mutex plus this patch. On Wed, Sep 14, 2016 at 9:55 AM, Peter Zijlstra wrote: > On Wed, Sep 14, 2016 at 06:13:40PM +0200, Peter Zijlstra

[PATCH -next] vme: fake: remove unexpected unlock in fake_master_set()

2016-09-16 Thread Wei Yongjun
From: Wei Yongjun image->lock is unlocked in some error handling path without take the lock, so remove those unexpected unlock. Fixes: 658bcdae9c67 ("vme: Adding Fake VME driver") Signed-off-by: Wei Yongjun --- drivers/vme/bridges/vme_fake.c | 3

[PATCH 2/2] Drivers: hv: get rid of id in struct vmbus_channel

2016-09-16 Thread kys
From: Vitaly Kuznetsov The auto incremented counter is not being used anymore, get rid of it. Signed-off-by: Vitaly Kuznetsov Signed-off-by: K. Y. Srinivasan --- drivers/hv/channel_mgmt.c |2 -- include/linux/hyperv.h|

[PATCH 1/3] staging: r8188eu: remove ODM_CmnInfoUpdate function

2016-09-16 Thread Ivan Safonov
This function does not improve code readability. Signed-off-by: Ivan Safonov --- drivers/staging/rtl8188eu/hal/odm.c | 43 +-- drivers/staging/rtl8188eu/hal/rtl8188e_dm.c | 12 +++ drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c

[PATCH 2/3] staging: r8188eu: remove ODM_CmnInfoHook function

2016-09-16 Thread Ivan Safonov
This function used once, and does not improve code readability. Signed-off-by: Ivan Safonov --- drivers/staging/rtl8188eu/hal/odm.c | 77 - drivers/staging/rtl8188eu/hal/rtl8188e_dm.c | 22 - 2 files changed, 11 insertions(+), 88

[PATCH 3/3] staging: r8188eu: remove ODM_CmnInfoPtrArrayHook function

2016-09-16 Thread Ivan Safonov
This function used once, and does not improve code readability. Signed-off-by: Ivan Safonov --- drivers/staging/rtl8188eu/hal/odm.c | 67 - drivers/staging/rtl8188eu/hal/rtl8188e_dm.c | 37 2 files changed, 20

RE: [PATCH 1/1] Drivers: hv: hv_util: Avoid dynamic allocation in time synch

2016-09-16 Thread KY Srinivasan
> -Original Message- > From: k...@exchange.microsoft.com [mailto:k...@exchange.microsoft.com] > Sent: Friday, September 16, 2016 9:31 PM > To: gre...@linuxfoundation.org; linux-ker...@vger.kernel.org; > de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com; >

[PATCH 1/2] Drivers: hv: make VMBus bus ids persistent

2016-09-16 Thread kys
From: Vitaly Kuznetsov Some tools use bus ids to identify devices and they count on the fact that these ids are persistent across reboot. This may be not true for VMBus as we use auto incremented counter from alloc_channel() as such id. Switch to using if_instance from

[PATCH 0/2] Drivers: hv: vmbus: Use persistent IDs for vmbus device names

2016-09-16 Thread kys
From: K. Y. Srinivasan Use IDs that persist across reboots as vmbus device IDs. Vitaly Kuznetsov (2): Drivers: hv: make VMBus bus ids persistent Drivers: hv: get rid of id in struct vmbus_channel drivers/hv/channel_mgmt.c |2 -- drivers/hv/vmbus_drv.c|4

[PATCH 1/1] Drivers: hv: hv_util: Avoid dynamic allocation in time synch

2016-09-16 Thread kys
From: Vivek yadav Under stress, we have seen allocation failure in time synch code. Avoid this dynamic allocation. Signed-off-by: Vivek Yadav Signed-off-by: K. Y. Srinivasan --- drivers/hv/hv_util.c | 39

RE: [PATCH v2 0/2] Drivers: hv: vmbus: make bus ids in sysfs persistent

2016-09-16 Thread KY Srinivasan
> -Original Message- > From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com] > Sent: Friday, September 16, 2016 4:53 PM > To: KY Srinivasan > Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org; Haiyang > Zhang > Subject: Re: [PATCH

Re: [PATCH] staging: wlan-ng: if statement style cleanup

2016-09-16 Thread Greg Kroah-Hartman
On Fri, Sep 16, 2016 at 06:48:50AM -0400, Jon Eyolfson wrote: > Formatted code to follow coding style guidelines. What specific style guidelines did you have to change the code for? Please always be specific. can you fix this up and resend it? thanks, greg k-h

Re: [PATCH v2 0/2] Drivers: hv: vmbus: make bus ids in sysfs persistent

2016-09-16 Thread Vitaly Kuznetsov
Vitaly Kuznetsov writes: > Bus ids for VMBus devices in /sys/bus/vmbus/devices/ are not guaranteed > to be persistent across reboot or kernel restart and this causes problems > for some tools. E.g. kexec tools use these ids to identify NIC on kdump. > Fix the issue by using

Re: [PATCH] Staging: wlan-ng: if statement style cleanup

2016-09-16 Thread Dan Carpenter
On Thu, Sep 15, 2016 at 02:59:35PM -0400, Jon Eyolfson wrote: > Signed-off-by: Jon Eyolfson > Patch is corrupt. Read Documentation/email-clients.txt regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org

Re: [PATCH] staging: rts5208: Comparisons should place the constant on the right side of the test

2016-09-16 Thread Dan Carpenter
On Thu, Sep 15, 2016 at 07:22:40PM +0200, Sergio Paracuellos wrote: > That's true. It seems that checkpatch script is getting a false > positive. Just trying to do checkpatch happy. Also the old code was better than new code so leave it alone. regards, dan carpenter

Re: [PATCH 01/11] staging: most: hdm-dim2: fix channel configuration

2016-09-16 Thread Dan Carpenter
On Thu, Sep 15, 2016 at 04:19:03PM +0200, Christian Gromm wrote: > From: Andrey Shvetsov > > The DIM2 HDM checks the parameters passed to the function > configure_channel() and adapts the buffer sizes of the configuration > according to the hardware limitation. This patch

[PATCHv2] staging: wlan-ng: if statement style cleanup

2016-09-16 Thread Jon Eyolfson
Changed if statement bodies from 2 levels deeper than if statement to 1. Signed-off-by: Jon Eyolfson --- drivers/staging/wlan-ng/cfg80211.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/wlan-ng/cfg80211.c

[PATCH] staging: lustre: include/lustre_net.h: Remove unnecessary space before function pointer arguments.

2016-09-16 Thread Richard Groux
Minor warnings spotted by checkpatch.pl in lustre Remove unnecessary space before function pointer arguments. Signed-off-by: Richard Groux --- drivers/staging/lustre/lustre/include/lustre_net.h | 46 +++--- 1 file changed, 23 insertions(+), 23