Re: [PATCH V4 2/15] KVM/MMU: Add tlb flush with range helper function

2018-10-14 Thread Tianyu Lan
Hi Russell: Thanks for your review. On Sun, Oct 14, 2018 at 5:36 PM Russell King - ARM Linux wrote: > > On Sun, Oct 14, 2018 at 10:27:34AM +0100, Russell King - ARM Linux wrote: > > On Sun, Oct 14, 2018 at 10:16:56AM +0200, Thomas Gleixner wrote: > > > On Sun, 14 Oct 2018, Liran

Re: [PATCH V4 2/15] KVM/MMU: Add tlb flush with range helper function

2018-10-14 Thread Russell King - ARM Linux
On Sun, Oct 14, 2018 at 09:21:23PM +0800, Tianyu Lan wrote: > Sorry to confuse your. I get from CCers from get_maintainer.pl script. Unfortunately you seem to have made a mistake. My email address is 'li...@armlinux.org.uk' not 'li...@armlinux.org'. There is no 'li...@armlinux.org' in

Re: [PATCH V4 2/15] KVM/MMU: Add tlb flush with range helper function

2018-10-14 Thread Russell King - ARM Linux
On Sun, Oct 14, 2018 at 10:16:56AM +0200, Thomas Gleixner wrote: > On Sun, 14 Oct 2018, Liran Alon wrote: > > > On 13 Oct 2018, at 17:53, lantianyu1...@gmail.com wrote: > > > > > > From: Lan Tianyu > > > > > > This patch is to add wrapper functions for tlb_remote_flush_with_range > > >

Re: [PATCH V4 2/15] KVM/MMU: Add tlb flush with range helper function

2018-10-14 Thread Liran Alon
> On 13 Oct 2018, at 17:53, lantianyu1...@gmail.com wrote: > > From: Lan Tianyu > > This patch is to add wrapper functions for tlb_remote_flush_with_range > callback. > > Signed-off-by: Lan Tianyu > --- > Change sicne V3: > Remove code of updating "tlbs_dirty" > Change since V2: >

Re: [PATCH V4 2/15] KVM/MMU: Add tlb flush with range helper function

2018-10-14 Thread Thomas Gleixner
On Sun, 14 Oct 2018, Liran Alon wrote: > > On 13 Oct 2018, at 17:53, lantianyu1...@gmail.com wrote: > > > > From: Lan Tianyu > > > > This patch is to add wrapper functions for tlb_remote_flush_with_range > > callback. > > > > Signed-off-by: Lan Tianyu > > --- > > Change sicne V3: > >

Re: [PATCH V4 2/15] KVM/MMU: Add tlb flush with range helper function

2018-10-14 Thread Liran Alon
> On 14 Oct 2018, at 11:16, Thomas Gleixner wrote: > > On Sun, 14 Oct 2018, Liran Alon wrote: >>> On 13 Oct 2018, at 17:53, lantianyu1...@gmail.com wrote: >>> >>> + >>> +static inline bool kvm_available_flush_tlb_with_range(void) >>> +{ >>> + return kvm_x86_ops->tlb_remote_flush_with_range;

Re: [PATCH V4 2/15] KVM/MMU: Add tlb flush with range helper function

2018-10-14 Thread Russell King - ARM Linux
On Sun, Oct 14, 2018 at 10:27:34AM +0100, Russell King - ARM Linux wrote: > On Sun, Oct 14, 2018 at 10:16:56AM +0200, Thomas Gleixner wrote: > > On Sun, 14 Oct 2018, Liran Alon wrote: > > > > On 13 Oct 2018, at 17:53, lantianyu1...@gmail.com wrote: > > > > > > > > From: Lan Tianyu > > > > > > >

[PATCH 6/8] staging: rtl8188eu: rename parameters of Hal_MappingOutPipe() - style

2018-10-14 Thread Michael Straube
Rename parameters of Hal_MappingOutPipe() in header to avoid CamelCase and match the names used in the function definition in hal_com.c. pAdapter -> adapter NumOutPipe -> numoutpipe Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/include/hal_com.h | 2 +- 1 file changed, 1

[PATCH 2/8] staging: rtl8188eu: rename parameters of HalSetBrateCfg() - style

2018-10-14 Thread Michael Straube
Rename parameters of HalSetBrateCfg() in header to avoid CamelCase and match the names used in the function definition in hal_com.c. mBratesOS -> brates BrateCfg -> rate_cfg Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/include/hal_com.h | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH 5/8] staging: rtl8188eu: rename parameter of hal_com_get_channel_plan() - style

2018-10-14 Thread Michael Straube
Rename parameter of hal_com_get_channel_plan() in header to avoid CamelCase and match the name used in the function definition in hal_com.c. AutoLoadFail -> load_fail Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/include/hal_com.h | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH 3/8] staging: rtl8188eu: rename HalSetBrateCfg() - style

2018-10-14 Thread Michael Straube
Rename HalSetBrateCfg() to avoid CamelCase. HalSetBrateCfg -> hal_set_brate_cfg Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/hal_com.c | 2 +- drivers/staging/rtl8188eu/hal/usb_halinit.c | 2 +- drivers/staging/rtl8188eu/include/hal_com.h | 2 +- 3 files changed, 3

[PATCH 4/8] staging: rtl8188eu: remove unused parameter of hal_com_get_channel_plan()

2018-10-14 Thread Michael Straube
The parameter 'struct adapter *padapter' of hal_com_get_channel_plan() is unused, so remove it. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/hal_com.c | 5 ++--- drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c | 3 +-- drivers/staging/rtl8188eu/include/hal_com.h

[PATCH 8/8] staging: rtl8188eu: remove whitespace - style

2018-10-14 Thread Michael Straube
Remove extra space in variable declaration. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/hal_com.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/hal/hal_com.c b/drivers/staging/rtl8188eu/hal/hal_com.c index

[PATCH 7/8] staging: rtl8188eu: rename Hal_MappingOutPipe() - style

2018-10-14 Thread Michael Straube
Rename Hal_MappingOutPipe() to avoid CamelCase. Hal_MappingOutPipe -> hal_mapping_out_pipe Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/hal_com.c | 2 +- drivers/staging/rtl8188eu/hal/usb_halinit.c | 2 +- drivers/staging/rtl8188eu/include/hal_com.h | 2 +- 3 files

[PATCH 1/8] staging: rtl8188eu: remove unused parameter of HalSetBrateCfg()

2018-10-14 Thread Michael Straube
The parameter 'struct adapter *adapt' of HalSetBrateCfg() is unused, so remove it. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/hal_com.c | 2 +- drivers/staging/rtl8188eu/hal/usb_halinit.c | 2 +- drivers/staging/rtl8188eu/include/hal_com.h | 2 +- 3 files changed, 3

Re: [PATCH V4 2/15] KVM/MMU: Add tlb flush with range helper function

2018-10-14 Thread Tianyu Lan
Hi Liran & Thomas: Thanks for your review. On Sun, Oct 14, 2018 at 5:20 PM Liran Alon wrote: > > > > > On 14 Oct 2018, at 11:16, Thomas Gleixner wrote: > > > > On Sun, 14 Oct 2018, Liran Alon wrote: > >>> On 13 Oct 2018, at 17:53, lantianyu1...@gmail.com wrote: > >>> > >>> + >

[PATCH] staging: rtl8188eu: cleanup comparsions to false

2018-10-14 Thread Michael Straube
Cleanup remaining comparsions to false. if(x == false) -> if(!x) Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_efuse.c | 2 +- drivers/staging/rtl8188eu/core/rtw_mlme.c | 12 ++-- drivers/staging/rtl8188eu/core/rtw_pwrctrl.c | 7 ---

[PATCH 06/11] staging: gasket: page table: fixup error path allocating coherent mem

2018-10-14 Thread Todd Poynor
From: Nick Ewalt Correctly clean up data structure state in gasket_alloc_coherent_memory error path, to ensure no double free on the stale pointer value. Signed-off-by: Nick Ewalt Signed-off-by: Todd Poynor --- drivers/staging/gasket/gasket_page_table.c | 6 +- 1 file changed, 5

[PATCH 08/11] staging: gasket: page_table: simplify gasket_components_to_dev_address

2018-10-14 Thread Todd Poynor
From: Nick Ewalt Refactor gasket_components_to_dev_address to be faster and easier to understand. The old implementation was unnecessarily complex and masked the page_index for simple addresses but not extended ones. It makes the most sense for this function to perform no such masking.

[PATCH 05/11] staging: gasket: page_table: rearrange gasket_page_table_entry

2018-10-14 Thread Todd Poynor
From: Nick Ewalt Rearrange gasket_page_table entry to reduce padding slop. Signed-off-by: Nick Ewalt Signed-off-by: Todd Poynor --- drivers/staging/gasket/gasket_page_table.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git

[PATCH 11/11] staging: gasket: Update device virtual address comment

2018-10-14 Thread Todd Poynor
From: Nick Ewalt Add that number of page table entries and extended address bit offset are configurable. Update example virtual address format to be more consistent with typical usage. Signed-off-by: Nick Ewalt Signed-off-by: Todd Poynor --- drivers/staging/gasket/gasket_page_table.c | 14

[PATCH 04/11] staging: gasket: page_table: remove unnecessary PTE status set to free

2018-10-14 Thread Todd Poynor
From: Nick Ewalt Remove unnecessary ptes[i].status update in gasket_perform_unmapping. The vaaue will be cleared in the following memset. Signed-off-by: Nick Ewalt Signed-off-by: Todd Poynor --- drivers/staging/gasket/gasket_page_table.c | 1 - 1 file changed, 1 deletion(-) diff --git

[PATCH 03/11] staging: gasket: page table: remove dead code in coherent mem alloc

2018-10-14 Thread Todd Poynor
From: Todd Poynor gasket_alloc_coherent_memory() has some unnecessary code related to out of memory checking that will never hit the condition checked, remove. Signed-off-by: Todd Poynor --- drivers/staging/gasket/gasket_page_table.c | 6 +- 1 file changed, 1 insertion(+), 5 deletions(-)

[PATCH 10/11] staging: gasket: sysfs: fix attribute release comment

2018-10-14 Thread Todd Poynor
From: Nick Ewalt Comments for gasket_sysfs_get_attr() incorrectly describe reference release procedure. Signed-off-by: Nick Ewalt Signed-off-by: Todd Poynor --- drivers/staging/gasket/gasket_sysfs.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH 02/11] staging: gasket: page table: return valid error code on map fail

2018-10-14 Thread Todd Poynor
From: Todd Poynor Return -EINVAL on mapping failures, instead of -1, which triggers a checkpatch error. Signed-off-by: Todd Poynor --- drivers/staging/gasket/gasket_page_table.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/staging/gasket/gasket_page_table.c

[PATCH 09/11] staging: gasket: apex: fix sysfs_show

2018-10-14 Thread Todd Poynor
From: Nick Ewalt sysfs_show was incorrectly extracting the sysfs_attribute_type from the gasket_sysfs_attribute. This prevented dispatch from working properly. Signed-off-by: Nick Ewalt Signed-off-by: Todd Poynor --- drivers/staging/gasket/apex_driver.c | 2 +- 1 file changed, 1

[PATCH 01/11] staging: gasket: core: debug log updates

2018-10-14 Thread Todd Poynor
From: Todd Poynor Add debug logs for device enable/disable events, remove logs for callbacks (the called functions can generate their own logs if needed). Signed-off-by: Todd Poynor --- drivers/staging/gasket/gasket_core.c | 9 +++-- 1 file changed, 3 insertions(+), 6 deletions(-) diff

[PATCH 07/11] staging: gasket: page_table: fix comment in components_to_dev_address

2018-10-14 Thread Todd Poynor
From: Nick Ewalt Comments in components_to_dev_address() describing examples are inconsistent, fix these to be accurate. Signed-off-by: Nick Ewalt Signed-off-by: Todd Poynor --- drivers/staging/gasket/gasket_page_table.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git

[PATCH 00/11] staging: gasket: fixes

2018-10-14 Thread Todd Poynor
From: Todd Poynor Various fixes for gasket/apex drivers. Nick Ewalt (8): staging: gasket: page_table: remove unnecessary PTE status set to free staging: gasket: page_table: rearrange gasket_page_table_entry staging: gasket: page table: fixup error path allocating coherent mem staging: