[PATCH] staging: skein: fix sparse warnings related to shift operator

2014-11-17 Thread Domagoj Trsan
Fix warnings: drivers/staging/skein/skein_base.h:89:30: warning: shift too big (50) for type int ... drivers/staging/skein/skein_base.h:89:30: warning: shift too big (39)for type int drivers/staging/skein/skein_base.h:89:19: warning: too many warnings Signed-off-by: Domagoj Trsan

Re: [PATCH] staging: comedi: me4000: Fixed code style issue

2014-11-17 Thread Ian Abbott
On 15/11/14 15:55, Marcus Hufvudsson wrote: Fixed checkpatch.pl error message. Space prohibited before that ',' Signed-off-by: Marcus Hufvudsson marcus...@gmail.com --- drivers/staging/comedi/drivers/me4000.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH] staging: rtl8723au: fix sparse warning

2014-11-17 Thread Aleh Suprunovich
drivers/staging/rtl8723au/hal/rtl8723a_hal_init.c:747:1: warning: symbol 'rtl8723a_EfusePgPacketRead' was not declared. Should it be static? Function 'rtl8723a_EfusePgPacketRead' seems to be unused in current staging code. Before, it was available as 'static s32 Hal_EfusePgPacketRead', but code

[PATCH v12 0/11] dw-hdmi: convert imx hdmi to bridge/dw_hdmi

2014-11-17 Thread Andy Yan
We found Freescale imx6 and Rockchip rk3288 and Ingenic JZ4780 (Xburst/MIPS) use the interface compatible Designware HDMI IP, but they also have some lightly differences, such as phy pll configuration, register width(imx hdmi register is one byte, but rk3288 is 4 bytes width and can only be

[PATCH v12 01/11] staging: imx-drm: imx-hdmi: make checkpatch happy

2014-11-17 Thread Andy Yan
CHECK: Alignment should match open parenthesis + if ((hdmi-vic == 10) || (hdmi-vic == 11) || + (hdmi-vic == 12) || (hdmi-vic == 13) || CHECK: braces {} should be used on all arms of this statement + if (hdmi-hdmi_data.video_mode.mdvi) [...] + else { [...]

[PATCH v12 02/11] staging: imx-drm: imx-hdmi: return defer if can't get ddc i2c adapter

2014-11-17 Thread Andy Yan
drm driver may probe before the i2c bus, so the driver should defer probing until it is available Signed-off-by: Andy Yan andy@rock-chips.com Reviewed-by: Daniel Kurtz djku...@chromium.org --- Changes in v12: - refactor of_node_put(ddc_node) Changes in v11: None Changes in v10: None

[PATCH v12 04/11] staging: imx-drm: imx-hdmi: move imx-hdmi to bridge/dw_hdmi

2014-11-17 Thread Andy Yan
the original imx hdmi driver is under staging/imx-drm, which depends on imx-drm, so move the imx hdmi driver out to drm/bridge and rename imx-hdmi to dw_hdmi handle encoder in dw_hdmi-imx.c, as most of the encoder operation are platform specific such as crtc select and panel format set

[PATCH v12 05/11] dt-bindings: add document for dw_hdmi

2014-11-17 Thread Andy Yan
Signed-off-by: Andy Yan andy@rock-chips.com --- Changes in v12: None Changes in v11: None Changes in v10: None Changes in v9: None Changes in v8: - correct some spelling mistake - modify ddc-i2c-bus and interrupt description Changes in v7: None Changes in v6: None Changes in v5: None

[PATCH v12 06/11] drm: bridge/dw_hdmi: add support for multi-byte register width access

2014-11-17 Thread Andy Yan
On rockchip rk3288, only word(32-bit) accesses are permitted for hdmi registers. Byte width accesses (writeb, readb) generate an imprecise external abort. Signed-off-by: Andy Yan andy@rock-chips.com --- Changes in v12: None Changes in v11: None Changes in v10: None Changes in v9: None

[PATCH v12 07/11] drm: bridge/dw_hdmi: add mode_valid support

2014-11-17 Thread Andy Yan
some platform may not support all the display mode, add mode_valid interface check it also add drm_connector_register which add a debugfs interface for dump display modes and edid information Signed-off-by: Andy Yan andy@rock-chips.com --- Changes in v12: None Changes in v11: None Changes

[PATCH v12 10/11] dt-bindings: Add documentation for rockchip dw hdmi

2014-11-17 Thread Andy Yan
Signed-off-by: Andy Yan andy@rock-chips.com --- Changes in v12: None Changes in v11: None Changes in v10: None Changes in v9: None Changes in v8: - Add documentation for rockchip dw hdmi Changes in v7: None Changes in v6: None Changes in v5: None Changes in v4: None Changes in v3: None

[PATCH v12 11/11] drm: bridge/dw_hdmi: add rockchip rk3288 support

2014-11-17 Thread Andy Yan
Rockchip RK3288 hdmi is compatible with dw_hdmi this patch is depend on patch by Mark Yao Add drm driver for Rockchip Socs see https://lkml.org/lkml/2014/10/8/201 Signed-off-by: Andy Yan andy@rock-chips.com --- Changes in v12: - add comment for the depend on patch Changes in v11: None

[PATCH 1/2] acquiring and storing all display timing flags from dt

2014-11-17 Thread stefan
Signed-off-by: stefan strawberrybl...@googlemail.com --- drivers/staging/imx-drm/parallel-display.c | 6 ++ 1 file changed, 6 insertions(+) diff --git a/drivers/staging/imx-drm/parallel-display.c b/drivers/staging/imx-drm/parallel-display.c index 4ca61af..a67c1ad 100644 ---

[PATCH 2/2] setting sig_cfg.clk_pol according to value of pixelclk-active

2014-11-17 Thread stefan
Signed-off-by: stefan strawberrybl...@googlemail.com --- drivers/staging/imx-drm/ipuv3-crtc.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/drivers/staging/imx-drm/ipuv3-crtc.c b/drivers/staging/imx-drm/ipuv3-crtc.c index 720868b..71c741b 100644 ---

RE: [PATCH] staging: unisys: Remove unnecessary spaces after casts in virthba.c

2014-11-17 Thread Depro, Kenneth J
This patch removes all of the unnecessary spaces after casts within the virthba.c file. The checkpatch script was run again after these changes, and no remove spaces after casts checks were generated. Signed-off-by: Ken Depro kenneth.de...@unisys.com ---

RE: [PATCH] staging: unisys: fix CamelCase methods/variables in virthba.c

2014-11-17 Thread Depro, Kenneth J
This patch fixes the CamelCase checks for methods/variables in virthba.c found with the checkpatch script. Signed-off-by: Ken Depro kenneth.de...@unisys.com --- drivers/staging/unisys/virthba/virthba.c | 122 +++--- 1 file changed, 61 insertions(+), 61 deletions(-)

Re: [PATCH 1/2] acquiring and storing all display timing flags from dt

2014-11-17 Thread Dan Carpenter
On Mon, Nov 17, 2014 at 05:21:48PM +0200, stefan wrote: Signed-off-by: stefan strawberrybl...@googlemail.com We need a full name for your from header and your signed off by line. (It's like signing a legal document that you didn't violate copyrights). Also, could you explain a bit more in the

[PATCH] drivers: staging: lustre: lnet: api-nc.c: Fix Style Warnings

2014-11-17 Thread Thomas Wood
Fixed Subject line containing the entire patch description. 88 Remove an unecessary return statement in a void function. Remove an unecessary space between a function name and the parentheses. Signed-off-by: Thomas Wood

Re: [PATCH] drivers: staging: lustre: lnet: api-nc.c: Fix Style Warnings

2014-11-17 Thread Greg KH
On Mon, Nov 17, 2014 at 11:11:36AM -0800, Thomas Wood wrote: Fixed Subject line containing the entire patch description. 88 Ick, what is that here? Please put that below the --- line, otherwise I have to hand-edit the

[PATCH 1/1] staging: unisys: parser.c bug

2014-11-17 Thread Jeffrey Brown
From: Jeff jeffrey.br...@unisys.com Replaced cleanups: with err_rgn, err_ctx, and out_rgn in the file. This is to have proper error and success handling. I also removed the variable rc because like cleanups, rc is redundant in this file Signed-off-by: Jeffrey Brown jeffrey.br...@unisys.com ---

[PATCH v3] drivers: staging: lustre: lnet: api-nc.c: Fix Style Warnings

2014-11-17 Thread Thomas Wood
Remove an unecessary return statement in a void function. Remove an unecessary space between a function name and the parentheses. Signed-off-by: Thomas Wood tommyandr...@gmail.com --- Fixed the subject line containing the entire description. Removed an attempt at scissor lines.

Re: [PATCH 1/1] staging: unisys: parser.c bug

2014-11-17 Thread Greg KH
On Mon, Nov 17, 2014 at 02:46:35PM -0500, Jeffrey Brown wrote: From: Jeff jeffrey.br...@unisys.com This doesn't match your signed-off-by: line, nor your From: line of your email above. Why even have this line when it isn't needed, and wrong? greg k-h

[PATCH 1/1] staging: unisys: parser.c bug

2014-11-17 Thread Jeffrey Brown
Replaced cleanups: with err_rgn, err_ctx, and out_rgn in the file. This is to have proper error and success handling. I also removed the variable rc because like cleanups, rc is redundant in this file Signed-off-by: Jeffrey Brown jeffrey.br...@unisys.com ---

Re: [PATCH 1/1] staging: unisys: parser.c bug

2014-11-17 Thread Dan Carpenter
Looks nice. Thanks, a lot! regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

[PATCH] staging: lustre: mdc: use __FMODE_EXEC macro

2014-11-17 Thread Juston Li
FMODE_EXEC is type fmode_t but is used in operations with integers which leads to sparse warnings: drivers/staging/lustre/lustre/mdc/mdc_lib.c:198:21: warning: restricted fmode_t degrades to integer drivers/staging/lustre/lustre/mdc/mdc_locks.c:300:49: warning: restricted fmode_t degrades to

Re: [PATCH] staging: lustre: mdc: use __FMODE_EXEC macro

2014-11-17 Thread Dan Carpenter
On Mon, Nov 17, 2014 at 02:23:48PM -0800, Juston Li wrote: FMODE_EXEC is type fmode_t but is used in operations with integers which leads to sparse warnings: drivers/staging/lustre/lustre/mdc/mdc_lib.c:198:21: warning: restricted fmode_t degrades to integer

Re: [PATCH] staging: lustre: mdc: use __FMODE_EXEC macro

2014-11-17 Thread Juston
On Tue, 2014-11-18 at 01:46 +0300, Dan Carpenter wrote: On Mon, Nov 17, 2014 at 02:23:48PM -0800, Juston Li wrote: FMODE_EXEC is type fmode_t but is used in operations with integers which leads to sparse warnings: drivers/staging/lustre/lustre/mdc/mdc_lib.c:198:21: warning: restricted

Re: [PATCH] staging:rtl8723au: Fix sparse warning cast to restricted __le16

2014-11-17 Thread Tobenna Peter, Igwe
On Mon, Nov 17, 2014 at 05:59:47PM -0800, Greg KH wrote: On Tue, Nov 18, 2014 at 01:45:41AM +, Tobenna P. Igwe wrote: This patch fixes the following sparse warning: drivers/staging/rtl8723au/hal/rtl8723a_bt-coexist.c:343:36: warning: cast to restricted __le16 by using the

Re: [PATCH] staging:rtl8723au: Fix sparse warning cast to restricted __le16

2014-11-17 Thread Greg KH
On Tue, Nov 18, 2014 at 02:51:45AM +, Tobenna Peter, Igwe wrote: On Mon, Nov 17, 2014 at 05:59:47PM -0800, Greg KH wrote: On Tue, Nov 18, 2014 at 01:45:41AM +, Tobenna P. Igwe wrote: This patch fixes the following sparse warning:

Re: [PATCH] staging: lustre: mdc: use __FMODE_EXEC macro

2014-11-17 Thread Dan Carpenter
On Mon, Nov 17, 2014 at 04:23:08PM -0800, Juston wrote: Seems to be the case. Looked at some old commits (2.6.17) and found FMODE_EXEC was mainlined to allow lustre to be installed on a vanilla kernel. We actually only care about the most recent kernel. I think you can remove the ifdefs in