Re: XVME 6300 with TSI148 bridge on 64 bit Debian (Linux 3.2.57) vme_user issue

2014-11-18 Thread Maurice Moss
Hi Martyn, Any update on this from your side? Cheers! On Mon, Nov 10, 2014 at 10:22 AM, Maurice Moss eightplusc...@gmail.com wrote: Hi Martyn, Thanks for your reply. I have pasted the code below. It is very much similar to your test code from the forum. Thanks! #define _XOPEN_SOURCE 500

Re: [PATCH] staging: lustre: mdc: use __FMODE_EXEC macro

2014-11-18 Thread Greg KH
On Mon, Nov 17, 2014 at 04:23:08PM -0800, Juston wrote: On Tue, 2014-11-18 at 01:46 +0300, Dan Carpenter wrote: On Mon, Nov 17, 2014 at 02:23:48PM -0800, Juston Li wrote: FMODE_EXEC is type fmode_t but is used in operations with integers which leads to sparse warnings:

[PATCH 05/11] staging: unisys: virthba: Remove blank lines before/after braces

2014-11-18 Thread Ken Depro
This patch removes unnecessary blank lines either before opening braces or after closing braces, as reported by the checkpatch script. Signed-off-by: Ken Depro kenneth.de...@unisys.com --- drivers/staging/unisys/virthba/virthba.c |4 1 file changed, 4 deletions(-) diff --git

[PATCH 02/11] staging: unisys: virthba: Fix CamelCase variables

2014-11-18 Thread Ken Depro
This patch fixes the improper CamelCase usage for variables, reported by the checkpatch script. Signed-off-by: Ken Depro kenneth.de...@unisys.com --- drivers/staging/unisys/virthba/virthba.c | 122 +++--- 1 file changed, 61 insertions(+), 61 deletions(-) diff --git

[PATCH 04/11] staging: unisys: virthba: Fix logical continuation checks

2014-11-18 Thread Ken Depro
This patch fixes checkpatch checks where the logical operator should be at the end of the line above, not beginning the next line. Signed-off-by: Ken Depro kenneth.de...@unisys.com --- drivers/staging/unisys/virthba/virthba.c | 38 +++--- 1 file changed, 19

[PATCH 07/11] staging: unisys: virthba: Change alloc calls to use var name instead of type

2014-11-18 Thread Ken Depro
This patch changes a couple of kzalloc calls to pass the variable name to the call, rather than the variable struct type. This is a result of checks generated during the checkpatch script. Signed-off-by: Ken Depro kenneth.de...@unisys.com --- drivers/staging/unisys/virthba/virthba.c |4 ++--

[PATCH 00/11] staging: unisys: virthba: Fix checkpatch issues in virthba

2014-11-18 Thread Ken Depro
This series fixes various issues in the virthba.c file that were reported by the checkpatch script. Ken Depro (11): staging: unisys: virthba: Remove unneeded spaces after casts staging: unisys: virthba: Fix CamelCase variables staging: unisys: virthba: Fix open parenthesis alignment checks

[PATCH 03/11] staging: unisys: virthba: Fix open parenthesis alignment checks

2014-11-18 Thread Ken Depro
This patch fixes the alignment should match open parenthesis checks from the checkpatch script. Signed-off-by: Ken Depro kenneth.de...@unisys.com --- drivers/staging/unisys/virthba/virthba.c | 74 +++--- 1 file changed, 37 insertions(+), 37 deletions(-) diff --git

[PATCH 01/11] staging: unisys: virthba: Remove unneeded spaces after casts

2014-11-18 Thread Ken Depro
This patch removes all unnecessary spaces after casts, as reported by the checkpatch script. Signed-off-by: Ken Depro kenneth.de...@unisys.com --- drivers/staging/unisys/virthba/virthba.c | 130 +++--- 1 file changed, 65 insertions(+), 65 deletions(-) diff --git

[PATCH 11/11] staging: unisys: virthba: Fix a couple open parenthesis alignment issues

2014-11-18 Thread Ken Depro
This patch fixes a couple checkpatch checks where alignment of the parameters did not match the open parenthesis of the function. Signed-off-by: Ken Depro kenneth.de...@unisys.com --- drivers/staging/unisys/virthba/virthba.c |6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff

[PATCH 10/11] staging: unisys: virthba: Fix warnings regarding lines over 80 characters

2014-11-18 Thread Ken Depro
This patch fixes warnings generated by checkpatch script regarding lines over 80 characters long. Signed-off-by: Ken Depro kenneth.de...@unisys.com --- drivers/staging/unisys/virthba/virthba.c | 40 -- 1 file changed, 22 insertions(+), 18 deletions(-) diff --git

[PATCH 06/11] staging: unisys: virthba: Fix missing braces at end of if-else statements

2014-11-18 Thread Ken Depro
This patch fixes checkpatch warnings that resulted from the else portion of if-else statements missing braces, so that it conforms with the rest of the statement. Signed-off-by: Ken Depro kenneth.de...@unisys.com --- drivers/staging/unisys/virthba/virthba.c |6 -- 1 file changed, 4

[PATCH 09/11] staging: unisys: virthba: Fix else not useful after return warning

2014-11-18 Thread Ken Depro
This patch fixes a warning generated during the checkpatch script that stated else not useful after return. I modified the code to return a designated status at the end of the function, and replaced the return statement in the else if to set the status accordingly. Signed-off-by: Ken Depro

[PATCH 08/11] staging: unisys: virthba: Fix a couple checkpatch problems

2014-11-18 Thread Ken Depro
This patch fixes a couple small issues reported by the checkpatch script: Adds a blank line after a struct definition. Removes unnecessary parentheses surrounding a struct member. Signed-off-by: Ken Depro kenneth.de...@unisys.com --- drivers/staging/unisys/virthba/virthba.c |3 ++- 1

[PATCH 2/9] staging: panel: Call init function directly

2014-11-18 Thread Mariusz Gorski
Remove useless function and let the kernel call the actual init function directly. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com --- drivers/staging/panel/panel.c | 7 +-- 1 file changed, 1 insertion(+), 6 deletions(-) diff --git a/drivers/staging/panel/panel.c

[PATCH 6/9] staging: panel: Make two more module params read-only

2014-11-18 Thread Mariusz Gorski
Make keypad_type and lcd_type module params read-only. This step also starts making it more clear what is the precedence of device params coming from different sources (device profile, runtime module param values etc). Signed-off-by: Mariusz Gorski marius.gor...@gmail.com ---

[PATCH 5/9] staging: panel: Start making module params read-only

2014-11-18 Thread Mariusz Gorski
Start decoupling module params from the actual device state, both for lcd and keypad, by keeping the params read-only and moving the device state to related structs. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com --- drivers/staging/panel/panel.c | 35 +--

[PATCH 4/9] staging: panel: Use a macro for checking module params state

2014-11-18 Thread Mariusz Gorski
Avoid values comparison and use a macro instead that checks whether module param has been set by the user to some value at loading time. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com --- drivers/staging/panel/panel.c | 88 ++- 1 file changed, 45

[PATCH 0/9] staging: panel: Refactor panel initialization

2014-11-18 Thread Mariusz Gorski
This set of patches focuses on making current initialization process easier to understand - especially it tries to emphasize what are the priorities of the params coming from different sources (Kconfig values, device profiles and module param values set on loading). I paid attention not to change

[PATCH 8/9] staging: panel: Remove more magic number comparison

2014-11-18 Thread Mariusz Gorski
Use a macro instead of magic number comparison for checking whether a module param value has been set. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com --- drivers/staging/panel/panel.c | 21 +++-- 1 file changed, 11 insertions(+), 10 deletions(-) diff --git

[PATCH 9/9] staging: panel: Move LCD-related state into struct lcd

2014-11-18 Thread Mariusz Gorski
Move more or less all LCD-related state into struct lcd in order to get better cohesion; use bool instead of int where it makes sense. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com --- drivers/staging/panel/panel.c | 255 ++ 1 file changed, 134

[PATCH 1/9] staging: panel: Set default parport module param value

2014-11-18 Thread Mariusz Gorski
Set default parport module param value to DEFAULT_PARPORT so that a if-block can be avoided. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com --- drivers/staging/panel/panel.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/drivers/staging/panel/panel.c

[PATCH 3/9] staging: panel: Remove magic numbers

2014-11-18 Thread Mariusz Gorski
Get rid of magic numbers indicating that the value of a module param is not set. Use a defined value instead. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com --- drivers/staging/panel/panel.c | 22 -- 1 file changed, 12 insertions(+), 10 deletions(-) diff --git

[PATCH 7/9] staging: panel: Refactor LCD init code

2014-11-18 Thread Mariusz Gorski
Rework lcd_init method to make it a little bit more clear about the precedence of the params, move LCD geometry and pins layout to the LCD struct and thus make the LCD-related module params effectively read-only. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com ---

Re: [PATCH 1/9] staging: panel: Set default parport module param value

2014-11-18 Thread Willy Tarreau
On Tue, Nov 18, 2014 at 09:56:06PM +0100, Mariusz Gorski wrote: Set default parport module param value to DEFAULT_PARPORT so that a if-block can be avoided. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com Acked-by: Willy Tarreau w...@1wt.eu

Re: [PATCH 3/9] staging: panel: Remove magic numbers

2014-11-18 Thread Willy Tarreau
On Tue, Nov 18, 2014 at 09:56:08PM +0100, Mariusz Gorski wrote: Get rid of magic numbers indicating that the value of a module param is not set. Use a defined value instead. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com Acked-by: Willy Tarreau w...@1wt.eu

Re: [PATCH 2/9] staging: panel: Call init function directly

2014-11-18 Thread Willy Tarreau
On Tue, Nov 18, 2014 at 09:56:07PM +0100, Mariusz Gorski wrote: Remove useless function and let the kernel call the actual init function directly. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com Acked-by: Willy Tarreau w...@1wt.eu ___ devel

Re: [PATCH 4/9] staging: panel: Use a macro for checking module params state

2014-11-18 Thread Willy Tarreau
On Tue, Nov 18, 2014 at 09:56:09PM +0100, Mariusz Gorski wrote: Avoid values comparison and use a macro instead that checks whether module param has been set by the user to some value at loading time. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com --- drivers/staging/panel/panel.c

Re: [PATCH 5/9] staging: panel: Start making module params read-only

2014-11-18 Thread Willy Tarreau
On Tue, Nov 18, 2014 at 09:56:10PM +0100, Mariusz Gorski wrote: Start decoupling module params from the actual device state, both for lcd and keypad, by keeping the params read-only and moving the device state to related structs. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com

Re: [PATCH 6/9] staging: panel: Make two more module params read-only

2014-11-18 Thread Willy Tarreau
On Tue, Nov 18, 2014 at 09:56:11PM +0100, Mariusz Gorski wrote: Make keypad_type and lcd_type module params read-only. This step also starts making it more clear what is the precedence of device params coming from different sources (device profile, runtime module param values etc).

Re: [PATCH 7/9] staging: panel: Refactor LCD init code

2014-11-18 Thread Willy Tarreau
On Tue, Nov 18, 2014 at 09:56:12PM +0100, Mariusz Gorski wrote: Rework lcd_init method to make it a little bit more clear about the precedence of the params, move LCD geometry and pins layout to the LCD struct and thus make the LCD-related module params effectively read-only. Signed-off-by:

Re: [PATCH 8/9] staging: panel: Remove more magic number comparison

2014-11-18 Thread Willy Tarreau
On Tue, Nov 18, 2014 at 09:56:13PM +0100, Mariusz Gorski wrote: Use a macro instead of magic number comparison for checking whether a module param value has been set. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com --- drivers/staging/panel/panel.c | 21 +++-- 1 file

Re: [PATCH 9/9] staging: panel: Move LCD-related state into struct lcd

2014-11-18 Thread Willy Tarreau
On Tue, Nov 18, 2014 at 09:56:14PM +0100, Mariusz Gorski wrote: Move more or less all LCD-related state into struct lcd in order to get better cohesion; use bool instead of int where it makes sense. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com Acked-by: Willy Tarreau w...@1wt.eu

Re: [PATCH 6/9] staging: panel: Make two more module params read-only

2014-11-18 Thread Mariusz Gorski
On Tue, Nov 18, 2014 at 10:20:34PM +0100, Willy Tarreau wrote: On Tue, Nov 18, 2014 at 09:56:11PM +0100, Mariusz Gorski wrote: Make keypad_type and lcd_type module params read-only. This step also starts making it more clear what is the precedence of device params coming from different

Re: [PATCH 4/9] staging: panel: Use a macro for checking module params state

2014-11-18 Thread Mariusz Gorski
On Tue, Nov 18, 2014 at 10:18:44PM +0100, Willy Tarreau wrote: On Tue, Nov 18, 2014 at 09:56:09PM +0100, Mariusz Gorski wrote: Avoid values comparison and use a macro instead that checks whether module param has been set by the user to some value at loading time. Signed-off-by: Mariusz

Re: [PATCH 8/9] staging: panel: Remove more magic number comparison

2014-11-18 Thread Mariusz Gorski
On Tue, Nov 18, 2014 at 10:25:23PM +0100, Willy Tarreau wrote: On Tue, Nov 18, 2014 at 09:56:13PM +0100, Mariusz Gorski wrote: Use a macro instead of magic number comparison for checking whether a module param value has been set. Signed-off-by: Mariusz Gorski marius.gor...@gmail.com

Re: [PATCH 7/9] staging: panel: Refactor LCD init code

2014-11-18 Thread Mariusz Gorski
On Tue, Nov 18, 2014 at 10:23:26PM +0100, Willy Tarreau wrote: On Tue, Nov 18, 2014 at 09:56:12PM +0100, Mariusz Gorski wrote: Rework lcd_init method to make it a little bit more clear about the precedence of the params, move LCD geometry and pins layout to the LCD struct and thus make the

Re: [PATCH 7/9] staging: panel: Refactor LCD init code

2014-11-18 Thread Willy Tarreau
On Tue, Nov 18, 2014 at 10:51:08PM +0100, Mariusz Gorski wrote: On Tue, Nov 18, 2014 at 10:23:26PM +0100, Willy Tarreau wrote: On Tue, Nov 18, 2014 at 09:56:12PM +0100, Mariusz Gorski wrote: Rework lcd_init method to make it a little bit more clear about the precedence of the params, move

[PATCH v2] staging: lustre: mdc: use __FMODE_EXEC macro

2014-11-18 Thread Juston Li
FMODE_EXEC is type fmode_t but is used in operations with integers which leads to sparse warnings: drivers/staging/lustre/lustre/mdc/mdc_lib.c:198:21: warning: restricted fmode_t degrades to integer drivers/staging/lustre/lustre/mdc/mdc_locks.c:300:49: warning: restricted fmode_t degrades to

Caro usuário

2014-11-18 Thread ADMIN
Caro usuário Seu e-mail ultrapassou 2 GB criados pelo webmaster, que está atualmente em execução no 2.30GB, o que não é possível enviar ou receber nova mensagem dentro das próximas 24 horas, até que você verifique se você enviar e-mail da conta. Por favor, informe seus dados abaixo para