[PATCH v10 3/3] staging/android: refactor SYNC IOCTLs

2016-03-18 Thread Gustavo Padovan
From: Gustavo Padovan Change SYNC_IOC_FILE_INFO (former SYNC_IOC_FENCE_INFO) behaviour to avoid future API breaks and optimize buffer allocation. Now num_fences can be filled by the caller to inform how many fences it wants to retrieve from the kernel. If the

[PATCH 24/42] staging: comedi: ni_660x: add a comment about the initial DIO state

2016-03-18 Thread H Hartley Sweeten
The (*auto_attach) initializes all the DIO channels to a default state. Add a comment for clarity. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/ni_660x.c |

[PATCH 41/42] staging: comedi: ni_660x: refactor GPCT_OFFSET

2016-03-18 Thread H Hartley Sweeten
This driver supports boards that have 1 or 2 TIO chips with base addresses 0x800 apart. Replace the static const array 'GPCT_OFFSET' with a define and calculate the base address based on the chip index. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott

[PATCH 19/42] staging: comedi: ni_660x: Prefer 'unsigned int' to bare use of 'unsigned'

2016-03-18 Thread H Hartley Sweeten
Fix the checkpatch.pl issues. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/ni_660x.c | 40 1 file changed, 20

Re: [PATCH v9 2/3] kernel.h: add to_user_ptr()

2016-03-18 Thread Gustavo Padovan
2016-03-17 Joe Perches : > On Thu, 2016-03-17 at 18:19 -0300, Gustavo Padovan wrote: > > 2016-03-17 Joe Perches : > > > On Thu, 2016-03-17 at 16:50 -0400, Rob Clark wrote: > > > > On Thu, Mar 17, 2016 at 4:40 PM, Joe Perches wrote: > > > [] >

Re: staging: most: warning: ‘mbo’ may be used uninitialized in this function

2016-03-18 Thread Andrey Shvetsov
On Fri, Mar 18, 2016 at 01:41:19PM +0100, Geert Uytterhoeven wrote: > On Fri, Mar 18, 2016 at 6:42 AM, Linux Kernel Mailing List > wrote: > > Web: > > https://git.kernel.org/torvalds/c/f45b0fba43f415f69982df743dfa9b5d1b57785e > > Commit:

Re: [PATCH v9 2/3] kernel.h: add to_user_ptr()

2016-03-18 Thread Joe Perches
On Thu, 2016-03-17 at 18:19 -0300, Gustavo Padovan wrote: > 2016-03-17 Joe Perches : > > On Thu, 2016-03-17 at 16:50 -0400, Rob Clark wrote: > > > On Thu, Mar 17, 2016 at 4:40 PM, Joe Perches wrote: > > [] > > > > It's a name that seems like it should be a

re: staging: most: hdm-dim2: Replace request_irq with devm_request_irq

2016-03-18 Thread Dan Carpenter
Hello Amitoj Kaur Chawla, The patch 3eced21a5afb: "staging: most: hdm-dim2: Replace request_irq with devm_request_irq" from Feb 18, 2016, leads to the following static checker warning: drivers/staging/most/hdm-dim2/dim2_hdm.c:841 dim2_probe() error: 'dev->netinfo_task'

[PATCH] Drivers: hv: vmbus: handle various crash scenarios

2016-03-18 Thread Vitaly Kuznetsov
Kdump keeps biting. Turns out CHANNELMSG_UNLOAD_RESPONSE is always delivered to CPU0 regardless of what CPU we're sending CHANNELMSG_UNLOAD from. vmbus_wait_for_unload() doesn't account for the fact that in case we're crashing on some other CPU and CPU0 is still alive and operational

[PATCH 31/42] staging: comedi: ni_mio_common: ni_gpct_device_destroy() can handle a NULL pointer

2016-03-18 Thread H Hartley Sweeten
Remove the unnecessary NULL pointer check. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/ni_mio_common.c | 6 ++ 1 file changed, 2 insertions(+), 4

Re: [PATCH v9 2/3] kernel.h: add to_user_ptr()

2016-03-18 Thread Rob Clark
On Thu, Mar 17, 2016 at 5:19 PM, Gustavo Padovan wrote: > 2016-03-17 Joe Perches : > >> On Thu, 2016-03-17 at 16:50 -0400, Rob Clark wrote: >> > On Thu, Mar 17, 2016 at 4:40 PM, Joe Perches wrote: >> [] >> > > It's a name that seems like

[PATCH 38/42] staging: comedi: ni_660x: sort enum ni_660x_register

2016-03-18 Thread H Hartley Sweeten
Sort this enum so that it has a 1:1 relationship with the ni_tio.h enum ni_gpct_register. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/ni_660x.c | 95

[PATCH 5/5] Drivers: hv: vmbus: Implement copy-free read APIs

2016-03-18 Thread K. Y. Srinivasan
Implement copy-free read APIs. Signed-off-by: K. Y. Srinivasan --- drivers/hv/ring_buffer.c | 55 ++ include/linux/hyperv.h |6 + 2 files changed, 61 insertions(+), 0 deletions(-) diff --git a/drivers/hv/ring_buffer.c

[PATCH 0/2] Add antenna selection code to rtl8723be

2016-03-18 Thread Larry Finger
These patches fix a problem that occurs for laptops that are constructed with only a single antenna, but have an incorrect programming of the on-board EEPROM. These changes have been extensively tested in the rtlwifi_new repo at GitHub.com. As the patches fix a deficiency rather than a bug, they

Re: [PATCH 1/1] scsi: storvsc: Support manual scan of FC hosts on Hyper-V

2016-03-18 Thread James Bottomley
On Wed, 2016-03-16 at 23:15 +, KY Srinivasan wrote: > > > -Original Message- > > From: James Bottomley [mailto:james.bottom...@hansenpartnership.com > > ] > > Sent: Wednesday, March 16, 2016 4:08 PM > > To: Martin K. Petersen ; KY Srinivasan > >

[PATCH 1/2] rtlwifi: rtl8723be: Add antenna select module parameter

2016-03-18 Thread Larry Finger
A number of new laptops have been delivered with only a single antenna. In principle, this is OK; however, a problem arises when the on-board EEPROM is programmed to use the other antenna connection. The option of opening the computer and moving the connector is not always possible as it will void

[PATCH 37/42] staging: comedi: ni_660x: remove inline mite_ring()

2016-03-18 Thread H Hartley Sweeten
This fuction just returns a pointer from the private data. The name might provide some confusion since it appears to be an exported function from the mite driver. Just remove it and get the pointer directly where needed. Signed-off-by: H Hartley Sweeten Cc: Ian

[PATCH 0/5] Drivers: hv: vmbus

2016-03-18 Thread K. Y. Srinivasan
Cleanup the Hyper-V ring buffer code. Also Implement APIs for supporting copy-free operations on the read side. K. Y. Srinivasan (5): Drivers: hv: vmbus: Introduce functions for estimating room in the ring buffer Drivers: hv: vmbus: Use READ_ONCE() to read variables that are volatile

[PATCH 2/2] storvsc_drv: make use of the lightweight FC transport class

2016-03-18 Thread James Bottomley
Signed-off-by: James Bottomley --- drivers/scsi/storvsc_drv.c | 11 +++ 1 file changed, 3 insertions(+), 8 deletions(-) diff --git a/drivers/scsi/storvsc_drv.c b/drivers/scsi/storvsc_drv.c index 3ddcabb..dcb7393 100644 --- a/drivers/scsi/storvsc_drv.c +++

Re: [PATCH] staging: refresh TODO for rtl8723au

2016-03-18 Thread Joe Perches
On Fri, 2016-03-18 at 23:58 -0400, Jes Sorensen wrote: > Joe Perches writes: > > On Fri, 2016-03-18 at 13:42 -0400, Jes Sorensen wrote: > > > Xose Vazquez Perez writes: > > > > > > > > People should not waste time and energy working on this staging

[PATCH 2/5] Drivers: hv: vmbus: Use READ_ONCE() to read variables that are volatile

2016-03-18 Thread K. Y. Srinivasan
Use the READ_ONCE macro to access variabes that can change asynchronously. Signed-off-by: K. Y. Srinivasan --- drivers/hv/ring_buffer.c |7 --- 1 files changed, 4 insertions(+), 3 deletions(-) diff --git a/drivers/hv/ring_buffer.c b/drivers/hv/ring_buffer.c index

[PATCH] Staging: fsl-mc: Fix up bad parameters to dev_err and dev_dbg

2016-03-18 Thread Guenter Roeck
The first parameter to dev_dbg() and dev_err() is struct device *, not struct device **. Fixes: de71daf5c839 ("Staging: fsl-mc: Replace pr_debug with dev_dbg") Fixes: 454b0ec8bf99 ("Staging: fsl-mc: Replace pr_err with dev_err") Cc: Bhumika Goyal Signed-off-by: Guenter Roeck

[PATCH] de-stage android sync framework

2016-03-18 Thread Gustavo Padovan
From: Gustavo Padovan Hi, This is the first step and the most important one of the de-stage of the the sync framework, it de-stage the sync_file part which is used to send/receive fence file descriptors with the userspace. These patches sits on top of the sync

Re: [PATCH] staging: refresh TODO for rtl8723au

2016-03-18 Thread Jes Sorensen
Joe Perches writes: > On Fri, 2016-03-18 at 13:42 -0400, Jes Sorensen wrote: >> Xose Vazquez Perez writes: >> > People should not waste time and energy working on this staging driver. >> > A replacement(rtl8xxxu) using the kernel wireless stack already

Re: [PATCH] staging: rtl8192e: fixed coding style issues

2016-03-18 Thread Yousof El-Sayed
Hi, Thank you for the email, apologies for that I'll get that sorted out now. Thanks again On Thu, Mar 17, 2016 at 10:11:18AM -0700, Greg KH wrote: > On Thu, Mar 17, 2016 at 04:55:37PM +, Yousof El-Sayed wrote: > > Signed-off-by: Yousof El-Sayed > > I

[PATCH] staging: rtl8188eu: remove return at end of void function call

2016-03-18 Thread Nicholas Sim
Remove unnecessary return statement from last line of void function call Signed-off-by: Nicholas Sim --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c

[PATCH 0/9] Fix Smatch warnings in rtlwifi family of drivers

2016-03-18 Thread Larry Finger
Today's patch by Arndt Bergman showing an indentation problem in rtl8821ae told me that it was time for rechecking all the code for indentation and other problems. Along with Arndt's patch, there are no remaining Smatch warnings. As with all other cleanup patches, these have low priority. Larry

Re: [PATCH] [media] media: rename media unregister function

2016-03-18 Thread Sakari Ailus
Shuah Khan wrote: > On 03/18/2016 08:12 AM, Javier Martinez Canillas wrote: >> Hello Shuah, >> >> On 03/18/2016 11:01 AM, Shuah Khan wrote: >>> On 03/18/2016 07:05 AM, Mauro Carvalho Chehab wrote: Now that media_device_unregister() also does a cleanup, rename it to

[PATCH 4/9] rtlwifi: rtl8192c-common: Fix Smatch warning

2016-03-18 Thread Larry Finger
Smatch lists the following: CHECK drivers/net/wireless/realtek/rtlwifi/rtl8192c/dm_common.c drivers/net/wireless/realtek/rtlwifi/rtl8192c/dm_common.c:243 rtl92c_dm_false_alarm_counter_statistics() warn: inconsistent indenting Signed-off-by: Larry Finger ---

Re: [PATCH] [media] media: rename media unregister function

2016-03-18 Thread Javier Martinez Canillas
Hello Shuah, On 03/18/2016 11:01 AM, Shuah Khan wrote: > On 03/18/2016 07:05 AM, Mauro Carvalho Chehab wrote: >> Now that media_device_unregister() also does a cleanup, rename it >> to media_device_unregister_cleanup(). >> >> Signed-off-by: Mauro Carvalho Chehab > > I

Re: [PATCH 1/1] scsi: storvsc: Support manual scan of FC hosts on Hyper-V

2016-03-18 Thread James Bottomley
On Thu, 2016-03-17 at 00:01 +, KY Srinivasan wrote: > The only attributes I would be interested are: > 1) node name > 2) port name > > Ideally, if this can show under /sys/class/fc_host/hostx/port_name > and node_name, > it will be ideal since all user scripts can work. OK, like this? >From

Re: [PATCH] staging: refresh TODO for rtl8723au

2016-03-18 Thread Joe Perches
On Fri, 2016-03-18 at 13:42 -0400, Jes Sorensen wrote: > Xose Vazquez Perez writes: > > People should not waste time and energy working on this staging driver. > > A replacement(rtl8xxxu) using the kernel wireless stack already was merged > > in the 4.3 kernel. [] > >  

[PATCH 21/42] staging: comedi: ni_660x: tidy up Digital I/O subdevice init

2016-03-18 Thread H Hartley Sweeten
Add some whitespace to the Digital I/O subdevice init and add a comment about the channels. This driver is a bit goofy, only 32 of the 40 channels can actually be used for Digital I/Os and 32 of them can be routed to the counters for alternate use. Signed-off-by: H Hartley Sweeten

[PATCH 17/42] staging: comedi: ni_660x: remove enum ni_660x_subdevices

2016-03-18 Thread H Hartley Sweeten
Hard-coding the subdevice order is normally a bad idea. If a new subdevice is added, or removed, it could potentially break pretty badly. Remove the enum and associated NI_660X_GPCT_SUBDEV() helper that hard-code the subdevice order. Fix the (*auto_attach) so it initializes all the subdevices

[PATCH 00/42] staging: comedi: ni_660x: big driver cleanup

2016-03-18 Thread H Hartley Sweeten
This driver has a lot of checkpatch.pl issues: total: 0 errors, 71 warnings, 27 checks, 1222 lines checked There is also a lot of cruft that bloats the driver and makes it harder to follow. This series fixes all the checkpatch.pl issues: total: 0 errors, 0 warnings, 0 checks, 944 lines checked

[PATCH 14/42] staging: comedi: ni_660x: tidy up ni_660x_select_pfi_output()

2016-03-18 Thread H Hartley Sweeten
Tidy up this function to fix the checkpatch.pl issues: WARNING: Prefer 'unsigned int' to bare use of 'unsigned' For aesthetics, remove the static const local variables. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman

[PATCH 27/42] staging: comedi: ni_660x: fix memory barrier without comment

2016-03-18 Thread H Hartley Sweeten
Fix the checkpatch.pl issue. Move the memory barrier to a better place. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/ni_660x.c | 4 +++- 1 file changed, 3

[PATCH 33/42] staging: comedi: ni_660x: init TIO chips before subdevice init

2016-03-18 Thread H Hartley Sweeten
For aesthetics, initialize the TIO chips before the subdevices are allocated and initialized. Refactor the function to initialize all the TIO chips and move it to a better place in the driver. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc:

[PATCH 3/5] Drivers: hv: vmbus: Fix a bug in hv_need_to_signal_on_read()

2016-03-18 Thread K. Y. Srinivasan
We need to issue a full memory barrier prior making a signalling decision. Signed-off-by: K. Y. Srinivasan Cc: sta...@vger.kernel.org --- drivers/hv/ring_buffer.c |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/drivers/hv/ring_buffer.c

[PATCH 4/5] Drivers: hv: vmbus: Use the new virt_xx barrier code

2016-03-18 Thread K. Y. Srinivasan
Use the virt_xx barriers that have been defined for use in virtual machines. Signed-off-by: K. Y. Srinivasan --- drivers/hv/ring_buffer.c | 14 +++--- 1 files changed, 7 insertions(+), 7 deletions(-) diff --git a/drivers/hv/ring_buffer.c b/drivers/hv/ring_buffer.c