Re: [PATCH] staging: sm750fb: rename getChipType to get_chip_type

2016-09-24 Thread Moshe Green
On Fri, Sep 23, 2016 at 02:13:52PM +0200, Greg KH wrote: > On Thu, Sep 22, 2016 at 09:15:45PM +0300, Moshe Green wrote: > > Rename CamelCased function getChipType to get_chip_type. > > This issue was found by checkpatch.pl > > As this is a global function, can you rename it to something like >

Re: [PATCH 1/2] rtlwifi: Add HAL_DEF_WOWLAN case to *_get_hw() routines

2016-09-24 Thread Joe Perches
On Sat, 2016-09-24 at 11:57 -0500, Larry Finger wrote: > Only rtl8821ae implements WOWLAN; however, the other drivers may receive > a call requesting information about this mode. The other drivers need to > ignore the request rather than logging that the default branch of the > switch statement

Re: [PATCH 2/2] rtlwifi: Add explicit values to hw_variables enum

2016-09-24 Thread Joe Perches
On Sat, 2016-09-24 at 11:57 -0500, Larry Finger wrote: > The entries in this enum may be referenced in debug output. Adding explicit > values simplifies the lookup. A negative aspect to this style is forced renumbering if a HW_VAR entry is inserted. Is that possible?

Re: [PATCH 2/2] rtlwifi: Add explicit values to hw_variables enum

2016-09-24 Thread Larry Finger
On 09/24/2016 12:43 PM, Joe Perches wrote: On Sat, 2016-09-24 at 11:57 -0500, Larry Finger wrote: The entries in this enum may be referenced in debug output. Adding explicit values simplifies the lookup. A negative aspect to this style is forced renumbering if a HW_VAR entry is inserted. Is

[PATCH] greybus: audio: fix uninitialized variable errors found by cppcheck

2016-09-24 Thread Vaibhav Agarwal
Currently, if info is null, the dev_err message is dereferencing an uninitialized module pointer. Instead, it should use codec->dev pointer in dev_err call and better align with other err msg in this function. Also, ret variable might be used uninitialized in a specific case. Avoid using it this

[PATCH 0/2] rtlwifi: Add missing values to case statements and simplify debugging

2016-09-24 Thread Larry Finger
Routines *_get_hw_reg() for some of the drivers were missing entries for HAL_DEF_WOWLAN. No action should be taken for these drivers. Patch 1 depends on "realtek: Add switch variable to 'switch case not processed' messages" submitted by Joe Perches. That patch will log missing cases with the hex

[PATCHv2] staging: ion: Align cases with switch

2016-09-24 Thread Christopher Pezley
The preferred indentation for cases and switches has the cases at the same level as the switch. Signed-off-by: Christopher H. Pezley --- drivers/staging/android/ion/ion_of.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git

[PATCH 1/2] rtlwifi: Add HAL_DEF_WOWLAN case to *_get_hw() routines

2016-09-24 Thread Larry Finger
Only rtl8821ae implements WOWLAN; however, the other drivers may receive a call requesting information about this mode. The other drivers need to ignore the request rather than logging that the default branch of the switch statement has been reached. Reported by: Jean Delvare

[PATCH 2/2] rtlwifi: Add explicit values to hw_variables enum

2016-09-24 Thread Larry Finger
The entries in this enum may be referenced in debug output. Adding explicit values simplifies the lookup. Signed-off-by: Larry Finger --- drivers/net/wireless/realtek/rtlwifi/wifi.h | 208 ++-- 1 file changed, 104 insertions(+), 104

Re: [PATCH 1/2] Staging: ks7010: mark symbols static where possible

2016-09-24 Thread Arnd Bergmann
On Saturday, September 24, 2016 9:34:41 AM CEST Baoyou Xie wrote: > On 24 September 2016 at 01:10, Greg KH wrote: > > > On Fri, Sep 23, 2016 at 09:22:29PM +0800, Baoyou Xie wrote: > > > We get 3 warnings when building kernel with W=1: > > >