Re: [PATCH] stating: lustre: fix sparse error: incompatible types in comparison expression

2017-07-12 Thread Oleg Drokin
On Jul 12, 2017, at 10:10 PM, Rui Teng wrote: > Comparing two user space addresses to avoid sparse error: > > drivers/staging//lustre/lnet/selftest/conrpc.c:490:30: error: > incompatible types in comparison expression (different address spaces) > > Signed-off-by: Rui Teng

[PATCH] stating: lustre: fix sparse error: incompatible types in comparison expression

2017-07-12 Thread Rui Teng
Comparing two user space addresses to avoid sparse error: drivers/staging//lustre/lnet/selftest/conrpc.c:490:30: error: incompatible types in comparison expression (different address spaces) Signed-off-by: Rui Teng --- drivers/staging/lustre/lnet/selftest/conrpc.c

Re: [PATCH v5] staging: lustre: lnet: remove dead code and useless wrapper

2017-07-12 Thread Dilger, Andreas
On Jul 7, 2017, at 16:03, Dmitriy Cherkasov wrote: > > After removing commented out code, ksocknal_csum() becomes a useless > wrapper for crc32_le(). Remove it, and instead call crc32_le() directly. > > Fixes the following checkpatch warning: > > WARNING: space

Re: [PATCH v5] staging: lustre: lnet: remove dead code and useless wrapper

2017-07-12 Thread Dilger, Andreas
On Jul 7, 2017, at 16:03, Dmitriy Cherkasov wrote: > > After removing commented out code, ksocknal_csum() becomes a useless > wrapper for crc32_le(). Remove it, and instead call crc32_le() directly. > > Fixes the following checkpatch warning: > > WARNING: space

[PATCH] staging: wlan-ng: Fix endianness warnings

2017-07-12 Thread alfonsolimaastor
From: Alfonso Lima Astor These variables were set to u16 and u32 although they always hold a little endian value. This patch fixes multiple sparse warnings like: drivers/staging/wlan-ng/prism2sta.c:375:46: warning: cast to restricted __le16 Signed-off-by: Alfonso

[PATCH v2] [media] lirc_zilog: Clean up lirc zilog error codes

2017-07-12 Thread Yves Lemée
According the coding style guidelines, the ENOSYS error code must be returned in case of a non existent system call. This code has been replaced with the ENOTTY error code indicating a missing functionality. v2: Improved punctuation Fixed patch subject Signed-off-by: Yves Lemée

Re: [patch] staging: speakup: safely close tty

2017-07-12 Thread Alan Cox
> spk_ttyio_initialise_ldisc is called separately for each module (e.g. > speakup_apollo, speakup_ltlk etc) when it is loaded. spk_ttyio_release > is also called separately for each module when it is unloaded. The ldisc > stays around until the last of the modules is unloaded. What guarantees

Re: [patch 0/3] Re: tty contention resulting from tty_open_by_device export

2017-07-12 Thread Alan Cox
> When opening from kernel, we don't use file pointer. The count mismatch > is between tty->count and #fd's. So opening from kernel leads to #fd's > being less than tty->count. I thought this difference is relevant to > user-space opening of tty, and not to kernel opening of tty. Can you >

Re: [PATCH v2] [media] staging/imx: remove confusing IS_ERR_OR_NULL usage

2017-07-12 Thread Steve Longerbeam
On 07/12/2017 08:50 AM, Philipp Zabel wrote: On Tue, 2017-07-11 at 15:18 +0200, Arnd Bergmann wrote: While looking at a compiler warning, I noticed the use of IS_ERR_OR_NULL, which is generally a sign of a bad API design and should be avoided. In this driver, this is fairly easy, we can

Re: [PATCH] staging: wlan-ng: Use little-endian type

2017-07-12 Thread Aviv Palivoda
On Wed, Jul 12, 2017 at 07:26:08AM +0200, Frans Klaver wrote: > On Tue, Jul 11, 2017 at 9:51 PM, Aviv Palivoda wrote: > > Fix the following sparse warning: > > drivers/staging//wlan-ng/prism2sta.c:1691:20: warning: incorrect type in > > assignment (different base types) > > >

Re: [PATCH RESEND] staging: sm750fb: avoid conflicting vesafb

2017-07-12 Thread Sudip Mukherjee
On Wed, Jul 12, 2017 at 08:06:24AM +0200, Greg Kroah-Hartman wrote: > On Tue, Jul 11, 2017 at 10:03:01PM +0100, Sudip Mukherjee wrote: > > Hi Greg, > > > > On Fri, Jun 30, 2017 at 09:57:43PM +0100, Sudip Mukherjee wrote: > > > From: Teddy Wang > > > > > > > A

Re: [PATCH v2] [media] staging/imx: remove confusing IS_ERR_OR_NULL usage

2017-07-12 Thread Philipp Zabel
On Tue, 2017-07-11 at 15:18 +0200, Arnd Bergmann wrote: > While looking at a compiler warning, I noticed the use of > IS_ERR_OR_NULL, which is generally a sign of a bad API design > and should be avoided. > > In this driver, this is fairly easy, we can simply stop storing > error pointers in

Re: New Driver for electrical energy measurement

2017-07-12 Thread Christian Gromm
On Wed, 12 Jul 2017 18:28:56 +0530 PrasannaKumar Muralidharan wrote: > Hi Christian, > > On 12 July 2017 at 17:48, Christian Gromm > wrote: > > > > Hi, > > > > Microchip is planning to introduce a driver for a new companion > > chip

Re: New Driver for electrical energy measurement

2017-07-12 Thread Christian Gromm
On Wed, 12 Jul 2017 14:51:01 +0200 Greg KH wrote: > On Wed, Jul 12, 2017 at 02:18:54PM +0200, Christian Gromm wrote: > > > > Hi, > > > > Microchip is planning to introduce a driver for a new companion > > chip series capable of electical energy measurement. However,

Re: New Driver for electrical energy measurement

2017-07-12 Thread PrasannaKumar Muralidharan
Hi Christian, On 12 July 2017 at 17:48, Christian Gromm wrote: > > Hi, > > Microchip is planning to introduce a driver for a new companion chip series > capable of electical energy measurement. However, we are not sure which > location in the source tree is the

Re: New Driver for electrical energy measurement

2017-07-12 Thread Greg KH
On Wed, Jul 12, 2017 at 02:18:54PM +0200, Christian Gromm wrote: > > Hi, > > Microchip is planning to introduce a driver for a new companion chip series > capable of electical energy measurement. However, we are not sure which > location in the source tree is the most suitable. First thought was

Re: [PATCH] Staging: speakup: speakup_keypc.c: usleep_range is preferred over udelay

2017-07-12 Thread Samuel Thibault
Jaya Durga, on mer. 12 juil. 2017 16:53:53 +0530, wrote: > Fix checkpatch issue: CHECK: usleep_range is preferred over udelay; IIRC synth_immediate is meant to be usable in atomic contexts too, so usleep can't be used. Samuel ___ devel mailing list

Re: [PATCH] Staging: speakup: speakup_keypc.c: usleep_range is preferred over udelay

2017-07-12 Thread Greg KH
On Wed, Jul 12, 2017 at 04:53:53PM +0530, Jaya Durga wrote: > Fix checkpatch issue: CHECK: usleep_range is preferred over udelay; > > Signed-off-by: Jaya Durga > --- > drivers/staging/speakup/speakup_keypc.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > >

[PATCH] media: staging: atomisp: disable warnings with cc-disable-warning

2017-07-12 Thread Mauro Carvalho Chehab
Instead of directly using -Wno-foo, use cc-disable-warning, as it checks if the compiler has the warnings we want to disable. Signed-off-by: Mauro Carvalho Chehab --- drivers/staging/media/atomisp/pci/atomisp2/Makefile | 10 ++ 1 file changed, 6 insertions(+),

New Driver for electrical energy measurement

2017-07-12 Thread Christian Gromm
Hi, Microchip is planning to introduce a driver for a new companion chip series capable of electical energy measurement. However, we are not sure which location in the source tree is the most suitable. First thought was to put it into /drivers/powercap. But now we are in discussions whether it

[PATCH] Staging: speakup: speakup_keypc.c: usleep_range is preferred over udelay

2017-07-12 Thread Jaya Durga
Fix checkpatch issue: CHECK: usleep_range is preferred over udelay; Signed-off-by: Jaya Durga --- drivers/staging/speakup/speakup_keypc.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/speakup/speakup_keypc.c

[PATCH v2 3/4] Staging: Lustre Fixing multiline block comments in lnetst.h

2017-07-12 Thread Craig Inches
This fixes multiple block statements found not to match style as per checkpatch Signed-off-by: Craig Inches --- drivers/staging/lustre/include/linux/lnet/lnetst.h | 129 + 1 file changed, 81 insertions(+), 48 deletions(-) diff --git

[PATCH v2 4/4] Staging: Lustre Fix block statement style issue

2017-07-12 Thread Craig Inches
This fixes a block statement which didnt end with */ Signed-off-by: Craig Inches --- drivers/staging/lustre/include/linux/lnet/socklnd.h | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/lustre/include/linux/lnet/socklnd.h

[PATCH v2 2/4] Staging: Lustre Fix up multiple Block Comments in lib-types.h

2017-07-12 Thread Craig Inches
This patch fixes some multiline comment blocks which didnt conform to the style guide, found by checkpatch. Signed-off-by: Craig Inches --- .../staging/lustre/include/linux/lnet/lib-types.h | 46 ++ 1 file changed, 30 insertions(+), 16 deletions(-)

[PATCH v2 1/4] Staging: Lustre Clean up line over 80Char in lib-lnet.h

2017-07-12 Thread Craig Inches
This patch fixes a warning generated by checkpatch for a line over 80 characters. Signed-off-by: Craig Inches --- drivers/staging/lustre/include/linux/lnet/lib-lnet.h | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git

[PATCH v2 0/4] Staging: Lustre Style Fixes

2017-07-12 Thread Craig Inches
This series fixes a few style issues in lustre. All where picked up by checkpatch. v2 Changes: - Fixed typo in patch subject s/luster/lustre/ Craig

Re: [PATCH] Stagingdriver cctree: Fix for checkpatch warning

2017-07-12 Thread bincy
Hi Gilad, I have added your comments and resent the patch.Thanks On 11/07/17 17:16, Gilad Ben-Yossef wrote: Hello Philip, Thank your patch. Your patch subject line is not descriptive and not formatted well. A better subject would be something like: staging: ccree: move comment to fit

Re: [PATCH] drivers/staging/wilc1000: fix sparse warning: right shift by bigger than source value

2017-07-12 Thread Joe Perches
On Wed, 2017-07-12 at 08:12 +0200, Greg Kroah-Hartman wrote: > On Wed, Jul 12, 2017 at 10:23:02AM +0800, Rui Teng wrote: > > On 12/07/2017 1:04 AM, Greg Kroah-Hartman wrote: > > > On Mon, Jul 10, 2017 at 04:57:31PM +0800, Rui Teng wrote: > > > > This patch sets memory to zero directly to avoid

Re: [PATCH] staging: ks7010: fix styling WARNINGs

2017-07-12 Thread Frans Klaver
On Fri, Jun 30, 2017 at 8:39 PM, Mark Rogers wrote: > Thank you for your feedback. I guess when making this patch I had the > preferred coding style in mind, but didn't ask myself if making the code > conform to it would truly improve readability. > > I agree with all of

[PATCH] staging: rtl8188eu: memory leak in rtw_free_cmd_obj()

2017-07-12 Thread Dan Carpenter
We were fixing checkpatch.pl warnings and accidentally reversed this condition. Fixes: 5b291e3c ("staging: rtl8188eu: removes comparison to null") Signed-off-by: Dan Carpenter diff --git a/drivers/staging/rtl8188eu/core/rtw_cmd.c

Re: Submit of a driver for Pi433 - a radio module for Raspberry Pi

2017-07-12 Thread Greg KH
On Tue, Jul 11, 2017 at 06:02:09PM +0200, Marcus Wolf wrote: > Hi folks, > > I developed a radio shield for the 433MHz ISM band [0] for the Raspberry Pi. > This shield is called Pi433 [1]. It can be used to communicate between two > Raspberries or to control third party equipment e. g. cheap

[PATCH] staging: ccree: move comment to fit coding style

2017-07-12 Thread Bincy K Philip
Trivial fix for Line over 80 characters Moved the comment to top of the definition Signed-off-by: Bincy K Philip --- drivers/staging/ccree/cc_hw_queue_defs.h | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git

Re: [PATCH] drivers/staging/wilc1000: fix sparse warning: right shift by bigger than source value

2017-07-12 Thread Greg Kroah-Hartman
On Wed, Jul 12, 2017 at 10:23:02AM +0800, Rui Teng wrote: > On 12/07/2017 1:04 AM, Greg Kroah-Hartman wrote: > > On Mon, Jul 10, 2017 at 04:57:31PM +0800, Rui Teng wrote: > > > This patch sets memory to zero directly to avoid unnecessary shift and > > > bitwise operations on bool type, which can

Re: [PATCH RESEND] staging: sm750fb: avoid conflicting vesafb

2017-07-12 Thread Greg Kroah-Hartman
On Tue, Jul 11, 2017 at 10:03:01PM +0100, Sudip Mukherjee wrote: > Hi Greg, > > On Fri, Jun 30, 2017 at 09:57:43PM +0100, Sudip Mukherjee wrote: > > From: Teddy Wang > > > > If vesafb is enabled in the config then /dev/fb0 is created by vesa > > and this sm750