Re: [PATCH] staging: lustre: Use 'kvfree()' for memory allocated by 'kvzalloc()'

2018-05-12 Thread NeilBrown
On Sat, May 12 2018, Christophe JAILLET wrote: > 'buf' is allocated with 'kvzalloc()'. 'kvfree()' must be used to free it. > > Signed-off-by: Christophe JAILLET Reviewed-by: NeilBrown Thanks. We could possible add: Fixes: 11c647caf74b ("staging:

[PATCH] staging: mt7621-eth: Refactor ethtool stats

2018-05-12 Thread Kamal Heib
This patch removes the ugly macro hack to make sure hw_stats and ethtool strings are consisten, instead define a new struct which will hold the stat string and his index within the hw_stats struct. Signed-off-by: Kamal Heib --- drivers/staging/mt7621-eth/ethtool.c | 49

Re: [PATCH v3 9/9] staging: iio: tsl2x7x/tsl2772: move out of staging

2018-05-12 Thread Jonathan Cameron
On Sat, 12 May 2018 08:36:30 -0400 Brian Masney wrote: > On Sat, May 12, 2018 at 12:44:37PM +0100, Jonathan Cameron wrote: > > On Thu, 10 May 2018 20:32:06 -0400 > > Brian Masney wrote: > > > > > On Thu, May 10, 2018 at 08:12:23PM -0400, Brian

RE: [PATCH char-misc 1/2] Drivers: hv: vmbus: Remove x86 MSR refs in arch independent code

2018-05-12 Thread Michael Kelley (EOSG)
> > -#define hv_init_timer(timer, tick) wrmsrl(timer, tick) > > -#define hv_init_timer_config(config, val) wrmsrl(config, val) > > +#define hv_init_timer(timer, tick) \ > > + wrmsrl(HV_X64_MSR_STIMER0_COUNT + (2*timer), tick) > > +#define hv_init_timer_config(timer, val) \ > > +

Re: [PATCH v3 9/9] staging: iio: tsl2x7x/tsl2772: move out of staging

2018-05-12 Thread Brian Masney
On Sat, May 12, 2018 at 12:44:37PM +0100, Jonathan Cameron wrote: > On Thu, 10 May 2018 20:32:06 -0400 > Brian Masney wrote: > > > On Thu, May 10, 2018 at 08:12:23PM -0400, Brian Masney wrote: > > > Move the tsl2772 driver out of staging and into mainline. > > > > Hey

[PATCH] staging: lustre: Use 'kvfree()' for memory allocated by 'kvzalloc()'

2018-05-12 Thread Christophe JAILLET
'buf' is allocated with 'kvzalloc()'. 'kvfree()' must be used to free it. Signed-off-by: Christophe JAILLET --- drivers/staging/lustre/lustre/obdclass/llog.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [PATCH v3 9/9] staging: iio: tsl2x7x/tsl2772: move out of staging

2018-05-12 Thread Jonathan Cameron
On Thu, 10 May 2018 20:32:06 -0400 Brian Masney wrote: > On Thu, May 10, 2018 at 08:12:23PM -0400, Brian Masney wrote: > > Move the tsl2772 driver out of staging and into mainline. > > Hey Jonathan, > > Here is the .c and .h file to make your review easier. Thanks for

Re: [PATCH v3 8/9] staging: iio: tsl2x7x: rename driver to tsl2772

2018-05-12 Thread Jonathan Cameron
On Thu, 10 May 2018 20:12:22 -0400 Brian Masney wrote: > This patch renames this driver from tsl2x7x to tsl2772 since it is > highly likely that additional devices will be added to this driver that > do not match that wildcard. The tsl2772 driver name was selected since >

Re: [PATCH v3 7/9] staging: iio: tsl2x7x: add range checking to tsl2x7x_write_raw

2018-05-12 Thread Jonathan Cameron
On Thu, 10 May 2018 20:12:21 -0400 Brian Masney wrote: > The CALIBBIAS and INT_TIME masks in tsl2x7x_write_raw did not have any > range checking in place so this patch adds the appropriate range > checking. The defines TSL2X7X_ALS_GAIN_TRIM_{MIN,MAX} are also > introduced

Re: [PATCH v3 6/9] staging: iio: tsl2x7x: correct IIO_EV_INFO_PERIOD values

2018-05-12 Thread Jonathan Cameron
On Thu, 10 May 2018 20:12:20 -0400 Brian Masney wrote: > The thresh periods assumed an integration time of 3ms. This patch adds > support for the correct integration time (2.72ms or 2.73ms). The code > had the ALS filter values as going up to 15, however the values

Re: [PATCH v3 4/9] staging: iio: tsl2x7x: use macro to populate tsl2X7X_device_info

2018-05-12 Thread Jonathan Cameron
On Thu, 10 May 2018 20:12:18 -0400 Brian Masney wrote: > This patch creates a macro that populates the tsl2X7X_device_info > structure to reduce duplicated code in the driver. > > Signed-off-by: Brian Masney Applied. Thanks, Jonathan > --- >

Re: [PATCH v3 5/9] staging: iio: tsl2x7x: convert to use read_avail

2018-05-12 Thread Jonathan Cameron
On Thu, 10 May 2018 20:12:19 -0400 Brian Masney wrote: > Make the sysfs attributes in_proximity0_calibscale_available, and > in_intensity0_{calibscale,integration_time}_available be created > using info_mask_separate_available on the channel configuration. > > The driver

Re: [PATCH v3 3/9] staging: iio: tsl2x7x: turn chip off if IIO device registration fails

2018-05-12 Thread Jonathan Cameron
On Thu, 10 May 2018 20:12:17 -0400 Brian Masney wrote: > This patch turns the chip off if IIO device registration fails so that > the error handling mirrors the device remove to make review easier in > preparation for moving this driver out of staging. > > This patch also

Re: [PATCH v3 2/9] staging: iio: tsl2x7x: use direct returns

2018-05-12 Thread Jonathan Cameron
On Thu, 10 May 2018 20:12:16 -0400 Brian Masney wrote: > This patch changes the functions tsl2x7x_read_event_value() and > tsl2x7x_read_raw() to use direct returns to simplify the code. > > Signed-off-by: Brian Masney Applied, thanks Jonathan >

Re: [PATCH v3 1/9] staging: iio: tsl2x7x: remove unnecessary whitespace

2018-05-12 Thread Jonathan Cameron
On Thu, 10 May 2018 20:12:15 -0400 Brian Masney wrote: > This patch removes unnecessary whitespace in preparation for moving this > driver out of staging. > > Signed-off-by: Brian Masney Applied to the togreg branch of iio.git and pushed out as

[PATCH 1/1] Drivers: hv: vmbus: enable VMBus protocol version 5.0

2018-05-12 Thread kys
From: Dexuan Cui With VMBus protocol 5.0, we're able to better support new features, e.g. running two or more VMBus drivers simultaneously in a single VM -- note: we can't simply load the current VMBus driver twice, instead, a secondary VMBus driver must be implemented.

[PATCH 1/1] doc: fix sysfs ABI documentation

2018-05-12 Thread kys
From: Stephen Hemminger In 4.9 kernel, the sysfs files for Hyper-V VMBus changed name but the documentation files were not updated. The current sysfs file names are /sys/bus/vmbus/devices//... See commit 9a56e5d6a0ba ("Drivers: hv: make VMBus bus ids persistent") and

RE: [PATCH char-misc 1/2] Drivers: hv: vmbus: Remove x86 MSR refs in arch independent code

2018-05-12 Thread KY Srinivasan
> -Original Message- > From: mhkelle...@gmail.com > Sent: Tuesday, May 8, 2018 8:38 AM > To: gre...@linuxfoundation.org; linux-ker...@vger.kernel.org; > de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com; > vkuzn...@redhat.com; jasow...@redhat.com; >

Re: [lustre-devel] [PATCH] staging: lustre: Fix an error handling path in 'client_common_fill_super()'

2018-05-12 Thread Dilger, Andreas
On May 12, 2018, at 00:33, Christophe JAILLET wrote: > > According to error handling path before and after this one, we should go > to 'out_md_fid' here, instead of 'out_md', if 'obd_connect()' fails. > > Signed-off-by: Christophe JAILLET

[PATCH] staging: lustre: Fix an error handling path in 'client_common_fill_super()'

2018-05-12 Thread Christophe JAILLET
According to error handling path before and after this one, we should go to 'out_md_fid' here, instead of 'out_md', if 'obd_connect()' fails. Signed-off-by: Christophe JAILLET --- The last goto 'out_lock_cn_cb' looks spurious but is correct. In case of error,