Re: [PATCH v3 3/8] staging: rtl8192u: User memset to initialize memory, instead of loop.

2018-06-25 Thread Greg Kroah-Hartman
On Mon, Jun 25, 2018 at 08:50:26PM +0100, John Whitmore wrote: > On Mon, Jun 25, 2018 at 02:05:04PM +0100, Justin Skists wrote: > > > > > On 25 June 2018 at 13:36 John Whitmore wrote: > > > > > > > > > On Mon, Jun 25, 2018 at 12:06:30PM +0300, Andy Shevchenko wrote: > > > > On Sun, Jun 24,

Re: [PATCH v3 5/8] staging: rtl8192u: Use %s and __func__ instead of hardcoded string - Style

2018-06-25 Thread Greg KH
On Sun, Jun 24, 2018 at 04:34:51PM +0100, John Whitmore wrote: > Changed a number of hard coded function names to use %s and __func__ > > Mailing list response suggest that there is a better method for debugging > using netdev_dbg(). I can't argue with that, but for the moment this change > will

Re: Do Qualcomm drivers use DMA buffers for request_firmware_into_buf()?

2018-06-25 Thread Bjorn Andersson
On Thu 07 Jun 11:42 PDT 2018, Ard Biesheuvel wrote: > On 7 June 2018 at 20:21, Bjorn Andersson wrote: > > On Thu 07 Jun 09:33 PDT 2018, Greg Kroah-Hartman wrote: [..] > >> > >> Why not just use kmalloc, it will always return a DMAable buffer. > >> > > > > For the buffers being targeted by

RE: [PATCH 3/4] x86/hyper-v: use cheaper HVCALL_SEND_IPI hypercall when possible

2018-06-25 Thread Michael Kelley (EOSG)
> -Original Message- > From: Vitaly Kuznetsov > Sent: Friday, June 22, 2018 10:06 AM > To: x...@kernel.org > Cc: de...@linuxdriverproject.org; linux-ker...@vger.kernel.org; KY Srinivasan > ; Haiyang Zhang ; Stephen > Hemminger > ; Thomas Gleixner ; Ingo Molnar > ; H. Peter Anvin ; Tianyu

RE: Will the name of hyperv_clocksource_tsc_page or hyperv_clocksource pages change?

2018-06-25 Thread Alma Eyre (Sonata Software North America)
Thank you everybody for your help. I have passed this information along to the customer and asked for the reason they want to refer to the name of the clocksource. エアー・アルマ Professional Direct Delivery Manager Email: v-ale...@microsoft.com Microsoft Azure Professional Direct Services 日本 +81

RE: [PATCH 2/4] x86/hyper-v: use 'fast' hypercall for HVCALL_SEND_IPI

2018-06-25 Thread Michael Kelley (EOSG)
> -Original Message- > From: Vitaly Kuznetsov > Sent: Friday, June 22, 2018 10:06 AM > To: x...@kernel.org > Cc: de...@linuxdriverproject.org; linux-ker...@vger.kernel.org; KY Srinivasan > ; Haiyang Zhang ; Stephen > Hemminger > ; Thomas Gleixner ; Ingo Molnar > ; H. Peter Anvin ; Tianyu

[PATCH] staging: rtl8188eu: add SPDX identifiers

2018-06-25 Thread Michael Straube
This satisfies a checkpatch warning and is the preferred method for notating the license. The SPDX identifier is a legally binding shorthand, which can be used instead of the full boiler plate text. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_ap.c| 10

Re: [PATCH v3 3/8] staging: rtl8192u: User memset to initialize memory, instead of loop.

2018-06-25 Thread John Whitmore
On Mon, Jun 25, 2018 at 02:05:04PM +0100, Justin Skists wrote: > > > On 25 June 2018 at 13:36 John Whitmore wrote: > > > > > > On Mon, Jun 25, 2018 at 12:06:30PM +0300, Andy Shevchenko wrote: > > > On Sun, Jun 24, 2018 at 6:34 PM, John Whitmore > > > wrote: > > > > Replaced memory

[PATCH v2] staging:iio:impedance-analyzer:ad5933: Macro replacement Cleanups.

2018-06-25 Thread Karim Eshapa
Doing some macro replacement to start an array of structures so it can be reused by manipulating it with different values. Signed-off-by: Karim Eshapa --- .../staging/iio/impedance-analyzer/ad5933.c | 57 +++ 1 file changed, 19 insertions(+), 38 deletions(-) diff --git

[PATCH v2 3/4] staging: rtl8723bs: use ether_addr_copy() in rtw_macaddr_cfg()

2018-06-25 Thread Michael Straube
Use ether_addr_copy() instead of memcpy() to copy the mac address. Signed-off-by: Michael Straube --- drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c

[PATCH v2 4/4] staging: rtl8723bs: use mac_pton() in rtw_macaddr_cfg()

2018-06-25 Thread Michael Straube
Use the mac_pton() helper to convert the mac address string. The functions key_char2num() and key_2char2num() are not used anywhere else and can be removed. This also has the benefit of validating the input since mac_pton() returns false if the string is not valid. Signed-off-by: Michael

[PATCH v2 2/4] staging: rtl8723bs: refactor rtw_macaddr_cfg()

2018-06-25 Thread Michael Straube
Using is_broadcast_ether_addr() and is_zero_ether_addr() instead of testing each byte of the mac[] array for 0xff and 0x00 shortens the code and improves readability. If np == NULL, of_get_property() returns NULL, hence the "np" check is not needed. Instead of a fixed default mac address use a

[PATCH v2 1/4] staging: rtl8723bs: fix comparsion to NULL - coding style

2018-06-25 Thread Michael Straube
Fix comparsion to NULL issues found by checkpatch. Use !x instead of x == NULL. Signed-off-by: Michael Straube --- drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c

[PATCH v2] staging: rtl8723bs: remove rtw_set_tx_chksum_offload()

2018-06-25 Thread Michael Straube
The function rtw_set_tx_chksum_offload() has empty definition. Signed-off-by: Michael Straube --- drivers/staging/rtl8723bs/core/rtw_xmit.c | 2 -- drivers/staging/rtl8723bs/include/xmit_osdep.h | 2 -- drivers/staging/rtl8723bs/os_dep/xmit_linux.c | 5 - 3 files changed, 9

Re: [PATCH] staging: media: omap4iss: Added SPDX license identifiers

2018-06-25 Thread Laurent Pinchart
Hi Daniel, Thank you for the patch. On Monday, 25 June 2018 16:21:32 EEST Daniel Graefe wrote: > Added missing SPDX license identifiers to all files of the omap4iss > driver. > > Most files already have license texts which clearly state them to be > licensed under GPL 2.0 or later. SPDX

Re: [PATCH v3] staging: pi433: replace simple switch statements

2018-06-25 Thread Dan Carpenter
If there are going to be actual users in the specific near term then that's fine. Otherwise if we're talking a year out, then it's too far away to predict what will happen a year from now so we should delete the dead weight. regards, dan carpenter ___

Re: [PATCH v3] staging: pi433: replace simple switch statements

2018-06-25 Thread marcus . wolf
Hi Dan, I'd like to mention once more, that the idea of the abstraction was to support multiple modules of Hope-RF. If the decision of the "team" of developer of this driver is, that it should be reduced to a Pi433 or RFM69CW driver only, I fully agree, that the abstraction layer isn't

[PATCH] staging: media: omap4iss: Added SPDX license identifiers

2018-06-25 Thread Daniel Graefe
Added missing SPDX license identifiers to all files of the omap4iss driver. Most files already have license texts which clearly state them to be licensed under GPL 2.0 or later. SPDX identifiers were added accordingly. Some files do not have any license text. SPDX identifiers for GPL 2.0 were

Re: [PATCH v3 3/8] staging: rtl8192u: User memset to initialize memory, instead of loop.

2018-06-25 Thread Justin Skists
> On 25 June 2018 at 13:36 John Whitmore wrote: > > > On Mon, Jun 25, 2018 at 12:06:30PM +0300, Andy Shevchenko wrote: > > On Sun, Jun 24, 2018 at 6:34 PM, John Whitmore > > wrote: > > > Replaced memory initialising loop with memset, as suggested by Andy > > > Shevchenko > > > > > > >

Re: [PATCH v3] staging: pi433: replace simple switch statements

2018-06-25 Thread Dan Carpenter
I'd still prefer if we just removed this abstraction entirely and used OPMODE_MODE_TRANSMIT everywhere instead of bringing "transmit" into it. I know that every author thinks their abstraction will definitely be useful in the future, but generally kernel style is to remove abstractions. But I

Re: [PATCH v3 3/8] staging: rtl8192u: User memset to initialize memory, instead of loop.

2018-06-25 Thread John Whitmore
On Mon, Jun 25, 2018 at 12:06:30PM +0300, Andy Shevchenko wrote: > On Sun, Jun 24, 2018 at 6:34 PM, John Whitmore > wrote: > > Replaced memory initialising loop with memset, as suggested by Andy > > Shevchenko > > > > Suggested-by ? > Em, not sure how to respond, it certainly wasn't my idea.

Re: [PATCH] staging: rtl8723bs: fix brace coding style issues

2018-06-25 Thread Dan Carpenter
On Mon, Jun 25, 2018 at 12:47:44PM +0300, Andy Shevchenko wrote: > On Fri, Jun 22, 2018 at 1:28 PM, Dan Carpenter > wrote: > > On Thu, Jun 21, 2018 at 08:21:55PM +0200, Michael Straube wrote: > >> Remove braces from single line if statements. > >> Also fix a comparsion to NULL in one of the

[PATCH] staging: pi433: cleanup comments in rf69.h

2018-06-25 Thread Valentin Vidic
Fixes checkpatch warning: WARNING: line over 80 characters Signed-off-by: Valentin Vidic --- drivers/staging/pi433/rf69.h | 9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/drivers/staging/pi433/rf69.h b/drivers/staging/pi433/rf69.h index c131ffbdc2db..d80c41966d39

[PATCH] staging: pi433: add SPDX-License-Identifier tag

2018-06-25 Thread Valentin Vidic
Use GPL-2.0+ based on the license text in each of the files. Signed-off-by: Valentin Vidic --- drivers/staging/pi433/pi433_if.c | 1 + drivers/staging/pi433/pi433_if.h | 3 ++- drivers/staging/pi433/rf69.c | 1 + drivers/staging/pi433/rf69.h | 3 ++-

Re: [PATCH v3 7/8] staging: rtl8192u: Correct if statement - Coding Style

2018-06-25 Thread John Whitmore
On Sun, Jun 24, 2018 at 08:59:22AM -0700, Joe Perches wrote: > Rather than doing individual patches for each line > with a whitespace issue, I think it'd be better to > do a single driver wide patch. > > Perhaps use a tool like: > > $ git ls-files drivers/staging/rtl8192u | > xargs

Re: [PATCH] staging: rtl8723bs: refactor rtw_macaddr_cfg()

2018-06-25 Thread Andy Shevchenko
On Sat, Jun 23, 2018 at 12:45 PM, Michael Straube wrote: > Using is_broadcast_ether_addr() and is_zero_ether_addr() instead of > testing each byte of the mac[] array for 0xff and 0x00 shortens the > code and improves readability. > > If np == NULL, of_get_property() returns NULL, hence the "np"

Re: [PATCH] staging: rtl8723bs: do not use assignment in if condition

2018-06-25 Thread Andy Shevchenko
On Fri, Jun 22, 2018 at 8:28 PM, Joe Perches wrote: > On Fri, 2018-06-22 at 14:48 +0200, Michael Straube wrote: >> On 06/22/18 12:57, Dan Carpenter wrote: > Output from checkpatch is not gospel and can be ignored > whenever appropriate. > > I think the below is ok: > > if

Re: [PATCH] staging: rtl8723bs: fix brace coding style issues

2018-06-25 Thread Andy Shevchenko
On Fri, Jun 22, 2018 at 1:28 PM, Dan Carpenter wrote: > On Thu, Jun 21, 2018 at 08:21:55PM +0200, Michael Straube wrote: >> Remove braces from single line if statements. >> Also fix a comparsion to NULL in one of the conditions. >> Issues found by checkpatch. >> >> Signed-off-by: Michael Straube

Re: [PATCH v3 3/8] staging: rtl8192u: User memset to initialize memory, instead of loop.

2018-06-25 Thread Andy Shevchenko
On Sun, Jun 24, 2018 at 6:34 PM, John Whitmore wrote: > Replaced memory initialising loop with memset, as suggested by Andy Shevchenko > Suggested-by ? > Signed-off-by: John Whitmore > --- > drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 5 + > 1 file changed, 1 insertion(+), 4