[PATCH 1/2] staging: erofs: fix compile error without built-in decompression support

2018-07-28 Thread Gao Xiang
This patch fixes incorrect code snippets due to spilt code into small patches by mistake. Link: https://lists.01.org/pipermail/kbuild-all/2018-July/050747.html Link: https://lists.01.org/pipermail/kbuild-all/2018-July/050750.html Reported-by: kbuild test robot Signed-off-by: Gao Xiang --- I

[PATCH 2/2] staging: erofs: fix conditional uninitialized `pcn' in z_erofs_map_blocks_iter

2018-07-28 Thread Gao Xiang
This patch adds error handling code for z_erofs_map_blocks_iter to fix the compiler blame. Signed-off-by: Gao Xiang --- let's solve the compiler warning first, more error handling code for other functions will be added in the future patch. drivers/staging/erofs/unzip_vle.c | 25

[staging:staging-next 560/569] drivers/staging//erofs/utils.c:189:12: error: implicit declaration of function 'erofs_shrink_workstation'

2018-07-28 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git staging-next head: 6d4abf1c0e265d8e99c155b91c1cf44e37793e53 commit: e7e9a307be9d75ecc3bf20b362af88140dfb4304 [560/569] staging: erofs: introduce workstation for decompression config: x86_64-randconfig-s0-07291008

[staging:staging-next 560/569] drivers/staging//erofs/utils.c:189:12: error: implicit declaration of function 'erofs_shrink_workstation'; did you mean 'erofs_shrink_scan'?

2018-07-28 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git staging-next head: 6d4abf1c0e265d8e99c155b91c1cf44e37793e53 commit: e7e9a307be9d75ecc3bf20b362af88140dfb4304 [560/569] staging: erofs: introduce workstation for decompression config: x86_64-randconfig-ws0-07290820

[PATCH v2 04/08] staging:rtl8192u: Remove unused union AC_PARAM - Style

2018-07-28 Thread John Whitmore
The union ACM_PARAM is never actually used in code so removed. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 15 --- 1 file changed, 15 deletions(-) diff --git

[PATCH v2 05/08] staging:rtl8192u: Remove unused union ECW -Style

2018-07-28 Thread John Whitmore
The union ECW is never used in code so has simply been removed. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 12 1 file changed, 12 deletions(-) diff --git

[PATCH v2 00/08] staging:rtl8192u: cleanup of rtl819x_Qos.h - Style

2018-07-28 Thread John Whitmore
These are a few coding style changes to the file drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h I had more patches in the list but had to dump some of the later patches as I made a mistake. Thought I'd send these 8. John Whitmore (8): staging:rtl8192u: Add spaces around operators - Style

[PATCH v2 03/08] staging:rtl8192u: Rename member variables - Style

2018-07-28 Thread John Whitmore
Rename the member variables of union aci_aifsn, which should be named in lowercase. The only member variable, of this union, which is actually used is 'acm'. This are coding style changes which should have no impact on runtime code execution. Signed-off-by: John Whitmore ---

[PATCH v2 07/08] staging:rtl8192u: Rename union QOS_TSINFO - Style

2018-07-28 Thread John Whitmore
The union QOS_TSINFO, as a type, should have a lowercase name. The union has therefore been renamed to qos_tsinfo. Additionally the 'typedef' directive has been removed to clear the checkpatch issue with defining new types. These are coding style changes which should have no impact on runtime

[PATCH v2 02/08] staging:rtl8192u: Rename ACI_AIFSN - Style

2018-07-28 Thread John Whitmore
Rename the union ACI_AIFSN to aci_aifsn and remove the typedef directive. The removal of the typedef clears the checkpatch issue with defining new types. The renaming is to adhere to the coding style where types are name in lower case. These changes are coding style changes which should have no

[PATCH v2 08/08] staging:rtl8192u: Remove unused constants - Style

2018-07-28 Thread John Whitmore
Remove defined constants from code, since they are never actually used in code. This is a simple coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 7 --- 1 file changed, 7

[PATCH v2 01/08] staging:rtl8192u: Add spaces around operators - Style

2018-07-28 Thread John Whitmore
Add the required spaces around '+' and '*' operators. This is a coding style change to clear the checkpatch issue. There should be no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH v2 06/08] staging:rtl8192u: Rename enum DIRECTION_VALUE - Style

2018-07-28 Thread John Whitmore
The enumerated type DIRECTION_VALUE should be named in lowercase to comply with coding standard so is renamed to direction_value. In addition the 'typedef' directive has been removed to clear the checkpatch issue with defining new types. These changes are coding style changes which should have no

Re: [PATCH 00/08] staging:rtl8192u: cleanup of rtl819x_Qos.h - Style

2018-07-28 Thread John Whitmore
On Sun, Jul 29, 2018 at 12:02:52AM +0100, John Whitmore wrote: > These are a few coding style changes to the file > drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h > I had more patches in the list but had to dump some of the later > patches as I made a mistake. Thought I'd send these 8. > > John

[PATCH 06/12] staging:rtl8192u: Rename enum DIRECTION_VALUE - Style

2018-07-28 Thread John Whitmore
The enumerated type DIRECTION_VALUE should be named in lowercase to comply with coding standard so is renamed to direction_value. In addition the 'typedef' directive has been removed to clear the checkpatch issue with defining new types. These changes are coding style changes which should have no

[PATCH 05/12] staging:rtl8192u: Remove unused union ECW -Style

2018-07-28 Thread John Whitmore
The union ECW is never used in code so has simply been removed. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 12 1 file changed, 12 deletions(-) diff --git

[PATCH 08/12] staging:rtl8192u: Remove unused constants - Style

2018-07-28 Thread John Whitmore
Remove defined constants from code, since they are never actually used in code. This is a simple coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 7 --- 1 file changed, 7

[PATCH 00/08] staging:rtl8192u: cleanup of rtl819x_Qos.h - Style

2018-07-28 Thread John Whitmore
These are a few coding style changes to the file drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h I had more patches in the list but had to dump some of the later patches as I made a mistake. Thought I'd send these 8. John Whitmore (8): staging:rtl8192u: Add spaces around operators - Style

[PATCH 01/12] staging:rtl8192u: Add spaces around operators - Style

2018-07-28 Thread John Whitmore
Add the required spaces around '+' and '*' operators. This is a coding style change to clear the checkpatch issue. There should be no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH 07/12] staging:rtl8192u: Rename union QOS_TSINFO - Style

2018-07-28 Thread John Whitmore
The union QOS_TSINFO, as a type, should have a lowercase name. The union has therefore been renamed to qos_tsinfo. Additionally the 'typedef' directive has been removed to clear the checkpatch issue with defining new types. These are coding style changes which should have no impact on runtime

[PATCH 04/12] staging:rtl8192u: Remove unused union AC_PARAM - Style

2018-07-28 Thread John Whitmore
The union ACM_PARAM is never actually used in code so removed. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 15 --- 1 file changed, 15 deletions(-) diff --git

[PATCH 02/12] staging:rtl8192u: Rename ACI_AIFSN - Style

2018-07-28 Thread John Whitmore
Rename the union ACI_AIFSN to aci_aifsn and remove the typedef directive. The removal of the typedef clears the checkpatch issue with defining new types. The renaming is to adhere to the coding style where types are name in lower case. These changes are coding style changes which should have no

[PATCH 03/12] staging:rtl8192u: Rename member variables - Style

2018-07-28 Thread John Whitmore
Rename the member variables of union aci_aifsn, which should be named in lowercase. The only member variable, of this union, which is actually used is 'acm'. This are coding style changes which should have no impact on runtime code execution. Signed-off-by: John Whitmore ---

[PATCH] staging: gasket: use NULL instead of 0 for null pointer

2018-07-28 Thread Dmitriy Cherkasov
Fixes sparse warning: Using plain integer as NULL pointer Signed-off-by: Dmitriy Cherkasov --- drivers/staging/gasket/gasket_page_table.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/gasket/gasket_page_table.c b/drivers/staging/gasket/gasket_page_table.c

[PATCH 4/4] Drivers: hv: vmbus: add numa_node to sysfs

2018-07-28 Thread kys
From: Stephen Hemminger Being able to find the numa_node for a device is useful for userspace drivers (DPDK) and also for diagnosing performance issues. This makes vmbus similar to pci. Signed-off-by: Stephen Hemminger Signed-off-by: K. Y. Srinivasan ---

[PATCH 2/4] Drivers: hv: vmbus: Fix the issue with freeing up hv_ctl_table_hdr

2018-07-28 Thread kys
From: Sunil Muthuswamy The check to free the Hyper-V control table header was reversed. This fixes it. Fixes: 81b18bce48af ("Drivers: HV: Send one page worth of kmsg dump over Hyper-V during panic") Signed-off-by: Sunil Muthuswamy Signed-off-by: K. Y. Srinivasan --- drivers/hv/vmbus_drv.c

[PATCH 3/4] Drivers: hv: vmbus: Get rid of MSR access from vmbus_drv.c

2018-07-28 Thread kys
From: Sunil Muthuswamy Get rid of ISA specific code from vmus_drv.c which is common code. Fixes: 81b18bce48af ("Drivers: HV: Send one page worth of kmsg dump over Hyper-V during panic") Signed-off-by: Sunil Muthuswamy Signed-off-by: K. Y. Srinivasan --- arch/x86/include/asm/mshyperv.h | 3

[PATCH 1/4] Drivers: hv: vmus: Fix the check for return value from kmsg get dump buffer

2018-07-28 Thread kys
From: Sunil Muthuswamy The code to support panic control message was checking the return was checking the return value from kmsg_dump_get_buffer as error value, which is not what the routine returns. This fixes it. Fixes: 81b18bce48af ("Drivers: HV: Send one page worth of kmsg dump over

[PATCH 0/4] Drivers: hv: vmbus: Miscellaneous fixes/enhancements

2018-07-28 Thread kys
From: "K. Y. Srinivasan" Miscellaneous fixes/enhancements Stephen Hemminger (1): Drivers: hv: vmbus: add numa_node to sysfs Sunil Muthuswamy (3): Drivers: hv: vmus: Fix the check for return value from kmsg get dump buffer Drivers: hv: vmbus: Fix the issue with freeing up

RE: [PATCH] Drivers: HV: panic kmsg dump, move MSR access to arch specific

2018-07-28 Thread KY Srinivasan
> -Original Message- > From: Sunil Muthuswamy > Sent: Thursday, July 26, 2018 5:28 PM > To: KY Srinivasan ; Michael Kelley (EOSG) > > Cc: Stephen Hemminger ; Haiyang Zhang > ; de...@linuxdriverproject.org > Subject: RE: [PATCH] Drivers: HV: panic kmsg dump, move MSR access to arch >

[PATCH 1/1] staging: gasket: core: hold reference on device while in use

2018-07-28 Thread Todd Poynor
From: Todd Poynor Hold a reference on the struct device while a pointer to that device is in use by gasket. Reported-by: Greg Kroah-Hartman Signed-off-by: Todd Poynor --- drivers/staging/gasket/gasket_core.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH 0/1 v2] staging: gasket: fixes and cleanups

2018-07-28 Thread Todd Poynor
From: Todd Poynor The fun continues with gasket+apex: remove dead code and unnecessary stuff, fixup apex PCI class for devices that advertise class 0 (undefined), and make sure the struct device doesn't go away on us. Most of these from review comments of previous patch series. Changed patches

[PATCH] Staging: fbtft: fbtft-sysfs: fixed a 80 char line coding style issue Staging: fbtft: flexfb: fixed a 80 char line coding style issue

2018-07-28 Thread sepehrdad . dev
From: sepehrdad sh Fixed multiple coding style issue Signed-off-by: Sepehrdad Sh --- drivers/staging/fbtft/fbtft-sysfs.c | 6 -- drivers/staging/fbtft/flexfb.c | 22 +++--- 2 files changed, 19 insertions(+), 9 deletions(-) diff --git

Re: [PATCH v2 2/3] Staging: octeon-usb: Change coding style of CVMX_WAIT_FOR_FIELD32 marco.

2018-07-28 Thread Georgios Tsotsos
I will change it into function, as i checked so far i will need to change USB_SET_FIELD32 for the same reason. On Fri, 27 Jul 2018 at 18:15, Greg Kroah-Hartman wrote: > > On Thu, Jul 26, 2018 at 06:41:52PM +0300, Georgios Tsotsos wrote: > > Fixing coding style for CVMX_WAIT_FOR_FIELD32 was

[PATCH 3/3] staging: rtl8188eu: remove unused rtw_calculate_wlan_pkt_size_by_attribue()

2018-07-28 Thread Michael Straube
The function rtw_calculate_wlan_pkt_size_by_attribue() also defined as rtw_wlan_pkt_size() is never used, so remove it. Discovered by cppcheck. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_xmit.c| 18 -- drivers/staging/rtl8188eu/include/rtw_xmit.h |

[PATCH 1/3] staging: rtl8188eu: fix comparsions to NULL - coding style

2018-07-28 Thread Michael Straube
Use !x instead of x == NULL. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_xmit.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_xmit.c b/drivers/staging/rtl8188eu/core/rtw_xmit.c index

[PATCH 2/3] staging: rtl8188eu: replace tabs with spaces

2018-07-28 Thread Michael Straube
Replace tabs with spaces, clears a checkpatch 'line over 80 characters' warning. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_xmit.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_xmit.c

Re: [PATCH] staging: erofs: fix a compile warning of Z_EROFS_VLE_VMAP_ONSTACK_PAGES

2018-07-28 Thread Chao Yu
On 2018/7/28 15:10, Gao Xiang wrote: > There is a type mismatch in the definition of > Z_EROFS_VLE_VMAP_ONSTACK_PAGES, let's fix it. > > Link: https://lists.01.org/pipermail/kbuild-all/2018-July/050707.html > Reported-by: kbuild test robot > Signed-off-by: Gao Xiang Reviewed-by: Chao Yu

Re: [PATCH 00/25] staging: erofs: introduce erofs file system

2018-07-28 Thread Chao Yu
Hello Greg, On 2018/7/28 15:25, Greg Kroah-Hartman wrote: > > Thanks for submitting this, the filesystem looks very interesting. I've > queued it all up now in the staging-next tree. Thanks very much for queuing erofs filesystem, that's actually excellent news for us that it can be upstreamed

Re: [PATCH 00/25] staging: erofs: introduce erofs file system

2018-07-28 Thread Gao Xiang
On 2018/7/28 15:25, Greg Kroah-Hartman wrote: > Thanks for submitting this, the filesystem looks very interesting. I've > queued it all up now in the staging-next tree. Thanks for applying, we are continuously optimizing further and hope to attract more fs guys :) Thanks, Gao Xiang

Re: [PATCH 00/25] staging: erofs: introduce erofs file system

2018-07-28 Thread Greg Kroah-Hartman
On Thu, Jul 26, 2018 at 08:21:43PM +0800, Gao Xiang wrote: > Hi, > > This is actually the 2nd patchset of erofs file system, > the original patchset can be found at > > Link: https://marc.info/?l=linux-fsdevel=152776480425624 > > In order to keep up with the mainline linux-kernel changes and >

Re: [PATCH 5/5] staging: gasket: core: hold reference on device kobj while in use

2018-07-28 Thread Greg Kroah-Hartman
On Fri, Jul 27, 2018 at 10:22:00PM -0700, Todd Poynor wrote: > From: Todd Poynor > > Hold a reference on the struct device kobject while a pointer to that > device is in use by gasket. > > Reported-by: Greg Kroah-Hartman > Signed-off-by: Todd Poynor > --- >

[PATCH] staging: erofs: fix a compile warning of Z_EROFS_VLE_VMAP_ONSTACK_PAGES

2018-07-28 Thread Gao Xiang
There is a type mismatch in the definition of Z_EROFS_VLE_VMAP_ONSTACK_PAGES, let's fix it. Link: https://lists.01.org/pipermail/kbuild-all/2018-July/050707.html Reported-by: kbuild test robot Signed-off-by: Gao Xiang --- drivers/staging/erofs/unzip_vle.h | 2 +- 1 file changed, 1