[PATCH v2] staging: greybus: arche-platform: Switch to the gpio descriptor interface

2018-11-16 Thread Nishad Kamdar
Use the gpiod interface instead of the deprecated old non-descriptor interface. Signed-off-by: Nishad Kamdar --- Changes in v2: - Move comment to the same line as to what it applies to. --- drivers/staging/greybus/arche-platform.c | 119 --- 1 file changed, 41

Re: [PATCH] staging: greybus: arche-platform: Switch to the gpio descriptor interface

2018-11-16 Thread Nishad Kamdar
On Fri, Nov 16, 2018 at 05:06:22PM +0100, Johan Hovold wrote: > On Fri, Nov 16, 2018 at 08:47:44PM +0530, Nishad Kamdar wrote: > > Use the gpiod interface instead of the deprecated > > old non-descriptor interface. > > > > Signed-off-by: Nishad Kamdar > > --- > > Always include a change log

Re: [PATCH 4/6] dt-bindings:iio:resolver: Add docs for ad2s90

2018-11-16 Thread Matheus Tavares Bernardino
On Sun, Nov 11, 2018 at 9:48 AM Jonathan Cameron wrote: > > On Fri, 9 Nov 2018 20:00:42 -0200 > Matheus Tavares wrote: > > > This patch adds the device tree binding documentation for the ad2s90 > > resolver-to-digital converter. > > > > Signed-off-by: Matheus Tavares > > --- > >

[PATCH 2/2] staging: emxx_udc: Fixing function naming

2018-11-16 Thread Cristian Sicilia
Fix function naming and parenthesis. Signed-off-by: Cristian Sicilia --- drivers/staging/emxx_udc/emxx_udc.c | 212 1 file changed, 70 insertions(+), 142 deletions(-) diff --git a/drivers/staging/emxx_udc/emxx_udc.c b/drivers/staging/emxx_udc/emxx_udc.c

[PATCH 1/2] staging: emxx_udc: Split line and fix eol parenthesis

2018-11-16 Thread Cristian Sicilia
Fix some parenthesis opened at end of line. Signed-off-by: Cristian Sicilia --- drivers/staging/emxx_udc/emxx_udc.c | 73 ++--- 1 file changed, 36 insertions(+), 37 deletions(-) diff --git a/drivers/staging/emxx_udc/emxx_udc.c

[PATCH 0/2] Split line, fix eol parenthesis and fix functions

2018-11-16 Thread Cristian Sicilia
Patch 1: therea are some trying to split the line, but not shure about the result, like 1) reg_data = _nbu2ss_readl((u32 *)IO_ADDRESS(USB_BASE_ADDRESS + i)); 2) regdata = _nbu2ss_readl(>EP_REGS[ep->epnum -

[PATCH] staging: axis-fifo: Split line to stay in 80 characters.

2018-11-16 Thread Cristian Sicilia
The line is split up to stay in 80 characters- Signed-off-by: Cristian Sicilia --- drivers/staging/axis-fifo/axis-fifo.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/axis-fifo/axis-fifo.c b/drivers/staging/axis-fifo/axis-fifo.c index c18bf31..805437f

[PATCH 7/7] Staging: iio: adt7316: Use device tree data to assign irq_type

2018-11-16 Thread Shreeya Patel
ADT7316 driver no more uses platform data and hence use device tree data instead of platform data for assigning irq_type field. Switch case figures out the type of irq and if it's the default case then assign the default value to the irq_type i.e. irq_type = IRQF_TRIGGER_LOW Signed-off-by:

[PATCH 6/7] Staging: iio: adt7316: Change the name from irq_flags to irq_type

2018-11-16 Thread Shreeya Patel
Most of the drivers in IIO uses irq_type as the name for storing the interrupt type and hence change the name from irq_flags to irq_type for maintaining the consistency. Signed-off-by: Shreeya Patel --- drivers/staging/iio/addac/adt7316.c | 8 1 file changed, 4 insertions(+), 4

[PATCH 5/7] Staging: iio: adt7316: Switch irq_flags to a local variable

2018-11-16 Thread Shreeya Patel
There is no need to store irq_flags into the structure as it is always set to the same thing. Hence switch irq_flags to a local variable. Signed-off-by: Shreeya Patel --- drivers/staging/iio/addac/adt7316-i2c.c | 1 - drivers/staging/iio/addac/adt7316-spi.c | 1 -

[PATCH 4/7] Staging: iio: adt7316: Use device tree data to set ldac_pin

2018-11-16 Thread Shreeya Patel
Make the driver use device tree instead of the platform data. Hence, use devm_gpiod_get_optional function to get the data from device tree for ldac-pin and accordingly make the needed changes in the driver. Signed-off-by: Shreeya Patel --- drivers/staging/iio/addac/adt7316.c | 14 ++

[PATCH 3/7] Staging: iio: adt7316: Add of_device_id table

2018-11-16 Thread Shreeya Patel
When the kernel starts up, it kicks off compiled-in drivers that match “compatible” entries it finds in the device tree. At a later stage (when /lib/modules is available), all kernel modules that match “compatible” entries in the device tree are loaded. Hence to be able to use device tree for

[PATCH 2/7] Staging: iio: adt7316: Add an extra check for 'ret' equals to 0

2018-11-16 Thread Shreeya Patel
ret = 0 indicates a case of no error but no data read from the bus which is an invalid case. This case doesn't ever happen in reality. It should perhaps be handled for correctness though. Signed-off-by: Shreeya Patel --- drivers/staging/iio/addac/adt7316-i2c.c | 4 1 file changed, 4

[PATCH 1/7] Staging: iio: adt7316: Set the data field

2018-11-16 Thread Shreeya Patel
adt7316_i2c_read function nowhere sets the data field. It is necessary to have an appropriate value for it. Hence, assign the value stored in 'ret' variable to data field. Signed-off-by: Shreeya Patel --- drivers/staging/iio/addac/adt7316-i2c.c | 2 ++ 1 file changed, 2 insertions(+) diff

[PATCH 0/7] Remove platform data and introduce DT bindings

2018-11-16 Thread Shreeya Patel
This patchset introduces device tree bindings for adt7316 driver and removes the usage of platform data from it. Also, it sets the data field to it's appropriate value in the i2c read function which was nowhere being set before. Shreeya Patel (7): Staging: iio: adt7316: Set the data field

Re: [PATCH V4] binder: ipc namespace support for android binder

2018-11-16 Thread Todd Kjos
On Thu, Nov 15, 2018 at 2:54 PM gre...@linuxfoundation.org wrote: ... > > A number of us have talked about this in the plumbers Android track, and > a different proposal for how to solve this has been made that should be > much more resiliant. So I will drop this patch from my queue and wait >

Re: [PATCH 2/6] staging:iio:ad2s90: Remove spi setup that should be done via dt

2018-11-16 Thread Jonathan Cameron
On Thu, 15 Nov 2018 12:44:39 -0200 Matheus Tavares Bernardino wrote: > On Sun, Nov 11, 2018 at 9:42 AM Jonathan Cameron wrote: > > > > On Fri, 9 Nov 2018 20:00:40 -0200 > > Matheus Tavares wrote: > > > > > The ad2s90 driver currently sets some spi settings (max_speed_hz and > > > mode) at

Re: [PATCH v2 1/2] staging: iio: ad7780: check if ad778x before gain update

2018-11-16 Thread Jonathan Cameron
On Mon, 12 Nov 2018 07:57:58 + "Ardelean, Alexandru" wrote: > On Sun, 2018-11-11 at 12:58 +, Jonathan Cameron wrote: > > On Thu, 8 Nov 2018 13:44:17 + > > "Ardelean, Alexandru" wrote: > > > > > On Thu, 2018-11-08 at 11:03 -0200, Giuliano Belinassi wrote: > > > > Only the ad778x

Re: [PATCH v4 1/2] staging: iio: ad7780: update voltage on read

2018-11-16 Thread Jonathan Cameron
On Mon, 12 Nov 2018 07:57:24 + "Ardelean, Alexandru" wrote: > On Sun, 2018-11-11 at 14:30 +, Jonathan Cameron wrote: > > On Tue, 6 Nov 2018 09:24:44 + > > "Ardelean, Alexandru" wrote: > > > > > On Mon, 2018-11-05 at 17:14 -0200, Renato Lui Geh wrote: > > > > The ad7780 driver

Re: [PATCH RFC 0/6] mm/kdump: allow to exclude pages that are logically offline

2018-11-16 Thread David Hildenbrand
On 14.11.18 22:16, David Hildenbrand wrote: > Right now, pages inflated as part of a balloon driver will be dumped > by dump tools like makedumpfile. While XEN is able to check in the > crash kernel whether a certain pfn is actuall backed by memory in the > hypervisor (see xen_oldmem_pfn_is_ram)

Re: [PATCH v4 4/4] staging: iio: ad7816: Add device tree table.

2018-11-16 Thread Jonathan Cameron
On Thu, 15 Nov 2018 19:55:06 +0530 Nishad Kamdar wrote: > On Thu, Nov 15, 2018 at 08:16:03AM +, Ardelean, Alexandru wrote: > > On Wed, 2018-11-14 at 23:16 +0530, Nishad Kamdar wrote: > > > Add device tree table for matching vendor ID. > > > > > > > This could have been just one patch.

Re: [PATCH 08/15] ARM/arm64: sunxi: Move H3/H5 syscon label over to soc-specific nodes

2018-11-16 Thread Maxime Ripard
Hi, On Fri, Nov 16, 2018 at 05:47:50PM +0800, Chen-Yu Tsai wrote: > On Fri, Nov 16, 2018 at 5:39 PM Maxime Ripard > wrote: > > > > On Thu, Nov 15, 2018 at 03:50:06PM +0100, Paul Kocialkowski wrote: > > > Now that we have specific nodes for the H3 and H5 system-controller > > > that allow proper

[PATCH v2 08/17] Platform: OLPC: Move EC-specific functionality out from x86

2018-11-16 Thread Lubomir Rintel
Move the olpc-ec driver away from the X86 OLPC platform so that it could be used by the ARM based laptops too. Notably, the driver for the OLPC battery, which is also used on the ARM models, builds on this driver's interface. It is actually plaform independent: the OLPC EC commands with their

[PATCH v2 14/17] power: supply: olpc_battery: Move priv data to a struct

2018-11-16 Thread Lubomir Rintel
The global variables for private data are not too nice. I'd like some more, and that would clutter the global name space even further. Signed-off-by: Lubomir Rintel Reviewed-by: Andy Shevchenko --- Changes since v1: - Split out the move to devm_* into a separate patch

[PATCH v2 11/17] dt-bindings: olpc_battery: Add XO-1.5 battery

2018-11-16 Thread Lubomir Rintel
The XO-1 and XO-1.5 batteries apparently differ in an ability to report ambient temperature. Signed-off-by: Lubomir Rintel Reviewed-by: Rob Herring Acked-by: Pavel Machek --- Changes since v1: - Collected Reviewed-by and Acked-by tags

[PATCH v2 16/17] power: supply: olpc_battery: Avoid using platform_info

2018-11-16 Thread Lubomir Rintel
This wouldn't work on the DT-based ARM platform. Let's read the EC version directly from the EC driver instead. This makes the driver no longer x86 specific. Signed-off-by: Lubomir Rintel Acked-by: Pavel Machek --- Changes since v1: - Use uint8_t instead of unsigned char [1] for ecver

[PATCH v2 17/17] power: supply: olpc_battery: Add OLPC XO 1.75 support

2018-11-16 Thread Lubomir Rintel
The battery and the protocol are essentially the same as OLPC XO 1.5, but the responses from the EC are LSB first. Signed-off-by: Lubomir Rintel Acked-by: Pavel Machek --- Changes since v1: - s/s16 ecword_to_cpu/u16 ecword_to_cpu/ - s/u16 ec_byte/u16 ec_word/

[PATCH v2 06/17] Platform: OLPC: Add XO-1.75 EC driver

2018-11-16 Thread Lubomir Rintel
It's based off the driver from the OLPC kernel sources. Somewhat modernized and cleaned up, for better or worse. Modified to plug into the olpc-ec driver infrastructure (so that battery interface and debugfs could be reused) and the SPI slave framework. Signed-off-by: Lubomir Rintel ---

[PATCH v2 03/17] Platform: OLPC: Remove an unused include

2018-11-16 Thread Lubomir Rintel
Also, the header is x86 specific, while there are non-x86 OLPC machines. Signed-off-by: Lubomir Rintel Acked-by: Pavel Machek --- drivers/platform/olpc/olpc-ec.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/platform/olpc/olpc-ec.c b/drivers/platform/olpc/olpc-ec.c index

[PATCH v2 04/17] Revert "platform/olpc: Make ec explicitly non-modular"

2018-11-16 Thread Lubomir Rintel
It doesn't make sense to always have this built-in, e.g. on ARM multiplatform kernels. A better way to address the problem the original commit aimed to solve is to fix Kconfig. That is what the next commit in the series does. This reverts commit f48d1496b8537d75776478c6942dd87f34d7f270.

[PATCH v2 09/17] Platform: OLPC: Use BIT() and GENMASK() for event masks

2018-11-16 Thread Lubomir Rintel
Just a cosmetic tidy-up. Signed-off-by: Lubomir Rintel --- Changes since v1: - This patch was added to the set. include/linux/olpc-ec.h | 23 --- 1 file changed, 12 insertions(+), 11 deletions(-) diff --git a/include/linux/olpc-ec.h b/include/linux/olpc-ec.h index

[PATCH v2 05/17] Platform: OLPC: Move OLPC config symbol out of x86 tree

2018-11-16 Thread Lubomir Rintel
There are ARM OLPC machines that use mostly the same drivers, including EC infrastructure, DCON and Battery. While at that, fix Kconfig to allow building this as a module. Signed-off-by: Lubomir Rintel Acked-by: Pavel Machek --- Changes since v1: - Use 'depends on OLPC && X86' idiom (thanks

[PATCH v2 02/17] dt-bindings: olpc, xo1.75-ec: Add OLPC XO-1.75 EC bindings

2018-11-16 Thread Lubomir Rintel
The OLPC XO-1.75 Embedded Controller is a SPI master that uses extra signals for handshaking. It needs to know when is the slave (Linux) side's TX FIFO ready for transfer (the ready-gpio signal on the SPI controller node) and when does it wish to respond with a command (the cmd-gpio property).

[PATCH v2 15/17] power: supply: olpc_battery: Use devm_power_supply_register()

2018-11-16 Thread Lubomir Rintel
This simplifies the error handling. Signed-off-by: Lubomir Rintel --- Changes since v1: - This was split off the "power: supply: olpc_battery: Move priv data to a struct" patch. drivers/power/supply/olpc_battery.c | 19 +-- 1 file changed, 5 insertions(+), 14 deletions(-)

[PATCH v2 12/17] x86, olpc: Use a correct version when making up a battery node

2018-11-16 Thread Lubomir Rintel
The XO-1 and XO-1.5 batteries apparently differ in an ability to report ambient temperature. Add a different compatible string to the 1.5 battery. Signed-off-by: Lubomir Rintel Acked-by: Pavel Machek --- Changes since v1: - Avoid splitting string literals arch/x86/platform/olpc/olpc_dt.c |

[PATCH v2 0/17] Add support for OLPC XO 1.75 Embedded Controller

2018-11-16 Thread Lubomir Rintel
Hi everyone! This is a second spin of the patch set that adds support for the Embedded Controller on an OLPC XO 1.75 machine. OLPC XO 1.75 is a MMP2 based ARM laptop. It plugs into the existing OLPC platform infrastructure, currently used by the x86 based models. The slave mode support for

[PATCH v2 07/17] Platform: OLPC: Avoid a warning if the EC didn't register yet

2018-11-16 Thread Lubomir Rintel
Just return ENODEV, so that whoever attempted to use the EC call can defer their work. Signed-off-by: Lubomir Rintel Acked-by: Pavel Machek --- Changes since v1: - EPROBE_DEFER instead of ENODEV drivers/platform/olpc/olpc-ec.c | 7 +-- 1 file changed, 5 insertions(+), 2 deletions(-)

[PATCH v2 01/17] power: supply: olpc_battery: correct the temperature units

2018-11-16 Thread Lubomir Rintel
According to [1] and [2], the temperature values are in tenths of degree Celsius. Exposing the Celsius value makes the battery appear on fire: $ upower -i /org/freedesktop/UPower/devices/battery_olpc_battery ... temperature: 236.9 degrees C Tested on OLPC XO-1 and OLPC XO-1.75

[PATCH v2 10/17] Platform: OLPC: add a regulator for the DCON

2018-11-16 Thread Lubomir Rintel
All OLPC ECs are able to turn the power to the DCON on an off. Use the regulator framework to expose the functionality. Signed-off-by: Lubomir Rintel --- Changes since v1: - Use idiomatic form of return on error - Avoid mixing bool and int drivers/platform/olpc/Kconfig | 1 +

[PATCH v2 13/17] power: supply: olpc_battery: Use DT to get battery version

2018-11-16 Thread Lubomir Rintel
Avoid using the x86 OLPC platform specific call to get the board version. It won't work on FDT-based ARM MMP2 platform. Signed-off-by: Lubomir Rintel Reviewed-by: Andy Shevchenko Acked-by: Pavel Machek --- Changes since v1: - Sort the new include a bit higher

Re: [PATCH] staging: greybus: arche-platform: Switch to the gpio descriptor interface

2018-11-16 Thread Johan Hovold
On Fri, Nov 16, 2018 at 08:47:44PM +0530, Nishad Kamdar wrote: > Use the gpiod interface instead of the deprecated > old non-descriptor interface. > > Signed-off-by: Nishad Kamdar > --- Always include a change log here after the cut-off line so we know what changed since previous versions.

[PATCH] staging: greybus: arche-platform: Switch to the gpio descriptor interface

2018-11-16 Thread Nishad Kamdar
Use the gpiod interface instead of the deprecated old non-descriptor interface. Signed-off-by: Nishad Kamdar --- drivers/staging/greybus/arche-platform.c | 120 --- 1 file changed, 42 insertions(+), 78 deletions(-) diff --git a/drivers/staging/greybus/arche-platform.c

Re: RFC: staging: gasket: re-implement using UIO

2018-11-16 Thread Ahmed S. Darwish
Hi Todd, On Tue, Nov 06, 2018 at 04:20:49PM -0800, Todd Poynor wrote: > On Mon, Sep 10, 2018 at 8:28 AM Ahmed S. Darwish wrote: > > > > The gasket in-kernel framework, recently introduced under staging, > > re-implements what is already long-time provided by the UIO > > subsystem, with extra PCI

Re: [PATCH] media: cedrus: Remove global IRQ spin lock from the driver

2018-11-16 Thread Maxime Ripard
On Thu, Nov 15, 2018 at 03:39:55PM +0100, Paul Kocialkowski wrote: > We initially introduced a spin lock to ensure that the VPU registers > are not accessed concurrently between our setup function and IRQ > handler. Because the V4L2 M2M API only allows one job to run at a time > and our jobs are

Re: [PATCH 01/15] ARM: dts: sun8i-a33: Remove heading 0 in video-codec unit address

2018-11-16 Thread Paul Kocialkowski
Hi, Le jeudi 15 novembre 2018 à 23:50 +0800, Chen-Yu Tsai a écrit : > On Thu, Nov 15, 2018 at 10:50 PM Paul Kocialkowski > wrote: > > This cosmetic change removes the heading 0 in the video-codec unit > > address, as it's done for other nodes. > > > > Signed-off-by: Paul Kocialkowski > > Nit:

Re: [PATCH 08/15] ARM/arm64: sunxi: Move H3/H5 syscon label over to soc-specific nodes

2018-11-16 Thread Paul Kocialkowski
Hi, Le vendredi 16 novembre 2018 à 17:47 +0800, Chen-Yu Tsai a écrit : > On Fri, Nov 16, 2018 at 5:39 PM Maxime Ripard > wrote: > > On Thu, Nov 15, 2018 at 03:50:06PM +0100, Paul Kocialkowski wrote: > > > Now that we have specific nodes for the H3 and H5 system-controller > > > that allow

Re: [PATCH 08/15] ARM/arm64: sunxi: Move H3/H5 syscon label over to soc-specific nodes

2018-11-16 Thread Chen-Yu Tsai
On Fri, Nov 16, 2018 at 5:39 PM Maxime Ripard wrote: > > On Thu, Nov 15, 2018 at 03:50:06PM +0100, Paul Kocialkowski wrote: > > Now that we have specific nodes for the H3 and H5 system-controller > > that allow proper access to the EMAC clock configuration register, > > we no longer need a common

Re: [PATCH 15/15] arm64: dts: allwinner: a64: Add Video Engine and reserved memory node

2018-11-16 Thread Maxime Ripard
On Thu, Nov 15, 2018 at 03:50:13PM +0100, Paul Kocialkowski wrote: > This adds nodes for the Video Engine and the associated reserved memory > for the A64. Up to 96 MiB of memory are dedicated to the CMA pool. > > The pool is located at the end of the first 256 MiB of RAM so that the > VPU can

Re: [PATCH 08/15] ARM/arm64: sunxi: Move H3/H5 syscon label over to soc-specific nodes

2018-11-16 Thread Maxime Ripard
On Thu, Nov 15, 2018 at 03:50:06PM +0100, Paul Kocialkowski wrote: > Now that we have specific nodes for the H3 and H5 system-controller > that allow proper access to the EMAC clock configuration register, > we no longer need a common dummy syscon node. > > Switch the syscon label over to each