Re: [PATCH v3 2/2] staging: erofs: fix i_blocks calculation

2019-05-27 Thread Chao Yu
On 2019/5/28 11:19, Gao Xiang wrote: > For compressed files, i_blocks should not be calculated > by using i_size. use i_u.compressed_blocks instead. > > In addition, i_blocks was miscalculated for non-compressed > files previously, fix it as well. > > Signed-off-by: Gao Xiang Reviewed-by: Chao

Re: [PATCH v3 1/2] staging: erofs: support statx

2019-05-27 Thread Chao Yu
On 2019/5/28 11:19, Gao Xiang wrote: > statx() has already been supported in commit a528d35e8bfc > ("statx: Add a system call to make enhanced file info available"), > user programs can get more useful attributes. > > Signed-off-by: Gao Xiang Reviewed-by: Chao Yu Thanks,

Re: [PATCH v2 2/2] staging: erofs: fix i_blocks calculation

2019-05-27 Thread Gao Xiang
On 2019/5/28 11:02, Chao Yu wrote: > On 2019/5/28 10:36, Gao Xiang wrote: >> For compressed files, i_blocks should not be calculated >> by using i_size. i_u.compressed_blocks is used instead. >> >> In addition, i_blocks was miscalculated for non-compressed >> files previously, fix it as well.

[PATCH v3 1/2] staging: erofs: support statx

2019-05-27 Thread Gao Xiang
statx() has already been supported in commit a528d35e8bfc ("statx: Add a system call to make enhanced file info available"), user programs can get more useful attributes. Signed-off-by: Gao Xiang --- change log v3: - update attributes_mask to indicate bits which erofs support as Chao pointed

[PATCH v3 2/2] staging: erofs: fix i_blocks calculation

2019-05-27 Thread Gao Xiang
For compressed files, i_blocks should not be calculated by using i_size. use i_u.compressed_blocks instead. In addition, i_blocks was miscalculated for non-compressed files previously, fix it as well. Signed-off-by: Gao Xiang --- change log v3: - wrap i.u.compressed_blocks with le32_to_cpu()

Re: [PATCH v2 2/2] staging: erofs: fix i_blocks calculation

2019-05-27 Thread Chao Yu
On 2019/5/28 10:36, Gao Xiang wrote: > For compressed files, i_blocks should not be calculated > by using i_size. i_u.compressed_blocks is used instead. > > In addition, i_blocks was miscalculated for non-compressed > files previously, fix it as well. > > Signed-off-by: Gao Xiang > --- > change

Re: [PATCH 1/2] staging: erofs: support statx

2019-05-27 Thread Gao Xiang
Hi Chao, On 2019/5/28 10:44, Chao Yu wrote: > On 2019/5/28 10:31, Gao Xiang wrote: >> statx() has already been supported in commit a528d35e8bfc >> ("statx: Add a system call to make enhanced file info available"), >> user programs can get more useful attributes. >> >> Signed-off-by: Gao Xiang >>

Re: [PATCH 1/2] staging: erofs: support statx

2019-05-27 Thread Chao Yu
On 2019/5/28 10:31, Gao Xiang wrote: > statx() has already been supported in commit a528d35e8bfc > ("statx: Add a system call to make enhanced file info available"), > user programs can get more useful attributes. > > Signed-off-by: Gao Xiang > --- > drivers/staging/erofs/inode.c| 18

[PATCH v2 2/2] staging: erofs: fix i_blocks calculation

2019-05-27 Thread Gao Xiang
For compressed files, i_blocks should not be calculated by using i_size. i_u.compressed_blocks is used instead. In addition, i_blocks was miscalculated for non-compressed files previously, fix it as well. Signed-off-by: Gao Xiang --- change log v2: - fix description in commit message - fix to

[PATCH 2/2] staging: erofs: fix i_blocks calculation

2019-05-27 Thread Gao Xiang
For compressed files, i_blocks should not be calculated by using i_size. i_u.compressed_blocks is used instead. In addition, i_blocks is miscalculated for non-compressed files previously, fix it as well. Signed-off-by: Gao Xiang --- drivers/staging/erofs/inode.c | 14 -- 1 file

[PATCH 1/2] staging: erofs: support statx

2019-05-27 Thread Gao Xiang
statx() has already been supported in commit a528d35e8bfc ("statx: Add a system call to make enhanced file info available"), user programs can get more useful attributes. Signed-off-by: Gao Xiang --- drivers/staging/erofs/inode.c| 18 ++ drivers/staging/erofs/internal.h | 2

Re: [PATCH -next v2] staging: kpc2000: Remove set but not used variable ‘status’

2019-05-27 Thread maowenan
please ignore v2 version. I will send v3 later according to Sven Van Asbroeck 's comments. On 2019/5/25 16:13, Mao Wenan wrote: > Fixes gcc '-Wunused-but-set-variable' warning: > > drivers/staging/kpc2000/kpc_spi/spi_driver.c: In function > ‘kp_spi_transfer_one_message’: >

Re: [PATCH 2/3] mm: remove cleancache.c

2019-05-27 Thread Chao Yu
On 2019/5/27 18:32, Juergen Gross wrote: > With the removal of tmem and xen-selfballoon the only user of > cleancache is gone. Remove it, too. > > Signed-off-by: Juergen Gross > --- > Documentation/vm/cleancache.rst | 296 > Documentation/vm/frontswap.rst

Re: [PATCH 2/3] mm: remove cleancache.c

2019-05-27 Thread Joseph Qi
On 19/5/27 18:32, Juergen Gross wrote: > With the removal of tmem and xen-selfballoon the only user of > cleancache is gone. Remove it, too. > > Signed-off-by: Juergen Gross > --- > Documentation/vm/cleancache.rst | 296 > Documentation/vm/frontswap.rst

Re: [PATCH] drivers: staging: speakup: serialio: fix warning linux/serial.h is included more than once

2019-05-27 Thread Samuel Thibault
Hariprasad Kelam, le dim. 26 mai 2019 12:43:22 +0530, a ecrit: > fix below warning reported by includecheck > > ./drivers/staging/speakup/serialio.h: linux/serial.h is included more > than once. > > Signed-off-by: Hariprasad Kelam That was indeed the result of

[PATCH v2 2/4] iio: adc: ad7606: Add software configuration

2019-05-27 Thread Beniamin Bia
Because this driver will support multiple configurations for software, the software configuration was made generic. Signed-off-by: Beniamin Bia Acked-by: Jonathan Cameron --- Changes in v2: -nothing changed drivers/iio/adc/ad7606.c | 40 +---

Re: [PATCH 2/3] mm: remove cleancache.c

2019-05-27 Thread David Sterba
On Mon, May 27, 2019 at 12:32:06PM +0200, Juergen Gross wrote: > With the removal of tmem and xen-selfballoon the only user of > cleancache is gone. Remove it, too. > > Signed-off-by: Juergen Gross > --- > Documentation/vm/cleancache.rst | 296 >

[PATCH v2 1/4] iio: adc: ad7606: Move oversampling and scale options to chip info

2019-05-27 Thread Beniamin Bia
The device dependent options which are going to be different for devices which will be supported in the future by this driver, were moved in chip info for a more generic driver. This patch allows supporting more devices by the driver. Also, it is an intermediate step of adding support for ad7616

[PATCH v2 4/4] iio: adc: ad7606: Add debug mode for ad7616

2019-05-27 Thread Beniamin Bia
Support for register access was added for spi devices. Signed-off-by: Beniamin Bia Acked-by: Jonathan Cameron --- Changes in v2: -nothing changed drivers/iio/adc/ad7606.c | 25 + 1 file changed, 25 insertions(+) diff --git a/drivers/iio/adc/ad7606.c

[PATCH v2 3/4] iio: adc: ad7606: Add support for software mode for ad7616

2019-05-27 Thread Beniamin Bia
Support for ad7616 running in software was added. In order to activate the software mode, HW_RNGSEL pins must be pulled low. Oversampling and input ranges are now configured in corresponding registers. Ad7616 has multiple scale options when it is configured in software mode. Also, in order to

[PATCH 2/3] mm: remove cleancache.c

2019-05-27 Thread Juergen Gross
With the removal of tmem and xen-selfballoon the only user of cleancache is gone. Remove it, too. Signed-off-by: Juergen Gross --- Documentation/vm/cleancache.rst | 296 Documentation/vm/frontswap.rst | 10 +- Documentation/vm/index.rst | 1 -

[PATCH 0/3] remove tmem and code depending on it

2019-05-27 Thread Juergen Gross
Tmem has been an experimental Xen feature which has been dropped recently due to security problems and lack of maintainership. So it is time now to drop it in Linux kernel, too. Juergen Gross (3): xen: remove tmem driver mm: remove cleancache.c mm: remove tmem specifics from frontswap

Re: [PATCH v8 5/5] media: imx: Try colorimetry at both sink and source pads

2019-05-27 Thread Hans Verkuil
On 5/22/19 3:03 AM, Steve Longerbeam wrote: > Retask imx_media_fill_default_mbus_fields() to try colorimetry parameters, > renaming it to to imx_media_try_colorimetry(), and call it at both sink and > source pad try_fmt's. The unrelated check for uninitialized field value is > moved out to

Re: [PATCH 10/10] docs: fix broken documentation links

2019-05-27 Thread Rafael J. Wysocki
On Mon, May 20, 2019 at 4:48 PM Mauro Carvalho Chehab wrote: > > Mostly due to x86 and acpi conversion, several documentation > links are still pointing to the old file. Fix them. > > Signed-off-by: Mauro Carvalho Chehab For the ACPI part: Acked-by: Rafael J. Wysocki

Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-05-27 Thread Sergio Paracuellos
Hi Greg, On Mon, May 27, 2019 at 9:29 AM Greg Ungerer wrote: > > Hi Sergio, > > On 27/5/19 4:35 pm, Sergio Paracuellos wrote: > > On Mon, May 27, 2019 at 6:37 AM Greg Ungerer wrote: > >> On 24/5/19 3:35 pm, Sergio Paracuellos wrote: > >>> On Fri, May 24, 2019 at 2:35 AM Greg Ungerer wrote: >

Re: [PATCH] emxx_udc : Fix #if 0 coding style warning

2019-05-27 Thread Greg KH
On Sun, May 26, 2019 at 11:10:55PM +0300, Yacov Simhony wrote: > This patch fixes the checkpathc.pl warning: > WARNING: Consider removing the code enclosed by this #if 0 and its #endif > > Signed-off-by: Yacov Simhony > --- > drivers/staging/emxx_udc/emxx_udc.h | 6 ++ > 1 file changed, 2

Re: [PATCH 3/4] staging: kpc2000: add missing spaces in core.c

2019-05-27 Thread Dan Carpenter
On Fri, May 24, 2019 at 01:08:01PM +0200, Simon Sandström wrote: > Fixes checkpatch.pl errors "space required before the open brace '{'" > and "(foo*)" should be "(foo *)". > > Signed-off-by: Simon Sandström > --- > drivers/staging/kpc2000/kpc2000/core.c | 4 ++-- > 1 file changed, 2

Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-05-27 Thread Greg Ungerer
Hi Sergio, On 27/5/19 4:35 pm, Sergio Paracuellos wrote: On Mon, May 27, 2019 at 6:37 AM Greg Ungerer wrote: On 24/5/19 3:35 pm, Sergio Paracuellos wrote: On Fri, May 24, 2019 at 2:35 AM Greg Ungerer wrote: On 23/5/19 3:26 pm, Sergio Paracuellos wrote: On Thu, May 23, 2019 at 4:11 AM Greg

RE: [PATCH v2 1/2] dt-bindings: iio: adc: add adi, ad7780.yaml binding

2019-05-27 Thread Hennerich, Michael
> -Original Message- > From: Jonathan Cameron [mailto:ji...@kernel.org] > Sent: Sonntag, 26. Mai 2019 18:39 > To: Renato Lui Geh > Cc: l...@metafoo.de; Hennerich, Michael ; > knaac...@gmx.de; pme...@pmeerw.net; > gre...@linuxfoundation.org; Popa, Stefan Serban > ; Ardelean, Alexandru

Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-05-27 Thread Sergio Paracuellos
Hi Greg, On Mon, May 27, 2019 at 6:37 AM Greg Ungerer wrote: > > Hi Sergio, > > On 24/5/19 3:35 pm, Sergio Paracuellos wrote: > > On Fri, May 24, 2019 at 2:35 AM Greg Ungerer wrote: > >> On 23/5/19 3:26 pm, Sergio Paracuellos wrote: > >>> On Thu, May 23, 2019 at 4:11 AM Greg Ungerer wrote: >