[PATCH v2] staging: vt6655: Change return type of function and remove variable

2019-05-31 Thread Nishka Dasgupta
Remove return variable bResult from function CARDbRadioPowerOff and change the return type of the function to void as it always returns true and the return value is never stored nor checked when called. Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta ---

Re: [GIT PULL] Staging/IIO driver fixes for 5.2-rc3

2019-05-31 Thread pr-tracker-bot
The pull request you sent on Thu, 30 May 2019 18:47:32 -0700: > git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git > tags/staging-5.2-rc3 has been merged into torvalds/linux.git: https://git.kernel.org/torvalds/c/2209a3055d6f366eeb070c217491afe855d3f389 Thank you! --

[PATCH] staging: vc04_services: remove redundant assignment to pointer service

2019-05-31 Thread Colin King
From: Colin Ian King Pointer service is being set to NULL however this value is never read and so the assignment is redundant and can be removed. Addresses-Coverity: ("Unused value") Signed-off-by: Colin Ian King --- .../staging/vc04_services/interface/vchiq_arm/vchiq_shim.c| 4 +--- 1

Re: [PATCH] staging: comedi: Remove variable runflags

2019-05-31 Thread Dan Carpenter
Anyway, Greg was never going to apply this so it's not worth worrying about too much. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH] staging: comedi: Remove variable runflags

2019-05-31 Thread Nishka Dasgupta
On 31/05/19 3:55 PM, Ian Abbott wrote: On 30/05/2019 21:51, Nishka Dasgupta wrote: Remove variable runflags and use its value directly. Issue found with checkpatch. Signed-off-by: Nishka Dasgupta ---   drivers/staging/comedi/comedi_fops.c | 8 ++--   1 file changed, 2 insertions(+), 6

Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-05-31 Thread Greg Ungerer
Hi Sergio, On 31/5/19 10:37 pm, Sergio Paracuellos wrote: On Thu, May 30, 2019 at 3:46 AM Greg Ungerer wrote: On 30/5/19 10:44 am, Greg Ungerer wrote: On 29/5/19 6:08 pm, Sergio Paracuellos wrote: [snip] I have added gpio consumer stuff and reorder a bit the code to be more similar to 4.20.

Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-05-31 Thread Sergio Paracuellos
Hi Greg, On Thu, May 30, 2019 at 3:46 AM Greg Ungerer wrote: > > Hi Sergio, > > On 30/5/19 10:44 am, Greg Ungerer wrote: > > On 29/5/19 6:08 pm, Sergio Paracuellos wrote: > > [snip] > >> I have added gpio consumer stuff and reorder a bit the code to be more > >> similar to 4.20. > >> > >> I

[GIT PULL net-next, resend] isdn: deprecate non-mISDN drivers

2019-05-31 Thread Arnd Bergmann
[resending, rebased on top of today's net-next] The following changes since commit 7b3ed2a137b077bc0967352088b0adb6049eed20: Merge branch '100GbE' of git://git.kernel.org/pub/scm/linux/kernel/git/jkirsher/next-queue (2019-05-30 15:17:05 -0700) are available in the Git repository at:

Re: [PATCH] staging: kpc2000: replace bogus variable name in core.c

2019-05-31 Thread Dan Carpenter
On Wed, May 29, 2019 at 09:42:22PM +0200, Simon Sandström wrote: > "struct kp2000_regs temp" has nothing to do with temperatures, so > replace it with the more proper name "regs". > > Signed-off-by: Simon Sandström > --- Reviewed-by: Dan Carpenter regards, dan carpenter

[PATCH 2/2] staging: kpc2000: removed misc device.

2019-05-31 Thread Jeremy Sowden
Now that all the card information is available via sysfs, the misc device is no longer necessary. Removed it. Signed-off-by: Jeremy Sowden --- drivers/staging/kpc2000/kpc2000/core.c | 127 + drivers/staging/kpc2000/kpc2000/pcie.h | 2 - 2 files changed, 2

[PATCH 1/2] staging: kpc2000: export more device attributes via sysfs.

2019-05-31 Thread Jeremy Sowden
Added more read-only device attributes in order to expose all the information about the hardware which is available by calling read() or ioct() on the misc device associated with it. Signed-off-by: Jeremy Sowden --- drivers/staging/kpc2000/kpc2000/core.c | 57 ++ 1 file

[PATCH 0/2] staging: kpc2000: replace per-card misc devices.

2019-05-31 Thread Jeremy Sowden
Each card has a misc device associated with it. The devices are used to get access to various attributes of the hardware. Most of these attributes are also available via sysfs. Therefore, we make all the attributes available via sysfs and remove the devices. Jeremy Sowden (2): staging:

Re: [PATCH] staging: comedi: Remove variable runflags

2019-05-31 Thread Ian Abbott
On 30/05/2019 21:51, Nishka Dasgupta wrote: Remove variable runflags and use its value directly. Issue found with checkpatch. Signed-off-by: Nishka Dasgupta --- drivers/staging/comedi/comedi_fops.c | 8 ++-- 1 file changed, 2 insertions(+), 6 deletions(-) diff --git

Re: [PATCH] staging: rtl8712: ieee80211.c: Remove leading p from variable names

2019-05-31 Thread Dan Carpenter
On Fri, May 31, 2019 at 02:33:59AM +0530, Nishka Dasgupta wrote: > Remove leading p from the names of the following pointer variables: > - pregistrypriv > - pdev_network > - pie > - pbuf. > Issue found with Coccinelle. > > Signed-off-by: Nishka Dasgupta Reviewed-by: Dan Carpenter regards, dan

Re: [PATCH] staging: rtl8712: Replace function r8712_init_mlme_priv

2019-05-31 Thread Dan Carpenter
On Fri, May 31, 2019 at 02:25:31AM +0530, Nishka Dasgupta wrote: > Delete r8712_init_mlme_priv as it does nothing except call > _init_mlme_priv, and rename _init_mlme_priv to > r8712_init_mlme_priv. > Change the type of the new r8712_init_mlme_priv (formerly _init_mlme_priv) > to (non-static) int,