[PATCH v3 16/20] docs: fix broken documentation links

2019-06-07 Thread Mauro Carvalho Chehab
Mostly due to x86 and acpi conversion, several documentation links are still pointing to the old file. Fix them. Signed-off-by: Mauro Carvalho Chehab Reviewed-by: Wolfram Sang Reviewed-by: Sven Van Asbroeck Reviewed-by: Bhupesh Sharma Acked-by: Mark Brown --- Documentation/acpi/dsd/leds.txt

Re: [PATCH 2/2] staging: rtl8712: r8712_createbss_cmd(): Change

2019-06-07 Thread Dan Carpenter
Fix the subject. On Fri, Jun 07, 2019 at 07:36:58PM +0530, Nishka Dasgupta wrote: > Change return values of r8712_createbss_cmd from _SUCCESS and _FAIL to 0 > and -ENOMEM respectively. > Change return type of the function from unsigned to int to reflect this. > Change call site to check for 0

Re: [PATCH 1/2] staging: rtl8712: r8712_setdatarate_cmd(): Change

2019-06-07 Thread Dan Carpenter
Probably you sent this patch unintentionally. The subject doesn't make any sort of sense. :P On Fri, Jun 07, 2019 at 07:36:57PM +0530, Nishka Dasgupta wrote: > Change the return values of function r8712_setdatarate_cmd from _SUCCESS > and _FAIL to 0 and -ENOMEM respectively. > Change the return

[PATCH v2] staging: rtl8188eu: core: Replace function rtw_free_network_nolock()

2019-06-07 Thread Nishka Dasgupta
Remove function rtw_free_network_nolock, as all it does is call _rtw_free_network_nolock, and rename _rtw_free_network_nolock to rtw_free_network_nolock. Keep the new rtw_free_network_nolock a static function and remove the old version from the header file. Signed-off-by: Nishka Dasgupta ---

[PATCH 1/2] staging: rtl8712: r8712_setdatarate_cmd(): Change

2019-06-07 Thread Nishka Dasgupta
Change the return values of function r8712_setdatarate_cmd from _SUCCESS and _FAIL to 0 and -ENOMEM respectively. Change the return type of the function from u8 to int to reflect this. Change the call site of the function to check for 0 instead of _SUCCESS. (Checking that the return value != 0 is

[PATCH 2/2] staging: rtl8712: r8712_createbss_cmd(): Change

2019-06-07 Thread Nishka Dasgupta
Change return values of r8712_createbss_cmd from _SUCCESS and _FAIL to 0 and -ENOMEM respectively. Change return type of the function from unsigned to int to reflect this. Change call site to check for 0 instead of _SUCCESS. (Instead of !=0, simply passing the function output to the conditional

Re: [PATCH] staging: rtl8723bs: Fix Unneeded variable: "ret". Return "0"

2019-06-07 Thread Bastien Nocera
On Thu, 2019-06-06 at 20:10 -0700, Shobhit Kukreti wrote: > coccicheck reported Unneeded variable ret at > rtl8723bs/core/rtw_ap.c:1400. > Function "rtw_acl_remove_sta" always returns 0. Modified return type > of the > function to void. > > Signed-off-by: Shobhit Kukreti Looks good, thanks.

[PATCH] staging: rtl8723bs: os_dep: ioctl_linux.c: Remove return variables

2019-06-07 Thread Nishka Dasgupta
Remove return variables and return the values directly, as the functions all return 0 in all cases. Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta --- drivers/staging/rtl8723bs/os_dep/ioctl_linux.c | 12 +++- 1 file changed, 3 insertions(+), 9 deletions(-) diff --git

[PATCH 1/2] staging: rtl8723bs: rtw_os_recv_resource_alloc(): Change type

2019-06-07 Thread Nishka Dasgupta
Remove assignment of the return value of rtw_os_recv_resource_alloc as this assignment at the call site is never used. Remove return statement from rtw_os_recv_resource_alloc() as its return variable is never used. Change the type of the function to void. Signed-off-by: Nishka Dasgupta ---

[PATCH 2/2] staging: rtl8723bs: rtw_os_recvbuf_resource_free(): Change type

2019-06-07 Thread Nishka Dasgupta
Change return type of function rtw_os_recvbuf_resource_free to void as its return value is never stored, checked or otherwise used. Signed-off-by: Nishka Dasgupta --- drivers/staging/rtl8723bs/include/recv_osdep.h | 2 +- drivers/staging/rtl8723bs/os_dep/recv_linux.c | 6 +- 2 files

[PATCH] staging: rtl8723bs: hal: sdio_halinit.c: Remove variables

2019-06-07 Thread Nishka Dasgupta
Remove the variables RegRATR and RegRRSR as they are never used after initialisation and assignment. Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta --- drivers/staging/rtl8723bs/hal/sdio_halinit.c | 11 --- 1 file changed, 11 deletions(-) diff --git

[PATCH] staging: rtl8723bs: hal: hal_btcoex.c: Remove variable

2019-06-07 Thread Nishka Dasgupta
Remove variable and use the values directly. Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta --- drivers/staging/rtl8723bs/hal/hal_btcoex.c | 10 ++ 1 file changed, 2 insertions(+), 8 deletions(-) diff --git a/drivers/staging/rtl8723bs/hal/hal_btcoex.c

[PATCH] staging: rtl8723bs: core: Remove variable priority

2019-06-07 Thread Nishka Dasgupta
Remove local variable change_priority, as it takes the value of the argument priority; as both of these variables are of type u8, priority can be modified without changing the value of its copy at the call site. Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta ---

[PATCH] staging: rtl8723bs: hal: rtl8723b_cmd.c: Remove variables

2019-06-07 Thread Nishka Dasgupta
Remove variables that are declared and initialised but never used. Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta --- drivers/staging/rtl8723bs/hal/rtl8723b_cmd.c | 6 -- 1 file changed, 6 deletions(-) diff --git a/drivers/staging/rtl8723bs/hal/rtl8723b_cmd.c

[PATCH] staging: rtl8723bs: core: rtw_mlme_ext.c: Remove unused variables

2019-06-07 Thread Nishka Dasgupta
Remove variables that are declared and assigned values but not otherwise used. Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta --- drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 9 - 1 file changed, 9 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c

Thanks and I wait for your answer

2019-06-07 Thread Martins Henry
Hello, I am Martin Henry, An American Citizen; I am the personal secretary to Mr. Donald Railton, the controller of a Lottery Company. Please I am having big problem now, I have a 6yrs old daughter who has leukemia, a disease of the blood, and she needs a bone marrow transplant or she will die.

[PATCH] Staging: vc04_services : vchiq_core: Fix a brace issue

2019-06-07 Thread Maxime Desroches
Remove braces in a single line if statement in the vchiq_core.c file Signed-off-by: Maxime Desroches --- drivers/staging/vc04_services/interface/vchiq_arm/vchiq_core.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git