[PATCH] staging: media: atomisp: i2c: atomisp-ov2680.c: fixed a brace coding style issue.

2020-06-27 Thread B K Karthik
Fixed a coding style issue. Signed-off-by: B K Karthik --- drivers/staging/media/atomisp/i2c/atomisp-ov2680.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/media/atomisp/i2c/atomisp-ov2680.c b/drivers/staging/media/atomisp/i2c/atomisp-ov2680.c index 9

[staging:staging-testing] BUILD SUCCESS 5bfb7eadc5874a3a08dd173d66a16a1ed0548444

2020-06-27 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git staging-testing branch HEAD: 5bfb7eadc5874a3a08dd173d66a16a1ed0548444 staging: rtl8188eu: remove blank lines in header files elapsed time: 725m configs tested: 124 configs skipped: 7 The following configs have be

Re: [PATCH v2] staging: wfx: Get descriptors for GPIOs

2020-06-27 Thread kernel test robot
Hi Linus, I love your patch! Yet something to improve: [auto build test ERROR on staging/staging-testing] url: https://github.com/0day-ci/linux/commits/Linus-Walleij/staging-wfx-Get-descriptors-for-GPIOs/20200628-073632 base: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.g

Re: [PATCH] fbtft-bus.c: Removing that prohibited space before ')'

2020-06-27 Thread kernel test robot
https://git-scm.com/docs/git-format-patch] url: https://github.com/0day-ci/linux/commits/B-K-Karthik/fbtft-bus-c-Removing-that-prohibited-space-before/20200627-125315 base: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git 92cd1b5d65f5c67147c7da39a3c2ad7e6ff81027 config: x86_64

[PATCH v2] staging: wfx: Get descriptors for GPIOs

2020-06-27 Thread Linus Walleij
The code has the functionality to insert the GPIO lines using the global GPIO numbers through module parameters. As we are clearly deprecating the use of global GPIO numbers look up the GPIO descriptors from the device instead. This usually falls back to device hardware descriptions using e.g. dev

[no subject]

2020-06-27 Thread lookman joe
MONEY-GRAM TRANSFERRED PAYMENT INFO: Below is the sender’s information 1. MG. REFERENCE NO#: 36360857 2. SENDER'S NAME: Johnson Williams 3. AMOUNT TO PICKUP: US$10,000 Go to any Money Gram office near you and pick up the payment Track the Reference Number by visiting and click the link be

[PATCH] staging: media: atomisp: Convert to GPIO descriptors

2020-06-27 Thread Linus Walleij
Convert the atomisp LM3554 driver to use GPIO descriptors fully. It was already retrieveing the GPIO lines as descriptors but for some reason converting them back into global GPIO numbers. There is no reason to do this, just deal with the descriptors as-is. Cc: Mauro Carvalho Chehab Signed-off-by

Re: [GIT PULL] Staging driver fixes for 5.8-rc3

2020-06-27 Thread pr-tracker-bot
The pull request you sent on Sat, 27 Jun 2020 13:40:37 +0200: > git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git > tags/staging-5.8-rc3 has been merged into torvalds/linux.git: https://git.kernel.org/torvalds/c/42afe7d1c6ef77212250af3459e549d1a944cc8a Thank you! -- Deet-doot-d

Re: [PATCH] staging: wfx: Get descriptors for GPIOs

2020-06-27 Thread kernel test robot
Hi Linus, I love your patch! Yet something to improve: [auto build test ERROR on staging/staging-testing] url: https://github.com/0day-ci/linux/commits/Linus-Walleij/staging-wfx-Get-descriptors-for-GPIOs/20200627-200038 base: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh

Re: [PATCH 2/4] staging: kpc2000: kpc_dma: Convert set_page_dirty() --> set_page_dirty_lock()

2020-06-27 Thread Souptick Joarder
On Wed, Jun 17, 2020 at 7:50 AM Souptick Joarder wrote: > > First, convert set_page_dirty() to set_page_dirty_lock() > > Second, there is an interval in there after set_page_dirty() and > before put_page(), in which the device could be running and setting > pages dirty. Moving set_page_dirty_lock(

Re: [PATCH] staging: rtl8188eu: remove unnecessary comments in hal8188e_phy_cfg.h

2020-06-27 Thread Dan Carpenter
On Sat, Jun 27, 2020 at 05:15:44PM +0200, Michael Straube wrote: > @@ -145,21 +138,7 @@ struct bb_reg_def { >*/ > }; > > -/*--Define > structure*/ > - > - > -/*Export global > variab

[PATCH] staging: rtl8188eu: remove unnecessary comments in hal8188e_phy_cfg.h

2020-06-27 Thread Michael Straube
Remove unnecessary comments in hal8188e_phy_cfg.h to improve readability and clear multiple blank lines checkpatch issues. CHECK: Please don't use multiple blank lines Signed-off-by: Michael Straube --- .../rtl8188eu/include/hal8188e_phy_cfg.h | 23 --- 1 file changed, 23 d

Re: [PATCH v2 0/4] staging: qlge: coding style fix for the qlge driver

2020-06-27 Thread Dan Carpenter
Looks Good! Thanks. Reviewed-by: Dan Carpenter regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH 1/4] fix trailing */ in block comment

2020-06-27 Thread Coiby Xu
On Sat, Jun 27, 2020 at 12:47:08PM +0200, Greg Kroah-Hartman wrote: On Sat, Jun 27, 2020 at 06:14:44PM +0800, Coiby Xu wrote: Remove trailing "*/" in block comments. Signed-off-by: Coiby Xu The subject lines of all of your patches should match other patches for this driver. It should look l

[PATCH v2 4/4] staging: qlge: replace pr_err with netdev_err

2020-06-27 Thread Coiby Xu
Replace all pr_errs with netdev_err. Suggested-by: Joe Perches Signed-off-by: Coiby Xu --- drivers/staging/qlge/qlge_dbg.c | 568 1 file changed, 289 insertions(+), 279 deletions(-) diff --git a/drivers/staging/qlge/qlge_dbg.c b/drivers/staging/qlge/qlge_dbg.c

[PATCH v2 0/4] staging: qlge: coding style fix for the qlge driver

2020-06-27 Thread Coiby Xu
v2 - let all patches' subject lines match the pattern "staging: qlge: ..." These patches fix three coding style problems for all files under drivers/staging/qlge, - trailing */ in block comment - unnecessary else after return or break - pr_err preferred over netdev_err and a bug abou

[PATCH v2 1/4] staging: qlge: fix trailing */ in block comment

2020-06-27 Thread Coiby Xu
Remove trailing "*/" in block comments. Signed-off-by: Coiby Xu --- drivers/staging/qlge/qlge_main.c | 3 ++- drivers/staging/qlge/qlge_mpi.c | 10 ++ 2 files changed, 8 insertions(+), 5 deletions(-) diff --git a/drivers/staging/qlge/qlge_main.c b/drivers/staging/qlge/qlge_main.c inde

[PATCH v2 2/4] staging: qlge: fix else after return or break

2020-06-27 Thread Coiby Xu
Remove unnecessary elses after return or break. Signed-off-by: Coiby Xu --- drivers/staging/qlge/qlge_dbg.c | 23 ++- drivers/staging/qlge/qlge_main.c | 8 drivers/staging/qlge/qlge_mpi.c | 4 ++-- 3 files changed, 16 insertions(+), 19 deletions(-) diff --git a/

[PATCH v2 3/4] staging: qlge: fix ql_sem_unlock

2020-06-27 Thread Coiby Xu
Some functions return without releasing the lock. Replace return with break. Suggested-by Dan Carpenter . Signed-off-by: Coiby Xu --- drivers/staging/qlge/qlge_dbg.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/qlge/qlge_dbg.c b/drivers/staging/qlge/

[PATCH] staging: wfx: Get descriptors for GPIOs

2020-06-27 Thread Linus Walleij
The code has the functionality to insert the GPIO lines using the global GPIO numbers through module parameters. As we are clearly deprecating the use of global GPIO numbers look up the GPIO descriptors from the device instead. This usually falls back to device hardware descriptions using e.g. dev

[GIT PULL] Staging driver fixes for 5.8-rc3

2020-06-27 Thread Greg KH
The following changes since commit b3a9e3b9622ae10064826dccb4f7a52bd88c7407: Linux 5.8-rc1 (2020-06-14 12:45:04 -0700) are available in the Git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git tags/staging-5.8-rc3 for you to fetch changes up to b65a2d8c861438

Re: [PATCH 1/4] fix trailing */ in block comment

2020-06-27 Thread Greg Kroah-Hartman
On Sat, Jun 27, 2020 at 06:14:44PM +0800, Coiby Xu wrote: > Remove trailing "*/" in block comments. > > Signed-off-by: Coiby Xu The subject lines of all of your patches should match other patches for this driver. It should look like "staging: qlge: ..." Please fix up and resend a v2 of this se

Re: [PATCH 2/2] staging: qlge: fix else after return or break

2020-06-27 Thread Coiby Xu
On Fri, Jun 26, 2020 at 05:06:33PM -0700, Joe Perches wrote: On Sat, 2020-06-27 at 07:57 +0800, Coiby Xu wrote: On Thu, Jun 25, 2020 at 03:13:14PM -0700, Joe Perches wrote: > On Fri, 2020-06-26 at 05:57 +0800, Coiby Xu wrote: > > Remove unnecessary elses after return or break. > > unrelated triv

[PATCH 1/4] fix trailing */ in block comment

2020-06-27 Thread Coiby Xu
Remove trailing "*/" in block comments. Signed-off-by: Coiby Xu --- drivers/staging/qlge/qlge_main.c | 3 ++- drivers/staging/qlge/qlge_mpi.c | 10 ++ 2 files changed, 8 insertions(+), 5 deletions(-) diff --git a/drivers/staging/qlge/qlge_main.c b/drivers/staging/qlge/qlge_main.c inde

[PATCH 0/4] staging: qlge: coding style fix for the qlge driver

2020-06-27 Thread Coiby Xu
These patches fix three coding style problems for all files under drivers/staging/qlge, - trailing */ in block comment - unnecessary else after return or break - pr_err preferred over netdev_err and a bug about releasing lock. Coiby Xu (4): fix trailing */ in block comment fix els

[PATCH 4/4] replace pr_err with netdev_err

2020-06-27 Thread Coiby Xu
Replace all pr_errs with netdev_err. Suggested-by: Joe Perches Signed-off-by: Coiby Xu --- drivers/staging/qlge/qlge_dbg.c | 568 1 file changed, 289 insertions(+), 279 deletions(-) diff --git a/drivers/staging/qlge/qlge_dbg.c b/drivers/staging/qlge/qlge_dbg.c

[PATCH 2/4] fix else after return or break

2020-06-27 Thread Coiby Xu
Remove unnecessary elses after return or break. Signed-off-by: Coiby Xu --- drivers/staging/qlge/qlge_dbg.c | 23 ++- drivers/staging/qlge/qlge_main.c | 8 drivers/staging/qlge/qlge_mpi.c | 4 ++-- 3 files changed, 16 insertions(+), 19 deletions(-) diff --git a/

[PATCH 3/4] fix ql_sem_unlock

2020-06-27 Thread Coiby Xu
Some functions return without releasing the lock. Replace return with break. Suggested-by Dan Carpenter . Signed-off-by: Coiby Xu --- drivers/staging/qlge/qlge_dbg.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/qlge/qlge_dbg.c b/drivers/staging/qlge/

Re: [PATCH] staging: media: usbvision: removing prohibited space before ',' (ctx:WxW)

2020-06-27 Thread Joe Perches
On Sat, 2020-06-27 at 10:49 +0200, Greg Kroah-Hartman wrote: > On Sat, Jun 27, 2020 at 10:28:31AM +0200, Hans Verkuil wrote: > > On 27/06/2020 07:07, Greg Kroah-Hartman wrote: > > > A: http://en.wikipedia.org/wiki/Top_post > > > Q: Were do I find info about this thing called top-posting? > > > A: B

[PATCH] staging: rtl8188eu: remove blank lines in header files

2020-06-27 Thread Michael Straube
Remove blank lines in header files to clear checkpatch issues. CHECK: Please don't use multiple blank lines Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/include/drv_types.h | 1 - drivers/staging/rtl8188eu/include/hal_com.h | 1 - drivers/staging/rtl8188eu/include/iee

Re: [PATCH] staging: media: usbvision: removing prohibited space before ',' (ctx:WxW)

2020-06-27 Thread B K Karthik
Thank you for the information. I will take care of all these things from the next time. sorry for wasting your time thanks, karthik On Sat, Jun 27, 2020 at 4:49 AM Greg Kroah-Hartman wrote: > > On Sat, Jun 27, 2020 at 10:28:31AM +0200, Hans Verkuil wrote: > > On 27/06/2020 07:07, Greg Kroah-Ha

Re: RT_TRACE in drivers/staging/rtl8188eu

2020-06-27 Thread Joe Perches
On Sat, 2020-06-27 at 10:18 +0200, Greg KH wrote: > On Sat, Jun 27, 2020 at 01:12:42AM -0700, Joe Perches wrote: > > On Sat, 2020-06-27 at 10:01 +0200, Greg KH wrote: > > > On Sat, Jun 27, 2020 at 12:33:56AM -0700, Joe Perches wrote: > > > > There are 3 parts of the email. > > > > > > > > 1: A des

Re: [PATCH] staging: media: usbvision: removing prohibited space before ',' (ctx:WxW)

2020-06-27 Thread Greg Kroah-Hartman
On Sat, Jun 27, 2020 at 10:28:31AM +0200, Hans Verkuil wrote: > On 27/06/2020 07:07, Greg Kroah-Hartman wrote: > > > > A: http://en.wikipedia.org/wiki/Top_post > > Q: Were do I find info about this thing called top-posting? > > A: Because it messes up the order in which people normally read text.

Re: [PATCH] fbtft-bus.c:

2020-06-27 Thread kernel test robot
https://git-scm.com/docs/git-format-patch] url: https://github.com/0day-ci/linux/commits/B-K-Karthik/fbtft-bus-c/20200627-125213 base: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git 92cd1b5d65f5c67147c7da39a3c2ad7e6ff81027 config: i386-randconfig-a005-20200624 (attached as

Re: [PATCH] staging: media: usbvision: removing prohibited space before ',' (ctx:WxW)

2020-06-27 Thread Hans Verkuil
On 27/06/2020 07:07, Greg Kroah-Hartman wrote: > > A: http://en.wikipedia.org/wiki/Top_post > Q: Were do I find info about this thing called top-posting? > A: Because it messes up the order in which people normally read text. > Q: Why is top-posting such a bad thing? > A: Top-posting. > Q: What is

Re: RT_TRACE in drivers/staging/rtl8188eu

2020-06-27 Thread Joe Perches
On Sat, 2020-06-27 at 10:01 +0200, Greg KH wrote: > On Sat, Jun 27, 2020 at 12:33:56AM -0700, Joe Perches wrote: > > There are 3 parts of the email. > > > > 1: A description and patch for a logging defect > > 2: A script to go along with the patch to do conversions > > 3: Current diff for this def

Re: [PATCH] staging: rtl8712: rtl8712_recv.h: Removing unnecessary blank line

2020-06-27 Thread Greg Kroah-Hartman
On Sat, Jun 27, 2020 at 04:03:56AM -0400, B K Karthik wrote: > Removing unnecessary blank line That says what you are doing, but not why you are doing it... Stop, take a day or so, relax, and come back after reading a bunch about how to write a good changelog text (link has been provided to you m

Re: RT_TRACE in drivers/staging/rtl8188eu

2020-06-27 Thread Greg KH
On Sat, Jun 27, 2020 at 01:12:42AM -0700, Joe Perches wrote: > On Sat, 2020-06-27 at 10:01 +0200, Greg KH wrote: > > On Sat, Jun 27, 2020 at 12:33:56AM -0700, Joe Perches wrote: > > > There are 3 parts of the email. > > > > > > 1: A description and patch for a logging defect > > > 2: A script to g

[PATCH] staging: rtl8712: rtl8712_recv.h: Removing unnecessary blank line

2020-06-27 Thread B K Karthik
Removing unnecessary blank line Signed-off-by: B K Karthik --- drivers/staging/rtl8712/rtl8712_recv.h | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/rtl8712/rtl8712_recv.h b/drivers/staging/rtl8712/rtl8712_recv.h index 3e385b2242d8..69d3d5b287d3 100644 --- a/drivers/staging/

Re: RT_TRACE in drivers/staging/rtl8188eu

2020-06-27 Thread Greg KH
On Sat, Jun 27, 2020 at 12:33:56AM -0700, Joe Perches wrote: > There are 3 parts of the email. > > 1: A description and patch for a logging defect > 2: A script to go along with the patch to do conversions > 3: Current diff for this defect > > -

Re: [PATCH] fbtft-bus.c:

2020-06-27 Thread kernel test robot
https://git-scm.com/docs/git-format-patch] url: https://github.com/0day-ci/linux/commits/B-K-Karthik/fbtft-bus-c/20200627-125213 base: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git 92cd1b5d65f5c67147c7da39a3c2ad7e6ff81027 config: m68k-randconfig-r016-20200624 (attached as

[PATCH 1/4] usb: cdns3: gadget: Replace trace_printk by dev_dbg

2020-06-27 Thread Nicolas Boichat
trace_printk should not be used in production code, replace it call with dev_dbg. Signed-off-by: Nicolas Boichat --- Unclear why a trace_printk was used in the first place, it's possible that some rate-limiting is necessary here. drivers/usb/cdns3/gadget.c | 2 +- 1 file changed, 1 insertion(

Re: [PATCH] qlge.h: Adding the missing blank line after declarations

2020-06-27 Thread Greg Kroah-Hartman
On Sat, Jun 27, 2020 at 02:07:58AM -0400, B K Karthik wrote: > Signed-off-by: B K Karthik > --- > drivers/staging/qlge/qlge.h | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/drivers/staging/qlge/qlge.h b/drivers/staging/qlge/qlge.h > index fc8c5ca8935d..0b971a633001 100644 > --- a/drive

[PATCH 3/4] media: camss: vfe: Use trace_printk for debugging only

2020-06-27 Thread Nicolas Boichat
trace_printk should not be used in production code. Since tracing interrupts is presumably latency sensitive, pr_dbg is not appropriate, so guard the call with a preprocessor symbol that can be defined for debugging purpose. Signed-off-by: Nicolas Boichat --- drivers/media/platform/qcom/camss/c

[PATCH v2 4/4] kernel/trace: Add TRACING_ALLOW_PRINTK config option

2020-06-27 Thread Nicolas Boichat
trace_printk is meant as a debugging tool, and should not be compiled into production code without specific debug Kconfig options enabled, or source code changes, as indicated by the warning that shows up on boot if any trace_printk is called: ** NOTICE NOTICE NOTICE NOTICE NOTICE NOTICE NOTICE

[PATCH 2/4] media: atomisp: Replace trace_printk by pr_info

2020-06-27 Thread Nicolas Boichat
trace_printk should not be used in production code, replace it call with pr_info. Signed-off-by: Nicolas Boichat --- drivers/staging/media/atomisp/pci/hmm/hmm.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/media/atomisp/pci/hmm/hmm.c b/drivers/

[PATCH 0/4] Detect and remove trace_printk

2020-06-27 Thread Nicolas Boichat
trace_printk is meant as a debugging tool, and should not be compiled into production code without specific debug Kconfig options enabled or source code changes. Patches 1 to 3 remove/disable trace_printk that should not be enabled by default. Patch 4 adds a config option that can be used to dete