Re: [PATCH] staging: greybus: fix checkpatch unsigned warnings

2017-01-16 Thread Johan Hovold
On Fri, Jan 13, 2017 at 09:54:51PM +0100, Roman Sommer wrote: > Fix checkpatch warnings for parameter type unsigned in greybus. > Note that this patch does not fix all checkpatch warnings for the > affected files. Thanks for the update. In the future, make sure to include a patch revision in the

Re: [PATCH] Staging: media: bcm2048: style fix - bare use of unsigned

2017-01-16 Thread Greg KH
On Mon, Jan 16, 2017 at 06:06:25PM +1300, Derek Robson wrote: > On Sun, Jan 15, 2017 at 10:40:02PM -0600, Scott Matheina wrote: > > > > > > > On Jan 15, 2017, at 10:30 PM, Derek Robson wrote: > > > > > > Changed bare use of 'unsigned' to the prefered us of 'unsigned int' >

Re: [PATCH V2] Staging: media: bcm2048: style fix - bare use of unsigned

2017-01-16 Thread Greg KH
On Mon, Jan 16, 2017 at 08:09:51PM +1300, Derek Robson wrote: > Changed macro to not pass signedness and size as seprate fields. > This is to improve code readablity. Not really, it reads just fine as is. In fact, it forces you to think about the signed vs. unsigned of the variable and doesn't

Re: [PATCH 4/4] staging: greybus: audio: Ensure proper byte order

2017-01-16 Thread Dan Carpenter
On Sat, Jan 14, 2017 at 11:17:07PM +0530, Vaibhav Agarwal wrote: > @@ -656,13 +660,13 @@ static int gbaudio_tplg_create_enum_kctl(struct > gbaudio_module_info *gb, > gb_enum = >info.value.enumerated; > > /* since count=1, and reg is dummy */ > - gbe->max = gb_enum->items; > +

Re: [PATCH 4/4] staging: greybus: audio: Ensure proper byte order

2017-01-16 Thread Vaibhav Agarwal
On Mon, Jan 16, 2017 at 4:17 PM, Dan Carpenter wrote: > On Sat, Jan 14, 2017 at 11:17:07PM +0530, Vaibhav Agarwal wrote: >> @@ -656,13 +660,13 @@ static int gbaudio_tplg_create_enum_kctl(struct >> gbaudio_module_info *gb, >> gb_enum = >info.value.enumerated; >> >>

Re: [PATCH v3 01/24] [media] dt-bindings: Add bindings for i.MX media driver

2017-01-16 Thread Philipp Zabel
On Fri, 2017-01-13 at 11:03 -0800, Steve Longerbeam wrote: > > On 01/13/2017 03:55 AM, Philipp Zabel wrote: > > Am Freitag, den 06.01.2017, 18:11 -0800 schrieb Steve Longerbeam: > >> Add bindings documentation for the i.MX media driver. > >> > >> Signed-off-by: Steve Longerbeam

Re: [PATCH v3 16/24] media: Add i.MX media core driver

2017-01-16 Thread Philipp Zabel
On Sat, 2017-01-14 at 14:46 -0800, Steve Longerbeam wrote: [...] > >> +Unprocessed Video Capture: > >> +-- > >> + > >> +Send frames directly from sensor to camera interface, with no > >> +conversions: > >> + > >> +-> ipu_smfc -> camif > > I'd call this capture interface,

[PATCH] staging: comedi: ni_pcimio: Support more PXI cards

2017-01-16 Thread Ian Abbott
Add support for NI PXI-6220, PXI-6221, PXI-6229, PXI-6250, PXI-6254, PXI-6259, PXIe-6259, PXI-6280, PXI-6284, and PXI-6289 boards, treating them the same as the correspondingly numbered PCI and PCIe boards (apart from having different Comedi board name strings). The same has previously been done

[PATCH] staging: comedi: ni_660x: Support PCI-6224

2017-01-16 Thread Ian Abbott
Add support for the NI PCI-6224 board, assuming it behaves like the NI PXI-6224 board at the register level. The PCI device ID comes from the "nitiowv.inf" file in National Instrument's Windows drivers. Signed-off-by: Ian Abbott --- drivers/staging/comedi/Kconfig |

Re: [PATCH v3 06/24] ARM: dts: imx6-sabrelite: add OV5642 and OV5640 camera sensors

2017-01-16 Thread Philipp Zabel
On Fri, 2017-01-13 at 15:04 -0800, Steve Longerbeam wrote: > > On 01/13/2017 04:03 AM, Philipp Zabel wrote: > > Am Freitag, den 06.01.2017, 18:11 -0800 schrieb Steve Longerbeam: > >> Enables the OV5642 parallel-bus sensor, and the OV5640 MIPI CSI-2 sensor. > >> Both hang off the same i2c2 bus, so

Re: [PATCH v3 17/24] media: imx: Add CSI subdev driver

2017-01-16 Thread Philipp Zabel
On Fri, 2017-01-06 at 18:11 -0800, Steve Longerbeam wrote: > This is a media entity subdevice for the i.MX Camera > Serial Interface module. s/Serial/Sensor/ > Signed-off-by: Steve Longerbeam > --- > drivers/staging/media/imx/Kconfig | 13 + >

[PATCH] staging: unisys: visorbus: fix checkpatch block comments warning

2017-01-16 Thread Abdul Rauf
Fix the following warnings: Block comments should align the * on each line Signed-off-by: Abdul Rauf --- Please ignore my previous two patches in staging: unisys. This is the combined patch of those two patches --- drivers/staging/unisys/visorbus/visorchipset.c|

Re: [PATCH v3 01/24] [media] dt-bindings: Add bindings for i.MX media driver

2017-01-16 Thread Steve Longerbeam
On 01/16/2017 04:09 AM, Philipp Zabel wrote: On Fri, 2017-01-13 at 11:03 -0800, Steve Longerbeam wrote: On 01/13/2017 03:55 AM, Philipp Zabel wrote: Am Freitag, den 06.01.2017, 18:11 -0800 schrieb Steve Longerbeam: Add bindings documentation for the i.MX media driver. Signed-off-by: Steve

Re: [PATCH v3 06/24] ARM: dts: imx6-sabrelite: add OV5642 and OV5640 camera sensors

2017-01-16 Thread Steve Longerbeam
On 01/16/2017 04:55 AM, Philipp Zabel wrote: On Fri, 2017-01-13 at 15:04 -0800, Steve Longerbeam wrote: @@ -299,6 +326,52 @@ pinctrl-names = "default"; pinctrl-0 = <_i2c2>; status = "okay"; + + ov5640: camera@40 { + compatible = "ovti,ov5640"; +

Re: [PATCH] staging: lustre: headers: potential UAPI headers

2017-01-16 Thread Greg Kroah-Hartman
On Mon, Jan 16, 2017 at 09:28:30PM +, James Simmons wrote: > > > On Mon, Dec 19, 2016 at 12:06:47PM -0500, James Simmons wrote: > > > Not for landing. This is the purposed UAPI headers > > > with the removal of unlikely and debugging macros. > > > This is just for feedback to see if this is

Re: [PATCH RFC] hv_utils: implement Hyper-V PTP source

2017-01-16 Thread Thomas Gleixner
On Fri, 13 Jan 2017, Vitaly Kuznetsov wrote: > With TimeSync version 4 protocol support we started updating system time > continuously through the whole lifetime of Hyper-V guests. Every 5 seconds > there is a time sample from the host which triggers do_settimeofday[64](). > While the time from

Re: [PATCH v3 17/24] media: imx: Add CSI subdev driver

2017-01-16 Thread Steve Longerbeam
On 01/16/2017 07:03 AM, Philipp Zabel wrote: On Fri, 2017-01-06 at 18:11 -0800, Steve Longerbeam wrote: This is a media entity subdevice for the i.MX Camera Serial Interface module. s/Serial/Sensor/ done. Signed-off-by: Steve Longerbeam ---

[PATCH 00/34] staging: lustre: lnet: change lnet selftest UAPI typedefs to proper structure

2017-01-16 Thread James Simmons
The upstream kernel requires proper structures so convert all the UAPI typdefs in lnetst.h. Signed-off-by: James Simmons Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 33/34] staging: lustre: lnet: change srpc_counters_t to proper structure

2017-01-16 Thread James Simmons
Change srpc_counters_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 15/34] staging: lustre: lnet: change lstio_group_del_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_group_del_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 30/34] staging: lustre: lnet: change lst_brw_[type|flags]_t to proper enum

2017-01-16 Thread James Simmons
Change lst_brw_[type|flags]_t from typedef to proper enum. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 25/34] staging: lustre: lnet: change lstio_batch_list_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_batch_list_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 29/34] staging: lustre: lnet: change lstio_test_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_test_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 34/34] staging: lustre: lnet: change sfw_counter_t to proper structure

2017-01-16 Thread James Simmons
Change sfw_counter_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 01/34] staging: lustre: lnet: change lst_nid_t to proper structure

2017-01-16 Thread James Simmons
Change lst_nid_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 03/34] staging: lustre: lnet: change lstcon_node_ent_t to proper structure

2017-01-16 Thread James Simmons
Change lstcon_node_ent_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 19/34] staging: lustre: lnet: change lstio_group_info_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_group_info_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 10/34] staging: lustre: lnet: change lstio_session_new_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_session_new_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 06/34] staging: lustre: lnet: change lstcon_batch_ent_t to proper structure

2017-01-16 Thread James Simmons
Change lstcon_batch_ent_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 04/34] staging: lustre: lnet: change lstcon_ndlist_ent_t to proper structure

2017-01-16 Thread James Simmons
Change lstcon_ndlist_ent_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 14/34] staging: lustre: lnet: change lstio_group_add_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_group_add_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 12/34] staging: lustre: lnet: change lstio_session_end_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_session_end_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 22/34] staging: lustre: lnet: change lstio_batch_run_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_batch_run_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 05/34] staging: lustre: lnet: change lstcon_test_ent_t to proper structure

2017-01-16 Thread James Simmons
Change lstcon_test_ent_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 07/34] staging: lustre: lnet: change lstcon_test_batch_ent_t to proper structure

2017-01-16 Thread James Simmons
Change lstcon_test_batch_ent_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 16/34] staging: lustre: lnet: change lstio_group_update_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_group_update_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 09/34] staging: lustre: lnet: change lstcon_trans_stat_t to proper structure

2017-01-16 Thread James Simmons
Change lstcon_trans_stat_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 23/34] staging: lustre: lnet: change lstio_batch_stop_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_batch_stop_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 17/34] staging: lustre: lnet: change lstio_group_nodes_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_group_nodes_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 11/34] staging: lustre: lnet: change lstio_session_info_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_session_info_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 02/34] staging: lustre: lnet: change lst_bid_t to proper structure

2017-01-16 Thread James Simmons
Change lst_bid_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 13/34] staging: lustre: lnet: change lstio_debug_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_debug_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 21/34] staging: lustre: lnet: change lstio_batch_del_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_batch_del_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 24/34] staging: lustre: lnet: change lstio_batch_query_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_batch_query_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 08/34] staging: lustre: lnet: change lstcon_rpc_ent_t to proper structure

2017-01-16 Thread James Simmons
Change lstcon_rpc_ent_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 20/34] staging: lustre: lnet: change lstio_batch_add_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_batch_add_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

Re: [PATCH] staging: lustre: headers: potential UAPI headers

2017-01-16 Thread James Simmons
> On Mon, Dec 19, 2016 at 12:06:47PM -0500, James Simmons wrote: > > Not for landing. This is the purposed UAPI headers > > with the removal of unlikely and debugging macros. > > This is just for feedback to see if this is acceptable > > for the upstream client. > > > > Signed-off-by: James

[PATCH 27/34] staging: lustre: lnet: change lstio_stat_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_stat_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 32/34] staging: lustre: lnet: change lst_test_ping_param_t to proper structure

2017-01-16 Thread James Simmons
Change lst_test_ping_param_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 18/34] staging: lustre: lnet: change lstio_group_list_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_group_list_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 28/34] staging: lustre: lnet: change lst_test_type_t to proper enum

2017-01-16 Thread James Simmons
Change lst_test_type_t from typedef to proper enum. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug Oucharek

[PATCH 31/34] staging: lustre: lnet: change lst_test_bulk_param_t to proper structure

2017-01-16 Thread James Simmons
Change lst_test_bulk_param_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug

[PATCH 26/34] staging: lustre: lnet: change lstio_batch_info_args_t to proper structure

2017-01-16 Thread James Simmons
Change lstio_batch_info_args_t from typedef to proper structure. Signed-off-by: James Simmons Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142 Reviewed-on: https://review.whamcloud.com/24188 Reviewed-by: Andreas Dilger Reviewed-by: Doug