Re: [RESEND PATCH v2] staging:speakup: Fix alignment with parenthesis.

2017-03-23 Thread Greg Kroah-Hartman
On Thu, Mar 23, 2017 at 07:15:38PM +0530, Arushi Singhal wrote: > Fix checkpatch issues: "CHECK: Alignment should match open parenthesis". > > Signed-off-by: Arushi Singhal I can't take patches sent in html format :( please fix your email client. thanks,

Re: [PATCH] staging: wilc1000: use kernel define byte order macros

2017-03-23 Thread Robert Perry Hooker
Well, yes, all data is 'endian' one way or another, right? I guess the byte order of the tx/rx_buffers is host-endian (which could be big), or _maybe_ network-endian... Regards, Perry On Thu, 2017-03-23 at 11:33 +0300, Dan Carpenter wrote: > On Wed, Mar 22, 2017 at 07:53:28PM -0600, Robert

Re: [PATCH] staging: lustre: Replace a bit shift by a use of BIT.

2017-03-23 Thread Dilger, Andreas
On Mar 22, 2017, at 06:12, Dilger, Andreas wrote: > > On Mar 21, 2017, at 22:39, Arushi Singhal > wrote: >> >> This patch replaces bit shifting on 1 with the BIT(x) macro. >> This was done with coccinelle: [snip] >> diff --git

Re: [PATCH v2] staging: lustre: Replace a bit shift by a use of BIT.

2017-03-23 Thread Dilger, Andreas
On Mar 22, 2017, at 09:53, Arushi Singhal wrote: > > This patch replaces bit shifting on 1 with the BIT(x) macro. > This was done with coccinelle: > @@ > constant c; > @@ > > -1 << c > +BIT(c) > > Signed-off-by: Arushi Singhal

[PATCH 2/2 v5] pci-hyperv: lock pci bus on device eject

2017-03-23 Thread Long Li
From: Long Li A PCI_EJECT message can arrive at the same time we are calling pci_scan_child_bus in the workqueue for the previous PCI_BUS_RELATIONS message or in create_root_hv_pci_bus(), in this case we could potentially modify the bus from multiple places. Properly lock

[PATCH 1/2 v5] pci-hyperv: properly handle pci bus remove

2017-03-23 Thread Long Li
From: Long Li hv_pci_devices_present is called in hv_pci_remove when we remove a PCI device from host (e.g. by disabling SRIOV on a device). In hv_pci_remove, the bus is already removed before the call, so we don't need to rescan the bus in the workqueue scheduled from

Re: [PATCH] drivers/staging/dgnc: Updating dev_dbg function

2017-03-23 Thread Greg Kroah-Hartman
On Wed, Mar 22, 2017 at 01:17:57PM +0530, Pushkar Jambhlekar wrote: > Making use of __func__ instead of using function name directly in dev_dbg. > > Signed-off-by: Pushkar Jambhlekar > --- > drivers/staging/dgnc/dgnc_tty.c | 4 ++-- > 1 file changed, 2 insertions(+), 2

[PATCH] staging: most: Adds parentheses around macros with complex values

2017-03-23 Thread Mark Stenglein
Fixes three instances of the following checklist error: - ERROR: Macros with complex values should be enclosed in parentheses Simply adds parentheses around the macros to fix the problem. Signed-off-by: Mark Stenglein --- drivers/staging/most/mostcore/core.c | 12

[bug report] Staging: media: Unmap and release region obtained by ioremap_nocache

2017-03-23 Thread Dan Carpenter
Hello Arvind Yadav, This is a semi-automatic email about new static checker warnings. The patch 4b4eda001704: "Staging: media: Unmap and release region obtained by ioremap_nocache" from Mar 17, 2017, leads to the following Smatch complaint:

[PATCH] drivers/staging/dgnc: Removing manual function tracing using dev_dbg

2017-03-23 Thread Pushkar Jambhlekar
Current implementation manually traces function using 'dev_dbg'. This way is not needed because of ftrace, making these calls redundant. Signed-off-by: Pushkar Jambhlekar --- drivers/staging/dgnc/dgnc_tty.c | 4 1 file changed, 4 deletions(-) diff --git

Re: [PATCH v2] staging: iio: Replace a bit shift by a use of BIT.

2017-03-23 Thread Dan Carpenter
On Wed, Mar 22, 2017 at 10:12:34PM +0530, Arushi Singhal wrote: > /* Capacitive Channel Setup Register Bit Designations (AD7746_REG_CAP_SETUP) > */ > -#define AD7746_CAPSETUP_CAPEN(1 << 7) > -#define AD7746_CAPSETUP_CIN2 (1 << 6) /* AD7746 only */ > -#define

Re: [PATCH] staging: vt6656: removed coding style errors

2017-03-23 Thread Greg KH
On Wed, Mar 22, 2017 at 09:39:24PM +0530, Prasant Jalan wrote: > The patch replaces spaces with tabs as required by kernel coding > standards. > > Signed-off-by: Prasant Jalan > --- > drivers/staging/vt6656/rxtx.c | 40 ++-- > 1 file

Re: [PATCH v8] staging: adis16060: Remove iio_dev mlock and refactor code

2017-03-23 Thread Jonathan Cameron
On 22 March 2017 19:22:20 GMT+00:00, Jonathan Cameron wrote: >On 22/03/17 16:20, simran singhal wrote: >> The IIO subsystem is redefining iio_dev->mlock to be used by >> the IIO core only for protecting device operating mode changes. >> ie. Changes between INDIO_DIRECT_MODE,

Re: [PATCH] staging: wilc1000: use kernel define byte order macros

2017-03-23 Thread Dan Carpenter
On Wed, Mar 22, 2017 at 07:53:28PM -0600, Robert Perry Hooker wrote: > I don't think buff is an ieee80211_hdr struct. I think it's the rx_buffer > allocated at wilc_wlan.c:1417. > The rx_buffer is going to end up filled with endian data, right? regards, dan carpenter

Re: [PATCH] staging: vt6656: removed coding style errors

2017-03-23 Thread Greg KH
On Thu, Mar 23, 2017 at 01:55:31PM +0530, Prasant Jalan wrote: > On Thu, Mar 23, 2017 at 1:02 PM, Greg KH wrote: > > > > On Wed, Mar 22, 2017 at 09:39:24PM +0530, Prasant Jalan wrote: > > > The patch replaces spaces with tabs as required by kernel coding > > >

Re: [PATCH] staging: most: Adds parentheses around macros with complex values

2017-03-23 Thread Greg KH
On Thu, Mar 23, 2017 at 04:38:38AM -0400, Mark Stenglein wrote: > Fixes three instances of the following checklist error: > - ERROR: Macros with complex values should be enclosed > in parentheses > > Simply adds parentheses around the macros to fix the problem. > > Signed-off-by: Mark

[PATCH v9] staging: iio: adis16060: Remove iio_dev mlock and refactor code

2017-03-23 Thread simran singhal
The IIO subsystem is redefining iio_dev->mlock to be used by the IIO core only for protecting device operating mode changes. ie. Changes between INDIO_DIRECT_MODE, INDIO_BUFFER_* modes. In this driver, mlock was being used to protect hardware state changes. In the driver, buf_lock protects both

Re: [PATCH] staging: vt6656: removed coding style errors

2017-03-23 Thread Prasant Jalan
On Thu, Mar 23, 2017 at 1:02 PM, Greg KH wrote: > > On Wed, Mar 22, 2017 at 09:39:24PM +0530, Prasant Jalan wrote: > > The patch replaces spaces with tabs as required by kernel coding > > standards. > > > > Signed-off-by: Prasant Jalan > > ---

[PATCH] drivers/staging/wilc1000: Fixing dev_err and removing dev_dbg calls for tracing

2017-03-23 Thread Pushkar Jambhlekar
dev_err: replacing function name with '%s' and __func__ dev_dbg: Removing calls which are used for tracing a function. Signed-off-by: Pushkar Jambhlekar --- drivers/staging/wilc1000/wilc_sdio.c | 8 ++-- 1 file changed, 2 insertions(+), 6 deletions(-) diff --git

[PATCH] drivers/staging/media: atomisp: Removing redundant information from dev_err

2017-03-23 Thread Pushkar Jambhlekar
Removing hardcoded function name as code is already using __func__ Signed-off-by: Pushkar Jambhlekar --- drivers/staging/media/atomisp/pci/atomisp2/hmm/hmm_bo.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [PATCH v3 2/2] staging: iio: ade7753: Replace mlock with driver private lock

2017-03-23 Thread SIMRAN SINGHAL
On Thu, Mar 23, 2017 at 1:55 AM, Jonathan Cameron wrote: > On 21/03/17 18:03, simran singhal wrote: >> The IIO subsystem is redefining iio_dev->mlock to be used by >> the IIO core only for protecting device operating mode changes. >> ie. Changes between INDIO_DIRECT_MODE,

RE: [PATCH v2] HV: properly delay KVP packets when negotiation is in progress

2017-03-23 Thread Long Li
> -Original Message- > From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com] > Sent: Thursday, March 23, 2017 9:04 AM > To: Long Li > Cc: KY Srinivasan ; Haiyang Zhang > ; Stephen Hemminger > ;

Re: [PATCH v3 2/2] staging: iio: ade7753: Replace mlock with driver private lock

2017-03-23 Thread Jonathan Cameron
On 23 March 2017 18:12:33 GMT+00:00, SIMRAN SINGHAL wrote: >On Thu, Mar 23, 2017 at 1:55 AM, Jonathan Cameron >wrote: >> On 21/03/17 18:03, simran singhal wrote: >>> The IIO subsystem is redefining iio_dev->mlock to be used by >>> the IIO core only

Re: [PATCH 09/11] staging: speakup: Simplify the NULL comparisons

2017-03-23 Thread Greg KH
On Tue, Mar 21, 2017 at 05:12:33PM +0530, Arushi Singhal wrote: > Fixed coding style for null comparisons in speakup driver to be more > consistant with the rest of the kernel coding style. > Replaced 'x != NULL' with 'x' and 'x = NULL' with '!x'. > > Signed-off-by: Arushi Singhal

Re: [PATCH] staging: ad7746: Moved contents of the header to the source file.

2017-03-23 Thread Lars-Peter Clausen
On 03/23/2017 12:36 PM, Arushi Singhal wrote: > Moved the contents of the header(ad7746.h) into the source file > ad7746.c with the exception of the platform data struct which is > supposed to be used from somewhere else other than the driver. > > Signed-off-by: Arushi Singhal

Re: [PATCH staging/speakup v3 3/3] use speakup_allocate as per required context

2017-03-23 Thread Greg KH
On Tue, Mar 21, 2017 at 12:40:24PM +0530, Pranay Kr. Srivastava wrote: > speakup_allocate used GFP_ATOMIC for allocations > even while during initialization due to it's use > in notifier call. > > Pass GFP_ flags as well to speakup_allocate depending > on the context it is called in. > >

Re: [PATCH 02/11] staging: speakup: Remove multiple assignments

2017-03-23 Thread Greg KH
On Tue, Mar 21, 2017 at 05:12:26PM +0530, Arushi Singhal wrote: > This patch fixes the checkpatch.pl warning "multiple assignments > should be avoided." > > Signed-off-by: Arushi Singhal > --- > drivers/staging/speakup/main.c | 18 -- > 1 file

Re: [PATCH] drivers/staging/dgnc: Removing manual function tracing using dev_dbg

2017-03-23 Thread Greg Kroah-Hartman
On Thu, Mar 23, 2017 at 02:20:53PM +0530, Pushkar Jambhlekar wrote: > Current implementation manually traces function using 'dev_dbg'. This way is > not needed because of ftrace, making these calls redundant. Always wrap your changelog lines properly. Also, someone else sent this same patch in

Re: [PATCH] staging:fbtft/fbtft-io: Fix incorrect type in assignment

2017-03-23 Thread Greg Kroah-Hartman
On Thu, Mar 23, 2017 at 03:08:38PM +0800, Zhengyi Shen wrote: > Fix endian sparse warnings of incorrect type in assignment. > This patch changes type to the appropriate endian specific versions. > > > Signed-off-by: Zhengyi Shen > --- > drivers/staging/fbtft/fbtft-io.c |

Re: [PATCH v2] staging: radio-bcm2048: fixed bare use of unsigned int

2017-03-23 Thread Greg Kroah-Hartman
On Wed, Mar 22, 2017 at 01:33:39PM +1100, Eddie Youseph wrote: > Fixed checkpatch WARNING: Prefer 'unsigned int' to bare use of 'unsigned' > > Signed-off-by: Eddie Youseph > --- > Changes in v2: > - Added changelog Did you actually build this change? Please do

Re: [PATCH] staging: media: atomisp: use kvmalloc and kvfree

2017-03-23 Thread Greg Kroah-Hartman
On Thu, Mar 23, 2017 at 09:12:39PM +0800, Geliang Tang wrote: > Use kvmalloc() and kvfree() instead of open-coding. These functions are not in Linus's tree, so I can't apply this patch without breaking things :( thanks, greg k-h ___ devel mailing list

[PATCH] staging: rtl8192e: Fix embedded function names with __func__

2017-03-23 Thread suniel . spartan
From: Suniel Mahesh Prefer and make it generic by using %s and __func__ to print functions name instead of embedding functions name in print statements Signed-off-by: Suniel Mahesh --- drivers/staging/rtl8192e/rtl8192e/rtl_ps.c | 22

Re: [PATCH] staging: tsl2x7x: Moved contents of the header to the source file.

2017-03-23 Thread Lars-Peter Clausen
On 03/23/2017 12:53 PM, Arushi Singhal wrote: > Moved the contents of the header(tsl2x7x.h) into the source file > tsl2x7x_core.c with the exception of the platform data struct which is > supposed to be used from somewhere else other than the driver. The platform_data struct uses the other

Re: [PATCH 11/11] staging: speakup: Fix alignment with parenthesis.

2017-03-23 Thread Greg KH
On Tue, Mar 21, 2017 at 05:12:35PM +0530, Arushi Singhal wrote: > This patch fixes the warnings reported by checkpatch.pl > for please use a blank line after function/struct/union/enum > declarations. That's not what this patch does at all! Please be more careful. greg k-h

[PATCH v2] staging:speakup: Fix alignment with parenthesis.

2017-03-23 Thread Arushi Singhal
Fix checkpatch issues: "CHECK: Alignment should match open parenthesis". Signed-off-by: Arushi Singhal --- changes in v2 - change the commit message. drivers/staging/speakup/speakup_apollo.c | 2 +- drivers/staging/speakup/speakup_decext.c | 4 ++-- 2 files

[PATCH] staging: media: atomisp: fix build error

2017-03-23 Thread Geliang Tang
Fix the following build error: CC drivers/staging/media/atomisp/pci/atomisp2/hmm/hmm.o drivers/staging/media/atomisp/pci/atomisp2/hmm/hmm.c:52:2: error: excess elements in array initializer [-Werror] "i", /* ion */ ^~~ drivers/staging/media/atomisp/pci/atomisp2/hmm/hmm.c:52:2: note:

[PATCH] staging: media: atomisp: use kvmalloc and kvfree

2017-03-23 Thread Geliang Tang
Use kvmalloc() and kvfree() instead of open-coding. Signed-off-by: Geliang Tang --- drivers/staging/media/atomisp/pci/atomisp2/atomisp_cmd.c | 10 ++ 1 file changed, 2 insertions(+), 8 deletions(-) diff --git

Re: [PATCH 05/11] staging: speakup: Remove multiple assignments

2017-03-23 Thread Greg KH
On Tue, Mar 21, 2017 at 05:12:29PM +0530, Arushi Singhal wrote: > This patch fixes the checkpatch.pl warning "multiple assignments > should be avoided." > > Signed-off-by: Arushi Singhal > --- > drivers/staging/speakup/main.c | 3 ++- > 1 file changed, 2

Re: [Outreachy kernel] [RESEND PATCH v2] staging:speakup: Fix alignment with parenthesis.

2017-03-23 Thread Julia Lawall
It should be staging: speakup:, not staging:speakup: On Thu, 23 Mar 2017, Arushi Singhal wrote: > Fix checkpatch issues: "CHECK: Alignment should match open parenthesis". It would really be better to say what the patch does, not just say what error message you have fixed. julia >

[PATCH] staging: ad7746: Moved contents of the header to the source file.

2017-03-23 Thread Arushi Singhal
Moved the contents of the header(ad7746.h) into the source file ad7746.c with the exception of the platform data struct which is supposed to be used from somewhere else other than the driver. Signed-off-by: Arushi Singhal --- drivers/staging/iio/cdc/ad7746.c | 5

[PATCH] staging: tsl2x7x: Moved contents of the header to the source file.

2017-03-23 Thread Arushi Singhal
Moved the contents of the header(tsl2x7x.h) into the source file tsl2x7x_core.c with the exception of the platform data struct which is supposed to be used from somewhere else other than the driver. Signed-off-by: Arushi Singhal ---

Re: [PATCH v2] HV: properly delay KVP packets when negotiation is in progress

2017-03-23 Thread Vitaly Kuznetsov
Long Li writes: > The host may send multiple negotiation packets (due to timeout) before > the KVP user-mode daemon is connected. We need to defer processing > those packets until the daemon is negotiated and connected. It's okay > for guest to respond to all negotiation

Re: [PATCH] staging: media: atomisp: fix build error

2017-03-23 Thread Alan Cox
On Thu, 2017-03-23 at 21:12 +0800, Geliang Tang wrote: > Fix the following build error: > >   CC  drivers/staging/media/atomisp/pci/atomisp2/hmm/hmm.o > drivers/staging/media/atomisp/pci/atomisp2/hmm/hmm.c:52:2: >  error: excess elements in array initializer [-Werror] >   "i", /* ion */ >  

Re: [Outreachy kernel] [PATCH v4] staging: iio: ade7753: Replace mlock with driver private lock

2017-03-23 Thread Alison Schofield
On Fri, Mar 24, 2017 at 12:05:20AM +0530, simran singhal wrote: > The IIO subsystem is redefining iio_dev->mlock to be used by > the IIO core only for protecting device operating mode changes. > ie. Changes between INDIO_DIRECT_MODE, INDIO_BUFFER_* modes. > > In this driver, mlock was being used

[Please ignore this is a test] pci-hyperv: properly handle pci bus remove

2017-03-23 Thread Long Li
From: Long Li hv_pci_devices_present is called in hv_pci_remove when we remove a PCI device from host (e.g. by disabling SRIOV on a device). In hv_pci_remove, the bus is already removed before the call, so we don't need to rescan the bus in the workqueue scheduled from

[PATCH v4] staging: iio: ade7753: Replace mlock with driver private lock

2017-03-23 Thread simran singhal
The IIO subsystem is redefining iio_dev->mlock to be used by the IIO core only for protecting device operating mode changes. ie. Changes between INDIO_DIRECT_MODE, INDIO_BUFFER_* modes. In this driver, mlock was being used to protect hardware state changes. Replace it with a lock in the devices

[PATCH] staging: iio: accel: remove unneeded braces around single statements

2017-03-23 Thread Mark Stenglein
Fixes three checkpatch warnings due to braces used when single statements are sufficient. Signed-off-by: Mark Stenglein --- drivers/staging/iio/accel/adis16209.c | 3 +-- drivers/staging/iio/accel/adis16240.c | 6 ++ 2 files changed, 3 insertions(+), 6 deletions(-) diff

Re: [PATCH 0/3] staging: media: Replace a bit shift.

2017-03-23 Thread Chris Moore
Hi, Le 22/03/2017 à 05:26, Arushi Singhal a écrit : Replace a bit shift by a use of BIT in media driver. Arushi Singhal (3): staging: media: Replace a bit shift by a use of BIT. staging: media: davinci_vpfe: Replace a bit shift by a use of BIT. staging: media: omap4iss: Replace a bit

[PATCH] staging:fbtft/fbtft-io: Fix incorrect type in assignment

2017-03-23 Thread Zhengyi Shen
Fix endian sparse warnings of incorrect type in assignment. This patch changes type to the appropriate endian specific versions. Signed-off-by: Zhengyi Shen --- drivers/staging/fbtft/fbtft-io.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git