Re: [PATCH 04/11] Staging: iio: accel: Rename few macro definitions

2018-03-07 Thread Jonathan Cameron
On Mon, 5 Mar 2018 13:19:23 +0530 Himanshu Jha wrote: > Rename few macros with appropriate names specifying their usage/function. Most of these are obviously good, but for one I didn't understand your reasoning. Given there are only a few of them, I'd put some more

Re: [PATCH 10/11] Staging: iio: accel: Add comments about units in data read function

2018-03-07 Thread Jonathan Cameron
On Mon, 5 Mar 2018 13:19:29 +0530 Himanshu Jha wrote: > Clarify the conversion and formation of resultant data in the > adis16201_read_raw() with sufficient comments. > > Signed-off-by: Himanshu Jha This is fine but it needs to be in

Re: [PATCH v3 1/4] Staging: iio: adis16209: Remove and add some comments and group the definitions

2018-03-07 Thread Jonathan Cameron
On Sun, 04 Mar 2018 18:37:04 +0530 Shreeya Patel wrote: > On Sun, 2018-03-04 at 18:26 +0530, Himanshu Jha wrote: > > Hi Shreeya, > > > > On Sun, Mar 04, 2018 at 06:06:22PM +0530, Shreeya Patel wrote: > > > > > > Remove some unnecessay comments and group the

Re: [PATCH v2 2/3] staging:iio:meter: Remove unused macro IIO_DEV_ATTR_CH_OFF

2018-03-07 Thread Jonathan Cameron
On Tue, 6 Mar 2018 21:44:07 -0300 Rodrigo Siqueira wrote: > This patch removes the macro IIO_DEV_ATTR_CH_OFF. The macro > IIO_DEV_ATTR_CH_OFF is not required, due to the replace of it by the > direct use of IIO_DEVICE_ATTR in files staging/iio/meter/ade7759.c and >

Re: [PATCH 03/11] Staging: iio: accel: Remove unnecessary comments

2018-03-07 Thread Jonathan Cameron
On Mon, 5 Mar 2018 13:19:22 +0530 Himanshu Jha wrote: > Remove unnecessary comments since the definitions are pretty clear > with their macro names. > > Signed-off-by: Himanshu Jha Hi, The art of commenting (and indeed removing

Re: [PATCH] staging: iio: Remove unnecessary cast on void pointer

2018-03-07 Thread Jonathan Cameron
On Wed, 7 Mar 2018 18:47:17 +0530 Arushi Singhal wrote: > The following Coccinelle script was used to detect this: > @r@ > expression x; > void* e; > type T; > identifier f; > @@ > ( > *((T *)e) > | > ((T *)x)[...] > | > ((T*)x)->f > | > > - (T*) > e > )

Re: [PATCH v2 3/3] staging:iio:meter: Aligns open parenthesis

2018-03-07 Thread Jonathan Cameron
On Tue, 6 Mar 2018 21:44:26 -0300 Rodrigo Siqueira wrote: > This patch fixes the checkpatch.pl checks: > > staging/iio/meter/ade7854-spi.c:19: CHECK: Alignment should match open > parenthesis > staging/iio/meter/ade7854-spi.c:44: CHECK: Alignment should match open

Re: [PATCH 05/11] Staging: iio: accel: Add _REG suffix to registers

2018-03-07 Thread Jonathan Cameron
On Mon, 5 Mar 2018 13:19:24 +0530 Himanshu Jha wrote: > Addition of _REG suffix to the register definitions allows a distinction > between registers and register fields. The various registers and its field > bits are grouped together to improve readability and easy

[PATCH v2] staging: lustre: Remove VLA usage

2018-03-07 Thread Kees Cook
The kernel would like to have all stack VLA usage removed[1]. This switches to a simple kasprintf() instead, and in the process fixes an off-by-one between the allocation and the sprintf (allocation did not include NULL byte in calculation). [1] https://lkml.org/lkml/2018/3/7/621 Signed-off-by:

Re: [PATCH v3 4/4] Staging: iio: adis16209: Use sign_extend32 function

2018-03-07 Thread Jonathan Cameron
On Sun, 4 Mar 2018 18:15:06 +0530 Shreeya Patel wrote: > Use sign_extend32 function instead of manually coding > it. > > Signed-off-by: Shreeya Patel Applied to the togreg branch of iio.git and pushed out as testing for the

Re: [PATCH 02/11] Staging: iio: accel: Add a blank space before returns

2018-03-07 Thread Jonathan Cameron
On Mon, 5 Mar 2018 13:19:21 +0530 Himanshu Jha wrote: > Adding a blank space before/after some returns improves readability. > > Signed-off-by: Himanshu Jha Applied - patch title adjusted. Thanks, Jonathan > --- >

Re: [PATCH 11/11] Staging: iio: accel: Move adis16201 driver out of staging subsystem

2018-03-07 Thread Jonathan Cameron
On Mon, 5 Mar 2018 13:19:30 +0530 Himanshu Jha wrote: > Move the adis16201 driver out of staging directory and merge to the > mainline IIO subsystem. > > Signed-off-by: Himanshu Jha One comment inline (that I should have noticed in one

Re: [PATCH v3 2/4] Staging: iio: adis16209: Change some macro names

2018-03-07 Thread Jonathan Cameron
On Sun, 4 Mar 2018 18:11:17 +0530 Shreeya Patel wrote: > Make some of the macro names according to the names > given in the datasheet of the adis16209 driver. > > Signed-off-by: Shreeya Patel A small comment inline which we should

Re: [PATCH] staging: iio: meter: Remove reduntant __func__ from debug print

2018-03-07 Thread Jonathan Cameron
On Wed, 7 Mar 2018 11:08:04 +0530 hariprasath.ela...@gmail.com wrote: > From: HariPrasath Elango > > dev_dbg includes the function name & line number by default when dynamic > debugging is enabled. Hence__func__ is reduntant here and removed. > > Signed-off-by:

Re: [PATCH v2 1/3] staging:iio:meter: Replaces IIO_DEV_ATTR_CH_OFF by IIO_DEVICE_ATTR

2018-03-07 Thread Jonathan Cameron
On Tue, 6 Mar 2018 21:43:47 -0300 Rodrigo Siqueira wrote: > The macro IIO_DEV_ATTR_CH_OFF is a wrapper for IIO_DEVICE_ATTR, with a > tiny change in the name definition. This extra macro does not improve > the readability and also creates some checkpatch errors. >

Re: [PATCH 01/11] Staging: iio: accel: Prefer alphabetical sequence of header files

2018-03-07 Thread Jonathan Cameron
On Mon, 5 Mar 2018 13:19:20 +0530 Himanshu Jha wrote: > Arrange header files in alphabetical sequence to improve readability. > > Signed-off-by: Himanshu Jha One general comment - when naming a patch it will form the description in the

Re: [PATCH 08/11] Staging: iio: accel: Use switch statement than if-else

2018-03-07 Thread Jonathan Cameron
On Mon, 5 Mar 2018 13:19:27 +0530 Himanshu Jha wrote: > Use switch statement instead of if-else pair to explicitly match > the only two channels present. > > Signed-off-by: Himanshu Jha I think this is going to generate some warnings

Re: [PATCH] staging: lustre: Remove VLA usage

2018-03-07 Thread Rasmus Villemoes
On Wed, Mar 07 2018, Kees Cook wrote: > On Wed, Mar 7, 2018 at 5:10 AM, Rasmus Villemoes > wrote: >> On 2018-03-07 06:46, Kees Cook wrote: >>> The kernel would like to remove all VLA usage. This switches to a >>> simple kasprintf() instead. >>>

Re: [PATCH v3 3/4] Staging: iio: adis16209: Adjust a switch statement

2018-03-07 Thread Jonathan Cameron
On Sun, 4 Mar 2018 18:13:12 +0530 Shreeya Patel wrote: > Adjust a switch block to explicitly match channels and > return -EINVAL as default case which makes the code > semantically more clear. > > Signed-off-by: Shreeya Patel Applied

[PATCH] staging: android: ashmem: Remove deadlock

2018-03-07 Thread Paul Lawrence
Regression introduced in commit ce8a3a9e76d0193e2e8d74a06d275b3c324ca652 ("staging: android: ashmem: Fix a race condition in pin ioctls") causing deadlock. No need to hold ashmem_mutex while copying from user Stacks are: ashmem_mmap+0x53/0x400 drivers/staging/android/ashmem.c:379

RE: [PATCH v3 6/6] PCI: hv: fix 2 hang issues in hv_compose_msi_msg()

2018-03-07 Thread Dexuan Cui
> From: Lorenzo Pieralisi > Sent: Wednesday, March 7, 2018 04:35 > On Tue, Mar 06, 2018 at 06:21:56PM +, Dexuan Cui wrote: > > 1. With the patch "x86/vector/msi: Switch to global reservation mode" > > (4900be8360), the recent v4.15 and newer kernels always hang for

Re: [PATCH] staging: android: ashmem: Remove deadlock

2018-03-07 Thread Nathan Chancellor
On Wed, Mar 07, 2018 at 01:40:30PM -0800, Paul Lawrence wrote: > Regression introduced in commit ce8a3a9e76d0193e2e8d74a06d275b3c324ca652 > ("staging: android: ashmem: Fix a race condition in pin ioctls") > causing deadlock. > > No need to hold ashmem_mutex while copying from user > > Stacks

[PATCH PATCH net v2 0/4] hv_netvsc: fix multicast flags and sync

2018-03-07 Thread Stephen Hemminger
This set of patches deals with the handling of multicast flags and addresses in transparent VF mode. The recent set of patches (in linux-net) had a couple of bugs. Stephen Hemminger (4): hv_netvsc: fix filter flags hv_netvsc: avoid repeated updates of packet filter hv_netvsc: fix locking

[PATCH] staging: fsl-mc/dpio: Add missing argument identifier

2018-03-07 Thread Roy Pledge
When running checkpatch over the DPIO code the following warning is reported: WARNING: function definition argument 'struct dpaa2_io_notification_ctx *' should also have an identifier name Add the missing identifier. Signed-off-by: Roy Pledge ---

Re: [PATCH] staging: android: ashmem: Remove deadlock

2018-03-07 Thread Greg Kroah-Hartman
On Wed, Mar 07, 2018 at 02:02:13PM -0800, Paul Lawrence wrote: > Great! We need to make sure this gets backported to 4.4 and 4.9, and to > 3.18 with the original dependency, please. That will happen when it lands in Linus's tree, which should be later this week if all goes well. thanks, greg

ACKNOWLEDGE RECEIPT 3/7/2018

2018-03-07 Thread MINT SA
Good Day, This is a letter of Intent for Investment Project. See attached for full details. Indicate your interest to my personal email: batud...@yandex.com Yours sincerely. Mr.Dave Batu ___ devel mailing list de...@linuxdriverproject.org

[PATCH PATCH net v2 3/4] hv_netvsc: fix locking for rx_mode

2018-03-07 Thread Stephen Hemminger
The rx_mode operation handler is different than other callbacks in that is not always called with rtnl held. Therefore use RCU to ensure that references are valid. Fixes: bee9d41b37ea ("hv_netvsc: propagate rx filters to VF") Signed-off-by: Stephen Hemminger ---

[PATCH PATCH net v2 4/4] hv_netvsc: fix locking during VF setup

2018-03-07 Thread Stephen Hemminger
The dev_uc/mc_sync calls need to have the device address list locked. This was spotted by running with lockdep enabled. Fixes: bee9d41b37ea ("hv_netvsc: propagate rx filters to VF") Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/netvsc_drv.c | 4 1 file

[PATCH PATCH net v2 2/4] hv_netvsc: avoid repeated updates of packet filter

2018-03-07 Thread Stephen Hemminger
The netvsc driver can get repeated calls to netvsc_rx_mode during network setup; each of these calls ends up scheduling the lower layers to update tha packet filter. This update requires an request/response to the host. So avoid doing this if we already know that the correct packet filter value is

[PATCH PATCH net v2 1/4] hv_netvsc: fix filter flags

2018-03-07 Thread Stephen Hemminger
The recent change to nto always enable all multicast and broadcast was broken; meant to set filter, not change flags. Fixes: 009f766ca238 ("hv_netvsc: filter multicast/broadcast") Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/rndis_filter.c | 4 ++-- 1 file

Re: [RFC] android: ion: How to properly clean caches for uncached allocations

2018-03-07 Thread Laura Abbott
On 02/28/2018 09:18 PM, Liam Mark wrote: The issue: Currently in ION if you allocate uncached memory it is possible that there are still dirty lines in the cache. And often these dirty lines in the cache are the zeros which were meant to clear out any sensitive kernel data. What this means is

,Your urgent confirmation

2018-03-07 Thread James Williams
Attn: Beneficiary, We have contacted the Federal Ministry of Finance on your Behalf and they have brought a solution to your problem by coordinating your payment in total (10,000,000.00) Ten Million Dollars in an atm card which you can use to withdraw money from any ATM MACHINE CENTER anywhere in

Re: [PATCH 10/11] Staging: iio: accel: Add comments about units in data read function

2018-03-07 Thread Himanshu Jha
On Wed, Mar 07, 2018 at 08:50:30PM +, Jonathan Cameron wrote: > On Mon, 5 Mar 2018 13:19:29 +0530 > Himanshu Jha wrote: > > > Clarify the conversion and formation of resultant data in the > > adis16201_read_raw() with sufficient comments. > > > > Signed-off-by:

Re: [PATCH] staging: lustre: Remove VLA usage

2018-03-07 Thread Kees Cook
On Wed, Mar 7, 2018 at 5:10 AM, Rasmus Villemoes wrote: > On 2018-03-07 06:46, Kees Cook wrote: >> The kernel would like to remove all VLA usage. This switches to a >> simple kasprintf() instead. >> >> Signed-off-by: Kees Cook >> --- >>

Re: [PATCH v3] staging: rtl8192u: Replace printk() with more standardize output format.

2018-03-07 Thread Dan Carpenter
On Wed, Mar 07, 2018 at 04:09:09PM +0530, Arushi Singhal wrote: > @@ -276,22 +276,22 @@ static int ieee80211_ccmp_decrypt(struct sk_buff *skb, > int hdr_len, void *priv) > keyidx = pos[3]; > if (!(keyidx & (1 << 5))) { > if (net_ratelimit()) { > -

Re: [Outreachy kernel] Re: [PATCH v3] staging: rtl8192u: Replace printk() with more standardize output format.

2018-03-07 Thread Julia Lawall
On Wed, 7 Mar 2018, Dan Carpenter wrote: > On Wed, Mar 07, 2018 at 04:09:09PM +0530, Arushi Singhal wrote: > > @@ -276,22 +276,22 @@ static int ieee80211_ccmp_decrypt(struct sk_buff > > *skb, int hdr_len, void *priv) > > keyidx = pos[3]; > > if (!(keyidx & (1 << 5))) { > >

Re: [PATCH] staging: most: Remove unnecessary usage of BUG_ON().

2018-03-07 Thread Christian Gromm
On 07.03.2018 02:31, Quytelda Kahja wrote: There is no need for the calls to BUG_ON() in this driver, which are used to check if mbo or mbo->context are NULL; mbo is never NULL, and if mbo->context is NULL it would have already been dereferenced and oopsed before reaching the BUG_ON().

[PATCH v3] staging: rtl8192u: Replace printk() with more standardize output format.

2018-03-07 Thread Arushi Singhal
printk() is the raw way to print output and should be avoided. For drivers with defined "struct device object", dev_*macro() is prefer and for "struct netdevice object", netdev_*macro() is prefer over dev_*macro() to standardize the output format within the subsystem. If no "struct device

[PATCH] staging: iio: Remove unnecessary cast on void pointer

2018-03-07 Thread Arushi Singhal
The following Coccinelle script was used to detect this: @r@ expression x; void* e; type T; identifier f; @@ ( *((T *)e) | ((T *)x)[...] | ((T*)x)->f | - (T*) e ) Signed-off-by: Arushi Singhal --- drivers/staging/iio/adc/ad7816.c | 2 +- 1 file changed,

Re: [Outreachy kernel] Re: [PATCH v3] staging: rtl8192u: Replace printk() with more standardize output format.

2018-03-07 Thread Dan Carpenter
On Wed, Mar 07, 2018 at 11:52:16AM +0100, Julia Lawall wrote: > > > On Wed, 7 Mar 2018, Dan Carpenter wrote: > > > On Wed, Mar 07, 2018 at 04:09:09PM +0530, Arushi Singhal wrote: > > > @@ -276,22 +276,22 @@ static int ieee80211_ccmp_decrypt(struct sk_buff > > > *skb, int hdr_len, void *priv) >

Re: [PATCH v3 6/6] PCI: hv: fix 2 hang issues in hv_compose_msi_msg()

2018-03-07 Thread Lorenzo Pieralisi
On Tue, Mar 06, 2018 at 06:21:56PM +, Dexuan Cui wrote: > 1. With the patch "x86/vector/msi: Switch to global reservation mode" > (4900be8360), the recent v4.15 and newer kernels always hang for 1-vCPU > Hyper-V VM with SR-IOV. This is because when we reach hv_compose_msi_msg() > by

Re: [PATCH] staging: lustre: Remove VLA usage

2018-03-07 Thread Rasmus Villemoes
On 2018-03-07 06:46, Kees Cook wrote: > The kernel would like to remove all VLA usage. This switches to a > simple kasprintf() instead. > > Signed-off-by: Kees Cook > --- > drivers/staging/lustre/lustre/llite/xattr.c | 19 +-- > 1 file changed, 13

Re: [PATCH] staging: lustre: Remove VLA usage

2018-03-07 Thread Tobin C. Harding
On Tue, Mar 06, 2018 at 09:46:08PM -0800, Kees Cook wrote: > The kernel would like to remove all VLA usage. This switches to a > simple kasprintf() instead. > > Signed-off-by: Kees Cook > --- > drivers/staging/lustre/lustre/llite/xattr.c | 19 +-- > 1 file