[PATCH v2 00/10] staging: mt7621-mmc: Fixes and cleanups

2018-04-07 Thread Christian Lütke-Stetzkamp
Again, here are some fixes (most of them reported by Dan Carpenter) and some removements of unused code in the mt7621-mmc driver. With this patches, the driver at least compiles while CONFIG_PM is selected, but it remains untested. Changes in v2: * Removed assignment and return value in

[PATCH v2 01/10] staging: mt7621-mmc: Fix power management by removing old api

2018-04-07 Thread Christian Lütke-Stetzkamp
The mmc_suspend|resume_host functions have been decrepated in the 3.11 [1] release and were completely removed in 3.13 [2]. Removing the calls to this functions as it was done for other mmc host drivers before the old api was removed (eg. [3]) fixes compile errors in this driver while CONFIG_PM is

[PATCH v2 05/10] staging: mt7621-mmc: Remove constant flag MSDC_HIGHSPEED

2018-04-07 Thread Christian Lütke-Stetzkamp
The MSDC_HIGHSPEED flag is always set and never unset, remove it to clean up the code. Signed-off-by: Christian Lütke-Stetzkamp Reviewed-by: NeilBrown --- drivers/staging/mt7621-mmc/board.h | 1 - drivers/staging/mt7621-mmc/sd.c| 7 ++- 2 files

[PATCH v2 03/10] staging: mt7621-mmc: Remove unused global: msdc_6575_host

2018-04-07 Thread Christian Lütke-Stetzkamp
The mt6575_host variable is never used, only set and exported. Removing it for code cleanup. Signed-off-by: Christian Lütke-Stetzkamp Reviewed-by: NeilBrown --- drivers/staging/mt7621-mmc/sd.c | 5 - 1 file changed, 5 deletions(-) diff --git

[PATCH v2 10/10] staging: mt7621-mmc: Remove redundant opcode check

2018-04-07 Thread Christian Lütke-Stetzkamp
The opcode check in msdc_command_start is redundant in case of MMC_SET_RELATIVE_ADDR, this is 3 like SD_SEND_RELATIVE_ADDR, so the second check can be removed. Reported-by: Dan Carpenter Signed-off-by: Christian Lütke-Stetzkamp Reviewed-by:

[PATCH v2 06/10] staging: mt7621-mmc: Fix dereference before check in msdc_drv_pm

2018-04-07 Thread Christian Lütke-Stetzkamp
In the msdc_drv_pm function the variable mmc is dereferenced before checked. Reordering fixes that. Reported-by: Dan Carpenter Signed-off-by: Christian Lütke-Stetzkamp Reviewed-by: NeilBrown --- drivers/staging/mt7621-mmc/sd.c | 6

[PATCH v2 02/10] staging: mt7621-mmc: Remove constant flag

2018-04-07 Thread Christian Lütke-Stetzkamp
The MSDC_SYS_SUSPEND flag is always set and is never unset. Removing it cleans up the code. Signed-off-by: Christian Lütke-Stetzkamp Reviewed-by: NeilBrown --- drivers/staging/mt7621-mmc/board.h | 1 - drivers/staging/mt7621-mmc/sd.c| 8 2

[PATCH v2 09/10] staging: mt7621-mmc: Fix: copy_from_user() returns a positive value

2018-04-07 Thread Christian Lütke-Stetzkamp
copy_from_user() returns a positive value in case of an error, to fix this the check is turned around, also a better return value is chosen. Reported-by: Dan Carpenter Suggested-by: Dan Carpenter Signed-off-by: Christian Lütke-Stetzkamp

[PATCH v2 07/10] staging: mt7621-mmc: Remove error message in debug

2018-04-07 Thread Christian Lütke-Stetzkamp
If the debug file in proc fs is not successfully created current code prints an error message, this is removed. de is also not an error pointer, so the IS_ERR() call leads to a static checker warning. The unused return value of the msdc_debug_proc_init function is also removed. Reported-by: Dan

[PATCH v2 04/10] staging: mt7621-mmc: Remove unused functions

2018-04-07 Thread Christian Lütke-Stetzkamp
The functions msdc_eirq_cd and msdc_eirq_sdio are defined but never used, so they are removed. This also fixes two compiler warnings: drivers/staging/mt7621-mmc/sd.c:517:13: warning: ‘msdc_eirq_cd’ defined but not used [-Wunused-function] static void msdc_eirq_cd(void *data)

[PATCH v2 08/10] staging: mt7621-mmc: Fix debug file world writable

2018-04-07 Thread Christian Lütke-Stetzkamp
Currently the debug file in proc fs is world writable, remove the access for other. Reported-by: Dan Carpenter Signed-off-by: Christian Lütke-Stetzkamp Reviewed-by: NeilBrown --- drivers/staging/mt7621-mmc/dbg.c | 2 +- 1 file

Re: [PATCH v2 1/3] resource: Use list_head to link sibling resource

2018-04-07 Thread kbuild test robot
Hi Baoquan, I love your patch! Yet something to improve: [auto build test ERROR on linus/master] [also build test ERROR on v4.16 next-20180406] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url:

[PATCH] staging: vt6655: remove unnecessary line breaks in function definition.

2018-04-07 Thread Danilo Alves
This patch corrects the function definition style of CARDvSafeResetRx. Issue found by checkpatch. CHECK: Lines should not end with a '(' Signed-off-by: Danilo Alves --- drivers/staging/vt6655/card.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git

Re: [PATCH v2 1/3] resource: Use list_head to link sibling resource

2018-04-07 Thread kbuild test robot
Hi Baoquan, I love your patch! Yet something to improve: [auto build test ERROR on linus/master] [also build test ERROR on v4.16 next-20180406] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url:

your images need editing and

2018-04-07 Thread Sam
We have been hailed as one of the top-tier photo retouching service providers in the world, supplying its tremendous expertise to more than 20 nations, and catering to myriad industry needs that include E-Commerce, Photography, and stock photo. Handling high volumes maintaining the highest

[PATCH v2 1/3] resource: Use list_head to link sibling resource

2018-04-07 Thread Baoquan He
The struct resource uses singly linked list to link siblings. It's not easy to do reverse iteration on sibling list. So replace it with list_head. And this makes codes in kernel/resource.c more readable after refactoring than pointer operation. Suggested-by: Andrew Morton