Re: [PATCH] staging: luster: llite: fix a potential missing-check bug when copying lumv

2018-04-29 Thread Greg Kroah-Hartman
On Sat, Apr 28, 2018 at 04:04:25PM +, Dilger, Andreas wrote: > On Apr 27, 2018, at 17:45, Wenwen Wang wrote: > > [PATCH] staging: luster: llite: fix potential missing-check bug when > > copying lumv > > (typo) s/luster/lustre/ > > > In ll_dir_ioctl(), the object lumv3 is

Re: [PATCH] staging: mt7621-eth: fix line over 80 char / extra line in mtk_set_link_ksettings()

2018-04-29 Thread Greg KH
On Thu, Apr 26, 2018 at 09:29:09PM -0300, Jefferson Capovilla wrote: > Fix 'line over 80 characters' issue found by checkpatch.pl script in > mtk_set_link_ksettings(). > Fix extra line before end of function. That is two different things, please break this up into two different emails and send

Re: [PATCH] [v4] staging: wlan-ng: prism2sta: fixed indent coding style issues.

2018-04-29 Thread Greg Kroah-Hartman
On Sat, Apr 28, 2018 at 08:26:29PM +, Efstratios Gavas wrote: > Fixed format/style issues found with checkpatch. No code changes. > Corrected alignment of variables after open parenthesis and line breaks. > Checkpatch now returns clean except for "line over 80 char" warnings. > >

Re: [PATCH 00/10] staging: ks7010: next cleanups

2018-04-29 Thread Greg KH
On Fri, Apr 27, 2018 at 04:05:54PM +0200, Sergio Paracuellos wrote: > Cleanups continues with this patch series. Main changes are > related with MIB where some preprocessor stuff has been change > in favour of an enumeration and some helper functions to increase > code readability has been

Re: [PATCH 00/10] cleanupas continue

2018-04-29 Thread Greg KH
On Sat, Apr 28, 2018 at 12:34:36PM +0200, Sergio Paracuellos wrote: > The following patch series continue with driver cleanups. This series > starts focusing in ks_hostif.c file which really needs refactors. > Some functions have been refactor as well as some style stuff > has been fixed. Please

[PATCH 17/30] staging: mt7621-mmc: Remove unused variable dma_xfer from msdc_host

2018-04-29 Thread Christian Lütke-Stetzkamp
The field dma_xfer of the struct msdc_host is not used anymore, remove it. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/mt6575_sd.h | 1 - drivers/staging/mt7621-mmc/sd.c| 2 +- 2 files changed, 1 insertion(+), 2 deletions(-) diff --git

[PATCH 29/30] staging: mt7621-mmc: Cleanup includes

2018-04-29 Thread Christian Lütke-Stetzkamp
This commit cleans the includes in the sd.c file. Those which are not needed are removed, the remaining ones are sorted alphabetically. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/sd.c | 51 +++-- 1 file

[PATCH 11/30] staging: mt7621-mmc: Replace macro sdr_get_field with function

2018-04-29 Thread Christian Lütke-Stetzkamp
Currently sdr_get_field is a macro, to bring the code in line with the upstream driver mtk-sd, it is changed to a function. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/mt6575_sd.h | 10 +- drivers/staging/mt7621-mmc/sd.c| 14

[PATCH 06/30] staging: mt7621-mmc: Remove unused field clk_drv from msdc_hw

2018-04-29 Thread Christian Lütke-Stetzkamp
The field clk_drv of msdc_hw is set to a constant and only used once, replace that position with the constant and remove the unused field. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/board.h | 1 - drivers/staging/mt7621-mmc/sd.c| 6 ++ 2

[PATCH 03/30] staging: mt7621-mmc: Remove unused field data_edge from msdc_hw

2018-04-29 Thread Christian Lütke-Stetzkamp
The field data_edge of msdc_hw is set to a constant and only used once, replace that position with the constant and remove the unused field. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/board.h | 1 - drivers/staging/mt7621-mmc/sd.c| 7 +++

[PATCH 02/30] staging: mt7621-mmc: Remove unused field cmd_edge from msdc_hw

2018-04-29 Thread Christian Lütke-Stetzkamp
The field cmd_edge of msdc_hw is set to a constant and only used once, replace that position with the constant and remove the unused field. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/board.h | 1 - drivers/staging/mt7621-mmc/sd.c| 4 ++-- 2

[PATCH 14/30] staging: mt7621-mmc: Remove transfer mode setting variable

2018-04-29 Thread Christian Lütke-Stetzkamp
Currently the transfer mode can be chosen between DMA, a size dependent mode and non-DMA by writing to a proc file. The upstream driver mtk-sd uses DMA all times. The previous patch removed the ability to set that option. Now the remaining uses of the transfer mode setting variable are cleaned

[PATCH 23/30] staging: mt7621-mmc: Remove initialisation in msdc_dma_config

2018-04-29 Thread Christian Lütke-Stetzkamp
Current code initialises the variable sg at the beginning of the msdc_dma_config function. This is not necessary, because the variable is assigned by the for_each_sg macro later on. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/sd.c | 2 +- 1 file

[PATCH 30/30] staging: mt7621-mmc: Remove unused barrier macros

2018-04-29 Thread Christian Lütke-Stetzkamp
The current code has some barrier macros in it, which are already '#if 0' out, so just remove them. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/sd.c | 7 --- 1 file changed, 7 deletions(-) diff --git a/drivers/staging/mt7621-mmc/sd.c

[PATCH 19/30] staging: mt7621-mmc: Remove unused field abort from msdc_host

2018-04-29 Thread Christian Lütke-Stetzkamp
The field abort of msdc_host is only set, but never read, so it can be removed. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/mt6575_sd.h | 2 -- drivers/staging/mt7621-mmc/sd.c| 2 -- 2 files changed, 4 deletions(-) diff --git

[PATCH 00/30] staging: mt7621-mmc: Next cleanups

2018-04-29 Thread Christian Lütke-Stetzkamp
Here are the next cleanups for the mt7621-mmc driver. It contains the removal of some unused things, the removal of the non DMA code and always using linked DMA mode together with some minor cleanups. Christian Lütke-Stetzkamp (30): staging: mt7621-mmc: Fix typo in function parameters

[PATCH 24/30] staging: mt7621-mmc: Inline function msdc_set_blknum

2018-04-29 Thread Christian Lütke-Stetzkamp
The function msdc_set_blknum consists of one (real) line of code and is only called once, so inline it makes the code shorter and more readable. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/sd.c | 10 +- 1 file changed, 1 insertion(+), 9

[PATCH 10/30] staging: mt7621-mmc: Replace macro sdr_set_field with function

2018-04-29 Thread Christian Lütke-Stetzkamp
Currently sdr_set_field is a macro, to bring the code in line with the upstream driver mtk-sd, it is changed to a function. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/mt6575_sd.h | 16 +--- 1 file changed, 9 insertions(+), 7

[PATCH 15/30] staging: mt7621-mmc: Remove unused global dma_size

2018-04-29 Thread Christian Lütke-Stetzkamp
The global variable dma_size was previously used to select DMA or non-DMA transfer mode based on the size of the data that should be transferred. This option was removed preivously, so the variable is not used any more and can be removed. Signed-off-by: Christian Lütke-Stetzkamp

[PATCH 28/30] staging: mt7621-mmc: Remove unused macro HOST_MAX_NUM

2018-04-29 Thread Christian Lütke-Stetzkamp
The macro HOST_MAX_NUM is never used, so remove it. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/sd.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/mt7621-mmc/sd.c b/drivers/staging/mt7621-mmc/sd.c index

[PATCH 13/30] staging: mt7621-mmc: Remove transfer mode setting from proc

2018-04-29 Thread Christian Lütke-Stetzkamp
Currently the transfer mode can be chosen between DMA, a size dependent mode and non-DMA by writing to a proc file. The upstream driver mtk-sd uses DMA all times. There is no apparent reason why somebody would like to change the transfer mode and the position of the setting in the debug part of

[PATCH 25/30] staging: mt7621-mmc: Don't disables DMA

2018-04-29 Thread Christian Lütke-Stetzkamp
Current code disables the DMA after the transfer. That only changes the transfer mode to non-DMA and does not save any power. This is not necessary any more, because now DMA transfer is always used. The macro for disabling DMA transfer is also removed, because it is not used any more.

[PATCH 21/30] staging: mt7621-mmc: Do not BUG() if mrq set in msdc_ops_request

2018-04-29 Thread Christian Lütke-Stetzkamp
Currently the code BUG()'s, if host->mrq is set at the beginning of msdc_ops_request. This shoould normally not happen, but it is not that critical, because the critical sections are protected by a spin lock and in the worst case, some commands to the card are lost, so it is sufficient to just

[PATCH 18/30] staging: mt7621-mmc: Fix error number assignment

2018-04-29 Thread Christian Lütke-Stetzkamp
Currently the value that data->error is set to is converted to an unsigned int, but it is a usual error number, so it should be negative. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/sd.c | 29 +++-- 1 file changed, 15

[PATCH 12/30] staging: mt7621-mmc: Remove unused static msdc_regs

2018-04-29 Thread Christian Lütke-Stetzkamp
The static variable msdc_regs is set once, but never used, so remove it. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/sd.c | 8 1 file changed, 8 deletions(-) diff --git a/drivers/staging/mt7621-mmc/sd.c b/drivers/staging/mt7621-mmc/sd.c

[PATCH 27/30] staging: mt7621-mmc: Always use linked DMA mode

2018-04-29 Thread Christian Lütke-Stetzkamp
Current code uses linked DMA mode only when there is more than one entry in the scatterlist. But the overhead of the linked DMA is very small, so the code is easier when only using linked DMA and this is also the way, the upstream driver mtk-sd handles it. Signed-off-by: Christian Lütke-Stetzkamp

[PATCH 07/30] staging: mt7621-mmc: Remove unused macro msdc_init_gpd_ex

2018-04-29 Thread Christian Lütke-Stetzkamp
The macro msdc_init_gpd_ex is never used and does not provied any information about the hardware, so it is removed. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/sd.c | 9 - 1 file changed, 9 deletions(-) diff --git

[PATCH 08/30] staging: mt7621-mmc: Remove unused macros sdr_{read, write}16

2018-04-29 Thread Christian Lütke-Stetzkamp
The sdr_{read,write}16 macros are never used and does not provide any information about the device, so they are removed. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/mt6575_sd.h | 2 -- 1 file changed, 2 deletions(-) diff --git

[PATCH 26/30] staging: mt7621-mmc: Change return value of msdc_dma_config to void

2018-04-29 Thread Christian Lütke-Stetzkamp
The msdc_dma_config function currently returns always 0. Remove the return and change to void. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/sd.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/mt7621-mmc/sd.c

Re: [PATCH 24/30] staging: mt7621-mmc: Inline function msdc_set_blknum

2018-04-29 Thread NeilBrown
On Sun, Apr 29 2018, Christian Lütke-Stetzkamp wrote: > The function msdc_set_blknum consists of one (real) line of code and > is only called once, so inline it makes the code shorter and more > readable. > > Signed-off-by: Christian Lütke-Stetzkamp > --- >

Re: [PATCH] staging: luster: llite: fix a potential missing-check bug when copying lumv

2018-04-29 Thread Wenwen Wang
On Sun, Apr 29, 2018 at 8:20 AM, Greg Kroah-Hartman wrote: > On Sat, Apr 28, 2018 at 04:04:25PM +, Dilger, Andreas wrote: >> On Apr 27, 2018, at 17:45, Wenwen Wang wrote: >> > [PATCH] staging: luster: llite: fix potential missing-check bug when

Re: [PATCH 09/30] staging: mt7621-mmc: Remove function uffs

2018-04-29 Thread NeilBrown
On Sun, Apr 29 2018, Christian Lütke-Stetzkamp wrote: > The function uffs that is implemented by this driver returns the same > values as the kernel function ffs. So the uffs function is removed and > the calls to it are replaced with calls to ffs. This difference is that uffs receives and

Re: [PATCH 11/30] staging: mt7621-mmc: Replace macro sdr_get_field with function

2018-04-29 Thread NeilBrown
On Sun, Apr 29 2018, Christian Lütke-Stetzkamp wrote: > Currently sdr_get_field is a macro, to bring the code in line with the > upstream driver mtk-sd, it is changed to a function. > > Signed-off-by: Christian Lütke-Stetzkamp > --- > drivers/staging/mt7621-mmc/mt6575_sd.h |

Re: [PATCH 23/30] staging: mt7621-mmc: Remove initialisation in msdc_dma_config

2018-04-29 Thread NeilBrown
On Sun, Apr 29 2018, Christian Lütke-Stetzkamp wrote: > Current code initialises the variable sg at the beginning of the > msdc_dma_config function. This is not necessary, because the variable > is assigned by the for_each_sg macro later on. But it isn't only used by the for_each_sg macro.

Re: [PATCH 27/30] staging: mt7621-mmc: Always use linked DMA mode

2018-04-29 Thread NeilBrown
On Sun, Apr 29 2018, Christian Lütke-Stetzkamp wrote: > Current code uses linked DMA mode only when there is more than one > entry in the scatterlist. But the overhead of the linked DMA is very > small, so the code is easier when only using linked DMA and this is > also the way, the upstream

Re: [PATCH 00/30] staging: mt7621-mmc: Next cleanups

2018-04-29 Thread NeilBrown
On Sun, Apr 29 2018, Christian Lütke-Stetzkamp wrote: > Here are the next cleanups for the mt7621-mmc driver. It contains the > removal of some unused things, the removal of the non DMA code and > always using linked DMA mode together with some minor cleanups. Thanks for these. As mentioned

[PATCH] staging: sm750fb: add drm development branch details

2018-04-29 Thread Sudip Mukherjee
The sm750 driver in staging has no future as new framebuffer driver will not be added to fbdev anymore. A drm driver is being prepared, and the details added to the TODO file. This sm750fb driver will be removed as soon as the drm driver is ready. Also, remove my old email. Cc:

[PATCH 22/30] staging: mt7621-mmc: Remove redundant check for card status

2018-04-29 Thread Christian Lütke-Stetzkamp
Current code checks the card status at the beginning of msdc_ops_request. This is not necessary because mmc core always checks the card status before calling this operation. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/sd.c | 14 -- 1

[PATCH 01/30] staging: mt7621-mmc: Fix typo in function parameters

2018-04-29 Thread Christian Lütke-Stetzkamp
The type pm_message does not exist in the kernel, the correct type is pm_message_t, so the type of the parameter is corrected. Fixes: 9673d9f6f44b ("staging: mt7621-mmc: Refactor suspend, resume") Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/sd.c |

[PATCH 16/30] staging: mt7621-mmc: Remove non-DMA transfer code

2018-04-29 Thread Christian Lütke-Stetzkamp
Currently the driver is capable of DMA and non-DMA transfer. But the option to choose non-DMA transfer has already been removed. Now remove also the code for the non-DMA transfer. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/sd.c | 261

[PATCH 09/30] staging: mt7621-mmc: Remove function uffs

2018-04-29 Thread Christian Lütke-Stetzkamp
The function uffs that is implemented by this driver returns the same values as the kernel function ffs. So the uffs function is removed and the calls to it are replaced with calls to ffs. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/mt6575_sd.h |

[PATCH 04/30] staging: mt7621-mmc: Remove unused field dat_drv from msdc_hw

2018-04-29 Thread Christian Lütke-Stetzkamp
The field dat_drv of msdc_hw is set to a constant and only used once, replace that position with the constant and remove the unused field. Signed-off-by: Christian Lütke-Stetzkamp --- drivers/staging/mt7621-mmc/board.h | 1 - drivers/staging/mt7621-mmc/sd.c| 5 ++--- 2

[PATCH] media: atomisp: fix spelling mistake: "diregard" -> "disregard"

2018-04-29 Thread Colin King
From: Colin Ian King Trivial fix to spelling mistake in ia_css_print message text Signed-off-by: Colin Ian King --- .../css2400/css_2401_csi2p_system/host/csi_rx_private.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff